Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

openSuse 15.2: Virtualbox braucht glibc 2.33

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

navi-cc
Member
Member
Beiträge: 191
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von navi-cc »

Da ich einen Lenovo T14s AMD besitze, kann ich den "serienmäßigen" Kernel 5.3.1.8 von Leap 15.2 nicht nutzen, wenn ich einen zweiten Bildschirm anschließe. Das wurde hier https://linux-club.de/forum/viewtopic.php?f=90&t=123265 schon diskutiert. Jetzt habe ich mal den aktuellen stable kernel 5.11.7.-2 installiert. Endlich geht das Booten mit dem Zweitbildschirm auf Anhieb.
Aber: Virtualbox benötigt zum Installieren der Kernel Module glibc 2.33, s. hier

Code: Alles auswählen

=== Building 'vboxdrv' module ===
make[1]: Entering directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
make V= CONFIG_MODULE_SIG= CONFIG_MODULE_SIG_ALL= -C /lib/modules/5.11.7-2.g68a1ba6-default/build M=/usr/src/kernel-modules/virtualbox/src/vboxdrv SRCROOT=/usr/src/kernel-modules/virtualbox/src/vboxdrv -j16 modules
make[2]: Entering directory '/usr/src/linux-5.11.7-2.g68a1ba6-obj/x86_64/default'
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/linux/SUPDrv-linux.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvGip.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvSem.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvTracer.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPLibAll.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/alloc-r0drv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/initterm-r0drv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/memobj-r0drv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/mpnotification-r0drv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/powernotification-r0drv.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/assert-r0drv-linux.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/alloc-r0drv-linux.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/initterm-r0drv-linux.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memobj-r0drv-linux.o
  CC [M]  /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memuserkernel-r0drv-linux.o
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPLibAll.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPLibAll.o'
make[4]: *** Waiting for unfinished jobs....
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvSem.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvSem.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/mpnotification-r0drv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/mpnotification-r0drv.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/initterm-r0drv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/initterm-r0drv.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/alloc-r0drv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/alloc-r0drv.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/powernotification-r0drv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/powernotification-r0drv.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/memobj-r0drv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/memobj-r0drv.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/initterm-r0drv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/initterm-r0drv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memuserkernel-r0drv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memuserkernel-r0drv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/assert-r0drv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/assert-r0drv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/alloc-r0drv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/alloc-r0drv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/linux/SUPDrv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvTracer.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvTracer.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memobj-r0drv-linux.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/r0drv/linux/memobj-r0drv-linux.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvGip.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrvGip.o'
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)
make[4]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/scripts/Makefile.build:280: /usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrv.o] Error 1
make[4]: *** Deleting file '/usr/src/kernel-modules/virtualbox/src/vboxdrv/SUPDrv.o'
make[3]: *** [/usr/src/linux-5.11.7-2.g68a1ba6/Makefile:1822: /usr/src/kernel-modules/virtualbox/src/vboxdrv] Error 2
make[2]: *** [../../../linux-5.11.7-2.g68a1ba6/Makefile:185: __sub-make] Error 2
make[2]: Leaving directory '/usr/src/linux-5.11.7-2.g68a1ba6-obj/x86_64/default'
make[1]: *** [/usr/src/kernel-modules/virtualbox/src/vboxdrv/Makefile-footer.gmk:117: vboxdrv] Error 2
make[1]: Leaving directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
make: *** [Makefile:59: vboxdrv] Error 2
oder genauer: das mit glibcc 2.33 compilierte Modul libc.so.6 fehlt.
Was mache ich jetzt - ohne mein System zu zerstören? Wo bekomme ich den GLIB_C 2.33 her?
Sauerland
Guru
Guru
Beiträge: 4030
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Sauerland »

Was mache ich jetzt - ohne mein System zu zerstören? Wo bekomme ich den GLIB_C 2.33 her?
glibc2.33 würde ich nicht installieren, das ist die grundlegende lib.

Ich bin bei Kernel 5.10 geblieben, da funktioniert es noch.
Ansonsten würde ich sagen:
Pech gehabt.

Hab auch schon seit Wochen einen Bugreport offen:
https://bugzilla.suse.com/show_bug.cgi?id=1182224
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
navi-cc
Member
Member
Beiträge: 191
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von navi-cc »

Danke.
Jetzt sitze ich zwischen den Stühlen. Mit dem Kernel 5.10 (Stand Januar) bootete mein Rechner nicht. Mit dem 5.3 geht der zweite Bildschirm nicht. Mit dem 5.9 geht Virtualbox, aber der Zweitbildschirm erst mit dem zweiten/dritten Bootversuch. Ich habe also die Auswahl ;-)

Also warten, bis Leap 15.2 glibc 2.33 verwendet? Oder auf Leap 15.3 warten.
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von susejunky »

Hallo naci-cc,
navi-cc hat geschrieben: 21. Mär 2021, 13:04... Jetzt sitze ich zwischen den Stühlen. Mit dem Kernel 5.10 (Stand Januar) bootete mein Rechner nicht. Mit dem 5.3 geht der zweite Bildschirm nicht. Mit dem 5.9 geht Virtualbox, aber der Zweitbildschirm erst mit dem zweiten/dritten Bootversuch. Ich habe also die Auswahl ;-)

Also warten, bis Leap 15.2 glibc 2.33 verwendet? Oder auf Leap 15.3 warten.
bevor ich alle meine "Produktivsysteme" auf openSUSE Tumbleweed umgestellt habe (vor ca. 1,5 Jahren) habe ich virtualbox von hier

https://download.opensuse.org/repositor ... _standard/

zusammen mit kernel stable benutzt.

Die könntest versuchen, ob das Dein Problem löst (OHNE GEWÄHR !!!).

Viele Grüße

suejunky
Sauerland
Guru
Guru
Beiträge: 4030
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Sauerland »

Also warten, bis Leap 15.2 glibc 2.33 verwendet? Oder auf Leap 15.3 warten.
Ersteres wird nicht passieren, bei zweiterem ist nicht gesagt,das es funktioniert.

Besser wäre ein bugreport mit kernel 5.3.
Einer der Kernel-maintainer ist da eigentlich immer sehr schnell mit Antworten und evtl. mit einem neu gepatchten Kernel.

Das Problem ist ja an sich nicht der kernel, sondern die zum Bau nötigen kernel-headers (kernel-devel).
Der Kernel läuft, nur virtualbox-kmp-default (oder mein r8168-kmp-default usw.) brechen mit der Fehlermeldung ab, ignorieren nutzt auch nichts.
Daher wird auch Virtualbox original von Oracle nicht bauen bzw. hinterher die Fehlermeldung ausspucken.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5488
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von tomm.fa »

susejunky hat geschrieben: 21. Mär 2021, 13:48 Hallo naci-cc,
navi-cc hat geschrieben: 21. Mär 2021, 13:04... Jetzt sitze ich zwischen den Stühlen. Mit dem Kernel 5.10 (Stand Januar) bootete mein Rechner nicht. Mit dem 5.3 geht der zweite Bildschirm nicht. Mit dem 5.9 geht Virtualbox, aber der Zweitbildschirm erst mit dem zweiten/dritten Bootversuch. Ich habe also die Auswahl ;-)

Also warten, bis Leap 15.2 glibc 2.33 verwendet? Oder auf Leap 15.3 warten.
bevor ich alle meine "Produktivsysteme" auf openSUSE Tumbleweed umgestellt habe (vor ca. 1,5 Jahren) habe ich virtualbox von hier

https://download.opensuse.org/repositor ... _standard/

zusammen mit kernel stable benutzt.

Die könntest versuchen, ob das Dein Problem löst (OHNE GEWÄHR !!!).

Viele Grüße

suejunky
Dann ist ebenfalls das Problem mit glibc-2.33 im Weg. :wink:
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von susejunky »

Hallo tomm.fa,
tomm.fa hat geschrieben: 21. Mär 2021, 16:09... Dann ist ebenfalls das Problem mit glibc-2.33 im Weg. :wink:
Hmmm, ich hatte jetzt gedacht, dass das Problem mit glibc-2-33 beim compilieren des virtualbox-kmp-Moduls für kernel stable auftritt.

Das Repository enthält aber ein bereits für kernel standard compiliertes virtualbox-kmp-default-6.1.18_k5.11.8_1.g995fe45-586.13.x86_64.rpm ?

Aber wie ich schon sagte: Es ist lange her und ich nutze zwischenzeitlich Tumbleweed. Ich kann da also durchaus falsch liegen ...

Viele Grüße

susejunky
Sauerland
Guru
Guru
Beiträge: 4030
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Sauerland »

Das Problem ist, das das kmp mit glibc2.33 gebaut wurde.

Die kmps in meinem Repo bauen ohne Probleme, setzen aber beim installieren die Fehlermeldung ab.......
Der Verursacher ist kernel-devel, den braucht es zum Bau von kmps und der schreibt das in diese kmps als Abhängigkeit.

Problem ist bekannt aber schwer zu lösen.

Auf gut deutsch:

Um mit dem kmps gebaut mit dem kernel aus kernel:stable zu installieren braucht es zwingen glibc2.33.
Ebenso wenn man kernel-devel aus kernel:stable installieren will.

Der eigentliche Kernel aus kernel:stable ist davon nicht betroffen und läuft auch weiterhin unter allen openSUSE Versionen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 902
Registriert: 19. Sep 2014, 18:22

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von susejunky »

Hallo Sauerland,
Sauerland hat geschrieben: 21. Mär 2021, 17:48 Das Problem ist, das das kmp mit glibc2.33 gebaut wurde.

Die kmps in meinem Repo bauen ohne Probleme, setzen aber beim installieren die Fehlermeldung ab.......
Der Verursacher ist kernel-devel, den braucht es zum Bau von kmps und der schreibt das in diese kmps als Abhängigkeit.

Problem ist bekannt aber schwer zu lösen.

Auf gut deutsch:

Um mit dem kmps gebaut mit dem kernel aus kernel:stable zu installieren braucht es zwingen glibc2.33.
Ebenso wenn man kernel-devel aus kernel:stable installieren will.

Der eigentliche Kernel aus kernel:stable ist davon nicht betroffen und läuft auch weiterhin unter allen openSUSE Versionen.
vielen Dank für die Erläuterung.

Ich hatte mir die von Dir verlinkte Bugzilla-Meldung durchgelesen, konnte aber die Problematik nicht nachvollziehen.

Es ist eben schon ein paar Jahrzehnte her, dass ich selbst Software entwickelt habe. Vielleicht muss ich da doch mal wieder etwas tiefer einsteigen ...

Viele Grüße

susejunky
navi-cc
Member
Member
Beiträge: 191
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von navi-cc »

Danke für die Diskussionsbeiträge.
Da auch der Bugreport von Sauerland bzw. die Antworten darin für mich noch keine klare Linie ergeben, benutze ich erst mal weiterhin den Kernel 5.9. Gelöst ist das Problem somit noch nicht. Vielleicht gibte es ja noch eine weitere Idee...
Christina
Member
Member
Beiträge: 102
Registriert: 4. Mär 2019, 13:44

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Christina »

navi-cc hat geschrieben: 21. Mär 2021, 19:39Vielleicht gibte es ja noch eine weitere Idee...
Muss es denn unbedingt Virtualbox sein?
stka
Moderator
Moderator
Beiträge: 3350
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von stka »

Oder auf Ubuntu 21.04 warten :-) und dann wechseln.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
navi-cc
Member
Member
Beiträge: 191
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von navi-cc »

Da warte ich eher auf Leap 15.3 - Suse Nutzer seit 9.1
Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 2296
Registriert: 10. Nov 2012, 11:00

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von gehrke »

Andere Mütter haben auch hübsche Töchter.
Keinen Bock mehr auf zentralisierte soziale Netzwerke von US-Konzernen?
Join the fediverse: https://fediverse.party/en/fediverse/ (Friendica, Mastodon, Diaspora und vieles mehr)
Christina
Member
Member
Beiträge: 102
Registriert: 4. Mär 2019, 13:44

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Christina »

navi-cc hat geschrieben: 22. Mär 2021, 22:08 Da warte ich eher auf Leap 15.3 - Suse Nutzer seit 9.1
Leap 15.3 gibt es jetzt bereits als Beta und ist ein Rolling Release bis zur Veröffentlichung im Juni.
https://en.opensuse.org/Features_15.3
Einige Leute hier haben in der Signatur schon seit letztem Jahr "Leap 15.3" stehen. Da bekommst du bestimmt Hilfe.
Benutzeravatar
manzek
Hacker
Hacker
Beiträge: 376
Registriert: 20. Mär 2005, 14:21
Wohnort: Metropolregion Bremen/Oldenburg

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von manzek »

@navi-cc

Da dein Laptop noch recht frisch ist, könntest du auch auf Tumbleweed umsteigen. Hier ist der Kernel bereits bei Version 5.11.6 angelangt.
AMD hat ohnehin derzeit massive Probleme mit der Firmware für seine Prozessoren. Abhilfe wird da am ehesten in aktuellen Kernel-Versionen zu finden sein.
So long, Stephan

---
Gigabyte AORUS MASTER X570 * AMD Ryzen 3900XT @ 4,0 GHz * 128 GB DDR4 @ 3200 MHz * nVIDIA GeForce RTX 2070 SUPER, 8192 MB * 27" - LED @ 3840 x 2160 * openSUSE Tumbleweed * KDE 5.21.x
Sauerland
Guru
Guru
Beiträge: 4030
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Sauerland »

In meinen Augen gibt es 2 Möglichkeiten:
  • 1. Entweder komplett auf Tumbleweed umsteigen, wie schon gesagt, dort läuft Virtualbox, die glibc2.33 ist auch vorhanden.
  • 2. Einen Kernel aus kernel:stable:backports installieren und ein gebautes virtualbox.src.rpm benutzen.
    Dafür müsste ich aber erst einmal die Repoliste sehen:

    Code: Alles auswählen

    zypper lr -d
Leap 15.3 ist meiner Meinung nach keine Alternative, dort gibt es einen von 5.8 oder 5.9 gepatchten 5.3 Kernel, wenn deine Grafik erst mit 5.10 zuverlässig läuft.......
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Christina
Member
Member
Beiträge: 102
Registriert: 4. Mär 2019, 13:44

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von Christina »

Sauerland hat geschrieben: 23. Mär 2021, 14:18 Leap 15.3 ist meiner Meinung nach keine Alternative, dort gibt es einen von 5.8 oder 5.9 gepatchten 5.3 Kernel, wenn deine Grafik erst mit 5.10 zuverlässig läuft.......
Hey, vielen Dank für die Info! :)
Mich interessiert das Thema ja auch. Mein AMD-System ist zwar schon alt, aber mein nächster PC/Laptop wird wieder einer mit AMD-APU. Vielleicht tut sich noch was bis zum Release Candidate von Leap 15.3. VirtualBox verwende ich nicht.
Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 2296
Registriert: 10. Nov 2012, 11:00

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von gehrke »

Christina hat geschrieben: 22. Mär 2021, 11:41 Muss es denn unbedingt Virtualbox sein?
Wie Christina schon andeutete: Es gibt auch hier Alternativen - beispielsweise KVM. Durch die Kernelintegration dürfte das auf Dauer deutlich schmerzfreier sein.
Die vorhandenen Images können leicht migriert werden.
Keinen Bock mehr auf zentralisierte soziale Netzwerke von US-Konzernen?
Join the fediverse: https://fediverse.party/en/fediverse/ (Friendica, Mastodon, Diaspora und vieles mehr)
navi-cc
Member
Member
Beiträge: 191
Registriert: 18. Jan 2005, 14:36
Wohnort: Dresden

Re: openSuse 15.2: Virtualbox braucht glibc 2.33

Beitrag von navi-cc »

Sauerland hat geschrieben: 23. Mär 2021, 14:18 In meinen Augen gibt es 2 Möglichkeiten:
  • 1. Entweder komplett auf Tumbleweed umsteigen, wie schon gesagt, dort läuft Virtualbox, die glibc2.33 ist auch vorhanden.
  • 2. Einen Kernel aus kernel:stable:backports installieren und ein gebautes virtualbox.src.rpm benutzen.
    Dafür müsste ich aber erst einmal die Repoliste sehen:

    Code: Alles auswählen

    zypper lr -d
Leap 15.3 ist meiner Meinung nach keine Alternative, dort gibt es einen von 5.8 oder 5.9 gepatchten 5.3 Kernel, wenn deine Grafik erst mit 5.10 zuverlässig läuft.......

Code: Alles auswählen

zypper lr -d
[/list]
liefert

Code: Alles auswählen

#  | Alias                                        | Name                                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                       | Service
---+----------------------------------------------+---------------------------------------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------+--------
 1 | openSUSE-Leap-15.2-1                         | openSUSE-Leap-15.2-1                                    | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_43172211CCC16FC5-0:0-part2 | 
 2 | openSUSE_Leap_15.2                           | X11                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/X11:/XOrg/openSUSE_Leap_15.2/  | 
 3 | opensuse-guide.org-openSUSE_Leap_$releasever | Libdvdcss Repository                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.2/                        | 
 4 | packman.inode.at-openSUSE_Leap_$releasever   | Packman Repository                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2/       | 
 5 | repo-debug-update                            | Update Repository (Debug)                               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                  | 
 6 | repo-debug-update-non-oss                    | Update Repository (Debug, Non-OSS)                      | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/              | 
 7 | repo-non-oss                                 | Non-OSS Repository                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/         | 
 8 | repo-oss                                     | Haupt-Repository                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/             | 
 9 | repo-source                                  | Source Repository                                       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/      | 
10 | repo-source-non-oss                          | Source Repository (Non-OSS)                             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/  | 
11 | repo-update                                  | Hauptaktualisierungs-Repository                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                         | 
12 | repo-update-non-oss                          | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                    | 
13 | standard                                     | Kernel stable                                           | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard/        | 
14 | teams                                        | teams                                                   | No      | ----      | ----    |   99     | rpm-md | https://packages.microsoft.com/yumrepos/ms-teams                          | 
Meine Bedingungen an mein System sind: Virtualbox für Win10 (gelegentlich), externer Monitor 2560x1440 zu Hause und im Büro und Funktion des WWAN (LTE) Modems für unterwegs. Für letzteres hoffe ich auf eine baldige Lösung ;-)
Meine häufigsten Anwendungen sind Thunderbird und Firefox - wie wohl bei den meisten hier ....
@Sauerland: Löst der Umstieg auf Tumbleweed Forderung 1 & 2? Dann mache ich das.
Antworten