Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

enlightenment e17 für SuSE

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

enlightenment e17 für SuSE

Beitrag von Djinn »

möchte enlightenment 17 unter suse 9.3 installieren
e16 rpm gibt es ja aber e17 noch nicht gefunden

hat e17 schon jemand am laufen unter suse 9.3



EDIT admine:
ich habe mal den Titel angepasst ;)
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Jo, habs unter der SuSE 9.3 laufen (eher stolpern ;-)), mit RPMs für
die 9.2.
Siehe hier:
http://www.linux-club.de/viewtopic.php?t=31275
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

Beitrag von Djinn »

und funzt es ohne prob
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Djinn hat geschrieben:und funzt es ohne prob
Jain *lol* E17 wehrt sich noch in einigen Dingen.
Also Enlightenment läuft ganz gut, aber mit engage und evidence kämpfe
ich noch. Die konnte ich auch nur installieren, indem ich einige
Abhängigkeiten ignoriert habe.
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

Beitrag von Djinn »

das so sollte es nicht sein es muss doch eine möglichkeit geben ohne die pakte von 9.2 zu installieren
versuche grade das mir zu backen aber irgendwie will er nicht :(
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

naja, wenn alles ausser engage und evidence funzt... die 2 kann man ja selber bauen dann ;)

eine möglichkeit wäre, sich die src.rpm's von }-Tux-{ zu schnappen und rpmbuild --rebuild foo, sozusagen ein back(oder eher forward?!)-port auf suse 9.3
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Gimpel hat geschrieben:naja, wenn alles ausser engage und evidence funzt... die 2 kann man ja selber bauen dann ;)

eine möglichkeit wäre, sich die src.rpm's von }-Tux-{ zu schnappen und rpmbuild --rebuild foo, sozusagen ein back(oder eher forward?!)-port auf suse 9.3
Das ist mein nächster Versuch. Ich gebe mich nicht so schnell
geschlagen ;) (Jetzt habt Ihr mich mit E17 angesteckt :D)
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

cero hat geschrieben:
Gimpel hat geschrieben:naja, wenn alles ausser engage und evidence funzt... die 2 kann man ja selber bauen dann ;)

eine möglichkeit wäre, sich die src.rpm's von }-Tux-{ zu schnappen und rpmbuild --rebuild foo, sozusagen ein back(oder eher forward?!)-port auf suse 9.3
Das ist mein nächster Versuch. Ich gebe mich nicht so schnell
geschlagen ;) (Jetzt habt Ihr mich mit E17 angesteckt :D)
:mrgreen: enlightenment for the world!

irgendwo gabs ein build-script .. *such* ... http://www.linuxforen.de/forums/showthread.php?t=183373 , aber laut djinn funzt das nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Gimpel hat geschrieben:
cero hat geschrieben:
Gimpel hat geschrieben:naja, wenn alles ausser engage und evidence funzt... die 2 kann man ja selber bauen dann ;)

eine möglichkeit wäre, sich die src.rpm's von }-Tux-{ zu schnappen und rpmbuild --rebuild foo, sozusagen ein back(oder eher forward?!)-port auf suse 9.3
Das ist mein nächster Versuch. Ich gebe mich nicht so schnell
geschlagen ;) (Jetzt habt Ihr mich mit E17 angesteckt :D)
:mrgreen: enlightenment for the world!

irgendwo gabs ein build-script .. *such* ... http://www.linuxforen.de/forums/showthread.php?t=183373 , aber laut djinn funzt das nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
Das Script werde ich mal probieren, wenn ich zu Hause bin :D
Momentan steht es noch 2:1 Enlightenment gegen cero - das
wird sich aber ändern *freu* 8)
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

Beitrag von Djinn »

bin ja gespannt obs bei dir funzt ?

sowie schon genannt worden ist will es bei mir nicht so

e_mod_main.c:706: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
make[3]: *** [e_mod_main.lo] Fehler 1
make[3]: Leaving directory `/root/e17/apps/e_modules/src/modules/flame'
make[2]: *** [install-recursive] Fehler 1
make[2]: Leaving directory `/root/e17/apps/e_modules/src/modules'
make[1]: *** [install-recursive] Fehler 1
make[1]: Leaving directory `/root/e17/apps/e_modules/src'
make: *** [install-recursive] Fehler 1


Cannot locate enlightenment. Is everything compiled correctly?
Please look in /root/e17/log/ to find an error.
terramon:/home/djinni/e177/e17install-0.4 #
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

Djinn hat geschrieben:bin ja gespannt obs bei dir funzt ?

sowie schon genannt worden ist will es bei mir nicht so

e_mod_main.c:706: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
make[3]: *** [e_mod_main.lo] Fehler 1
make[3]: Leaving directory `/root/e17/apps/e_modules/src/modules/flame'
make[2]: *** [install-recursive] Fehler 1
make[2]: Leaving directory `/root/e17/apps/e_modules/src/modules'
make[1]: *** [install-recursive] Fehler 1
make[1]: Leaving directory `/root/e17/apps/e_modules/src'
make: *** [install-recursive] Fehler 1


Cannot locate enlightenment. Is everything compiled correctly?
Please look in /root/e17/log/ to find an error.
terramon:/home/djinni/e177/e17install-0.4 #
gimpel hat geschrieben:irgendwo gabs ein build-script .. *such* ... http://www.linuxforen.de/forums/showthread.php?t=183373 , aber laut djinn funzt das nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
:wink:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

}-Tux-{ hat geschrieben:
Djinn hat geschrieben:bin ja gespannt obs bei dir funzt ?

sowie schon genannt worden ist will es bei mir nicht so

e_mod_main.c:706: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:707: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
e_mod_main.c:708: error: dereferencing pointer to incomplete type
make[3]: *** [e_mod_main.lo] Fehler 1
make[3]: Leaving directory `/root/e17/apps/e_modules/src/modules/flame'
make[2]: *** [install-recursive] Fehler 1
make[2]: Leaving directory `/root/e17/apps/e_modules/src/modules'
make[1]: *** [install-recursive] Fehler 1
make[1]: Leaving directory `/root/e17/apps/e_modules/src'
make: *** [install-recursive] Fehler 1


Cannot locate enlightenment. Is everything compiled correctly?
Please look in /root/e17/log/ to find an error.
terramon:/home/djinni/e177/e17install-0.4 #
gimpel hat geschrieben:irgendwo gabs ein build-script .. *such* ... http://www.linuxforen.de/forums/showthread.php?t=183373 , aber laut djinn funzt das nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
:wink:
}-Tux-{ kuck mal in besagten thread... Djinn hatte das script schon entdeckt *gg*

bau lieber mal 9.3 rpm's!!
*duck*
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

Gimpel hat geschrieben:nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
das war darauf bezogen nicht auf das entdeckte script :wink:
gimpel hat geschrieben:bau lieber mal 9.3 rpm's!!
*duck*
witzbold :P Aber wenn du mir so ein schönes nettes suse93 paket käufst && zuschickst, kann ich das gerne machen *gg*


mfg }-Tux-{
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

}-Tux-{ hat geschrieben:
Gimpel hat geschrieben:nicht so recht mit e_modules, welche man aber weglassen könnte da eher weniger wichtig...
das war darauf bezogen nicht auf das entdeckte script :wink:
gimpel hat geschrieben:bau lieber mal 9.3 rpm's!!
*duck*
witzbold :P Aber wenn du mir so ein schönes nettes suse93 paket käufst && zuschickst, kann ich das gerne machen *gg*


mfg }-Tux-{
asuuuu, hehe
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Mist :-(
Habe gerade gelesen das ca. 130MB gezogen werden.
Hatte ich schon erwähnt, dass es die Telekom nicht so gut mit
mir meint? Ich habe nur ISDN *heul*
Einen Download dieser Größe muß ich genau planen ;) Ich werde
es mir mal überlegen...

Naja, wenn }-Tux-{ natürlich die RPMs bauen würde.... ;-) *stichel*
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

Beitrag von Djinn »

ja so ein rpm wer auch eine schöne sache :)

gibt mir ein T gib mir u gib mir X Tux :lol:
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

rofl!!

jungs, nur weil das script versagt, heißt das doch nicht, dass ihr jetzt dasitzen müsst und warten bis 9.3 frei über die server erhältlich ist.

es gibt da noch mehr möglichkeiten:

a) do it yourself

cvs co
./autogen.sh
make
make install

und das in der richtigen reihenfolge, wo is das problem? nur weil dieses script nicht funzt?

b) port it

src.rpm's von 9.2 besorgen, und rpmbuild --rebuild foo.src.rpm, ebenfalls in richtiger reihenfolge

c) ladet die ersten 3 cd's von 9.3 auf nen ftp hoch irgendwo (is sogar legal) und lasst }-Tux-{ saugen ;) dann hat er schneller 9.3 *gg*

d) die rpm's von 9.2 funzen doch, so wie ich das verstanden habe, und engage und evidence selber bauen, ist doch wohl null problem o_O
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
Djinn
Member
Member
Beiträge: 50
Registriert: 14. Mai 2004, 14:57

Beitrag von Djinn »

funzt es bei dir ohne prob, meine ohne das script
/root is watching you

"Jeder Tag, an dem du nicht lächelst, ist ein verlorener Tag." Charles Chaplin
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

Djinn hat geschrieben:funzt es bei dir ohne prob, meine ohne das script
naja, ich hab gentoo. wir haben einfach CVS ebuilds dafür, aber die tun nichts anderes als der reihe nach kompilieren.

hab aber schonmal selber gebaut, ging auch.

nach jeder lib ein 'ldconfig' laufen lassen, passt

}-Tux-{ hat ja die rpm's kompiliert, hat ja auch geklappt. evtl kann er bei einzelnen fehlern weiter helfen ;)
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Beitrag von cero »

Jo, war auch nur als kleiner Scherz gemeint. :mrgreen:

Ich habe mich mal für Lösung B entschieden. Die SRPMs habe ich
schon zum Teil. Bei einigen wundert mich nur die geringe Dateigröße (2KB). Da stimmt doch was nicht, oder?

Wenn alles nichts hilft, versuche ich halt selber welche zu bauen.
Oder ich schleppe meinen Rechner mit in die Firma und teste
das Script *lol*
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Antworten