OpenOffice/Serienbriefe

Aus Linupedia
Wechseln zu: Navigation, Suche

Als Serienbrief bezeichnet man ein Textdokument, bei dem einzelne Teile – typischerweise Adresse und Anrede – aus einer Datenbank eingefügt werden. Dabei besteht die Möglichkeit, automatisch jeweils einen Datensatz in das Dokument zu mischen, dann dieses Dokument so zu drucken, und dann den nächsten Datensatz einzumischen, wieder zu drucken usw.

Erstellung von Serienbriefen

Seit Version 2 von OpenOffice.org ist zu der Möglichkeit, einen Serienbrief „von Hand“ zu erstellen, die Möglichkeit getreten, sich von einem Assistenten bei dieser Aufgabe helfen zu lassen. Den Assistenten rufen Sie mit Extras → Serienbrief-Assistent im Modul Writer auf. Er führt Sie dann Schritt für Schritt durch die Erstellung und den Versand eines Serienbriefs.

Nach wie vor besteht die Möglichkeit, Serienbrief-Felder aus dem geöffneten Datenbank-Browser (Ansicht → Datenquellen) in ein Dokument – etwa einen bereits vorbereiteten Brief – zu ziehen und dann mit Daten in Felder diese Felder mit den Daten eines Datensatzes zu füllen oder mit Drucken einen Seriendruck auszulösen.

Dank der Vielzahl guter Howtos kann hier auf eine genaue Beschreibung der beiden Verfahren verzichtet werden; stattdessen verweisen wir auf die guten externen Howtos:

http://www.ooowiki.de/SerienBrief
Howto zur Erstellung von Serienbriefen ohne Verwendung des Assistenten (OpenOffice.org-Wiki)
http://de.openoffice.org/doc/howto_2_0/writer/erstellung-serienbrief.pdf
Howto zur Erstellung von Serienbriefen mithilfe des Assistenten (OpenOffice.org Dokumentationsportal)
http://de.openoffice.org/doc/howto/serienbriefe/index.html
Howto für die Versionen 1.0/1.1 von OpenOffice.org (OpenOffice.org Dokumentationsprojekt)

Umwandlung von Serienbriefdaten aus MS Office

Grundsätzlich müssen die Daten, die für den Serienbrief verwendet werden sollen, in einer in OpenOffice.org angemeldeten Datenquelle stehen. Während es in älteren Versionen ausreichend und zweckmäßig war, z.B. eine Excel-Tabelle einfach als Calc-Datei zu speichern und diese direkt als Datenquelle anzumelden, ist es seit Version 2 von OpenOffice.org grundsätzlich nötig, das Modul Base für die Verwaltung der Datenquelle zu verwenden.

Aber dies stellt für den Umsteiger kein größeres Problem dar: Haben Sie erst einmal eine neue (leere) Datenbank erstellt, angemeldet und gespeichert (Datei → Neu → Datenbank und dann dem Assistenten folgen), können Sie eine bestehende Datentabelle, egal ob nun aus Calc, Excel, Writer oder Word, einfach per Copy&Paste einfügen.

  1. Markieren Sie Ihre Ausgangs-Tabelle und kopieren Sie sie in die Zwischenablage.
  2. Wählen Sie in Base unter „Datenbank“ Tabellen und klicken mit der rechten Maustaste in den Bereich „Tabellen“ um die Tabelle aus dem ersten Schritt einzufügen.

Hat man die Daten erst einmal in einer Base-Datenbank (HSQL) stehen, kann man sie für die Erstellung eines Serienbriefs – egal ob nun von Hand oder mithilfe des Assistenten – verwenden. Dieses Verfahren ist ausführlich in der oben genannten Anleitung beschrieben.

Weiterführende Links


Zurück zu Office