Dell Inspiron 6400

Aus Linupedia
Wechseln zu: Navigation, Suche

Hier will ich die Installation von openSUSE auf meinem Dell Inspiron 6400 beschreiben. Zunächst sei gesagt, daß ich das Gerät gekauft habe, mit der Absicht, das Betriebssystem, sowie die mitgelieferte OEM Software zurück zu geben. Meine Wahl fiel aus verschiedenen Gründen auf ein Dell Notebook. Zum einen kann man sein Notebook bei Dell auf die eigenen Bedürfnisse anpassen. Zum anderen gehört Dell zu den wenigen Herstellern, die das Betriebssystem und die mitgelieferte OEM-Software anstandslos zurücknehmen. Während andere Hersteller dies meist erst tun, wenn man sein Recht einklagt.

OK, das Notebook ausgepackt und eingeschaltet. An dem Punkt als es galt die Lizenzvereinbarungen zu akzeptieren, habe ich dies nicht getan. Bei den Vereinbarungen von Dell ganz nach unten geblättert, kommt eine Info, was zu tun ist. In meinem Fall hieß es, ich solle den technischen Support anrufen, was ich auch tat.

Eine freundliche Supportmitarbeiterin war sehr bemüht, das Problem zu lösen. Nachdem ich ihr klar gemacht hatte, daß die Software nicht laufen wird, da ich ganz sicher nicht mit den Lizenzvereinbarungen einverstanden bin, hat sie mich mit dem Kundenservice verbunden.

Auch dort wieder eine freundliche Supportmitarbeiterin, diesmal mit gebrochenem Deutsch, die mich kaum verstand, doch sehr bemüht war, mein Anliegen zu meiner Zufriedenheit zu lösen. Etwa eine halbe Stunde später war geklärt, welchen Geräte Tag mein Notebook hat, welche Softwarelizenzen ich zurückgeben wollte und welchen Lizenzcode diese hatte. Sie sagte mir, ich würde eine Mail bekommen, mit der Adresse, an die ich die CDs sowie evtl. vorhandene Lizenzcodeaufkleber per Post senden sollte.

Diese Mail lies 2 Tage auf sich warten, in denen ich nichts machen wollte. Doch dann war es soweit, die Mail war da und der Formatierung der Festplatte stand nichts mehr im Wege. Doch bleiben wir zunächst noch bei der Rückgabe der Softwarelizenzen. Ich habe die Windows Vista Home, Works Suite 8.5, und von Corel eine Bildverwaltung zurückgegeben. Des weiteren habe ich den Portobeleg für das Einschreiben-Einwurf mit beigelegt. Etwa 1 Woche später kam von Dell der Bescheid, sie hätten für die zurückgebene Softwarelizenzen 132 € auf meine Kreditkarte zurückgebucht. Wie sich die 132 € zusammensetzen, kann ich jedoch nicht sagen, da Dell mich darüber im dunkeln läßt. Für mich klingt es jedoch fair. Windows Vista Home 80 € Works Suite 8.5 15 € (enthält heute kein MS Word mehr) Porto 3,85 € Macht 108,85 € + die Corel Bildverwaltung mit unbekanntem Wert.

OK, jetzt kommt endlich Linux drauf. ;-)

Hier ein paar Hardwaredetails

  • Dell Inspiron 6400 Notebook
  • CPU Intel Pentium Dual-Core 1,73 Ghz 1MB L2 Cache
  • 2 GB DDR3 RAM
  • 160 GB HD
  • Intel Chipsatz 82801G mit Onboard Sound
  • Intel Grafik Modul 945GM
  • DVD+-RW TS-L632D Rev DE04
  • Wireless 355 Bluetooth 2.0-Modul
  • WLAN Dell Wireless 1390 WLAN Mini-PCI Card (Broadcom Corporation)
  • 4x USB über USB Controller Intel 82801G
  • Firewire Contoller von Ricoh
  • Ricoh Card Reader für SD/MMC, Memory Stick, xD Karten am PCI Port
  • Modem nicht erkannt


Zunächst wollte ich die vorhandene Partitionierung abändern, um so die Systemwiederherstellungspartition nicht löschen zu müssen, man kann ja nie wissen, ob im Supportfall, darauf Wert gelegt wird, oder nicht. Jedoch lies sich die Partition nicht mit parted bearbeiten. Also flog erst mal alles runter, und dafür wanderten zwei taufrische ext3 Partitionen auf die Platte.

Die Suse Linux 10.2 Basis Installation verlief ohne Schwierigkeiten.

Nachdem ich mich das erste mal anmeldete, wirkte der Bildschirminhalt etwas verzerrt. Ich hatte nur eine Bildschirmauflösung von 1024x768 Pixeln auf einem WXGA Display mit 1280x800 Pixeln.

Sax2 brachte mich nicht weiter. Auch die im Netz viel gepriesene Bearbeitung und Anpassung xorg.conf Beispielsweise: http://www.rrze.uni-erlangen.de/dienste/arbeiten-rechnen/linux/projekte/dell-d820.shtml brachten mich nicht weiter. Erst über die Seite: http://www.linux-club.de/viewtopic.php?t=73798 bekam ich die Lösung für mein Problem präsentiert. Ich musste quasi die korrekte Bildschirmauflösung ins Grafikbios eintragen. Dies ist bei jedem Systemstart nötig und wird über das Tool 915resolutions umgesetzt. Dieses Programm liefert Suse als Paket mit, ist jedoch nicht in der Standartinstallation installiert. Siehe auch: http://en.opensuse.org/Patch_the_Video_BIOS.

Endlich die korrekte Bildschirmauflösung und das Bild sieht gut aus. Das Display spiegelt nicht und die Auflösung ist fein genug, für gutes Arbeiten.

Netzwerk über Kabel funktioniert auf Anhieb.

Sound auch.

Das Brennerlaufwerk brutzelt auch anstandslos.

USB Controller arbeitet ohne zutun.

Firewire habe ich nicht ausprobieren können, da ich keine Geräte mit Firewireanschluß besitze. Da dies jedoch auch über den Chipsatz 82801G von Intel angesteuert wird und alle anderen Funktionen dieses Chipsatzes funktionieren, gehe ich davon aus, daß Firewire keine Schwierigkeiten machen wird.

Die Funktionstasten für die Displayhelligkeit funktioneren auch ohne zutun. Die Tasten für die Lautstärkeregelung und den Ruhezustand muss ich jedoch noch anderweitig konfigurieren. Ein Druck auf Fn+Funk und das Bluetoothmodul springt an. Und wird auch korrekt vom System erkannt und von Yast eingerichtet. Ich muss dazu sagen, daß ich die Taste im Bios so eingetragen habe, wodurch das WLAN ständig läuft. Ohne Änderung im Bios, sollte bei Fn+Funk startet dann beides, Bluetooth und WLAN. Doch leider arbeitet das WLAN nicht auf Knopfdruck. Da ich Bluetooth selten brauche, aktiviere ich es zwar im Bios, stelle für die Fn+Funk Taste ein, nur BT, da das WLAN ständig laufen soll. Doch Yast erkennt das WLAN-Modun weiterhin nicht.

Nach vielen Recherchen und dem Ausprobieren, diverser Kernelmodule für WLAN Chips, die ich letztlich wieder entfernt habe, komme ich zu dem Schluß, das dieses Modul nicht unterstützt wird. Es bleibt also nur noch der Ndiswrapper. Bei Dell den Treiber für die Broadcom Corporation 1390 Mini PCI Card – r151517.exe – herunter geladen unter /lib die Ordner wlan/drivers angelegt und darin die Datei r151517.exe gespeichert. Diese dann mit 'unzip r151517.exe' entpackt.

Nun zunächst getestet ob bereits zufällig irgendwelche andere Treiber ins System gefunden haben. ndiswrapper -l keine Ausgabe ist gut. ndiswrapper -i bcmwl5.inf installiert den Treiber ins ndiswrapper Modul ndiswrapper -l zeigt mir nun an, daß der Treiber bcmwl5 installiert ist. modprobe ndiswrapper zeigt mir an, welchen Treiber ndiswrapper als Modul in den Kernel geladen hat, hier sollte stehen: bcmwl5

Ich habe auf dieser Basis sehr lange herumkonfiguriert und irgendwie wollte nichts. Bei mir hat es geholfen, alle fehlgeschlagenen Konfigurationen zu entfernen, den Rechner neu zu starten und erst danach das Wifi-Modul zu konfigurieren, anschließend noch mal den Rechner neu starten und schon leuchtet nicht nur die Wifi Lampe, nein auch der Internetzugriff funktioniert über WLAN.

In Yast, Netzwerkkarte auf ifup, Hinzufügen Drahtlos, Externe Zone, bei Kabelanschluß, Benutzergesteuert, die Geräteid und alles auf Voreinstellung gelassen, zunächst ausgewählt, Gerät direkt an PCI, später Modulname auf ndiswrapper geändert, sonst alles auf Voreinstellung außer was das Netzwerk fordert.

Suspend to RAM funktionierte sofort und Suspend to Disk erst, nachdem ich verfügbare Updates für die Powersave Funktionen eingespielt habe. Seither passiert es nicht mehr, daß ich das Notebook im Akkubetrieb stehen lasse - und für längere Zeit vergesse - und wenn ich wiederkomme ist die nicht gespeicherte Arbeit futsch.

Wie schon erwähnt, funktionierten die Funktionstasten für die Displayhelligkeit, sowie für das Funkmodul out of the box. Die Vielen anderen Tasten wollten jedoch irgendwie nicht, und ließen sich auch nicht auf Anhieb in Betrieb nehmen. Zunächst wollte ich es mit der xmodmap versuchen, dieser Ansatz funktioniert jedoch nicht unter Xorg, sondern nur unter Xfree86.

Prinzipiell funktionierte xbinkeys, jedoch konnte ich nicht in Erfahrung bringen, wie die ganzen Scancodes für die verschiedenen Funktionstasten hießen. Als ich mich gerade auf viel Arbeit einstellte, fiel mir ein bei Packman - http://packman.iu-bremen.de/suse/10.2/ - gehostetes Paket Namens keytouch auf. Installiert und funktioniert, was will man mehr.

Der Card Reader jedoch funktioniert noch nicht. Es ist zwar bereits ein Treiber in der Entwicklung, - http://sourceforge.net/projects/sdricohcs/ - dieser funktioniert wohl jedoch bis jetzt nur mit SD Karten und das wohl auch nur im Lesezugriff zuverlässig. Da ich jedoch MemoryStick und xD-Karten besitze, muss ich auf den internen Card Reader wohl vorerst noch verzichten.


zurück zum Notebook