Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 24. Jun 2004, 12:28

Hallo ich habe Probleme beim einrichten meines Canon BJC250 Drucker am
Parallelport. Ich verwende Suse 9.1.
Folgende Fehlermeldung wird ausgegeben.
Beim speichern der Warteschlange ist ein Fehler aufgetreten.
Cups (File) Do Rwquest error: client-error-request-value-too-long

Für Hilfe bin ich sehr Dankbar
Siegbert

Werbung:
Benutzeravatar
Hunterlein
Newbie
Newbie
Beiträge: 7
Registriert: 14. Jun 2004, 22:52

Beitrag von Hunterlein » 29. Jun 2004, 15:58

Das könnte das Problem sein:

Dein Drucker liefert eine lange Identifikation zurück welche in die DeviceURI übernommen wird.

Versuch mal in Yast das Device manuell auszuwählen oder in printers.conf eine kürzere DeviceURI wie:

Code: Alles auswählen

DeviceURI parallel:/dev/lp0
einzutragen. Vielleicht hilfts ja.

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Hier ist meine Printer.conf

Beitrag von siegbert » 30. Jun 2004, 08:55

Der entsprechende Eintrag ist in der printers.conf enthalten.

# Printer configuration file for CUPS v1.1.20
# Written by cupsd on Sa 26 Jun 2004 18:07:23 CEST
<Printer bjc250>
Info bjc250
DeviceURI parallel:/dev/lp0
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
<Printer psc1110>
Info psc1110
DeviceURI ptal:/mlc:usb:psc_1100_series
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>
<DefaultPrinter tp0>
Info tp0
DeviceURI usb://Hewlett-Packard/psc%201100%20series?serial=MY36QD617CB0
State Idle
Accepting Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
</Printer>

Kann es eventuell an den Zugriffsrechten liegen? Kann man cups auch neu installieren? Was ist dann alles zu löschen?
Danke für die Hilfe
Siegbert Wwein

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Hier ist meine Printer.conf

Beitrag von RG » 30. Jun 2004, 09:04

siegbert hat geschrieben:
Kann es eventuell an den Zugriffsrechten liegen? Kann man cups auch neu installieren? Was ist dann alles zu löschen?
Hallo,

also ich habe mir den CUPS auch schon mal zerschossen.Manuell habe ich da nichts gelöscht. Habe das Paket kompl. ( mit allen Abhängigkeiten )via Yast einfach drüber inst. Hat eigentlich ohne Probleme funkt.

Aber der HPPSC 1110 läuft ohne Probleme? oder?

Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

HPSC1110

Beitrag von siegbert » 30. Jun 2004, 12:16

Hallo,
auf beiden Druckern kann nicht gedruckt werden. Für beide Drucker kann keine Warteschleife gespeichert werden. Bin inzwischen total frustriert.
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: HPSC1110

Beitrag von RG » 30. Jun 2004, 12:38

siegbert hat geschrieben:Hallo,
auf beiden Druckern kann nicht gedruckt werden. Für beide Drucker kann keine Warteschleife gespeichert werden. Bin inzwischen total frustriert.
Siegbert
Hallo,
also ich habe Deine Printers.conf mit meiner verglichen sieht identisch aus!
Hat eigentlich irgendwann der Ausdruck schon funkt. oder hat das Problem seit der Grundinst. schon bestanden?
Mit was hast Du den Drucker eingerichtet?
Also ich habe meine Drucker via Yast eingerichtet funkt. tadellos:
SUSE 9.1 prof auf ACER Aspire 1400 NB.
1.Drucker via Intel druckerserver am Heimnetz (hppsc2100)
2.Drucker an 2.pc (Samsung ML1250)
3. Drucker im Büro via Jetdirect P1. ( Hplj 4000 )

wie schon oben geschrieben, ich habe mir den CUPS auch mal abgeschossen, da ging dann gar nix mehr. Habe von der SUSE original DVD dann den CUPS neu drübergezogen und die Drucker wieder via Yast neu inst. hat funkt.

schönen Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 30. Jun 2004, 19:02

Unter Suse 8.2 konnte ich mit beiden Druckern arbeiten. Seit ich Suse 9.1 installiert habe haben die Drucker noch nie gedruckt.
Gruß
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 1. Jul 2004, 07:59

siegbert hat geschrieben:Unter Suse 8.2 konnte ich mit beiden Druckern arbeiten. Seit ich Suse 9.1 installiert habe haben die Drucker noch nie gedruckt.
Gruß
Siegbert
Hallo,

hmm, ok dann müssen wir ganz von vorne anfangen! Ich versuch mal Dir hierbei zu helfen.Ich würde mal den CUPS via YAST2 kompl. neu inst. Ich würde vorschlagen das wir einen Drucker nach den anderen ins Rennen bringen. Also einen abstecken, am besten den PSC 1110, und dann sicherheitshalber neu booten.
Ja und jetzt via Yast2 den parallel Drucker einrichten.

Was meinst Du?

Schönen Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 1. Jul 2004, 12:38

Hallo,
werde heute abend cupd nochmal neu installieren. Melde mich dann wieder.
Danke für deine Hilfe
Grüße
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 1. Jul 2004, 13:05

siegbert hat geschrieben:Hallo,
werde heute abend cupd nochmal neu installieren. Melde mich dann wieder.
Danke für deine Hilfe
Grüße
Siegbert
Hi,

kein Problem, ich muß heute Abend zwar weg, aber morgen früh ca. 7.00 bin ich wieder hier ;-)

Keine Sorge das kriegen wir schon geschaukelt.....

Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 1. Jul 2004, 20:51

Hallo,
ich habe alle cups Pakete gelöscht, den Inhalt de Verzeichnisse /etc/cups/ , /var/log/cups/ habe ich ebenfalle gelöscht.
Danach habe ich alle cups Pakete neu installiert.
Leider hatte ich hiermit wieder kein Erfolg. Gleiche Fehlermeldung:
Beim speichern der Warteschlange ist ein Fehler aufgetreten.
Cups (File) Do Rwquest error: client-error-request-value-too-long

Beim Versuch den paralledrucker mit dem Web-Fontend des cups zu konfigurieren (http://127.0.0.1:631/admin) wird folgende Feldung ausgegeben:
Request Entity Too Large
Der Auftrag ist zu groß, um auf diesem Server verarbeitet zu werden.
Grüße
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 2. Jul 2004, 07:11

siegbert hat geschrieben:Hallo,
ich habe alle cups Pakete gelöscht, den Inhalt de Verzeichnisse /etc/cups/ , /var/log/cups/ habe ich ebenfalle gelöscht.
Danach habe ich alle cups Pakete neu installiert.
Leider hatte ich hiermit wieder kein Erfolg. Gleiche Fehlermeldung:
Beim speichern der Warteschlange ist ein Fehler aufgetreten.
Cups (File) Do Rwquest error: client-error-request-value-too-long

Beim Versuch den paralledrucker mit dem Web-Fontend des cups zu konfigurieren (http://127.0.0.1:631/admin) wird folgende Feldung ausgegeben:
Request Entity Too Large
Der Auftrag ist zu groß, um auf diesem Server verarbeitet zu werden.
Grüße
Siegbert
Hallo,

gut, hmmm - ok:
diese Fehlermeldung kommt beim einrichten des Druckers wenn Du die Konfig. abspeichern willst, oder?
andere Sache, was gibt df ( einfach in der Bash tippen und enter ) aus?

Ich recherchier mal was diese Meldung alles heißen könnte.

Das kriegen wir schon gebacken, keine Sorge.....

Schönen Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 2. Jul 2004, 07:25

Hallo,
kann mit erst wieder heute abend weiterprobieren, bin auf arbeit. Ich habe noch die rechte des Verzeichnis /etc/cups/ überprüft. Der User lp hat alle rechte. Beim Versuch den Parallelportdrucker mit yast einzurichten konnte ich den Anschluss testen und den Drucker den Ausdruck Hallo World entlocken.
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 2. Jul 2004, 07:54

siegbert hat geschrieben:Hallo,
kann mit erst wieder heute abend weiterprobieren, bin auf arbeit. Ich habe noch die rechte des Verzeichnis /etc/cups/ überprüft. Der User lp hat alle rechte. Beim Versuch den Parallelportdrucker mit yast einzurichten konnte ich den Anschluss testen und den Drucker den Ausdruck Hallo World entlocken.
Siegbert
hallo,
habe noch was gefunden evtl. hilfts, schau Dir bitte mal diese 2 links an:
http://lists.suse.com/archive/suse-linu ... /1678.html
http://lists.suse.com/archive/suse-linu ... /1769.html

und vielleicht noch weiter in --> Next in thread:

könnte eine Spur für uns sein.....

Schönen Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 2. Jul 2004, 08:50

Hallo,
das Verzeichnis /var/spool/cups/ ist auf meinem System nicht vorhanden. Soll ich es als User root oder lp anlegen?
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 2. Jul 2004, 10:50

siegbert hat geschrieben:Hallo,
das Verzeichnis /var/spool/cups/ ist auf meinem System nicht vorhanden. Soll ich es als User root oder lp anlegen?
Siegbert
hallo,

also bei mir siehts so aus:

drwx--x--- 3 lp lp 2832 2004-07-02 09:51 cups

ich würd es als root anlegen und dann Rechte wie oben vergeben und user und guppe mit chown lp und chgrp lp zuweisen, Rechte mit chmod 710 cups ;-)

Gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 2. Jul 2004, 18:22

Hallo,
ich habe das Verzeichnis /var/spool/cups/ angelegt. Jetzt kann ich den BJC250 mit yast einrichten aber immer noch nicht mal eine Testseite drucken.
Die Fehlermeldung erscheint nicht mehr.
Gruß
Siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 2. Jul 2004, 18:29

siegbert hat geschrieben:Hallo,
ich habe das Verzeichnis /var/spool/cups/ angelegt. Jetzt kann ich den BJC250 mit yast einrichten aber immer noch nicht mal eine Testseite drucken.
Die Fehlermeldung erscheint nicht mehr.
Gruß
Siegbert
Hallo,
gut, probier bitte mal, ob auf der bash mit lpr irgendeinetextdatei, mal sehen ob dann was kommt. jetzt hört es sich nach treiberprob. an.

gruß
RG

Benutzeravatar
siegbert
Newbie
Newbie
Beiträge: 49
Registriert: 24. Jun 2004, 12:13
Wohnort: 76703 Kraichtal

Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von siegbert » 3. Jul 2004, 11:34

Hallo,
ich habe das Verzeichnis /var/spool/cups/ und /var/spool/cups/tmp/ angelegt. Dann cups nochmals neu installiert. Jetzt kann ich mit dem BJC250 drucken. Nur mein HP PSC1110 will immer noch nicht.

gruß
siegbert

RG
Member
Member
Beiträge: 95
Registriert: 24. Jun 2004, 13:48

Re: Problem bei der Druckerinstallation Suse Linux 9.1 cups

Beitrag von RG » 3. Jul 2004, 17:20

siegbert hat geschrieben:Hallo,
ich habe das Verzeichnis /var/spool/cups/ und /var/spool/cups/tmp/ angelegt. Dann cups nochmals neu installiert. Jetzt kann ich mit dem BJC250 drucken. Nur mein HP PSC1110 will immer noch nicht.

gruß
siegbert
Hallo,

Super!
OK, dann nehmen wir uns jetzt den 2.Drucker vor ;-)
Gibts da eine Fehlermeldung?
Was passiert, wenn Du den Drucker im laufenden Betrieb erst ansteckst? Ist doch ein USB Gerät? Vielleicht erfahren wir so etwas mehr....

Super, ich freue mich für Dich, das jetzt der Ausdruck klappt, schön...

Gruß
RG

Antworten