Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Virtualbox Guest Additions 2.0.2xy - Hilfe:

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Virtualbox Guest Additions 2.0.2xy - Hilfe:

Beitrag von revealed »

Hallo!

Hier melde ich mich mal nochmal mit fortschreitenden interessen zu VirtualBox:

Ich habe jetzt eine Linux (SuSE 10.3) VM und eine Windows VM (Windows XP Pro) und mein Host System (SuSE 10.3);

Jedenfalls habe ich habe ich auf dem Hostsystem eben Virtualbox eingerichtet. Das klappt soweit. Networking läuft momentan alles via NAT; Jedes Virtuelle Diskimage hat an die 10 Gigabyte und liegt auf einer seperaten dafür angelegten Partition des Host.

Für das Windows XP habe ich die Guest additions installieren können. Guest Additions gehöhren im Gastsystem installiert. Dazu habe ich einfach Virtualbox heruntergeladen und im GAST sowie HOST installiert. Aber die Additions nur im Gastsystem; Dann bin ich auf dem Host System eben in VirtualBox rein. Habe dort die XPvm gestartet und bin oben im Menü auf:

Code: Alles auswählen

Geräte --> Gasterweiterungen installieren ...

Jedenfalls meinte er dann, dass er in zwei Pfaden das File nicht finden konnte und hat mir einen Link angeboten, der es ermöglicht ein ISO image herunterzuladen. Dieses habe ich heruntergeladen und dort mit folgendem Namen platziert:

Code: Alles auswählen

/usr/share/virtualbox/VBoxGuestAdditions.iso
Dann bin ich eben nochmals auf das Menü geräte -> installieren und zack startete innerhalb der VM die Installation. Ich wurde aufgefordert diverse Treiber trotzdem zu installieren alles gemacht gut ok. Und shared Folders funktionieren auch.

Es funktioniert auch, dass man einfach mit der Maus aus der VM auf den Desktop wechseln kann, ohne Hosttaste. Obendrein läuft das ganze recht flott und angenehm! Sehr schön!

Jedoch habe ich ein Problem mit dem Seemless Window Mode. Der funktioniert schlicht bei mir nicht. Er schaltet um. Aber nach dem Umschalten ist die VM unsichtbar? Weiss jemand, woran das liegt?

Dann noch ein Problem Mit dem SuSE 10.3 Gastsystem:
Vorgehen (Gast):
-> The Perfect Webserver Howto
-> ISPCONFIG installiert
-> VirtualBox installiert (mit GuestAdditions) vom Repo;
-> User vboxadd angelegt
-> X-Server Pattern nachinstalliert
-> Updates gemacht.
-> sax2
-> startx (Funtkioniert!)
-> Neugestartet

Vorgehen Host:
-> /usr/share/virtualbox/VBoxGuestAdditions.iso als CD Rom Image in der Konfiguration der VM eingebunden.

Vorgehen Gast:
-> VM gestartet
-> mount /dev/sr0 /media/fd0
-> cd /media/fd0
-> ./VBoxLinuxAdditions-x86.run
-> startx
-> Und das resultiert in einem schwarzen Bildschirm. Man sieht leider leider nur den Cursor und das war es. Interessanter Weise ändert der Mauszeiger auch seine Form innerhalb des Fensterbereichs der VM allerdings sieht man nix. Da bringts mir auch nichts, wenn ich Fenster verschieben kann. :(

Weiss jemand woran dies liegt? -- Hilfe!
EDIT: --> Lösung Linux GAST Problem #1;;
Direkt nach der Installation der VirtualBoxLinuxAdditions musste ich die xorg.conf editieren.
Dort den Eintrag Usemodes entfernen.
Die Sektion Modes entfernen;
In Sektion Screen alle Subsektionen die default enthalten bis auf die 24 Bit entfernen.
Xorg.conf des Gastsystem: (hat scheinbar noch paar schwierigkeiten -- versetzter Mauszeiger beispielsweise.)

Code: Alles auswählen

# /.../
# SaX generated X11 config file
# Created on: 2008-10-12T20:36:29+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
    Driver      "vboxmouse"
    Option      "CorePointer"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImExPS/2 Generic Explorer Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  305 230
  HorizSync    31-38
  Identifier   "Monitor[0]"
  ModelName    "800X600@60HZ"
  Option       "DPMS"
  VendorName   "--> VESA"
  VertRefresh  50-60
EndSection


Section "Screen"
  SubSection "Display"
    Depth      24
    Modes      "800x600" "640x480" "320x240" "1024x768"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "Framebuffer Graphics"
    Driver      "vboxvideo"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
Jetzt ist das Problem, dass der Seemles Mode garnicht funktioniert, geschwaige denn reagiert. Also bei STRG+L passiert garnichts. Mit der Maus einfach auf den Hostdesktop ohne Hosttaste klappt; Jedoch bin ich jetzt scheinbar an die erste festgelegte Auflösung in Section Screen gebunden. Mit Skalieren ist da nix. Diese Auflösung ist auch festgelegt für fullscreenmode. ?? Kennt sich da jemand aus?
/EDIT

Ahso und shared folder auf dem Linux gast funktioniert auch:
Auf Host:
Shared Folder anlegen und in VirtualBox bei den VM's konfigurieren.

Auf linux Gast:
-> mkdir /media/virtualbox
-> mount -t vboxsf SharedfolderShareNameAufHost /media/virtualbox
Man beachte hier^ diese schreibweise das wirkt wie nen Buchstabendreher, ist aber keiner.

Auf XP Gast:
Netzlaufwerk verbinden im Explorer.
Und wo ich da grad noch von der Windows VM auf meinem SuSE 10.3 Host rede, Sound geht über INTEL hda - ALSA;

Vielen Dank für Hilfe!

Gruß,

R

PS.: Und meine Screenshots werden immer sinnfreier.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |
Antworten