Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

ATI X1250 2 Soundkarten gelistet YAST

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

ATI X1250 2 Soundkarten gelistet YAST

Beitrag von tommy tulpe »

Hallo! Habe ATI x1250 onboard Soundkarte und das Paket realtek-linux-audiopack-4.05.e.tar.bz von der ATI Homepage runtergeladen und installiert. Es ist irgendwas schiefgelaufen und jetzt habe ich 2 Soundkarten im System, von denen ich die falsche nicht entfernen kann. Wie bekomme ich die weg? Habe die Vermutung, dass diese die ATI behindert, die ist nämlich als x1200 gelistet.
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
spoensche
Moderator
Moderator
Beiträge: 7587
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von spoensche »

Die x1250 ist keine Soundkarte, sondern meinse Wissens eine Grafikkarte.
Benutzeravatar
prinzunix
Hacker
Hacker
Beiträge: 520
Registriert: 19. Sep 2005, 11:05
Wohnort: Pulheim
Kontaktdaten:

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von prinzunix »

spoensche hat geschrieben:Die x1250 ist keine Soundkarte, sondern meinse Wissens eine Grafikkarte.
Nicht nur, denn die kann über HDMI auch Audio übertragen und nun weißt Du auch, warum da 2 sind.
Wenn man Audio über HDMI nicht braucht, dann lässt sich das eventuell im BIOS abschalten.
Habe ich bei mir gemacht.
Der Trend geht klar zum Siebtrechner. 64 Bit für alle!
Greets to linux-club.de powercrunchers!
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von whois »

Hi

Lässt du uns bitte das auch mal sehen.

Code: Alles auswählen

hwinfo --sound
bzw.

Code: Alles auswählen

lspci
cu
Benutzeravatar
prinzunix
Hacker
Hacker
Beiträge: 520
Registriert: 19. Sep 2005, 11:05
Wohnort: Pulheim
Kontaktdaten:

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von prinzunix »

whois hat geschrieben:Hi

Lässt du uns bitte das auch mal sehen.

Code: Alles auswählen

hwinfo --sound
Wäre nicht schlecht. Ich habe das Barebone mit dem AMD/ATI x1250 wieder aussortiert wegen
schlechter Treiberunterstützung bei 3D und DVB-Wiedergabe.

Bis denn.
Der Trend geht klar zum Siebtrechner. 64 Bit für alle!
Greets to linux-club.de powercrunchers!
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von tommy tulpe »

Danke für schnelle Nachricht. Ausgabe der infos später, da nicht mein pc

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von tommy tulpe »

hier hwinfo:
" hwinfo --sound
10: PCI 105.2: 0403 Audio device
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_1002_7919
Unique ID: dP62.Z4p2VAWz7L7
Parent ID: vSkL.HjQnVRFuoa8
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.2
SysFS BusID: 0000:01:05.2
Hardware Class: sound
Model: "ATI Radeon X1200 Series Audio Controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x7919 "Radeon X1200 Series Audio Controller"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x8287
Memory Range: 0xfe9e8000-0xfe9ebfff (rw,non-prefetchable)
IRQ: 10 (no events)
Module Alias: "pci:v00001002d00007919sv00001043sd00008287bc04sc03i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #30 (PCI bridge)

18: PCI 14.2: 0403 Audio device
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_1002_4383
Unique ID: 5Dex.fR1N9NDAEWC
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "ATI SBx00 Azalia"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x4383 "SBx00 Azalia"
SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
SubDevice: pci 0x8289
Memory Range: 0xfe7f4000-0xfe7f7fff (rw,non-prefetchable)
IRQ: 5 (no events)
Module Alias: "pci:v00001002d00004383sv00001043sd00008289bc04sc03i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown"

Hier lspci:

"lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]
01:05.2 Audio device: ATI Technologies Inc Radeon X1200 Series Audio Controller
03:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
04:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)"

Gruss

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von tommy tulpe »

Nachtrag:
Beim make Befehl im ersten Paket alsa-driver-1.0.17-5.07 kommt diese Fehlermeldung:

make
make dep
make[1]: Entering directory `/home/margot/Documents/Treiber/Sound/SUSE/realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07'
make[2]: Entering directory `/home/margot/Documents/Treiber/Sound/SUSE/realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07/acore'
copying file alsa-kernel/core/info.c
/home/margot/Documents/Treiber/Sound/SUSE/realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07/utils/patch-alsa: line 22: patch: command not found
make[2]: *** [info.c] Fehler 1
make[2]: Leaving directory `/home/margot/Documents/Treiber/Sound/SUSE/realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07/acore'
make[1]: *** [dep] Fehler 1
make[1]: Leaving directory `/home/margot/Documents/Treiber/Sound/SUSE/realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07'
make: *** [include/sndversions.h] Fehler 2


Das sagt mir nichts. Line 22 in alsa-driver-1.0.17-5.07/utils/patch-alsa scheint unbekannt zu sein. Hier "patch-alsa", line 22 habe ich die 22 vorangestellt:

#!/bin/sh
#
# copy a file from alsa-kernel tree and apply a patch
#

dst="$1"
pat=`echo $dst | sed -e 's/.c$/.patch/'`

case $dst in
/*)
xtmp=`dirname $dst | sed -e s@/acore@/core@ -e s@alsa-driver/@alsa-driver/alsa-kernel/@`/`basename $dst`
echo copying file $xtmp
cp -v $xtmp $dst || exit 1
patch -p0 $dst $pat || { rm $dst; exit 1; }
;;
*)
curd=`/bin/pwd`
MODCURDIR=`echo $curd | sed -e s@$SND_TOPDIR/@@`
xtmp=`echo $MODCURDIR | sed -e 's/^acore/core/'`/$dst
echo copying file alsa-kernel/$xtmp
cp $SND_TOPDIR/alsa-kernel/$xtmp $@ || exit 1
22 patch -p0 -i $pat || { rm $dst; exit 1; }
;;
esac
exit 0

Hilft das weiter?
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von whois »

Hi tommy

Schmeiss einen der Soundchips im Bios raus wenn das geht.
Am besten den prinzunix empfohlen hat da ich keine Erfahrung damit habe.

cu
Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von Tooltime »

Da wir ja festgestellt haben das die zwei Soundkarten Ok sind, frage ich mich was jetzt noch das Problem ist. Kein Sound? Schon mal probiert unter YaST -> Hardware -> Sound die primäre Soundkarte zu ändern?
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von tommy tulpe »

tooltime:
Na klar kein Sound.... Über Yast kann ich wahlweise eine Karte als primäre Soundkarte festlegen. Die Karten stehen aber als nicht kofiguriert drin. Wenn ich die automatische Konfiguration durchlaufen lasse, kommt aber jeweils die Fehlermeldung: Das Kernelmodul hda-snd-intel für die Soundunterstützung konnte nicht geladen werden. Ein möglicher Grund dafür könnten falsche Modulparameter sein, sowie ungültige IQ- oder IRQ
Parameter sein.
Ich bekomme doch aber beim make die geschilderte Fehlermeldung, kann da keiner was mit anfangen?
Whois:
Das mit dem bios werde ich mal testen und berichten

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von whois »

tommy tulpe hat geschrieben:Das mit dem bios werde ich mal testen und berichten
Das sollte zwar auch so gehen bei den aktuellen Distributionen aber ich habe festgestellt das es doch meist Probleme bereitet.
Damit wirst du dieses zumindest los. ;)
Tooltime
Advanced Hacker
Advanced Hacker
Beiträge: 1202
Registriert: 28. Mai 2008, 17:49

Re: ATI X1250 2 Soundkarten gelistet YAST

Beitrag von Tooltime »

Hatte vor kurzen ein Asus M3A (NB770,SB600)in Kombination mit einer ATI 3450 in der Hand. Da lief der Sound ohne Probleme, bis auf den Punkt das sich die Grafikkarte zuerst vor gedrängelt hat. Im BIOS hatte ich den Parameter
  • "Front Panel support Type" von "HD Audio" auf "AC97"
umgestellt. Klingt eigentlich nicht unbedingt danach etwas wesentliches zu verändern, aber vielleicht wird da mehr im Soundchip umgestellt, als der Name vermuten läßt.

Zu der Fehlermeldung bei make, sie bedeutet in der Datei
..../realtek-linux-audiopack-5.07/alsa-driver-1.0.17-5.07/utils/patch-alsa:
in Zeile 22 wird der Befehl patch aufgerufen und kann nicht gefunden werden.
--> der Befehl patch ist nicht installiert.

Also das Paket "patch" installieren, oder besser gleich das komplette allgemeine Zubehör zum Kompilieren.
YaST -> Software -> Software installieren oder löschen
"Filter" auf "Schemata" stellen.
In der Rubrik "Entwicklung" einfach "Grundlegende Entwicklungsumgebung" anwählen.
Mit Button "Akzeptieren" die entsprechenden Komponenten installieren.

Aus reiner Neugierde wie heißt das Motherboard eigentlich genau.
Antworten