Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Umgangen] KDE4-Amarok stürzt beim Öffnen ab

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
So*******

[Umgangen] KDE4-Amarok stürzt beim Öffnen ab

Beitrag von So******* »

Hallo,
seit ich KDE 4.1.2 installiert habe, stürzt bei mir die KDE 4 Version von Amarok beim
Öffnen ab.
Hier die Fehlermeldung:
Application: Amarok (amarok), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[Current thread is 0 (LWP 11073)]
Thread 6 (Thread 0xb0f45b90 (LWP 11076)):
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb7ddcf42 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0xb1a81841 in ?? () from /usr/lib/libxine.so.1
Thread 5 (Thread 0xb0744b90 (LWP 11077)):
#0 0xb7ddbbc6 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1 0xb68516cb in ?? () from /usr/lib/libglib-2.0.so.0
#2 0xb68519d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3 0xb7f54217 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#4 0xb7f2813a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#5 0xb7f282fa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#6 0xb7e36549 in QThread::exec () from /usr/lib/libQtCore.so.4
#7 0xb1ad05c9 in ?? () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#8 0xb7e3984e in ?? () from /usr/lib/libQtCore.so.4
#9 0xb7dd9175 in start_thread () from /lib/libpthread.so.0
#10 0xb766edce in clone () from /lib/libc.so.6
Thread 4 (Thread 0xaff43b90 (LWP 11080)):
#0 0xb398e452 in snd_mixer_poll_descriptors () from /usr/lib/libasound.so.2
#1 0xb1916f2c in ?? () from /usr/lib/xine/plugins/1.24/xineplug_ao_out_alsa.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Thread 3 (Thread 0xaf700b90 (LWP 11081)):
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb7ddcc15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0xb1a94024 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Current language: auto; currently asm
Thread 2 (Thread 0xaeeffb90 (LWP 11082)):
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb7667ef1 in select () from /lib/libc.so.6
#2 0xb7f08e67 in ?? () from /usr/lib/libQtCore.so.4
#3 0xb7e3984e in ?? () from /usr/lib/libQtCore.so.4
#4 0xb7dd9175 in start_thread () from /lib/libpthread.so.0
#5 0xb766edce in clone () from /lib/libc.so.6
Thread 1 (Thread 0xb37856f0 (LWP 11073)):
[KCrash Handler]
#6 0xb6a80176 in QAction::setEnabled () from /usr/lib/libQtGui.so.4
#7 0xb7911111 in Playlist::Model::insertTracksCommand () from /usr/lib/libamaroklib.so.1
#8 0xb791be92 in Playlist::AddTracksCmd::redo () from /usr/lib/libamaroklib.so.1
#9 0xb706b558 in QUndoStack::push () from /usr/lib/libQtGui.so.4
#10 0xb790de9d in Playlist::Model::insertTracks () from /usr/lib/libamaroklib.so.1
#11 0xb7911eee in Playlist::Model::insertOptioned () from /usr/lib/libamaroklib.so.1
#12 0xb7912368 in Playlist::Model::insertOptioned () from /usr/lib/libamaroklib.so.1
#13 0xb7912736 in Playlist::Model::restoreSession () from /usr/lib/libamaroklib.so.1
#14 0xb7a8580d in App::continueInit () from /usr/lib/libamaroklib.so.1
#15 0xb7a85a9b in App::qt_metacall () from /usr/lib/libamaroklib.so.1
#16 0xb7f3e730 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#17 0xb7f3f4b2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb7f44b77 in ?? () from /usr/lib/libQtCore.so.4
#19 0xb7f44c9c in ?? () from /usr/lib/libQtCore.so.4
#20 0xb7f391ef in QObject::event () from /usr/lib/libQtCore.so.4
#21 0xb6a8482c in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#22 0xb6a8c6ce in QApplication::notify () from /usr/lib/libQtGui.so.4
#23 0xb740cded in KApplication::notify () from /usr/lib/libkdeui.so.5
#24 0xb7f29a61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#25 0xb7f57dd6 in ?? () from /usr/lib/libQtCore.so.4
#26 0xb7f542a0 in ?? () from /usr/lib/libQtCore.so.4
#27 0xb684e2d9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0xb685185b in ?? () from /usr/lib/libglib-2.0.so.0
#29 0xb68519d8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0xb7f541f8 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#31 0xb6b1d885 in ?? () from /usr/lib/libQtGui.so.4
#32 0xb7f2813a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#33 0xb7f282fa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#34 0xb7f2a995 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#35 0xb6a846a7 in QApplication::exec () from /usr/lib/libQtGui.so.4
#36 0x0804bf06 in main ()

Wer kann mir evtl. bei diesem Problem helfen ?


Danke im Voraus.

Gruß
Sonja
gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: KDE4-Amarok stürzt beim Öffnen ab

Beitrag von gropiuskalle »

Hallo Sonja,

Die Meldungen lassen auf Probleme mit Qt4 schließen, als Frage fällt mir dazu erstmal nur ein, ob Du das KDE:Qt-Repository schon eingebunden hast - ein aktuelles KDE4 benötigt daraus zahlreiche Pakete. Das ist aber ehrlich gesagt nur so ins Blaue getippt...

Allgemein empfehle ich, zunächst amarok 1.4 zu verwenden, denn die 1.92 ist noch sowas von beta, wie es betaiger kaum geht (ist schließlich auch nur der Vorläufer der Version 2.0). Ich kann damit zwar tracks abspielen, aber weder eine Sammlung erstellen lassen, noch Cover holen noch plugins nutzen.
So*******

Re: KDE4-Amarok stürzt beim Öffnen ab

Beitrag von So******* »

Hallo und danke für deine Antwort,
ich habe Amarok 1.4 auch installiert.

Unter KDE 4.0 habe ich auch schon mit dieser Alpha - Version
meine Musik angehört.

Ich werde einfach abwarten, bis es dann die Version 2.0 Final
gibt.
Aber vielleicht löst sich das Problem ja auch wieder mit einer
neueren Version von KDE 4 von selbst.

Danke für die Hilfe.

Gruß
Sonja
So*******

Re: [Umgangen] KDE4-Amarok stürzt beim Öffnen ab

Beitrag von So******* »

Hallo,
ich möchte mich noch mal dazu melden.
Heute habe ich die neue Version 1.92.2 mit samt der deutschen
Sprache installiert.
Jetzt klappt der Player wieder.
Gruß
Sonja
Antworten