Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
wichita_c12ca
Member
Member
Beiträge: 114
Registriert: 5. Okt 2008, 21:27

[gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von wichita_c12ca »

Hallo,
ich hab jetz vor kurzem openSuSe neben mein Windows XP Home installiert um Linux einfach mal kennen zu lernen.
Mir gefällt Linux auch ganz gut, das Problem ist nur, ich bin jetz ein totaler noob.
Unter Windows kenn ich mich recht gut aus und werd auch oft als Freak bezeichnet, aber Linux ist ja was ganz anderes.

Mein erstes Problem das ich nicht gelöst krieg:
Ich würd gern meine 3 NTFS Partitionen mit Read-Write Rechten unter Linux erreichbar machen.
Ich hab schon rausgefunden, dass man da irgendwie mit dem Befehl mount rumhantieren muss und dass die datei /etc/fstab etwas damit zu tun hat.

Wenn ich versuche meine erste Partition (bei windows: C bei Linux: sda1)
in den ordner /mnt/windows/ zu mounten:

Code: Alles auswählen

su
Passwort:
mkdir /mnt/windows
mount /dev/sda1 /mnt/windows/
dann kommt beim öffnen von /mnt/windows/
einfach nur ein leerer ordner.


in der fstab steht folgendes drin:

Code: Alles auswählen

/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part6 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part7 /home                ext3       acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part3 /windows/D           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part4 /windows/E           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
so wie ich das verstehe müssten meine partitionen automatisch nach /windows/[buchstabe] gemountet werden. aber auch diese ordner sind leer.

ich hoffe ihr könnt mir helfen. :D
Zuletzt geändert von wichita_c12ca am 7. Okt 2008, 12:59, insgesamt 1-mal geändert.
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

Ntfs-3g installiert? Wenn nicht, nachholen.
Zeig doch mal zusätzlich die Ausgabe von

Code: Alles auswählen

fdisk -l (kleines L)
als Root unter Linux.
Um auch Schreibrechte zu haben sollte der Eintrag in der fsatb so aussehen

Code: Alles auswählen

/dev/disk/dein_Kram    /Mountpunkt    ntfs-3g    user,users,gid=users,fmask=133,dmask=022,umask=0002,locale=de_DE.UTF-8    0 0
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
wichita_c12ca
Member
Member
Beiträge: 114
Registriert: 5. Okt 2008, 21:27

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von wichita_c12ca »

hallo,
danke erstmal für die super schnelle antwort.

YaST zeigt an das Ntfs-3g installiert ist.

ausgabe von fdisk -l

Code: Alles auswählen

fdisk -l

Platte /dev/sda: 122.9 GByte, 122942324736 Byte
255 Köpfe, 63 Sektoren/Spuren, 14946 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x9a639a63

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           1        3186    25591513+   7  HPFS/NTFS
/dev/sda2           12337       14946    20964825    f  W95 Erw. (LBA)
/dev/sda3            3187        9099    47496172+   7  HPFS/NTFS
/dev/sda4            9100       12336    26001202+   7  HPFS/NTFS
/dev/sda5           12337       12598     2104483+  82  Linux Swap / Solaris
/dev/sda6           12599       13588     7952143+  83  Linux
/dev/sda7           13589       14946    10908103+  83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge
in der fstab hab ich vor die 3 entsprechenden zeilen das "user," davorgeschrieben.

edit: ach ja, da vorher ne fehlermeldung angezeigt wurde (ich glaube >>unbekanntes dateiformat "ntfs"<< und dasselbe auch für meinen usb-stick. nur mit "vfat") hatte ich gegoogelt und den hinweis gefunden dass ich die beiden module mit modprobe nachladen soll. dass hab ich dann auch gemacht, und seitdem kommt die fehlermeldung nicht mehr. mein usb-stick funktioniert jetz auch. aber die partitionen werden nicht angezeigt.
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

Das "user" allein wird nicht reichen. Schau auf die ganze Zeile, dass die da so steht. Ansonsten schau mal in /var/log/messages oder var/log/boot.msg ob es dort Fehlermeldungen beim Mounten gab. Könnte sein, dass das Dateisystem nicht ganz stimmt. Dann ggf. unter Windows mal chkdsk drüberlaufen lassen. Was sagt die Ausgabe von

Code: Alles auswählen

mount
bzw gibt es Fehlermeldungen wenn du manuell mountest oder wird das so akzeptiert?
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von Heinz-Peter »

Also ich verstehe das nicht. Warum soll er die Windows Verzeichnisse mit Kommando mount einbinden?
Er hat dort bestimmt grafische Oberfläche, ich meine KDE oder Gnome also die Verzeichnisse werden automatisch nach dem hochfahren eingebunden. Ja, er kann vielleicht nicht auf NTFS Partition (WIN Partition) schreiben aber deswegwn muss er nicht gleich mount ausführen.
Das er im Linux die ersten Schritte macht soll er lieber das lesen: http://wiki.linux-club.de/opensuse/Partition
Gruß
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

1. hat er das schon manuell gemacht allerdings nicht geschrieben ob es entsprechende Meldungen auf der Konsole gab
2. hab ich nicht gesagt dass er das tun soll, sondern
3. will ich wissen ob die aktuell gemountet sind oder nicht (deswegen ein einzelnes "mount")
4. werden sie ja anscheinend nicht korrekt eingebunden, da er nicht nur nicht drauf schreiben kann sondern nicht einmal lesen (außerdem ist das Vorhandensein einer grafischen Oberfläche kein Indiz für automatisches Mounten) ;)
5. sollte er sich richtiger Weise im Wiki einlesen, allerdings versuche ich gerade lieber direkt zu helfen ;)
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von Heinz-Peter »

(außerdem ist das Vorhandensein einer grafischen Oberfläche kein Indiz für automatisches Mounten)
Mit der Aussage bin ich nicht einverstanden.
Bei der Suse (Standart) Installation werden alle Festplatten eingebunden. Festplatten die später dazu kommen müssen von „Hand“ eingebunden werden.
Gruß
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
wichita_c12ca
Member
Member
Beiträge: 114
Registriert: 5. Okt 2008, 21:27

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von wichita_c12ca »

das mounten wird einfach so stumm hingenommen. keine fehlermeldung.
danach liefert mount:

Code: Alles auswählen

linux-68t4:~ # mount
/dev/sda6 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda7 on /home type ext3 (rw,acl,user_xattr)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sda1 on /mnt/windows type ntfs (rw)
aber wenn ich jetz in den ordner /mnt/windows/ reingehe erschein unten in rot der hinweis:
ordner /mnt/windows lässt sich nicht öffnen

so und die beiden logs haben geholfen!

in /var/log/boot.msg ist imho das hier interessant:

Code: Alles auswählen

Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Die Operation ist nicht erlaubt
The NTFS partition is hibernated. Please resume and shutdown Windows
properly, or mount the volume read-only with the 'ro' mount option, or
mount the volume read-write with the 'remove_hiberfile' mount option.
For example type on the command line:

            mount -t ntfs-3g /dev/sda1 /windows/C -o remove_hiberfile

$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda3': Die Operation wird nicht unterstützt
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sda3 /windows/D -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sda3 /windows/D ntfs-3g force 0 0
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda4': Die Operation wird nicht unterstützt
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/sda4 /windows/E -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/sda4 /windows/E ntfs-3g force 0 0
failedFuse filesystem already availabledone
Mounting fuse control filesystemdone 
in /var/log/messages imho das hier:

Code: Alles auswählen

Oct  7 12:08:52 linux-68t4 kernel: NTFS-fs warning (device sda1): load_system_files(): Unsupported volume flags 0x4000 encountered.
Oct  7 12:08:52 linux-68t4 kernel: NTFS-fs error (device sda1): load_system_files(): Volume has unsupported flags set.  Mounting read-only.  Run chkdsk and mount in Windows.
Oct  7 12:08:52 linux-68t4 kernel: NTFS-fs warning (device sda1): load_system_files(): $LogFile is not clean.  Will not be able to remount read-write.  Mount in Windows.
Oct  7 12:08:52 linux-68t4 kernel: NTFS-fs warning (device sda1): load_system_files(): Windows is hibernated.  Will not be able to remount read-write.  Run chkdsk. 
und weil das steht das ihn stört das windows hibernated (im ruhezustand) ist, hab ich mich mal unter windows angemeldet und es ganz sauber heruntergefahren. und jetz gehts!

ich frag mich warum ich nicht selbst darauf gekommen bin.
danke für die super hilfe.
ich hab jetz zwar erstmal nur read rechte, aber ich denke mit ein bisschen lesen und ausprobieren krieg ich das auch noch write rechte ;)

PS: ich hab KDE 4.1
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

Sowas hatte ich in Verdacht.
Für die Schreibrechte die gesamte Zeile in der fstab so abändern wie ich dir gepostet habe ;)
Ansonsten, lesen und fragen ;)
Und dann diesen Thread bitte auf gelöst setzen. Einfach deinen ersten Beitrag bearbeiten und dem Titel ein [gelöst] voranstellen. Danke.
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
wichita_c12ca
Member
Member
Beiträge: 114
Registriert: 5. Okt 2008, 21:27

Re: NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von wichita_c12ca »

ich hab die zeile(n) in der fstab so umgeändert wie du es gepostet hast. aber ich hab trotzdem nur leserechte.
fstab sieht jetz so aus:

Code: Alles auswählen

/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part6 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part7 /home                ext3       acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part1 /windows/C           ntfs-3g    user,users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part3 /windows/D           ntfs-3g    user,users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part4 /windows/E           ntfs-3g    user,users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
ich denke rw wird mir read-write rechte geben oder?

edit: nein! rw bringt auch nichts. naja dann suche und lese ih halt noch ein bisschen
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: [gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

Ich sag nur umask ;)
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: [gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von Heinz-Peter »

Das hat @lOtz geschrieben:

Code: Alles auswählen

/dev/disk/dein_Kram    /Mountpunkt    ntfs-3g    user,users,gid=users,fmask=133,dmask=022,umask=0002,locale=de_DE.UTF-8    0 0
Das ist Auszug aus Deiner fsab

Code: Alles auswählen

/dev/disk/by-id/scsi-SATA_Maxtor_4G120J6_G60J1DEE-part1 /windows/C           ntfs-3g    user,users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
@lOtz hat noch in seinem Tipp umask=0002 drin. Ich habe mich bis jetzt mit dem Problem nicht beschäftigt deswegen verlasse ich mich voll auf @lOtz

Gruß

Edit: @lOtz war schneller. 1:0 für Ihn. Ich weiß auch warum. Ich schreibe hier aus Windows und muss immer die rechte Maustaste drücken dann kopieren und ... und dann verwechsle ich das noch alles.
Ich werde langsam alt.
Heißt das seid neustem senil?
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
wichita_c12ca
Member
Member
Beiträge: 114
Registriert: 5. Okt 2008, 21:27

Re: [gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von wichita_c12ca »

lOtz hat geschrieben:Ich sag nur umask ;)
Mario Barth hat geschrieben: :schockiert: das hast du da grad hingemacht!!!
peinlich, peinlich :ops: :ops:
das mir das auch gleich im ersten Thema passieren muss!


Naja jetz läufts auf jedenfall mir read-write rechten und ich bedanke mich nochmal ganz herzlich bei lOtz und Heinz-Peter!
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: [gelöst] NTFS Partition nicht sichtbar trotz mount und fstab

Beitrag von lOtz1009 »

x_puma_x hat geschrieben:
Mario Barth hat geschrieben:
:schockiert: das hast du da grad hingemacht!!!
:D neenee ;)
x_puma_x hat geschrieben:peinlich, peinlich :ops: :ops:
nicht solange man draus lernt ;)
x_puma_x hat geschrieben:Naja jetz läufts auf jedenfall mir read-write rechten und ich bedanke mich nochmal ganz herzlich bei lOtz und Heinz-Peter!
Freut mich und "gerne :up:"
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Antworten