Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Patch wg. Abhängigkeitsprob. nicht installierbar

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Benutzeravatar
mafg
Member
Member
Beiträge: 104
Registriert: 28. Aug 2008, 22:25

[gelöst] Patch wg. Abhängigkeitsprob. nicht installierbar

Beitrag von mafg »

Hallo Leute!

Auf meinem Lenovo 3000 N200 läuft opensuse 10.3, KDE 3.5.7-87.5, Kernel 2.6.22.18-0.2.

Seit einigen Wochen stellt YOU einen Patch namens bytefx-data-mysql zur Verfügung, der Sicherheitslücken in der mono-core Umgebung schliessen soll (wenn ich es richtig verstanden habe :/ ). Allerdings kann ich es wegen nicht auflösbarer Abhängigkeiten nicht installieren. Ich habe mir die Liste schon oft durchgelesen, steige aber einfach nicht dahinter, wo ich ansetzen muss, bzw. kann um die Abhängigkeiten aufzulösen.

Hier die conflicts list:

Code: Alles auswählen

#### YaST2 conflicts list - generated 2008-10-04 22:06:41 ####

bytefx-data-mysql kann aufgrund fehlender Abhaengigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von mono-core == 1.9.1-3.1 verfuegbar fuer bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird vom Benutzer installiert.
        mono-core-1.2.5-16.2.i586 wird benoetigt von bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono(ICSharpCode.SharpZipLib) == 2.84.0.0)
        mono-data-1.2.5-16.2.i586 wird benoetigt von bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono(System.Data) == 2.0.0.0)
    Weitere 4...
    Konfliktloesung:
        ( ) bytefx-data-mysql nicht installieren
        ( ) Anforderung nur hier ignorieren
mono-data kann aufgrund fehlender Abhaengigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von mono-core == 1.9.1-3.1 verfuegbar fuer mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird benoetigt von bytefx-data-mysql-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-data == 1.9.1-3.1)
        mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] stellt mono-core == 1.9.1-3.1 zur Verfuegung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        atom:mono-data-1.2.5-16.2.i586 wird zur Installation in Betracht gezogen (als Ergaenzung) von mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-data == 1.9.1-3.1)
    (null)
    Konfliktloesung:
        ( ) mono-data nicht installieren
        ( ) Anforderung nur hier ignorieren

#### YaST2 conflicts list END ###
Installiert ist mono-core 1.2.5-16.2. Wenn ich das aktuallisiere wird die Liste der Konflikte noch länger... :???:

Code: Alles auswählen

#### YaST2 conflicts list - generated 2008-10-04 22:15:02 ####

Anforderung mono-core == 1.2.5-16.2 für mono-data-sqlite-1.2.5-16.2.i586 kann nicht erfüllt werden

Fehlende Abhängigkeiten von beagle
    Es sind keine installierbaren Anbieter von mono-data-sqlite verfügbar für beagle-0.2.18-30.i586
    === beagle-0.2.18-30.i586 ===
        mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird benötigt von beagle-0.2.18-30.i586 (libmono.so.0)
        mono-data-sqlite-1.2.5-16.2.i586 stellt mono-data-sqlite == 1.2.5-16.2 zur Verfügung, soll jedoch planmässig deinstalliert werden.
        mono-data-sqlite-1.2.5-16.2.i586[openSUSE-10.3-Updates] stellt mono-data-sqlite == 1.2.5-16.2 zur Verfügung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        beagle-0.2.18-30.i586 hängt von mono-data-sqlite ab
        beagle-0.2.18-30.i586 fehlt die Anforderung mono(Mono.Data.SqliteClient) == 2.0.0.0
    (null)
    Konfliktlösung:
        ( ) beagle löschen
        ( ) Anforderung nur hier ignorieren
Fehlende Abhängigkeiten von beagle-index
    Es sind keine installierbaren Anbieter von beagle verfügbar für beagle-index-10.3_20070203-118.i586
    === beagle-index-10.3_20070203-118.i586 ===
        beagle-0.2.18-30.i586 stellt beagle == 0.2.18-30 zur Verfügung, soll jedoch planmässig deinstalliert werden.
        beagle-0.2.18-30.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt beagle == 0.2.18-30 zur Verfügung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        beagle-index-10.3_20070203-118.i586 hängt von beagle ab
        beagle-index-10.3_20070203-118.i586 fehlt die Anforderung beagle
    (null)
    Konfliktlösung:
        ( ) beagle-index löschen
        ( ) Anforderung nur hier ignorieren
Fehlende Abhängigkeiten von kdebase3-beagle
    Es sind keine installierbaren Anbieter von beagle >= 0.2.4 verfügbar für kdebase3-beagle-3.5.7-87.5.i586
    === kdebase3-beagle-3.5.7-87.5.i586 ===
        beagle-0.2.18-30.i586 stellt beagle == 0.2.18-30 zur Verfügung, soll jedoch planmässig deinstalliert werden.
        beagle-0.2.18-30.i586[http://download.opensuse.org/repositories/openSUSE:10.3/standard/] stellt beagle == 0.2.18-30 zur Verfügung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        kdebase3-beagle-3.5.7-87.5.i586 hängt von beagle ab
        kdebase3-beagle-3.5.7-87.5.i586 fehlt die Anforderung beagle >= 0.2.4
    (null)
    Konfliktlösung:
        ( ) kdebase3-beagle löschen
        ( ) Anforderung nur hier ignorieren
mono-core kann aufgrund fehlender Abhängigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von libgdiplus0 verfügbar für mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird vom Benutzer installiert.
        glibc-2.6.1-18.3.i686 wird benötigt von mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (libc.so.6)
        zlib-1.2.3-75.i586 wird benötigt von mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (libz.so.1)
    Weitere 9...
    Konfliktlösung:
        ( ) mono-core nicht installieren
        ( ) Anforderung nur hier ignorieren
mono-data kann aufgrund fehlender Abhängigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von mono-core == 1.9.1-3.1 verfügbar für mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird benötigt von mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-core == 1.2.5-16.2)
        mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] stellt mono-core == 1.9.1-3.1 zur Verfügung, soll jedoch planmässig deinstalliert werden.
        mono-core-1.2.5-16.2.i586[openSUSE-10.3-Updates] stellt mono(mscorlib) == 1.0.5000.0 zur Verfügung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        atom:mono-data-1.2.5-16.2.i586 wird zur Installation in Betracht gezogen (als Ergänzung) von mono-data-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-data == 1.9.1-3.1)
    (null)
    Konfliktlösung:
        ( ) mono-data nicht installieren
        ( ) Anforderung nur hier ignorieren
mono-web kann aufgrund fehlender Abhängigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von mono-core == 1.9.1-3.1 verfügbar für mono-web-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === mono-web-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        mono-data-sqlite-1.2.5-16.2.i586 wird benötigt von mono-web-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono(Mono.Data.Sqlite) == 2.0.0.0)
        mono-web-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird benötigt von mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-core == 1.2.5-16.2)
        mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] stellt mono-core == 1.9.1-3.1 zur Verfügung, soll jedoch planmässig deinstalliert werden.
        mono-core-1.2.5-16.2.i586[openSUSE-10.3-Updates] stellt mono(mscorlib) == 1.0.5000.0 zur Verfügung, ist aber nicht installierbar.  Versuchen Sie das Objekt separat zu installieren, um weitere Details zu erhalten.
        atom:mono-web-1.2.5-16.2.i586 wird zur Installation in Betracht gezogen (als Ergänzung) von mono-web-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-web == 1.9.1-3.1)
    (null)
    Konfliktlösung:
        ( ) mono-web nicht installieren
        ( ) Anforderung nur hier ignorieren
mono-winforms kann aufgrund fehlender Abhängigkeiten nicht installiert werden
    Es sind keine installierbaren Anbieter von mono-core == 1.9.1-3.1 verfügbar für mono-winforms-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/]
    === mono-winforms-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] ===
        mono-data-1.2.5-16.2.i586 wird benötigt von mono-winforms-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono(System.Data) == 2.0.0.0)
        mono-web-1.2.5-16.2.i586 wird benötigt von mono-winforms-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono(System.Web) == 2.0.0.0)
        mono-winforms-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] wird benötigt von mono-core-1.9.1-3.1.i586[http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/] (mono-core == 1.2.5-16.2)
    Weitere 4...
    Konfliktlösung:
        ( ) mono-winforms nicht installieren
        ( ) Anforderung nur hier ignorieren

#### YaST2 conflicts list END ###
Ich wäre froh, wenn mir jemand auf die Sprünge helfen könnte.

Danke und Gruß,
matthias
Zuletzt geändert von mafg am 9. Okt 2008, 21:10, insgesamt 1-mal geändert.
Benutzeravatar
mafg
Member
Member
Beiträge: 104
Registriert: 28. Aug 2008, 22:25

Re: bytefx-data-mysql wg. Abhängigkeitsprob. nicht installierbar

Beitrag von mafg »

Also...
ich hab mich jetzt noch mal durchgewühlt und herausgefunden, dass u.a. libgdiplus0 benötigt wird. Meine Installationsquellen geben aber nur libgdiplus her. Die einzige Quelle für dieses repository habe ich auf http://ftp5.gwdg.de/pub/opensuse/reposi ... nSUSE_10.3 gefunden.
Bei der Initialisierung der Quelle brechen allerdings sowohl YAST, als auch zypper mit einem parse error ab.

Kennt zufällig jemand noch eine weitere Quelle für libgdiplus0?

Danke,
matthias
gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: bytefx-data-mysql wg. Abhängigkeitsprob. nicht installierbar

Beitrag von gropiuskalle »

URL richtig angegeben? Prüf die doch mal etwas genauer.

In Zukunft »Webpin« verwenden, damit ersparst Du Dir langes Herumgesuche.
Benutzeravatar
mafg
Member
Member
Beiträge: 104
Registriert: 28. Aug 2008, 22:25

Re: [gelöst] Patch wg. Abhängigkeitsprob. nicht installierbar

Beitrag von mafg »

gropiuskalle hat geschrieben:URL richtig angegeben? Prüf die doch mal etwas genauer.
Habe die URL abgeschrieben, als es nicht ging kopiert und als das nicht ging wieder abgeschrieben. In der Zwischenzeit hatte ich auch das Paket auf dem opensuse server gefunden und als Quelle angegeben. Leider mit demselben Ergebnis.
Habe es dann einfach heruntergeladen und von local installiert. Damit war dann auch das Problem mit dem Patch und den Mono-Paketen gelöst. :D
gropiuskalle hat geschrieben:In Zukunft »Webpin« verwenden, damit ersparst Du Dir langes Herumgesuche.
Vielen Dank für den Link!

Gruß,
matthias
Antworten