Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kein Ton mit Webcammikrofon

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
WhopperBS
Member
Member
Beiträge: 153
Registriert: 8. Jan 2007, 11:53

Kein Ton mit Webcammikrofon

Beitrag von WhopperBS »

Hallo zusammen,

mein Notebook hat eine eingebaute Webcam von Chicony Electronics (Device-ID: 04f2:b018), die so weit auch ganz ordentlich funktioniert. Leider kann ich aber nicht das ebenfalls integrierte Mikrofon benutzen. Wenn ich 'modprobe snd-usb-audio' eingebe, passiert leider auch nichts (außer, dass das Modul geladen wird). Nach einem Neustart von alsa fliegt das Modul auch wieder raus.

Hier mal ein paar Ausgaben, die u.U. hilfreich sein könnten:

Code: Alles auswählen

rpm -qa | grep uvcvideo
uvcvideo-kmp-default-r242_2.6.25.16_0.1-2.3

Code: Alles auswählen

lsusb
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 04f2:b018 Chicony Electronics Co., Ltd Video Device
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 147e:2016
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Beim Gerät 147e:2016 handelt es sich übrigens um einen Fingerabdrucksensor.

Code: Alles auswählen

lsmod | grep uvcvideo
uvcvideo               76680  0
compat_ioctl32         25984  1 uvcvideo
videodev               52096  3 saa7146_vv,uvcvideo,compat_ioctl32
v4l1_compat            29444  3 saa7146_vv,uvcvideo,videodev
usbcore               188376  9 ohci_hcd,dvb_usb_dtt200u,uvcvideo,dvb_usb,usbhid,usb_storage,ehci_hcd,uhci_hcd

Code: Alles auswählen

lsmod | grep snd
snd_pcm_oss            68992  0
snd_mixer_oss          35584  1 snd_pcm_oss
snd_seq                83600  0
snd_seq_device         26516  1 snd_seq
snd_hda_intel         497580  3
snd_pcm               115208  3 snd_pcm_oss,snd_hda_intel
snd_timer              45072  3 snd_seq,snd_pcm
snd_page_alloc         28688  2 snd_hda_intel,snd_pcm
snd_hwdep              28424  1 snd_hda_intel
snd                    96248  12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore              26000  1 snd
In KMix sind alle Regler bis zum Anschlag aufgedreht und ein "richtiges" Mikro kann ich auch sinnvoll verwenden. Das Ganze findet mit openSUSE 11.0 64-Bit statt.

Wäre schön, wenn jemand helfen könnte!
Antworten