Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Hi Leute,

nach der Anschaffung eines Samsung R710 (Notebook) habe ich ein Problem mit der Ethernet-Karte. Bekomme die Karte zwar im Yast angezeigt, kann sie aber nicht konfigurieren.

Mein System:

openSUSE 11.0
kernel-default-2.6.25.16-0.1
kernel-source-2.6.25.16-0.1
linux-kernel-headers-2.6.25-8.1
(gcc, make, pp. vorhanden)

Gem. "dmesg" sollte das Problem hier liegen:

ACPI: PCI Interrupt 0000:06:00.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Unable to reserve I/O region #3:100@5000 for device 0000:06:00.0
sky2 0000:06:00.0: cannot obtain PCI resources
ACPI: PCI interrupt for device 0000:06:00.0 disabled
sky2: probe of 0000:06:00.0 failed with error -16
Driver 'sr' needs updating - please use bus_type methods

Über "lspci" ist der Bösewicht auch schnell gefunden:

06:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)

Im Netz bin ich bezüglich meines Problems nicht fündig geworden. Hab dann über den Hersteller das Treiberpaket "Kernel v2.4.20+ Linux Driver Install Package v10.61.3.3" geladen und über die Konsole installiert. Bis zum Kompilieren des Kernels lief auch alles durch, dann kam ein Fehler.

Das Log zur Treiberinstallation sieht so aus:

+++ Compile the driver
+++ ====================================
make: Entering directory `/usr/src/linux-2.6.25.16-0.1'

WARNING: Symbol version dump /usr/src/linux-2.6.25.16-0.1/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.o
CC [M] /tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.o
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c: In function ‘sk98lin_init_device’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:483: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:484: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:489: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:490: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:611: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:612: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:617: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:618: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c: In function ‘SkGeIsr’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:2315: error: too few arguments to function ‘netif_rx_schedule_prep’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:2318: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c: In function ‘SkGeIsrOnePort’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:2486: error: too few arguments to function ‘netif_rx_schedule_prep’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:2491: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c: In function ‘SkGePoll’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:3250: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:3250: warning: type defaults to ‘int’ in declaration of ‘_y’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:3250: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:3271: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.c:3275: error: too few arguments to function ‘netif_rx_complete’
make[1]: *** [/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/skge.o] Fehler 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c: In function ‘SkY2Isr’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:428: error: implicit declaration of function ‘__netif_rx_schedule_prep’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:429: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c: In function ‘SkY2Poll’:
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:665: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:665: warning: type defaults to ‘int’ in declaration of ‘_y’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:665: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:672: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.c:694: error: too few arguments to function ‘netif_rx_complete’
make[1]: *** [/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all/sky2.o] Fehler 1
make: *** [_module_/tmp/Sk98IiVKXbBIOpFUZpihVqTMa/all] Fehler 2
make: Leaving directory `/usr/src/linux-2.6.25.16-0.1'
+++ Compiler error

Und exakt an dieser Stelle bleibe ich hängen. Jemand 'ne Idee oder gar die Lösung?
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Grothesk »

Such da mal nach 'sky2-backport'

http://www.pc-forum24.de/downloads.php?do=search

Rückmeldung zu dem Modul ist höchst willkommen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5540
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von tomm.fa »

Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Grothesk hat geschrieben:Rückmeldung zu dem Modul ist höchst willkommen.
Erst mal Danke für die schnellen Antworten! :)

Leider bin ich nicht wirklich weiter gekommen. Sowohl die "aktuellen" als auch die "zurück portierten" Module lassen sich zwar problemlos über den Paketmanager einbinden, die Ethernetkarte lässt sich aber partout nicht ansteuern. Das geladene Modul "sky2" läuft, meldet aber gem. "dmesg" den bereits anfänglich von mir geposteten Fehler

"ACPI: PCI interrupt for device 0000:06:00.0 disabled / sky2: probe of 0000:06:00.0 failed with error -16".

Weder über YAST noch über die Konsole (ifup pp.) kann ich die Karte ansteuern. In YAST erzählt er mir nach wie vor:

"Konfiguration der Netzwerkkarte nicht möglich, weil das Kernel-Gerät (eth0, wlan0) nicht verfügbar ist. Dies wird zumeist durch fehlende Firmware (für WLAN-Geräte) verursacht. Zu Einzelheiten s. die dmesg-Ausgabe."

Mal weiter auf den Stein der Weisen hoffen... :)
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Grothesk »

"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Hier der Auszug aus dem Skript:

!!! CND0240E: Knetworkmanager wird für die Netzwerkkonfiguration benutzt aber die Netzwerkkartenkonfiguration für wlan0 existiert
--- 1 Fehler gefunden
--- Gehe zu http://www.linux-tips-and-tricks.de/CND um detailiertere Hinweise zu den Fehlermeldungen/Warnungen zu bekommen und wie die Fehler beseitigt werden könnenF

==================================================================================================================
==================================================================================================================
*** uname -a
Linux linux-ge22 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux
==================================================================================================================
*** SuSE release
openSUSE 11.0 (i586)
VERSION = 11.0
==================================================================================================================
*** /etc/resolv
nameserver 192.@@@
==================================================================================================================
*** route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.@@@ 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.@@@ 0.0.0.0 UG 0 0 0 wlan0
==================================================================================================================
*** ifconfig
lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:46 errors:0 dropped:0 overruns:0 frame:0
TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:0
RX bytes:3044 (2.9 Kb) TX bytes:3044 (2.9 Kb)
wlan0 Link encap:Ethernet Hardware Adresse 00:21:@@@
inet Adresse:192.@@@ Bcast:192.@@@ Maske:255.255.255.0
inet6 Adresse: fe80::221:@@@/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1156 errors:0 dropped:0 overruns:0 frame:0
TX packets:1174 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:1000
RX bytes:900243 (879.1 Kb) TX bytes:252300 (246.3 Kb)
wmaster0 Link encap:UNSPEC Hardware Adresse 00-21-5D-@@@
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
==================================================================================================================
*** ping tests
Ping of 195.135.220.3 OK
Ping of http://www.suse.de OK
==================================================================================================================
*** PCI devices
02:00.0 Network controller [0280]: Intel Corporation Device [8086:4232]
06:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller [11ab:4363] (rev 13)
==================================================================================================================
*** USB devices
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 13ee:0003
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0ac8:c302 Z-Star Microelectronics Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
==================================================================================================================
*** List of loaded modules
| ac | acpi_cpufreq | af_packet | agpgart |
| ahci | arc4 | battery | binfmt_misc |
| button | cdrom | cfg80211 | compat_ioctl32 |
| container | cpufreq_conservative | cpufreq_powersave | cpufreq_userspace |
| crypto_blkcipher | dm_mod | dock | ecb |
| edd | ehci_hcd | ext3 | fan |
| ff_memless | firmware_class | fuse | hid |
| i2c_core | i2c_i801 | intel_agp | ip6table_filter |
| ip6_tables | iptable_filter | ip_tables | ipv6 |
| iwl4965 | iwlcore | jbd | joydev |
| libata | loop | mac80211 | mbcache |
| microcode | nvidia | output | processor |
| rtc_cmos | rtc_core | rtc_lib | scsi_mod |
| sd_mod | serio_raw | sg | sky2 |
| snd | snd_hda_intel | snd_hwdep | snd_mixer_oss |
| snd_page_alloc | snd_pcm | snd_pcm_oss | snd_seq |
| snd_seq_device | snd_timer | soundcore | speedstep_lib |
| sr_mod | thermal | uhci_hcd | usbcore |
| usbhid | uvcvideo | v4l1_compat | vboxdrv |
| video | videodev | x_tables |
==================================================================================================================
*** cat /etc/sysconfig/network/ifcfg-[earwd]* | egrep -v ".*=''"
==================================================================================================================
*** cat /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO='dhcp'
NAME='Intel WLAN controller'
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AUTH_MODE='psk'
WIRELESS_BITRATE='auto'
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='@@@'
WIRELESS_KEY_LENGTH='@@@'
WIRELESS_MODE='Managed'
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK='@@@@@@'
==================================================================================================================
*** NWEliza states
IF:wlan0 IP:192.@@@ IM:2 ES:@@@
DI:1 dI:1 NI:1 cNI:1 NIWD:0 KM:1 WLW: 0
[/code]

Der gleich zu Beginn auftauchende Fehler entstammt noch von der "Installation" des WLAN-Treibers - der brav seinen Dienst versieht :)
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von SUSEDJAlex »

@franzenmonster:

Deine Ausgabe des Scriptes ist nicht vollständig. Deaktiviere bitte sämtliche Netzwerkverbindungen und lasse den Script noch einmal laufen.
Anschließend kannst du es auf http://www.phpfi.com posten und dessen Link hier reinsetzen.

EDIT: Habe im Netz recherchiert und bin auf diese Seite gestossen: http://www.marvell.com/drivers/driverSearchResults.do
Es gibt auch den Treiber für den Kernel 2.4.20 und höher. Vielleicht hilft dir das weiter...

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Heinz-Peter »

Ich verstehe das nicht. Der ping Test ist doch positiv :

Code: Alles auswählen

 *** ping tests
Ping of 195.135.220.3 OK
Ping of http://www.suse.de OK
Er ist doch drin ;)
Gruß
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4326
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von framp »

Code: Alles auswählen

wlan0 Link encap:Ethernet Hardware Adresse 00:21:@@@
inet Adresse:192.@@@ Bcast:192.@@@ Maske:255.255.255.0
inet6 Adresse: fe80::221:@@@/64 Gültigkeitsbereich:Verbindung
sowie die positiven PingTests zeigen das alles OK ist.

BTW: Die Mac Adressen sowie die externen IP Adressen werden vom Script mittlerweile automatisch maskiert wenn man einen Aufrufparameter -m (wie maskieren) angibt. Die Maskierung der privaten Adressen ist allerdings nicht unterstützt da niemand aus dem Internet auf Deine privaten Adressen zugreifen kann und somit die Kenntnis der privaten IP Adressen keinem was nützt. Falls Du mich eines Anderen überzeugst baue ich auch noch die Maskierung der privaten IPs ein.

BTW2: Der default key und die key length sollten eigentlich automatisch maskiert werden. War ein Bug im Script. Ist jetzt gefixed.
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von SUSEDJAlex »

Heinz-Peter hat geschrieben:Ich verstehe das nicht. Der ping Test ist doch positiv :

Code: Alles auswählen

 *** ping tests
Ping of 195.135.220.3 OK
Ping of http://www.suse.de OK
Er ist doch drin ;)
Gruß
Um fehler zu finden oder Netzwerkeinstellungen zu testen sollte man eigentlich stets offline den Script durchlaufen lassen.
Deswegen sage ich das immer wieder...

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4326
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von framp »

SUSEDJAlex hat geschrieben:Um fehler zu finden oder Netzwerkeinstellungen zu testen sollte man eigentlich stets offline den Script durchlaufen lassen.
Deswegen sage ich das immer wieder...
Bin ich doch auch in dasselbe Loch getreten :ops: Der TE hat eine existierende WLAN Verbindung und es geht nicht mit der Netzwerkkarte. Nicht umgekehrt ... :o

Das Problem ist, dass die Scriptausgabe nicht vollständig ist wie schon SUSEDJAlex schrieb und man nicht sieht ob der networkmanager oder die ifup Methode benutzt wird... Die fehlenden Ausgaben sind vermutlich dem Sicherheitsaspekt zum Opfer gefallen :/
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4326
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von framp »

SUSEDJAlex hat geschrieben:Um fehler zu finden oder Netzwerkeinstellungen zu testen sollte man eigentlich stets offline den Script durchlaufen lassen.
Deswegen sage ich das immer wieder...LG SUSEDJAlex
Wenn jemand mit einem WLAN Prob mit existierender KabelVerbindung das Script laufen läßt wird eine dementsprechende Fehlermeldung erzeugt da dieser Fehler doch recht häufig begangen wird. Den umgekehrten Fall hatte ich noch nie gesehen ... aber das nehme ich auf meine ToDo Liste so dass zukünftig auch bei einem KabelProb bei bestehender WLAN Verbindung eine dementsprechende Fehlermeldung erzeugt werden wird.
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

framp hat geschrieben:
SUSEDJAlex hat geschrieben:Um fehler zu finden oder Netzwerkeinstellungen zu testen sollte man eigentlich stets offline den Script durchlaufen lassen.
Deswegen sage ich das immer wieder...
Bin ich doch auch in dasselbe Loch getreten :ops: Der TE hat eine existierende WLAN Verbindung und es geht nicht mit der Netzwerkkarte. Nicht umgekehrt ... :o

Das Problem ist, dass die Scriptausgabe nicht vollständig ist wie schon SUSEDJAlex schrieb und man nicht sieht ob der networkmanager oder die ifup Methode benutzt wird... Die fehlenden Ausgaben sind vermutlich dem Sicherheitsaspekt zum Opfer gefallen :/
So. Habe nun den Networkmanager deaktiviert und die klassische Konsolensteuerung gewählt. Wlan0 mit ifdown deaktiviert => keine Netzwerkverbindung vorhanden. Danach habe ich das Skript nochmal laufen lassen. Meines Erachtens mit dem gleichen Ergebnis - also nicht ausführlicher. Habe nur die ESSID für wlan0 aus der sysconfig unkenntlich gemacht. An der restlichen Ausgabe habe ich nichts gekürzt - würde mir ja damit "ins eigene Fleisch schneiden". Was müsste denn noch zusätzlich ausgegeben werden?

Hier der Links zur Ausgabe des Skript: http://phpfi.com/359661

Bin bis dato noch nicht weiter gekommen. Von daher ist jede weitere Hilfe echt willkommen...
Python
Newbie
Newbie
Beiträge: 6
Registriert: 4. Okt 2008, 18:47

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Python »

Anscheinend haben noch mehr Leute Probleme mit den Netzwerk-Adaptern von Marvell.

Ebenso bin ich im Besitz eines Notebooks von Samsung, jedoch ist es das Modell R-510 Aura Melroi. Die Ethernet-Karte ist aber völlig identisch.

In manchen Foren kann man RPM-Pakete herunterladen, aber die helfen auch nicht weiter, da Yast nicht das Kernelmodul novell-sk98lin auf der DVD findet. Womöglich ist dieses Modul auch noch verbuggt.

Habe schon den Treiber von der Marvell-Webseite versucht zu installieren, jedoch gibt es bei der Installation eine Fehlermeldung und eine Warnung:

Code: Alles auswählen

 
Do nothing:
  - The sk98lin will be installed
  NOTE: It may happen that the alternative driver will be loaded on
  the next boot process. In this case the Marvell driver _WON'T_ be
  loaded.

Deactivate driver:
  - The alternative driver will be renamed to _skge.ko or _sky2.ko
  - All references in the /etc/modprobe.conf file will be changed to
    the sk98lin driver
  - The alternative driver will be unloaded
  - The sk98lin driver will be installed

Remove driver (recommended):
  - The alternative driver will be removed from your system
  - All references in the /etc/modprobe.conf file will be changed to
    the sk98lin driver
  - The alternative driver will be unloaded
  - The sk98lin driver will be installed


1) Do nothing
2) Deactivate diver
3) Remove driver
Action: 2
Disconnect alternative devices:  (done)                              [   OK   ]
Unload alternative driver (done)                                     [   OK   ]
Create tmp dir (/tmp/Sk98IqZoXemYVNjZiSJYUhMRC)                      [   OK   ]
Check user id (0)                                                    [   OK   ]
Check kernel version (2.6.25.5-1.1-pae)                              [   OK   ]
Check kernel symbol file (/proc/kallsyms)                            [   OK   ]
Check kernel type (SMP)                                              [   OK   ]
Check number of CPUs (2)                                             [   OK   ]
Check architecture (found)                                           [   OK   ]
Set architecture (i386)                                              [   OK   ]
Check compiler (/usr/bin/gcc)                                        [   OK   ]
Check mcmodel flags (none)                                           [   OK   ]
Check module support (/sbin/insmod)                                  [   OK   ]
Check makewhich: no make in (/usr/sbin:/bin:/usr/bin:/sbin)
 (not found)                                                         [ failed ]
./functions: line 465: inst_failed: command not found
Check kernel gcc version (4.3.1) (Kernel:4.3.1 == gcc:4.3.1)         [   OK   ]
Check sk98lin driver availability (not loaded)                       [   OK   ]
Check kernel header files (/usr/src/linux)                           [   OK   ]
Check sources for .config file (/usr/src/linux/.config)              [   OK   ]
Copying file from proc directory (done)                              [   OK   ]
Copy and check .config file (done)                                   [   OK   ]
Check the mem address space (highmem64)                              [   OK   ]
Change IOMMU (disabled)                                              [   OK   ]
Create new .config file (done)                                       [   OK   ]
Execute: make oldconfig (done)                                       [   OK   ]
Delete old .config file (done)                                       [   OK   ]
Execute: make oldconfig (done))                                      [   OK   ]
Check modpost availability (not available)                           [  warn  ]
Rebuild kernel scripts (done)                                        [   OK   ]

The kernel's modpost utility is not available. As the source code
for the utility is available in your current installed linux kernel
source tree, you can compile the utility for your own.

To do so, please follow the description below:
(Please read the next lines before you execute them!)
[1] Change to /usr/src/linux
[2] Call make (this begins to create a new linux kernel)
[3] Take a look at the output: After a few seconds the modpost utility
    will be compiled
[4] Now interrupt the make process by pressing ctrl-c

The modpost utility now is created. You can check this by taking a look
at /usr/src/linux/scripts/mod. Here you should find a file modpost now.

If you are finished recall install.sh again. That's it.
Wenn man vorher /usr/src/linux/scripts/mod überprüft, so findet man bereits zwei Modpost Dateien (modpost.c und modpost.h).

:???:
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Python hat geschrieben: Check makewhich: no make in (/usr/sbin:/bin:/usr/bin:/sbin)
(not found) [ failed ]
./functions: line 465: inst_failed: command not found
Hmm... Auch wenn ich mir das kaum vorstellen kann, aber kann es sein das bei dir "make" aus den build-essential tools fehlt? Oder deute ich die Fehlermeldung falsch?

Bei mir scheiterte die Implementierung des Marvell-Treibers - wie zuvor gepostet - auch. Und nach wie vor kann ich mit der Fehlermeldung "WARNING: Symbol version dump /usr/src/linux-2.6.25.16-0.1/Module.symvers is missing; modules will have no dependencies and modversions." absolut nichts anfangen. :???:
Python
Newbie
Newbie
Beiträge: 6
Registriert: 4. Okt 2008, 18:47

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Python »

Bei mir waren die Paketquellen falsch eingetragen. Yast versuchte die ganze Zeit über das Internet die Pakete zu beziehen. Seltsam, ich habe aber vorher schon Pakete von der DVD installiert, indem ich jeweils auf "Abbrechen" klickte. Dann bezog der Paketmanager die Daten immer von dieser Quelle. Wie auch immer...

Habe mal dieses RPM-Paket ausprobiert, Sky-Backport mit PAE:
http://www.pc-forum24.de/downloads.php?do=file&id=1446

Schön, dass openSUSE 11 jetzt meine 4 GB Arbeitsspeicher voll erkennt. Aber es brachte nichts, denn bei den Netzwerk-Adaptern steht immer noch:

Code: Alles auswählen

Konfiguration der Netzwerkkarte nicht möglich, weil das Kernel-Gerät (eth0, wlan0) nicht verfügbar ist. Dies wird zumeist durch fehlende Firmware (für WLAN-Geräte) verursacht. Zu Einzelheiten s. die dmesg-Ausgabe.
Achso, ich werde mal schauen und "make" nachinstallieren, falls wenn es fehlt.


Edit:
Jetzt läuft die Prozedur weiter und bin jetzt an der gleichen Stelle angelangt wie du. ;)

Gleiches Problem mit module.symvers hat auch dieser User. Er wollte auch unter openSUSE den Marvell-Treiber installieren. Anscheinend kriegt man das einfach nicht zum laufen:
http://www.hackerboard.de/thread.php?th ... 33275&sid=

So wie er schreibt, läuft der Marvell-Adapter unter Gentoo aber einwandfrei. :schockiert:
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Python hat geschrieben:So wie er schreibt, läuft der Marvell-Adapter unter Gentoo aber einwandfrei. :schockiert:
Schade. Da ich aber nicht vor habe, auf mein openSUSE zu verzichten, hoffe ich weiterhin auf Hilfe. Vielleicht findet sich ja noch jemand, der die entscheidende Idee hat. Solange das WLAN funktioniert, bin ich ja nicht ganz von der Welt abgeschnitten ;)
Benutzeravatar
framp
Moderator
Moderator
Beiträge: 4326
Registriert: 6. Jun 2004, 20:57
Wohnort: bei Stuttgart
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von framp »

franzenmonster hat geschrieben:Habe nur die ESSID für wlan0 aus der sysconfig unkenntlich gemacht. An der restlichen Ausgabe habe ich nichts gekürzt - würde mir ja damit "ins eigene Fleisch schneiden". Was müsste denn noch zusätzlich ausgegeben werden?
Errare humanum est. Habe schon lange keine Ausgaben des Scripts wg kabelgebundener Probleme gesehen. Die von WLAN sind wesentlich länger ...
So wie es für mich aussieht ist das wohl ein HW/Treiber Problem bei dem ich leider nicht weiterhelfen kann :(
Python
Newbie
Newbie
Beiträge: 6
Registriert: 4. Okt 2008, 18:47

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von Python »

Ok, wie man das Problem wegen module.symvers löst habe ich herausgefunden. Man muss per Terminal/Konsole in das Verzeichnis /usr/scr/<kernel> gehen und dort ./make all ausführen. Der Vorgang kann eine halbe Stunde dauern. Anschließend ist dann aber das Modul da. Allerdings kommen auch schon neue Probleme:

Code: Alles auswählen

1) Do nothing
2) Deactivate diver
3) Remove driver
Action: 3
Disconnect alternative devices:  (done)                              [   OK   ]
Unload alternative driver (done)                                     [   OK   ]
Create tmp dir (/tmp/Sk98INfMDmjTElbCVKoJQndXY)                      [   OK   ]
Check user id (0)                                                    [   OK   ]
Check kernel version (2.6.25.5-1.1-pae)                              [   OK   ]
Check kernel symbol file (/proc/kallsyms)                            [   OK   ]
Check kernel type (SMP)                                              [   OK   ]
Check number of CPUs (2)                                             [   OK   ]
Check architecture (found)                                           [   OK   ]
Set architecture (i386)                                              [   OK   ]
Check compiler (/usr/bin/gcc)                                        [   OK   ]
Check mcmodel flags (none)                                           [   OK   ]
Check module support (/sbin/insmod)                                  [   OK   ]
Check make (/usr/bin/make)                                           [   OK   ]
Check kernel gcc version (4.3.1) (Kernel:4.3.1 == gcc:4.3.1)         [   OK   ]
Check sk98lin driver availability (not loaded)                       [   OK   ]
Check kernel header files (/usr/src/linux)                           [   OK   ]
Check sources for .config file (/usr/src/linux/.config)              [   OK   ]
Copying file from proc directory (done)                              [   OK   ]
Copy and check .config file (done)                                   [   OK   ]
Check the mem address space (highmem64)                              [   OK   ]
Change IOMMU (disabled)                                              [   OK   ]
Create new .config file (done)                                       [   OK   ]
Execute: make oldconfig (done)                                       [   OK   ]
Check modpost availability (available)                               [   OK   ]
Unpack the sources (done)                                            [   OK   ]
Check firmware availability (not available)                          [   OK   ]
Check kernel header version (Kernel:2.6.25.5 == Header:2.6.25.5)     [   OK   ]
Check kernel functions (Changed: nothing)                            [   OK   ]
Compile the kernel (error)                                           [ failed ]

An error has occurred during the compile proces which prevented
the installation from completing.
Take a look at the log file install.log for more informations.
Installation of package failed.

In der Log-Datei steht dann Folgendes:

Code: Alles auswählen

make: Entering directory `/usr/src/linux-2.6.25.5-1.1'
  CC [M]  /tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.o
  CC [M]  /tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.o
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c: In function ‘sk98lin_init_device’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:483: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:484: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:489: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:490: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:611: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:612: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:617: error: ‘struct net_device’ has no member named ‘poll’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:618: error: ‘struct net_device’ has no member named ‘weight’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c: In function ‘SkGeIsr’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:2315: error: too few arguments to function ‘netif_rx_schedule_prep’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:2318: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c: In function ‘SkGeIsrOnePort’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:2486: error: too few arguments to function ‘netif_rx_schedule_prep’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:2491: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c: In function ‘SkGePoll’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:3250: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:3250: warning: type defaults to ‘int’ in declaration of ‘_y’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:3250: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:3271: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.c:3275: error: too few arguments to function ‘netif_rx_complete’
make[1]: *** [/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/skge.o] Fehler 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c: In function ‘SkY2Isr’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:428: error: implicit declaration of function ‘__netif_rx_schedule_prep’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:429: error: too few arguments to function ‘__netif_rx_schedule’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c: In function ‘SkY2Poll’:
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:665: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:665: warning: type defaults to ‘int’ in declaration of ‘_y’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:665: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:672: error: ‘struct net_device’ has no member named ‘quota’
/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.c:694: error: too few arguments to function ‘netif_rx_complete’
make[1]: *** [/tmp/Sk98INfMDmjTElbCVKoJQndXY/all/sky2.o] Fehler 1
make: *** [_module_/tmp/Sk98INfMDmjTElbCVKoJQndXY/all] Fehler 2
make: Leaving directory `/usr/src/linux-2.6.25.5-1.1'
+++ Compiler error
Aber hauptsache PAE funktioniert. :roll:

Naja, wenn man das Web durchsucht, findet man sehr viele Problemfälle mit der Marvell 88E8055. Vielleicht läuft es doch unter Gentoo, da dort alles erst kompiliert wird. Wäre vielleicht mal interessant das auszuprobieren. Ansonsten finde ich es schade, dass ich unter Linux nicht ins Internet kann. Zumindest momentan nicht.
Benutzeravatar
franzenmonster
Newbie
Newbie
Beiträge: 19
Registriert: 4. Okt 2007, 17:49
Kontaktdaten:

Re: Samsung R710 Ethernet-Karte (Marvell 88E8055) läuft nicht!

Beitrag von franzenmonster »

Da stehen wir jetzt an der gleichen Stelle. Ist echt ärgerlich, weil mein Notebook ansonsten echt super läuft. Nur dieses be*** Ethernet-Device will nicht. Habe gerade dem Hersteller (http://www.marvell.com/index.jsp) eine E-Mail geschrieben. Bin zwar relativ sicher, dass openSUSE in den USA nicht sehr bekannt sein dürfte, aber ein Versuch scheint es mir Wert zu sein. Vielleicht gibt es ja doch noch eine Möglichkeit, Treiber und Modul zum Laufen zu bringen... Sollte ich eine brauchbare Antwort bekommen, lass ich wieder von mir hören. Bis dahin bleibt wohl nur zu hoffen, dass sich noch jemand findet der den rettenden Anker wirft :D Auf jeden Fall schon mal vielen Dank für die Unterstützung!

PS: Habe mir grad die aktuelle Version von Gentoo-Linux (2008.0-r1) gezogen. Wenn ich Zeit und Platz auf meiner Platte finde, werd ich mal testen, ob ich dort die Ethernet-Karte zum Laufen bringe - wahrscheinlich geht dann nur das WLAN-Device nicht ;)
Antworten