Seite 1 von 1

[gelöst] s/mime in kmail

Verfasst: 16. Sep 2008, 18:26
von derRichard
hi!

kann man s/mime überhaupt im kmail verwenden?
ich habe bereits das p12-zertifikat zu meiner kmail-identität hinzugefügt.
"s/mime (gpgsm)" ist auch unter kryptomodule ausgewählt.

aber jedes mal wenn ich eine mail signieren will kommt diese meldung:
Signierung fehlgeschlagen: Allgemeiner Fehler
openpgp/mime geht einwandfrei.
irgendwo muss da ein hund sein...

danke,
//richard

Re: s/mime in kmail

Verfasst: 16. Sep 2008, 21:11
von derRichard
kleiner nachtrag, mir ist es gelungen die logmeldungen von gpgsm zu bekommen:
2008-09-16 21:08:53 gpgsm[28710] Verbindung zum gpg-agent nicht möglich - Ersatzmethode wird versucht
2008-09-16 21:08:53 gpgsm[28714] Verbindung zum gpg-agent nicht möglich - Ersatzmethode wird versucht
2008-09-16 21:08:53 gpgsm[28714] Fingerprint=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
2008-09-16 21:08:53 gpgsm[28714] Interaktives vertrauenswürdig-Markieren ist in gpg-agent ausgeschaltet
2008-09-16 21:08:53 gpgsm[28718] Verbindung zum gpg-agent nicht möglich - Ersatzmethode wird versucht
2008-09-16 21:08:53 gpgsm[28718] Fingerprint=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
2008-09-16 21:08:53 gpgsm[28718] Interaktives vertrauenswürdig-Markieren ist in gpg-agent ausgeschaltet
2008-09-16 21:08:53 gpgsm[28721] Verbindung zum gpg-agent nicht möglich - Ersatzmethode wird versucht
2008-09-16 21:08:53 gpgsm[28729] Verbindung zum gpg-agent nicht möglich - Ersatzmethode wird versucht
2008-09-16 21:08:53 gpgsm[28729] certificate #XXXXXXXXXXXXXXXXX/CN=Thawte Personal Freemail Issuing CA,O=Thawte Consulting (Pty) Ltd.,C=ZA
2008-09-16 21:08:53 gpgsm[28729] Die CRL konnte nicht geprüft werden: Konfigurationsfehler
der gpg-agent läuft aber, ich kapiere das nicht.
was kann da sein?

Re: s/mime in kmail

Verfasst: 17. Sep 2008, 19:39
von derRichard
problem gelöst, mein gpg-agent lief doppelt --> falscher socket.
und in der ~/.gnupg/gpg-agent.conf gehört das rein:

Code: Alles auswählen

allow-mark-trusted
und in die ~/.gnupg/gpgsm.conf das:

Code: Alles auswählen

disable-crl-checks
disable-policy-checks
auto-issuer-key-retrieve
include-certs -1
wobei das "include-certs -1" ganz wichtig ist, sonst erkennt outlook die signatur nicht an.

//richard