Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Soundausgabe unter open Suse 11

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

whois hat geschrieben:Hi

Code: Alles auswählen

Also mein Soundproblem äußert sich so, jedesmal wenn ich eine Sounddatei (mp3, wma usw.) abspielen möchte hört man den gesang die Instrumente kaum, in vordergrund ist nur Rauschen zu hören, welches metronomartig lauter und leiser wird! Also ich kann eigentlich überhaupt nichts vom Lied hören.
Sorry aber das hört sich nicht nach einem Hardware Problem an.
Das tritt bei allen Musik Files auf ob mp3,ogg oder ähnliches also auch bei Flash Videos von youtube?

Dast du dir den alsamixer bzw. Kmix mal angesehen und welche switches da geschaltet sind?

Guck auch mal im Kontrollzentrum unter Sound und Multimedia nach wie die Hardware da eingerichtet ist.
-Vollduplex
-Soundsystem aktiviert

cu

Ja das tritt leider bei allen musik files auf !!! Das ist ja so schrecklich !!!

ähhmmm.... blöde Frage wie kann ich den sehen wann switches (was sind das überhaupt?) flasch geschaltet sind ?

Versuch gerade im Kontrollzentrum irgendwie zu schauen, wo ich die infos herbekomme !!! Aber irgendwie komm ich da net ran, hast du vllt. einen genauen weg ???

Ich habe ja leider die befürchtung, das es mit dem Treiber zusammenhängt, unter Windows gab es lange zeit die gleichen Probleme, bis eine neue Treiberversion raus kam, aber bei linux muss es doch irgendwie einen Trick geben !!!

lg
liese

P.S Sry, das ich mich gerade so dumm anstelle !!!
gropiuskalle
Guru
Guru
Beiträge: 4603
Registriert: 20. Nov 2007, 15:17
Wohnort: Berlin
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von gropiuskalle »

P.S Sry, das ich mich gerade so dumm anstelle !!!
Nanana. ;)
ähhmmm.... blöde Frage wie kann ich den sehen wann switches (was sind das überhaupt?) flasch geschaltet sind ?
Gib mal einfach

alsamixer

...in eine Konsole, dann tut sich eine Konsolenvariante Deines Mixers auf (Navigation und Regelung via Pfeiltasten, beenden mit Strg +C). Du kannst auch z.B. KMix verwenden, der greift auf die selben ALSA-Treiber zu.

Ich würde die Einstellungen dort auch nochmal genauer unter die Lupe nehmen, aber ich glaube fast, das ist vergebene Liebesmüh - offenbar liegt hier weder ein codec- noch ein Treiberproblem vor, hier spinnt die Karte (ohne Gewähr).
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von whois »

gropiuskalle hat geschrieben:offenbar liegt hier weder ein codec- noch ein Treiberproblem vor, hier spinnt die Karte (ohne Gewähr).
So unglaublich das klingt scheint mir aber wirklich so zu sein.
Na vielleicht kommt mit dem Alsamixer noch was raus.
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

Also ich glaube nicht, das die Karte kaputt ist, da sie unter windows einwandfrei funktioniert !!!

Ich habe mal den alsamixer fotografiert (ich kann da irgendwie nichts dran erkennen) :

http://liese.lima-city.de/alsamixer

lg
liese
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von whois »

Puh, da steht ja alles auf 100% das Ding muss doch total übersteuert sein.
Dreh vor allem den PCM Mixer mal runter auf die Häfte genau wie den Rest ausser Master.
Benutzeravatar
Ganymed
Guru
Guru
Beiträge: 1609
Registriert: 15. Mai 2006, 12:58
Wohnort: JETZT ? DIREKT HINTER DIR !!

Re: Soundausgabe unter open Suse 11

Beitrag von Ganymed »

Hi,
erstens wie Whois schon anmerkte , die Kanäle stehen alle auf 100%.
Für Einstellungen reichen 75% alle Mal - auch zum Schutz Deiner Ohren und der Lautsprecher.

Hast Du evtl. ein Programm laufen das den Sound irgendwie verändert, Hall, Echo Raumklang o.ä. - usw, - ist ein Verstärker mit solchen o. ä. Features an die Soundkarte angeschlossen oder hängen die Brüllwürfel direkt an der Soundkarte?

Gruß Ganymed
julia ist gut zu vögeln --- Groß- und Kleinschreibung retten die Ehre.
komm wir essen Opa --- Satzzeichen retten sogar das Leben
:)
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Soundausgabe unter open Suse 11

Beitrag von misiu »

Das einzige , was mir in den Sinn noch kommt:
Du könntest die ALSA-Pakete aktualisieren.

und
verschiedene Optionen für deine Karte ausprobieren:
AD1988
6stack 6-jack
6stack-dig ditto with SPDIF
3stack 3-jack
3stack-dig ditto with SPDIF
laptop 3-jack with hp-jack automute
laptop-dig ditto with SPDIF
auto auto-config reading BIOS (default)
Im Moment läuft im AUTO-Modus

Code: Alles auswählen

options snd slots=snd-hda-intel 
# M71A.IBGOrOFSaa6:nVidia Corporation
alias snd-card-0 snd-hda-intel

Sollte dann so Aussehen:

Code: Alles auswählen

options snd slots=snd-hda-intel model=6stack
# M71A.IBGOrOFSaa6:nVidia Corporation
alias snd-card-0 snd-hda-intel

Oder:

Code: Alles auswählen

options snd slots=snd-hda-intel model=6stack position_fix=1
# M71A.IBGOrOFSaa6:nVidia Corporation
alias snd-card-0 snd-hda-intel

Danach :

Code: Alles auswählen

rcalsasound stop
rcalsasound start
und
Mixer neu starten


Weiterhin:
Note 2: If you get click noises on output, try the module option
position_fix=1 or 2. position_fix=1 will use the SD_LPIB
register value without FIFO size correction as the current
DMA pointer. position_fix=2 will make the driver to use
the position buffer instead of reading SD_LPIB register.
(Usually SD_LPLIB register is more accurate than the
position buffer.)
NB: If you get many "azx_get_response timeout" messages at
loading, it's likely a problem of interrupts (e.g. ACPI irq
routing). Try to boot with options like "pci=noacpi". Also, you
can try "single_cmd=1" module option. This will switch the
communication method between HDA controller and codecs to the
single immediate commands instead of CORB/RIRB. Basically, the
single command mode is provided only for BIOS, and you won't get
unsolicited events, too. But, at least, this works independently
from the irq. Remember this is a last resort, and should be
avoided as much as possible...
Versuche mal, vielleicht geht es so.

MfG
misiu
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

Wie kann ich die Optionen ändern ??

muss ich die config daten selber umschreiben oder kann ich das irgendwo zusammen klicken ???

-----

ne leider ist da nichts mehr zwischen geschaltet, was den ton beeinflussen könnte !

lg
Liese
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Soundausgabe unter open Suse 11

Beitrag von misiu »

Per Hand geht es am schnellstem, aber zuerst Backup anlegen!

MfG
misiu
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

Wo finde ich die Datei, inder ich das ändern muss ???

muss ich nach der änderung einen neustart machen oder nur den mixer neu starten ???


lg
liese !
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Soundausgabe unter open Suse 11

Beitrag von misiu »

Code: Alles auswählen

/etc/modprobe.d/sound
Alles als root ausführen.
1. Kopie von /etc/modprobe.d/sound erstellen.
2. Texteditor mit root-Rechten öffnen (KDE):

Code: Alles auswählen

kdesu kwriter
oder

Code: Alles auswählen

kdesu kedit
oder

Code: Alles auswählen

kdesu kate
(je nach Editor)
+ root-Passwort
3.Änderung durchführen und speichern.
4. Textkonsole auf:

Code: Alles auswählen

misiu@exotux1:~> su
Passwort:
tux1:/home/misiu # rcalsasound stop
Shutting down sound driver                                           done
tux1:/home/misiu # rcalsasound start
Starting sound driver:  hda-intel                                    done
tux1:/home/misiu #
Mit "su" erhälst du die root-Rechte, danach das Passwort blind eingeben.
Somit ist runterfahren des Rechners nicht notwendig.

5. Nach Neustart vom Soundsystem verschwindet normalerweise der Mixer, diesen
einfach im Programmmenü finden und starten
(KDE3.5.x-> Anwendungen->Multimedia->Lautstärkeregler->Kmix)

MfG
misiu
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

ach, das funzt alles nicht !!! habe jetzt alles ausprobiert !!!

werd das system die tage mal neu machen und schauen obs dann funktioniert!!! werd euch davon berichten !!!

lg
liese
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

ach, ich habe jetzt einen anderen gedanken gefasst !!! Ich baue mir einfach eine PCI-Soundkarte ein !!! Gibt es da irgendwelche Empfehlungen, welche Karte den unter Linux wirklich funktioniert oder die einen schönen klang hat !!! Vielleicht kennt ihr auch Seiten, wo man so ne art Kompatibilitätsliste hat !!!

Für jeden Tip wäre ich dankbar !!!

lg
Liese !
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von whois »

Hi

Ich bin Soundblaster Audgy Fan.
Die haben bei mir bisher alle out-of-the-box funktioniert.

cu
Z-City
Hacker
Hacker
Beiträge: 649
Registriert: 17. Jan 2005, 15:16
Wohnort: Kreis Karlsruhe
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Z-City »

whois hat geschrieben:Hi

Ich bin Soundblaster Audgy Fan.
Die haben bei mir bisher alle out-of-the-box funktioniert.

cu
Sag das nicht so laut. Ich habe die Woche einen Soundblaster X-Fi installiert. Da ging nix out-of-the-box. Da gibt es einen speziellen Treiber, der zum Glück von Creative für Linux zur Verfügung gestellt wird. Der muss installiert werden und dann geht das nach einem Neustart problemlos. War eine ganz neue Erfahrung für mich.

Gruß vom BEN
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 817
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: Soundausgabe unter open Suse 11

Beitrag von spezi »

Guten Abend,

Code: Alles auswählen

Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfe020000-0xfe023fff (rw,non-prefetchable)
  IRQ: 21 (5510 events)
  Module Alias: "pci:v000010DEd00000774sv00001043sd000082C0bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
http://de.opensuse.org/SDB:Intel-hda
Das hat bei mir geholfen.

mfg
spezi
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
Liselotte Meyer
Newbie
Newbie
Beiträge: 29
Registriert: 8. Mai 2008, 18:38
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von Liselotte Meyer »

Hi Leudde,

habe mein Problem gelöst, indem ich einfach mal Ubuntu installiert habe. Jetzt funzt das einwandfrei.

Aber vielen Dank für eure Hilfe, endlich wieder Musik hören über den Rechner !!!

lg
Liese
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Soundausgabe unter open Suse 11

Beitrag von whois »

Naja im Prinzip ist es egal welche Distribution da läuft solange alles Einwandfrei funktioniert.
Ich verstehe zwar nicht warum das bei Buntu anders laufen soll , aber egal. ;)
Antworten