Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

sensors - irgendwas stimmt da nicht?

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
OpenSuxiser
Newbie
Newbie
Beiträge: 12
Registriert: 5. Sep 2008, 15:53

sensors - irgendwas stimmt da nicht?

Beitrag von OpenSuxiser »

Hallo,

ich habe in YaST2 die beiden Pakete "libsensors4" und "sensors" installiert. Beide Version 3.0.2-4.1
Dann habe ich in der Konsole als root "sensors-detect" ausgeführt.
Dann soll man folgendes eintippen:

Code: Alles auswählen

cp /usr/share/doc/packages/sensors/prog/init/lm_sensors.init.suse /etc/init.d/lm_sensors
Das funktioniert aber nicht.
Folgende Fehlermeldung kommt:
cp: Aufruf von stat für „/usr/share/doc/packages/sensors/prog/init/lm_sensors.init.suse“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Ich kann aber "sensors" aufrufen und erhalten folgende Werte:

Code: Alles auswählen

k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:  +18.0°C
Core0 Temp:   +6.0°C
Core1 Temp:  +10.0°C
Core1 Temp:   +4.0°C

it8718-isa-0228
Adapter: ISA adapter
in0:         +1.01 V  (min =  +0.00 V, max =  +4.08 V)
in1:         +1.95 V  (min =  +0.00 V, max =  +4.08 V)
in2:         +3.33 V  (min =  +0.00 V, max =  +4.08 V)
in3:         +2.94 V  (min =  +0.00 V, max =  +4.08 V)
in4:         +3.09 V  (min =  +0.00 V, max =  +4.08 V)
in5:         +3.22 V  (min =  +0.00 V, max =  +4.08 V)
in6:         +4.08 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
in7:         +3.33 V  (min =  +0.00 V, max =  +4.08 V)
in8:         +3.04 V
fan1:        703 RPM  (min =   10 RPM)
fan2:        487 RPM  (min =   10 RPM)
fan3:          0 RPM  (min =    0 RPM)
temp1:       +40.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = transistor
temp2:       +27.0°C  (low  = +127.0°C, high = +60.0°C)  sensor = thermal diode
temp3:       +84.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = transistor
cpu0_vid:   +1.525 V
Meine Konfigurationdatei hat außerdem den Namen "sensors3.conf "? Warum denn das?
Normal sollte sie doch einfach "sensors.conf" heißen in /etc/.

Funktioniert sensors bei mir erstmal generell oder nicht?
Was muß ich wegen obiger Fehlermeldung machen?
Gibt es eine verständliche Anleitung für das editieren der sensors.conf? Ich sehe da nicht durch.
Wie kann ich die .conf in Dolphin mit root öffnen? Sonst kann ich nicht speichern.

Wer möchte helfen?
Tschau
OpenSuxiser


AMD X2 4850e | GA-MA78GM-S2H | 4GB | WD5000AACS
OpenSuse 11.0 (Kernel 2.6.25.11-0.1-default) & Gnome 2.22.1 (64Bit)
Benutzeravatar
spezi
Advanced Hacker
Advanced Hacker
Beiträge: 817
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Re: sensors - irgendwas stimmt da nicht?

Beitrag von spezi »

Hallo,
Deine Ausgabe sieht ganz ok aus.
Was dieses cp soll weiss ich nicht. Wo hast Du das her?
Normal ist das im Rahmen von sensors-detect am Schluß folgendes kommt . Bei Deinem System werden die Ausgaben natürlich anders aussehen

Code: Alles auswählen

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `w83627hf' (should be inserted):
  Detects correctly:
  * ISA bus, address 0x290
    Chip `Winbond W83637HF Super IO Sensors' (confidence: 9)

I will now generate the commands needed to load the required modules.
Just press ENTER to continue:

To make the sensors modules behave correctly, add these lines to
/etc/modprobe.conf:

#----cut here----
# I2C module options
alias char-major-89 i2c-dev
#----cut here----

To load everything that is needed, add this to some /etc/rc* file:

#----cut here----
# Chip drivers
modprobe w83627hf
# sleep 2 # optional
/usr/bin/sensors -s # recommended
#----cut here----

If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones! You really
should try these commands right now to make sure everything is
working properly. Monitoring programs won't work until the needed
modules are loaded.

Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no): n
den ersten Teil packst Du in die modprobe.conf, den zweiten in die boot.local und lässt sensors die /etc/sysconfig/lm_sensors schreiben.
Bei Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no) musst Du natürlich y antworten. Das wars.
In der sensors.conf Dateien muss man eigentlich nichts ändern.

mfg
spezi
Dell Optiplex 790 i5-2400, LG-32MP58, Lenovo V320 i5-7200U, BR MFC-J4420DW, FRITZ!Box 7490, Synology DS215j, oS Leap 15.2, Raucher
Antworten