Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

USB-Stick wird nicht geöffnet:"A security policy in place.."

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Olaf123
Member
Member
Beiträge: 219
Registriert: 21. Jun 2005, 00:49
Wohnort: Schleswig-Holstein, Kreis Segeberg
Kontaktdaten:

USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von Olaf123 »

Hallo !

Bei zwei PCs, auf denen ich Suse 10.3 installiert habe, wird mein USB-Stick zwar "irgendwie" erkannt, aber die Daten werden nicht angezeigt:

- USB-Stick rein
-> Fenster poppt auf mit der Frage, was weiter geschehen soll. Ich klicke auf "in neuem Fenster öffnen"
-> es wird ein neues Fenster geöffnet mit der Adresse system:/media/sdb1
Das Fenster ist leer. Zusätzlich kommt die Meldung
"A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")"

Auf einem der beiden Rechner lief früher Suse 10.0, da klappte es einwandfrei. Der USB-Stick wurde seinerzeit korrekt unter /media/NAME-DES-STICKS eingebunden.
Auf einem weiteren, absolut identischen PC (an dem ich jetzt gerade sitze) ist noch imer 10.0 installiert, auch da klappt es einwandfrei.

In #opensuse-de wurde mir von mehreren Usern bestätigt, dass sie dieses Problem nicht kennen.
Auf Anraten hab ich es heute mit einem anderen USB-Stick getestet, gleiches Ergebnis, es funktioniert nicht.

Ich habe zwar einen Link zu einer kanotix-Seite gefunden (http://kanotix.com/PNphpBB2-viewtopic-t-23313.html), wo evtl. das gleiche Problem besprochen wird, aber es kann doch nicht sein, dass ich sowas auf allen 10.3 PCs habe, und andere kennen dieses Problem nicht ?!

EDIT:
Wenn ich mich als root in kde einlogge (ja ja, ich weiß, gaaanz böse Sache) dann kommt beim Einstecken des USB-Sticks die Meldung "The file or folder /media/PKBACK does not exist". (PKBACK ist der Name bzw. das Label des Sticks)
Aber der Stick ist dann trotzdem gemountet, unter "/media/PKBACK#001". Dort läuft er dann wunderbar, aber das hilft mir nicht wirklich.

Wer weiss Rat ?

Gruß
Olaf

Versuch als normaler User in kde:
var/log/messages

Code: Alles auswählen

Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: new full speed USB device using uhci_hcd and address
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: new device found, idVendor=ffff, idProduct=1300
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=3
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: Product: USB DISK Pro
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: Manufacturer:
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: SerialNumber: 574917000DA9
Sep  2 20:08:40 linux-wb1 kernel: usb 1-2: configuration #1 chosen from 1 choice
Sep  2 20:08:40 linux-wb1 kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Sep  2 20:08:40 linux-wb1 kernel: usb-storage: device found at 3
Sep  2 20:08:40 linux-wb1 kernel: usb-storage: waiting for device to settle before scanning
Sep  2 20:08:41 linux-wb1 kernel: scsi 3:0:0:0: Direct-Access              USB DISK Pro     3.0
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] 253952 512-byte hardware sectors (130 MB)
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Write Protect is off
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Mode Sense: 03 00 00 00
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write through
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] 253952 512-byte hardware sectors (130 MB)
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Write Protect is off
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Mode Sense: 03 00 00 00
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write through
Sep  2 20:08:41 linux-wb1 kernel:  sdb: sdb1
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: [sdb] Attached SCSI removable disk
Sep  2 20:08:41 linux-wb1 kernel: sd 3:0:0:0: Attached scsi generic sg1 type 0
Sep  2 20:08:41 linux-wb1 kernel: usb-storage: device scan complete
Versuch als root in kde:
/var/log/messages

Code: Alles auswählen

Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: new full speed USB device using uhci_hcd and address 3
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: new device found, idVendor=ffff, idProduct=1300
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: new device strings: Mfr=1, Product=2, SerialNumber=3
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: Product: USB DISK Pro    
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: Manufacturer:         
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: SerialNumber: 574917000DA9
Sep  3 14:08:10 linux-wb1 kernel: usb 1-1: configuration #1 chosen from 1 choice
Sep  3 14:08:11 linux-wb1 kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Sep  3 14:08:11 linux-wb1 kernel: usb-storage: device found at 3
Sep  3 14:08:11 linux-wb1 kernel: usb-storage: waiting for device to settle before scanning
Sep  3 14:08:12 linux-wb1 kernel: scsi 3:0:0:0: Direct-Access              USB DISK Pro     3.09 PQ: 0 ANSI: 0 CCS
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] 253952 512-byte hardware sectors (130 MB)
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Write Protect is off
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Mode Sense: 03 00 00 00
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write through
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] 253952 512-byte hardware sectors (130 MB)
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Write Protect is off
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Mode Sense: 03 00 00 00
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Assuming drive cache: write through
Sep  3 14:08:12 linux-wb1 kernel:  sdb: sdb1
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: [sdb] Attached SCSI removable disk
Sep  3 14:08:12 linux-wb1 kernel: sd 3:0:0:0: Attached scsi generic sg1 type 0
Sep  3 14:08:12 linux-wb1 kernel: usb-storage: device scan complete
Sep  3 14:08:13 linux-wb1 hald: mounted /dev/sdb1 on behalf of uid 0
Olaf123
Member
Member
Beiträge: 219
Registriert: 21. Jun 2005, 00:49
Wohnort: Schleswig-Holstein, Kreis Segeberg
Kontaktdaten:

Re: USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von Olaf123 »

misiu hat geschrieben:Dateisystem?
hdd (/): ext3
USB-Stick: Fat16
Zuletzt geändert von Olaf123 am 4. Sep 2008, 12:56, insgesamt 1-mal geändert.
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von lOtz1009 »

Schau mal ob dir das weiterhilft: http://www.linux-club.de/viewtopic.php?t=78230
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4023
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von misiu »

Formatiere den Stick unter Windows neu, nicht, dass es von der Formatierung kommt.....

MfG
misiu
Olaf123
Member
Member
Beiträge: 219
Registriert: 21. Jun 2005, 00:49
Wohnort: Schleswig-Holstein, Kreis Segeberg
Kontaktdaten:

Re: USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von Olaf123 »

lOtz hat geschrieben:Schau mal ob dir das weiterhilft: http://www.linux-club.de/viewtopic.php?t=78230
Leider keine Besserung.
Nach Durchführen der Änderungen ergibt das Einstecken des USB-Sticks und folgende Öffnen des entsprechenden Fensters nun die Fehlermeldung
hal-storage-mount-removable no <-- (action, result)
misiu hat geschrieben:Formatiere den Stick unter Windows neu, nicht, dass es von der Formatierung kommt.....

MfG
misiu
Dürfte nicht relevant sein, da ich ja bereits mit einem anderen Stick getestet habe.
Des Weiteren wird der Stick von Suse 10.0 einwandfrei erkannt.


EDIT:

Unter Suse 10.0 werden mit den aufpoppenden Abfragen (das sind ja immer zwei ?!) und meiner Bestätigung "in neuen Fenster öffnen" folgende Pfade geöffnet:
system:/media/sda1
/media/PKBACK__001

Beide funktionieren.
Auffällig finde ich den Unterschied des zweiten Pfades im Vergleich zu dem, den Suse 10.3 wählt:
/media/PKBACK#001 (der wie erwähnt _nicht_ funktioniert, ebenso wie der system:/blablubb unter 10.3)
Zuletzt geändert von Olaf123 am 5. Sep 2008, 12:22, insgesamt 2-mal geändert.
Olaf123
Member
Member
Beiträge: 219
Registriert: 21. Jun 2005, 00:49
Wohnort: Schleswig-Holstein, Kreis Segeberg
Kontaktdaten:

Re: USB-Stick wird nicht geöffnet:"A security policy in place.."

Beitrag von Olaf123 »

Ich relativiere übrigens meine Aussage von weiter oben
Olaf123 hat geschrieben: es kann doch nicht sein, dass ich sowas auf allen 10.3 PCs habe, und andere kennen dieses Problem nicht ?!
Tatsächlich schaut es nämlich so aus, dass google haufenweise Ergebnisse dazu anzeigt, eine Menge User (nicht nur Suse) mit dem gleichen und ähnlichen Problem.
Die oben bereits genannte Bastelei ist eine für einige User funktionierende Lösung, nur halt leider nicht bei jedem.

Ich werd's wohl mal mit 11.0 versuchen müssen.

EDIT:

mit 11.0 klappts ebenfalls nicht, dort wird der gleiche ("falsche"?) Pfad geöffnet, ebenso wird unter Media mit der falschen Bezeichnung "PKBACK#001" (statt "PKBACK__001) gemountet.
Stimmt da was mit dem Zeichensatz nicht, so dass da nur der Name falsch ausgelesen wird?
Antworten