Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

rpmdb lock

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
sharky_

rpmdb lock

Beitrag von sharky_ »

hi, bei mir kommt beim update mit smart diese Fehlermeldung, mit der kann ich leider nicht wirklich was anfangen :???:

Code: Alles auswählen

Übermittle Transaktion ...
error: can't create transaction lock on /var/lib/rpm/__db.000

Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in <module>
    main(sys.argv[1:])
  File "/usr/bin/smart", line 167, in main
    exitcode = iface.run(opts.command, opts.argv)
  File "/usr/lib/python2.5/site-packages/smart/interface.py", line 53, in run
    result = _command.main(self._ctrl, opts)
  File "/usr/lib/python2.5/site-packages/smart/commands/upgrade.py", line 187, in main
    ctrl.commitTransaction(trans, confirm=confirm)
  File "/usr/lib/python2.5/site-packages/smart/control.py", line 500, in commitTransaction
    return self.commitChangeSet(trans.getChangeSet(), caching, confirm)
  File "/usr/lib/python2.5/site-packages/smart/control.py", line 568, in commitChangeSet
    os.unlink(path)
OSError: [Errno 13] Permission denied: '/var/lib/smart/packages/kdenetwork3-wireless-3.5.10-3.2.i586.rpm'
habe auch schon versucht nur einzelne Pakete zu upgraden, aber das funktioniert auch nicht, ich bin der Meinung, dass es an smart liegt
Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Re: rpmdb lock

Beitrag von Appleonkel »

Bitte keine alten Threads kapern! Danke!
sharky_ hat geschrieben:error: can't create transaction lock on /var/lib/rpm/__db.000
Mach mal Yast zu oder warte bis der openSUSE-Updater fertig ist, irgendwas greift noch auf deien RPM Datenbank zu.
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4
sharky_

Re: rpmdb lock

Beitrag von sharky_ »

Bitte keine alten Threads kapern! Danke!
Sorry aber wenn das Wissen begrenzt ist ist es nicht leicht richtig zu posten und
normaler Weise ist es in Foren nicht erwünscht zu viele Threads zu einem Problem zu
öffnen

an Yast kann es nicht liegen, nach einem kompletten Neustart kommt jetzt immer
von smart die Meldung, dass es die Konfiguration nur im Lese Modus arbeitet :???:
Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Re: rpmdb lock

Beitrag von Appleonkel »

Du hast smart aber schon als root laufen?
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4
sharky_

Re: rpmdb lock

Beitrag von sharky_ »

hab es nochmal direkt als root laufen lassen, dann kam das mit dem Read only nicht mehr...
das eigentliche Problem war jedoch ein Konflikt zwischen den Paketen:

liboil
libnut0
libavformat52
libavcodec51
libschroedinger0
gstream

hab die Pakete deinstalliert, was viele andere mitgenommen hat, aber jetzt geht es wieder
Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Re: rpmdb lock

Beitrag von Appleonkel »

Wenn es gelöst ist bitte mal hier einen Blick drauf werfen Bild
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4
Antworten