Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von Becksta »

Huhu,

um mich mal näher mit dem Thema Sharepoint ausseinander zu setzen, habe ich vorgehabt, mich mal dem Thema xen zu nähern.
Ohne große Vormaßnahmen einfach mal im Yast die Funktion ausgewählt und dann die geforderten Pakete installiert. Dieses Procedere lief ohne Probleme durch. Sowohl auf meinem Server, als auch auf meinem Notebook, wo ich es im Anschluss ebenfalls versucht habe.

Auf beiden Rechner kann ich nun im grub ne Kernelversion mit xen booten. Wenn ich dann allerdings über Yast versuche eine neue virtuelle Maschine anzulegen, kriege ich auf beiden Testrechnern den Hinweis, dass der Hypervisor nicht läuft.

Sowas wie "rcxend start" hab ich schon versucht. Der Befehl läuft auch ohne Fehler durch.
Hab ich da noch einen Denkfehler, oder sollte das nicht so funktionieren? Ich meine damit, den Xen-Kernel zu booten und dann die virtuellen Maschinen dort zu installieren. Welche Dienste müssen denn da noch mitlaufen??

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von Becksta »

Hm,

hier mal die Details der Fehlermeldung die ich in Yast erhalte, wenn ich "Virtual Machine Manager" aufrufen möchte:

Code: Alles auswählen

Unable to open connection to hypervisor URI 'xen:///':
<class 'libvirt.libvirtError'> virConnectOpenReadOnly() failed
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 325, in _open_thread
    self.vmm = libvirt.openReadOnly(self.uri)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 144, in openReadOnly
    if ret is None:raise libvirtError('virConnectOpenReadOnly() failed')
libvirtError: virConnectOpenReadOnly() failed
Und das folgende gibt tail -f /var/log/xen/xend.log aus:

Code: Alles auswählen

BeckstaNotebook:/home/becksta # tail -f /var/log/xen/xend.log
[2008-08-29 23:39:04 3667] INFO (SrvDaemon:331) Xend Daemon started
[2008-08-29 23:39:04 3667] INFO (SrvDaemon:335) Xend changeset: 17990.
[2008-08-29 23:39:04 3667] ERROR (SrvDaemon:347) Exception starting xend (ssl_key_file or ssl_cert_file for ssl relocation server is missing.)
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/xen/xend/server/SrvDaemon.py", line 338, in run
    relocate.listenRelocation()
  File "/usr/lib/python2.5/site-packages/xen/xend/server/relocate.py", line 170, in listenRelocation
    raise XendError("ssl_key_file or ssl_cert_file for ssl relocation server is missing.")
XendError: ssl_key_file or ssl_cert_file for ssl relocation server is missing.
[2008-08-29 23:39:04 3666] INFO (SrvDaemon:219) Xend exited with status 1.
Hätten im Rahmen der Installation Zertifikate angelegt worden sein??

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional
stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von stefan.becker »

Die Dinger gingen bei mir auch nie unter 10.3.

Vergiss es einfach.

1) Online Update, danach könnte es gehen

2) Suse 11+Online Update, danach geht es auf jeden Fall

3) Den Kram in die Tonne kloppen und stattdessen "convirt" nehmen
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von whois »

stefan.becker hat geschrieben:Die Dinger gingen bei mir auch nie unter 10.3.
Ack, es war an der Version von Suse doch einiges Gewöhnungsbedürftig. ;)
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von Becksta »

Hm,

damit kann ich ja jetzt mal noch nicht viel anfangen... *g*

Also auf meinem Notebook, wo sich das Problem identisch zeigt, habe ich die Suse11 installiert und natürlich auch schon ein Online Update gemacht....

Leider geht es trotzdem nicht.... :(

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional
Benutzer 41186 gelöscht

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von Benutzer 41186 gelöscht »

Hallo
also ich habe mit openSuSE 11 das gleich Problem. (Die Konfiguration von virtuellen Maschinen via Yast tut nicht). Ich habe das Problem mit der Benutzung der Konsolentools "vm-install" und "xm" umgangen.

Karlchen
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von Becksta »

aha...

damit geht es schonmal los.... *g*
Folgende Frage habe ich aber noch:
Auf dem Server läuft keine grafische Benutzeroberfläche. Wenn ich jetzt die virtuelle Maschine angelegt habe und das Installationsmedium als iso hinterlegt habe, wie kann ich dann grafisch den windows installer nutzen??
Ich müsste mich dann von einem anderen Rechner aus per Yast Xen Modul mit der Maschine verbinden, oder??? *g*

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional
stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: Nach XEN-Kernel keine Anlage von virt. Maschinen möglich

Beitrag von stefan.becker »

Du kannst das Image für die Windows Installation an einem anderen Rechner z. B. per Qemu erstellen und dann später rüberkopieren.

Wenn der Windows Gast bereits läuft, ist RDP das entsprechende Mittel zur Verwaltung des Gastes.
Antworten