Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

bittornado unter suse 11

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
mad-max
Member
Member
Beiträge: 84
Registriert: 13. Apr 2005, 22:37

bittornado unter suse 11

Beitrag von mad-max »

tag zusammen,

wie in der anleitung zu bittornado beschrieben, habe ich python-wxgtk (version 2.8.7..) installiert.
beim versuch bittornado zu starten kommt es jedoch zu folgender meldung:

Code: Alles auswählen

./btdownloadgui.py:20: DeprecationWarning: The wxPython compatibility package is no longer automatically generated or actively maintained.  Please switch to the wx package as soon as possible.
  from wxPython.wx import *
wxPython is either not installed or has not been installed properly.
kann mir jemand zu dem problem was sagen?

gruß
mad-max
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5540
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: bittornado unter suse 11

Beitrag von tomm.fa »

mad-max hat geschrieben:wie in der anleitung zu bittornado beschrieben, habe ich python-wxgtk (version 2.8.7..) installiert.
Nach welcher Anleitung? Nutze deinen Paketmanager, Bittornado gibt es im Packman-Repo.
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
mad-max
Member
Member
Beiträge: 84
Registriert: 13. Apr 2005, 22:37

Re: bittornado unter suse 11

Beitrag von mad-max »

im zip archiv zu dem neuesten client auf der bittornado seite, ist die rede unter anderem davon, dass python-wxgtk version 2.8.7 benötigt wird...
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: bittornado unter suse 11

Beitrag von whois »

mad-max hat geschrieben:im zip archiv zu dem neuesten client auf der bittornado seite, ist die rede unter anderem davon, dass python-wxgtk version 2.8.7 benötigt wird...
Warum benutzt du nicht dein Repo und Compilierst selber?
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5540
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: bittornado unter suse 11

Beitrag von tomm.fa »

tomfa hat geschrieben:Nutze deinen Paketmanager, Bittornado gibt es im Packman-Repo.
und python-wxgtk 2.8.7.1 gibt es unter anderem im OSS Repo.
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: bittornado unter suse 11

Beitrag von oc2pus »

tomfa hat geschrieben:
tomfa hat geschrieben:Nutze deinen Paketmanager, Bittornado gibt es im Packman-Repo.
und python-wxgtk 2.8.7.1 gibt es unter anderem im OSS Repo.
und auch im packman repo :)
http://packman.links2linux.de/package/wxWidgets

damit BitTornado funktioniert folgende Änderung vornehmen:

editiere /usr/bin/btdownloadgui.py
und ändere 2.6 zu 2.8

Code: Alles auswählen

try:
    import wxversion
    wxversion.select("2.8")
except Exception, e:
    print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
    sys.exit(1)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Antworten