Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 10.0 und Windows98: KDE bootet nicht bei einem User

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
sortesindet
Newbie
Newbie
Beiträge: 2
Registriert: 22. Aug 2008, 01:15

Suse 10.0 und Windows98: KDE bootet nicht bei einem User

Beitrag von sortesindet »

Hi all,

ich hatte zwar seit 1975 mit Computern zu tun, bin aber kein Linuxexperte. Daher weiß ich jetzt nicht, unter welchem Stichwort ich Hilfe zur Problemlösung finden kann.

Kürzlich habe ich das System vom Monitor auf TFT (der Vesa unterstützt) umgestellt und dazu Sax2 -m 0=vesa ausgeführt. Daraufhin wurde der TFT gelistet und alles funktionierte mit vesa wunderbar. Und dies, obgleich der für die Grafik genutzte SiS-Chip des Motherboards als "unknown" geführt wird.

Dann stellte sich heraus, das bei einem User Monzilla nicht mehr ansprechbar war. Zuvor war ein Linuxupdate des Flashplayers von der Neckermannseite durchgeführt worden. Unmittelbar danach war mehrfach ein Wechsel über Grub zwischen Win98SE und Linux möglich. Scheinbar war alles in Ordnung.

Dann jedoch wurde der PC ausgeschaltet und sollte am folgenden Tag wieder hochgefahren werden. Alles funktioniert bis zur Auswahl des Users und der Passworteingabe. Der User und das Passwort wurde eingegeben, Linux öffnete für den Bruchteil einer Sekunde das X-System, brach mit einem kurzzeitigen schwarzen Screen ab und man landete wieder auf dem Bildschirm zur Auswahl des Users und der Eingabe des Passworts.

Könnte der Flashplayerupdate einen falschen init-V aufgespielt haben?

X bzw. KDE läßt sich aus Failsafe heraus nicht mit startx starten, wenn man zuvor den betreffenden User und sein Passwort eingegeben hat. Alle anderen User und auch root sind davon nicht betroffen.

Es wäre schön, den User wieder graphisch ansprechen zu können, da in diesem Arm des Daten-Verzeichnis wichtige Daten und 3 Jahre Arbeit stecken. So gut ich kann werde ich - wenn nötig - weitere Angaben machen.

Med venlig hilsen,
sortesindet
sortesindet
Newbie
Newbie
Beiträge: 2
Registriert: 22. Aug 2008, 01:15

Re: Suse 10.0 und Windows98: KDE bootet nicht bei einem User

Beitrag von sortesindet »

Hallo Linux-Club,

falls das hier das falsche Bord ist, bitte ich die Admins, meine Anfrage ins richtige Bord zu verschieben.

In einem anderen Tread fand ich die Info, daß Suse 10.0 nur noch root als angemeldet akzeptiert, wenn die Platte über 90% belegt ist. Wie mein Suse 10.0 dann noch die Einrichtung eines weiteren Users akzeptiert, deren Zugang ebenso wie der root-Zugang einwandfrei funktioniert, ältere eingetragene User aber blockt, ist mir nicht erklärlich.

Hat sich inzwischen herausgestellt, daß die Linuxpartition zu 93% belegt war. Durch Löschen und Datensicherung wurde die Belegung der Partition inzischen auf 74% reduziert.

Wie überrede ich die Suse jetzt, die alten User-Bereiche zu entsperren?

Mit freundlichen Grüssen,
sortesindet
Benutzeravatar
Wusel1007
Member
Member
Beiträge: 202
Registriert: 24. Mär 2007, 17:26
Wohnort: Mechernich
Kontaktdaten:

Re: Suse 10.0 und Windows98: KDE bootet nicht bei einem User

Beitrag von Wusel1007 »

Das mit den 10% (eigentlich 5%) ist eine Standardoption bei der Erstellung von Partitionen und Erstellung des Filesystems (option -m bei mkfs ; Standardwert 5% wenn nicht anders festgelegt) Das hat zur Auswirkung, das normale Nutzer auf diesen Bereich nicht zugreifen können, also das System nicht zufahren können, weil die Platte voll ist. Hier wird aber nichts gesperrt, sondern nur reserviert. Daher muss auch nichts wieder freigegeben werden. Ich denke mal, das dein Problem wo anders liegt. Wahrscheinlich wird beim Start von KDE irgendwas gestartet oder geladen, was den X-Server beendet (schwarzer Bildschirm). Da bei den anderen Nutzer alles funktioniert scheint ja der Grafikkartentreiber oder deren Einstellung nicht das Problem zu sein. Du kannst nun folgendes versuchen. Auf der Konsole in den Home-Ordner des betreffenden Nutzers wechseln. Hier gibt es einen versteckten Ordern /home/deinNutzer/.kde (Punkt beachten). Hier werden alle Einstellungen für den Desktop und Anwendungen gespeichert. Verschiebe den Ordner unter einen anderen Namen. Bei der nächsten Anmeldung erstellt KDE den Ordner neu. Falls das Problem doch das Flash-Player-Plugin sein sollte, so schau Dir auch im Home Ordner den versteckten Ordner /home/deinUser/.Mozilla an. Hier werden auch verschiedene Einstellungen für den Browser gesichert. Da allerdings X bereits bei der Anmeldung aussteigt und nicht erst mit Start von Firefox/Mozilla denke ich, das der .kde Ordner ein guter Ansatz ist.
Schönes Wochenende.
There are 10 Types of People In The World

Those That Understand BINARY And Those That Don't
Antworten