Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehler bei der Initialisierung des Repositorys 'repo-oss'

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Hallo,

ich bekomme folgende Fehlermeldung in Yast bei einem System-Update:
Fehler bei der Initialisierung des Repositorys.
'repo-oss': Keine gültigen Metadaten an der angegebenen Adresse (URL) gefunden
Folgende Fehler sind aufgetreten:
- Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-ossQzuzmu
- Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-ossQzuzmu
Wie kann ich denn diesen Fehler beheben? :\
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

In der Konsole sieht es wie folgt aus:

Code: Alles auswählen

fish@linux-i1r9:~> sudo zypper dup
root's password:
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-ossuO8geP
Warning: Disabling repository 'openSUSE-11.0-Oss' because of the above error.
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-non-ossDXccN0
Warning: Disabling repository 'openSUSE-11.0-Non-Oss' because of the above error.
Reading installed packages...
76 Problems:
Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
Problem: nothing provides libc.so.6 needed by insserv-1.11.0-31.2.i586
Problem: nothing provides libc.so.6 needed by aaa_base-11.0-79.2.i586
Problem: nothing provides libc.so.6 needed by timezone-2008c-0.1.i586
Problem: nothing provides libc.so.6 needed by libpng12-0-1.2.26-14.2.i586
Problem: nothing provides libc.so.6 needed by pcre-7.6-22.2.i586
Problem: nothing provides libc.so.6 needed by freetype2-2.3.5-62.2.i586
Problem: nothing provides libc.so.6 needed by nspluginwrapper-0.9.91.5.99.20071225-22.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nspr-4.7.1-18.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nss-3.12.0-23.2.i586
Problem: nothing provides libc.so.6 needed by yast2-qt-pkg-2.16.47-0.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-7.3-96.2.i586
Problem: nothing provides libc.so.6 needed by libgobject-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgmodule-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by glib2-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libglib-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-fam-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgthread-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-7.3-70.2.noarch
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-core-7.3-70.2.noarch
Problem: nothing provides libc.so.6 needed by bind-utils-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by bind-libs-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by libxcrypt-3.0-14.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-x11-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-qt3support-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-sql-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libkdecore4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by libkde4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-core-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by acpid-1.0.6-63.2.i586
Problem: nothing provides libc.so.6 needed by procinfo-18-170.2.i586
Problem: nothing provides libc.so.6 needed by libpoppler-qt2-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler-glib3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by poppler-tools-0.8.2-1.3.i586
Problem: nothing provides /bin/bash needed by SuSEfirewall2-3.6_SVNr195-9.2.noarch
Problem: nothing provides libc.so.6 needed by x11-input-wacom-tools-0.7.9-50.2.i586
Problem: nothing provides /bin/sh needed by gconf2-branding-openSUSE-2.20-53.2.noarch
Problem: nothing provides /bin/sh needed by kernel-default-2.6.25.11-0.1.i586
Problem: nothing provides libc.so.6 needed by libsnmp15-5.4.1-77.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-gnomevfs-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by MozillaFirefox-3.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by kdebase4-runtime-4.0.4-20.2.i586
Problem: nothing provides libc.so.6 needed by kdebase4-workspace-ksysguardd-4.0.4-24.6.i586
Problem: nothing provides libc.so.6 needed by fileshareset-2.0-501.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-runtime-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-nsplugin-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-samba-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-kdm-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-beagle-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-Xvnc-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-server-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by libexif-0.6.16.2-32.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-x11-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by libacl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by acl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-driver-video-7.3-138.5.i586
Problem: nothing provides libc.so.6 needed by libesd0-0.2.38-75.2.i586
Problem: nothing provides libc.so.6 needed by libgnome-2.22.0-30.2.i586
Problem: nothing provides libc.so.6 needed by yast2-ncurses-pkg-2.16.14-0.2.i586
Problem: nothing provides libc.so.6 needed by libzypp-4.27.1-0.1.i586
Problem: nothing provides libc.so.6 needed by satsolver-tools-0.9.4-0.1.i586
Problem: nothing provides libc.so.6 needed by zypper-0.11.10-0.2.i586
Problem: nothing provides libc.so.6 needed by yast2-pkg-bindings-2.16.40-0.2.i586
Problem: nothing provides libc.so.6 needed by postfix-2.5.1-28.3.i586
Problem: nothing provides libc.so.6 needed by python-xml-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by python-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by NetworkManager-kde-0.7r821737-0.3.i586
Problem: nothing provides libc.so.6 needed by ruby-1.8.6.p114-6.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586

Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
 Solution 1: do not install autoyast2-installation-2.16.19-0.1.noarch

Choose the above solution using '1' or skip, retry or cancel [1/s/r/C]:    
Habe gerade nochmals frisch installiert und dieses Mal noch keine neuen Repos eingebunden.

Ist also noch eine Suse 11.0 Standardinstallation. :???:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Wenn ich nach der Fehlermeldung google, dann finde ich übermäßig viele Meldungen, die auf ein krummes Installationsmedium hinweisen.
md5sums gecheckt? War das Installationsmedium zufällig eine CD-RW?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Es war eine DVD +R 4.7GB Single Sided 1-16x Version 1.3 von TDK. So wie ich das sehe keine RW.

Nein, MD5 habe ich nicht geprüft. Kann ich das nachträglich noch machen? Wie? Das ISO ist schon überschrieben, hab nur noch die gebrannte CD...
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Wenn man die DVD einlegt kann man das Medium vor der Auswahl der Installation prüfen lassen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Danke, wird gleich gemacht. Ich werde berichten.
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

No errors found. Die CD ist also okay. Woran könnte es sonst liegen?
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von lOtz1009 »

Das ganze mal richtig als Root probiert, also

Code: Alles auswählen

su - (mit Enter bestätigen und dann wie aufgefordert das Rootpasswort eingeben und bestätigen)
zypper dup
Wenn auch das nichts nützt, dann

Code: Alles auswählen

zypper clean
zypper refresh
zypper dup
Ansonsten kann ich mich Grothesk nur anschließen. :/
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Code: Alles auswählen

fish@linux-i1r9:~> su
Password:
linux-i1r9:/home/fish # zypper dup
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-osstU0BPW
Warning: Disabling repository 'openSUSE-11.0-Oss' because of the above error.
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-non-ossBO8Nlb
Warning: Disabling repository 'openSUSE-11.0-Non-Oss' because of the above error.
Reading installed packages...
76 Problems:
Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
Problem: nothing provides libc.so.6 needed by insserv-1.11.0-31.2.i586
Problem: nothing provides libc.so.6 needed by aaa_base-11.0-79.2.i586
Problem: nothing provides libc.so.6 needed by timezone-2008c-0.1.i586
Problem: nothing provides libc.so.6 needed by libpng12-0-1.2.26-14.2.i586
Problem: nothing provides libc.so.6 needed by pcre-7.6-22.2.i586
Problem: nothing provides libc.so.6 needed by freetype2-2.3.5-62.2.i586
Problem: nothing provides libc.so.6 needed by nspluginwrapper-0.9.91.5.99.20071225-22.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nspr-4.7.1-18.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nss-3.12.0-23.2.i586
Problem: nothing provides libc.so.6 needed by yast2-qt-pkg-2.16.47-0.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-7.3-96.2.i586
Problem: nothing provides libc.so.6 needed by libgobject-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgmodule-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by glib2-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libglib-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-fam-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgthread-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-7.3-70.2.noarch
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-core-7.3-70.2.noarch
Problem: nothing provides libc.so.6 needed by bind-utils-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by bind-libs-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by libxcrypt-3.0-14.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-x11-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-qt3support-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-sql-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libkdecore4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by libkde4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-core-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by acpid-1.0.6-63.2.i586
Problem: nothing provides libc.so.6 needed by procinfo-18-170.2.i586
Problem: nothing provides libc.so.6 needed by libpoppler-qt2-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler-glib3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by poppler-tools-0.8.2-1.3.i586
Problem: nothing provides /bin/bash needed by SuSEfirewall2-3.6_SVNr195-9.2.noarch
Problem: nothing provides libc.so.6 needed by x11-input-wacom-tools-0.7.9-50.2.i586
Problem: nothing provides /bin/sh needed by gconf2-branding-openSUSE-2.20-53.2.noarch
Problem: nothing provides /bin/sh needed by kernel-default-2.6.25.11-0.1.i586
Problem: nothing provides libc.so.6 needed by libsnmp15-5.4.1-77.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-gnomevfs-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by MozillaFirefox-3.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by kdebase4-runtime-4.0.4-20.2.i586
Problem: nothing provides libc.so.6 needed by kdebase4-workspace-ksysguardd-4.0.4-24.6.i586
Problem: nothing provides libc.so.6 needed by fileshareset-2.0-501.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-runtime-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-nsplugin-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-samba-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-kdm-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-beagle-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-Xvnc-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-server-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by libexif-0.6.16.2-32.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-x11-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by libacl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by acl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-driver-video-7.3-138.5.i586
Problem: nothing provides libc.so.6 needed by libesd0-0.2.38-75.2.i586
Problem: nothing provides libc.so.6 needed by libgnome-2.22.0-30.2.i586
Problem: nothing provides libc.so.6 needed by yast2-ncurses-pkg-2.16.14-0.2.i586
Problem: nothing provides libc.so.6 needed by libzypp-4.27.1-0.1.i586
Problem: nothing provides libc.so.6 needed by satsolver-tools-0.9.4-0.1.i586
Problem: nothing provides libc.so.6 needed by zypper-0.11.10-0.2.i586
Problem: nothing provides libc.so.6 needed by yast2-pkg-bindings-2.16.40-0.2.i586
Problem: nothing provides libc.so.6 needed by postfix-2.5.1-28.3.i586
Problem: nothing provides libc.so.6 needed by python-xml-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by python-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by NetworkManager-kde-0.7r821737-0.3.i586
Problem: nothing provides libc.so.6 needed by ruby-1.8.6.p114-6.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586

Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
 Solution 1: do not install autoyast2-installation-2.16.19-0.1.noarch

Choose the above solution using '1' or skip, retry or cancel [1/s/r/C]: C
linux-i1r9:/home/fish # zypper clean
All repositories have been cleaned up.
linux-i1r9:/home/fish # zypper refresh
Downloading repository 'openSUSE-11.0-Oss' metadata [error]
Repository 'openSUSE-11.0-Oss' is invalid.
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-oss2Ptb8j
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'openSUSE-11.0-Oss' because of the above error.
Repository 'Updates for 11.0' is up to date.
Downloading repository 'openSUSE-11.0-Non-Oss' metadata [error]
Repository 'openSUSE-11.0-Non-Oss' is invalid.
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-non-ossKg1n2e
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'openSUSE-11.0-Non-Oss' because of the above error.
Some of the repositories have not been refreshed because of an error.
linux-i1r9:/home/fish # zypper dup$
Unknown command 'dup$'
Type 'zypper help' to get a list of global options and commands.
linux-i1r9:/home/fish # zypper dup
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-ossw6KVt4
Warning: Disabling repository 'openSUSE-11.0-Oss' because of the above error.
Error building the cache database:
Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-non-ossq8BtGY
Warning: Disabling repository 'openSUSE-11.0-Non-Oss' because of the above error.
Reading installed packages...
76 Problems:
Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
Problem: nothing provides libc.so.6 needed by insserv-1.11.0-31.2.i586
Problem: nothing provides libc.so.6 needed by aaa_base-11.0-79.2.i586
Problem: nothing provides libc.so.6 needed by timezone-2008c-0.1.i586
Problem: nothing provides libc.so.6 needed by libpng12-0-1.2.26-14.2.i586
Problem: nothing provides libc.so.6 needed by pcre-7.6-22.2.i586
Problem: nothing provides libc.so.6 needed by freetype2-2.3.5-62.2.i586
Problem: nothing provides libc.so.6 needed by nspluginwrapper-0.9.91.5.99.20071225-22.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nspr-4.7.1-18.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-nss-3.12.0-23.2.i586
Problem: nothing provides libc.so.6 needed by yast2-qt-pkg-2.16.47-0.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-7.3-96.2.i586
Problem: nothing provides libc.so.6 needed by libgobject-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgmodule-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by glib2-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libglib-2_0-0-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgio-fam-2.16.3-20.2.i586
Problem: nothing provides libc.so.6 needed by libgthread-2_0-0-2.16.3-20.2.i586
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-7.3-70.2.noarch
Problem: nothing provides /bin/sh needed by xorg-x11-fonts-core-7.3-70.2.noarch
Problem: nothing provides libc.so.6 needed by bind-utils-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by bind-libs-9.4.2-39.2.i586
Problem: nothing provides libc.so.6 needed by libxcrypt-3.0-14.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-x11-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-qt3support-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libqt4-sql-4.4.0-12.2.i586
Problem: nothing provides libc.so.6 needed by libkdecore4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by libkde4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-core-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by kdelibs4-4.0.4-15.2.i586
Problem: nothing provides libc.so.6 needed by acpid-1.0.6-63.2.i586
Problem: nothing provides libc.so.6 needed by procinfo-18-170.2.i586
Problem: nothing provides libc.so.6 needed by libpoppler-qt2-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler-glib3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by libpoppler3-0.8.2-1.3.i586
Problem: nothing provides libc.so.6 needed by poppler-tools-0.8.2-1.3.i586
Problem: nothing provides /bin/bash needed by SuSEfirewall2-3.6_SVNr195-9.2.noarch
Problem: nothing provides libc.so.6 needed by x11-input-wacom-tools-0.7.9-50.2.i586
Problem: nothing provides /bin/sh needed by gconf2-branding-openSUSE-2.20-53.2.noarch
Problem: nothing provides /bin/sh needed by kernel-default-2.6.25.11-0.1.i586
Problem: nothing provides libc.so.6 needed by libsnmp15-5.4.1-77.2.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by mozilla-xulrunner190-gnomevfs-1.9.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by MozillaFirefox-3.0.1-0.1.i586
Problem: nothing provides libc.so.6 needed by kdebase4-runtime-4.0.4-20.2.i586
Problem: nothing provides libc.so.6 needed by kdebase4-workspace-ksysguardd-4.0.4-24.6.i586
Problem: nothing provides libc.so.6 needed by fileshareset-2.0-501.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-runtime-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-nsplugin-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-samba-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-kdm-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-beagle-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-Xvnc-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-server-7.3-110.9.i586
Problem: nothing provides libc.so.6 needed by libexif-0.6.16.2-32.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by ConsoleKit-x11-0.2.10-14.2.i586
Problem: nothing provides libc.so.6 needed by libacl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by acl-2.2.47-6.1.i586
Problem: nothing provides libc.so.6 needed by xorg-x11-driver-video-7.3-138.5.i586
Problem: nothing provides libc.so.6 needed by libesd0-0.2.38-75.2.i586
Problem: nothing provides libc.so.6 needed by libgnome-2.22.0-30.2.i586
Problem: nothing provides libc.so.6 needed by yast2-ncurses-pkg-2.16.14-0.2.i586
Problem: nothing provides libc.so.6 needed by libzypp-4.27.1-0.1.i586
Problem: nothing provides libc.so.6 needed by satsolver-tools-0.9.4-0.1.i586
Problem: nothing provides libc.so.6 needed by zypper-0.11.10-0.2.i586
Problem: nothing provides libc.so.6 needed by yast2-pkg-bindings-2.16.40-0.2.i586
Problem: nothing provides libc.so.6 needed by postfix-2.5.1-28.3.i586
Problem: nothing provides libc.so.6 needed by python-xml-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by python-2.5.2-26.2.i586
Problem: nothing provides libc.so.6 needed by NetworkManager-kde-0.7r821737-0.3.i586
Problem: nothing provides libc.so.6 needed by ruby-1.8.6.p114-6.2.i586
Problem: nothing provides libc.so.6 needed by kdebase3-3.5.9-65.2.i586

Problem: nothing provides /bin/sh needed by autoyast2-installation-2.16.19-0.1.noarch
 Solution 1: do not install autoyast2-installation-2.16.19-0.1.noarch

Choose the above solution using '1' or skip, retry or cancel [1/s/r/C]: C
linux-i1r9:/home/fish # 
Das wars dann wohl mit Suse...

Aber wenn ich nach einer Standardinstallation nicht mal Programme installieren (geschweige denn ein Update machen) kann, gehe ich wieder zurück zu Kubuntu...schade. Vielleicht hat ja noch jemand den entscheidenden Tipp. Google hilft mir auch nicht weiter...

:(

Edit: Falls es was zur Problemlösung beiträgt: Ich verwende die 64bit DVD.
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Schau dir mal genau an, welche Quellen da angelegt sind. Irgendwas ist da 'krumm' bei dir.

Code: Alles auswählen

zypper sl
Wie 64bit? Und warum schaut dein zypper nach 32bit-Paketen? Da stimmt doch irgendwas hinten und vorne nicht bei der Installation.

Code: Alles auswählen

uname -a
cat /etc/SuSE-release
Zuletzt geändert von Grothesk am 20. Aug 2008, 22:34, insgesamt 1-mal geändert.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Das gibt folgendes aus:

Code: Alles auswählen

linux-i1r9:/home/fish # zypper sl
# | Alias                 | Name                  | Enabled | Refresh
--+-----------------------+-----------------------+---------+--------
1 | openSUSE-DVD 11.0     | openSUSE-DVD 11.0     | Yes     | No
2 | repo-oss              | openSUSE-11.0-Oss     | Yes     | No
3 | openSUSE-11.0-Updates | Updates for 11.0      | Yes     | Yes
4 | repo-debug            | openSUSE-11.0-Debug   | No      | No
5 | repo-non-oss          | openSUSE-11.0-Non-Oss | Yes     | No
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Nummer 4 kannst du schon mal rauswerfen.
Und setz die verbleibenden drei mal auf 'aktualisieren'.

Und schau mein Edit oben nochmal an.

Die Installation ist in meinen Augen total krumm. Die libc.so.6 ist im Paket glibc enthalten. Und das MUSS auf dem System sein.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Grothesk hat geschrieben:Wie 64bit?
So 64bit:

Bild
Grothesk hat geschrieben:Und warum schaut dein zypper nach 32bit-Paketen? Da stimmt doch irgendwas hinten und vorne nicht bei der Installation.
Macht es das? Keine Ahnung warum. Ich weiss nur, dass ich die 64bit Installations-CD runtergeladen und diese in K3B als ISO gebrannt habe. Ich habe mehrmals neu installiert, aber beide Partitionen (/home und /) jedes mal wieder neu formatiert. Es kam immer die gleiche Fehlermeldung.

Die CD ist gemäss Test okay.

Code: Alles auswählen

linux-i1r9:/home/fish # uname -a
Linux linux-i1r9 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

Code: Alles auswählen

linux-i1r9:/home/fish # cat /etc/SuSE-release
openSUSE 11.0 (X86-64)
VERSION = 11.0
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Das passt nicht zueinander.
Laut uname -a hast du ein 32bit-System installiert, die anderen Meldungen würden auf ein 64bit-System schließen lassen.
Ich würde mir da nochmal eine InstallationsCD aus einer guten Quelle laden und dann beim brennen mit k3b vor und nach dem brennen die md5sum prüfen und dann halt nochmal sauber neuinstallieren.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Grothesk hat geschrieben:Nummer 4 kannst du schon mal rauswerfen.
Und setz die verbleibenden drei mal auf 'aktualisieren'.
Done.

Code: Alles auswählen

linux-i1r9:/home/fish # zypper sl
# | Alias                 | Name                  | Enabled | Refresh
--+-----------------------+-----------------------+---------+--------
1 | openSUSE-DVD 11.0     | openSUSE-DVD 11.0     | Yes     | Yes
2 | repo-oss              | openSUSE-11.0-Oss     | Yes     | Yes
3 | openSUSE-11.0-Updates | Updates for 11.0      | Yes     | Yes
4 | repo-non-oss          | openSUSE-11.0-Non-Oss | Yes     | Yes
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Grothesk hat geschrieben:Das passt nicht zueinander.
Laut uname -a hast du ein 32bit-System installiert, die anderen Meldungen würden auf ein 64bit-System schließen lassen.
Ich würde mir da nochmal eine InstallationsCD aus einer guten Quelle laden und dann beim brennen mit k3b vor und nach dem brennen die md5sum prüfen und dann halt nochmal sauber neuinstallieren.
Okay, mache ich mal. Ich dachte eigentlich, opensuse.org sei eine saubere Quelle... :ugly:
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

So, dieses Mal habe ich alles anders gemacht...

Torrent anstatt FTP.
Sony anstatt TDK Rohling.
MD5 geprüft vor dem Brennen - OK.
CD geprüft nach dem Brennen - OK.
Sämtliche Partitionen gelöscht und neu partitioniert.

Das Ergebnis? Genau der gleiche Fehler...

Code: Alles auswählen

There was an error in the repository initialization.
'repo-oss': Valid metadata not found at specified URL(s)
History:
- Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-osskurtBU
- Can't provide /suse/setup/descr/EXTRA_PROV : Can't copy /var/adm/mount/AP_0x00000001/suse/setup/descr/EXTRA_PROV to /var/cache/zypp/raw/repo-osskurtBU
Hab die Hoffnung, die 11.0 noch zum Laufen zu kriegen, irgendwie aufgegeben... :nosmile:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von Grothesk »

Welche URL steckt denn hinter der Quelle?
Mal versucht einen anderen Mirror da anzugeben?
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von SUSEDJAlex »

@stoked:

Was ergibt bei der Eingabe von

Code: Alles auswählen

zypper repos
Auf diese Liste bin ich sehr gespannt.

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
stoked
Newbie
Newbie
Beiträge: 36
Registriert: 18. Aug 2008, 23:05

Re: Fehler bei der Initialisierung des Repositorys 'repo-oss'

Beitrag von stoked »

Grothesk hat geschrieben:Welche URL steckt denn hinter der Quelle?
Mal versucht einen anderen Mirror da anzugeben?
Wie mache ich das denn? Wo gibt es alternative Mirrors?

Code: Alles auswählen

fish@linux-pyk5:~> zypper repos
# | Alias                 | Name                  | Enabled | Refresh
--+-----------------------+-----------------------+---------+--------
1 | openSUSE-DVD 11.0     | openSUSE-DVD 11.0     | Yes     | No
2 | repo-non-oss          | openSUSE-11.0-Non-Oss | Yes     | No
3 | repo-oss              | openSUSE-11.0-Oss     | Yes     | No
4 | openSUSE-11.0-Updates | Updates for 11.0      | Yes     | Yes
5 | repo-debug            | openSUSE-11.0-Debug   | No      | No
Antworten