Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

GRUB Problem in MehrOS System bei Installation

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
soapy
Newbie
Newbie
Beiträge: 2
Registriert: 19. Aug 2008, 00:41

GRUB Problem in MehrOS System bei Installation

Beitrag von soapy »

Hallo zusammen.
Würde gerne auf meinem Rechner neben XP, Vista und Ubuntu noch Suse installieren. Installation lief auch problemlos bis es zum Bootmanager kam. Folgende Fehlermeldung beleidigte dort meine Augen:
"Beim Installieren von GRUB ist ein Fehler aufgetreten.
GNU GRUB version 0.97 (640k lower/3072k upper memory)
Minimal bash-like line editing is supported. For the first word, TAB lists possible command copletitions. Anywhre else TAB lists the possible completions of a device/filename.
grub>setup --stage2=boot/grub/stage2 (hd0)(hd1.6)
Error 17: Cannot mount selected partition
grub>quit

Ist es überhaupt möglich ein viertes OS auf eine Platte zu Packen? Falls ja, welche Einstellungen benötigt GRUB, dass ich alle 4 booten kann? Derzeit läuft GRUB einwandfrei. Kann erst zwischen Windows und Linux wählen und dann natürlich auch noch falls ich Win starte zwischen Vista und XP.

Wäre nett wenn jemand ne Idee hätte wie ich das hinbekomme bzw was mit der Fehlermeldung anfangen kann.

MfG
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von lOtz1009 »

Zeig doch mal bitte die Ausgaben von

Code: Alles auswählen

fdisk -l (kleines L)

Code: Alles auswählen

cat /boot/grub/menu.lst
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
admine
Administrator
Administrator
Beiträge: 8947
Registriert: 15. Feb 2004, 21:13

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von admine »

soapy hat geschrieben: Ist es überhaupt möglich ein viertes OS auf eine Platte zu Packen?
Ja, sollte kein Problem sein.
soapy hat geschrieben: Falls ja, welche Einstellungen benötigt GRUB, dass ich alle 4 booten kann? Derzeit läuft GRUB einwandfrei.
Dann behalte doch den Grub, den du jetzt benutzt und ergänze einen Eintrag für das openSUSE.
Den kannst du aus der openSUSE-menu.lst entnehmen (wenn er denn korrekt ist).

Zur Fehlermeldung?
Du willst Grub auf die 2. Platte in Partition 7 schreiben lassen? Irgendwas kann aber mit dieser Partition nicht stimmen, wenn die nicht gemountet werden kann.
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von tommy tulpe »

Hallo!
Habe gerade mit Interesse diesen Beitrag gelesen. Habe ähnliches vor mir. Habe einen Laptop, (ASUS f7f Serie) auf dem ich neben dem schon bestehenden Vista home premium noch WinXp und openSUSE 11 installieren würde. Wie stelle ich das am Besten an, bzw. geht es überhaupt?
Ich habe gelesen, das XP Vista herausschiesst, wenn man es nach Vista installiert. Da auch Linux drauf sein soll, kam mir nun die Idee, das ich vielleicht zunächst XP und dann openSUSE dazuinstalliere. Optimal wäre dann ein Bootmenü mit Vista Xp und openSUSE als Einträgen. Wunschtraum?

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von lOtz1009 »

Soweit ich mich erinner war hier letztens sowas. Vista, XP und Suse. Schau dir mal die etwas älteren Threads durch. Falls ich den entsprechenden wiederfinde reiche ich den nach.
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von tommy tulpe »

Hallo!
Die Suche bringt zwar einiges zu Xp Vista und openSUSE, aber nicht mein spezielles Problem. Man scheint ja auch umgehen zu können, das Grub benutzt wird, was den Vorteil hat, das es weniger verschachtelt ist. Also Nicht
- Suse
- Windows > dann Vista oder Xp nachfolgen auswählen aus dem Vista Bootloader
-Failsafe
- Diskette
sondern so wie http://forum.cinefacts.de/177453-howto- ... eboot.html unter Benutzung des Vista Bootloaders. Ob das sinnvoll ist sei dahingestellt.
Mein Problem ist die schon bestehnde Vista Installation (Recovery CD ist verschlunzt) auf dem Laptop. Sonst würde ich erst Xp installieren. Oder ist das sowieso alles egal und Grub bootet alles, was er findet..
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von lOtz1009 »

Grub bootet normalerweise das was ihm vorgelegt wird. Du solltest nur vorher prüfen welche Bootvoraussetzungen für XP bzw. Vista gelten.
Wenn man Vista und XP jeweils als einzelnes Zweitsystem zu SuSE benutzen kann (was ja funktioniert), dann wüsste ich nicht warum man nicht beide parallel zu SuSE nehmen kann. Letztlich kommt ja GRUB in den MBR und bootet das ausgewählte System von der Systemeigenen Partition.

Aber was spricht gegen Gargi's Version? Den Vista-Bootloader kannste dir auch so sichern. Entweder mit einer Linux-LiveCD deiner Wahl oder sonstiger "Ultimate Boot CDs".
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von tommy tulpe »

Gegen Gargi spricht, dass er von einer XP Erstinstallation ausgeht, wahrscheinlich stillschweigend aus gutem Grund...
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von lOtz1009 »

Vista ersetze den XP Bootloader mit seinem neuen Vista/Longhorn Bootloader.
Da Vista schon drauf ist, kannst du den Bootloader _vorher_ sichern. Dann XP drauf, dann SuSE und dann den Vistaloader zurück und die entsprechenden Einstellungen machen. Oder h abe ich da nen Denkfehler?
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
admine
Administrator
Administrator
Beiträge: 8947
Registriert: 15. Feb 2004, 21:13

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von admine »

Übrigens ist das wirklich ganz toll von euch einen fremden Thread zu kapern !! :x
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von tommy tulpe »

Was heisst das? Wieso gekapert? Ich schmücke mich doch nicht mit fremden Blumen sondern verweise auf andere Quellen. Ist das nicht erlaubt, bzw. was ist da schlimm dran?
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB
soapy
Newbie
Newbie
Beiträge: 2
Registriert: 19. Aug 2008, 00:41

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von soapy »

Tommy Tulpes Problem wiederum kann ich lösen. Die Installationsreihenfolge sollte XP, Vista und dann Suse sein. Das klappt einwandfrei, hatte ich so auch schon auf meinem Rechner.Im Grub wählst du dann zwische Suse und Windows, wenn du dich für Windows entscheidest kannst dann zwischen XP und Vista wählen. Wichtig ist aber das ältere Win zuerst zu installieren. Hab ja wie gesagt XP, Vista und Ubuntu drauf nach diesem System.
So und nun back @ topic :)Wie bekomm ich nun zu den dreien noch Suse zum laufen?Kann ich in Ubuntu irgendwas in Grub schreiben und falls ja was und wo? (bin da etwas unerfahren und unwissend).Installiert ist Suse vom Prinzip ja schon. Fehlt an sich nur noch die Hardwareerkennung. Fragen über Fragen :schockiert: Bin für jeden Tip dankbar.
admine
Administrator
Administrator
Beiträge: 8947
Registriert: 15. Feb 2004, 21:13

Re: GRUB Problem in MehrOS System bei Installation

Beitrag von admine »

soapy hat geschrieben: So und nun back @ topic :)Wie bekomm ich nun zu den dreien noch Suse zum laufen?Kann ich in Ubuntu irgendwas in Grub schreiben und falls ja was und wo? (bin da etwas unerfahren und unwissend).Installiert ist Suse vom Prinzip ja schon. Fehlt an sich nur noch die Hardwareerkennung. Fragen über Fragen :schockiert: Bin für jeden Tip dankbar.
Du kannst in die menu.lst von Ubuntu einen Eintrag hinzufügen ... sollte kein Problem sein.
Nur musst du, wenn ich das richtig sehe, die SUSE-Installation erstmal abschließen.
Evt. ist das möglich, wenn du via Install-DVD versuchst das "installierte" SUSE zu booten ...?
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Antworten