Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Geloest] Problem beim installieren von libxine1

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
radlwadl
Newbie
Newbie
Beiträge: 41
Registriert: 20. Feb 2006, 13:21
Kontaktdaten:

[Geloest] Problem beim installieren von libxine1

Beitrag von radlwadl »

Hallo,

beim Multimedia-Aufruesten nach Anleitung (ueber den manuellen Weg) von gropiuskalle werden die Abhaengigkeiten des libxine1 Packetes nicht aufgeloest. Genauer: There are no installable providers of libspeexdsp.so.1() for speex-1.1.99.4-0.pm.x86_64[http://ftp/skynet.be/pub/packmansuse/10.3/]
Die 1-Click Variante geht auch nicht.

Nun gehe ich davon aus, dass meine Installationsquellen nicht stimmen, habe viel gegoogelt, gropiuskalle im pc-forum24.de wiedergefunden, packman, videolan, update, oss und non-oss repos per Hand und ueber die Community Installationsquellen eingetragen, aber nichts half.

zypper sl bringt:

Code: Alles auswählen

# | Enabled | Refresh | Type   | Alias                                                             | Name
--+---------+---------+--------+-------------------------------------------------------------------+--------------------------
1 | Yes     | Yes     | rpm-md | http://www2.ati.com/suse/10.3                                     | ATI Repository
2 | Yes     | Yes     | rpm-md | http://ftp.skynet.be/pub/packman/suse/10.3/                       | Packman Repository
3 | Yes     | No      | yast2  | http://download.opensuse.org/repositories/openSUSE:10.3/standard/ | Main Repository (OSS)
4 | Yes     | Yes     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/10.3/          | VideoLan Repository
5 | Yes     | Yes     | rpm-md | NX                                                                | NX
6 | Yes     | Yes     | rpm-md | http://download.opensuse.org/update/10.3/                         | Main Update Repository
7 | Yes     | No      | yast2  | openSUSE-10.3-retail 10.3                                         | openSUSE-10.3-retail 10.3
8 | Yes     | No      | yast2  | http://download.opensuse.org/distribution/10.3/repo/non-oss/      | Main Repository (NON-OSS)
Kann mich jemand von der Leitung stossen?

Danke und Gruesse,
Radlwadl
Zuletzt geändert von radlwadl am 26. Aug 2008, 09:40, insgesamt 1-mal geändert.
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Problem beim installieren von libxine1, SuSE 10.3, x86-64

Beitrag von SUSEDJAlex »

@radlwadl:

dein Main-Repositories stimmt nicht, richtig muss es heissen:

http://download.opensuse.org/distributi ... /repo/oss/

rein theoretisch müsste libxine1 installiert sein. Aber auch die 64-bit deines Systems kann auch Probleme bereiten. Hast du die Schlüsseln der nicht signierten Sachen importiert?

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
radlwadl
Newbie
Newbie
Beiträge: 41
Registriert: 20. Feb 2006, 13:21
Kontaktdaten:

Re: Problem beim installieren von libxine1, SuSE 10.3, x86-64

Beitrag von radlwadl »

Sorry, kam eine Woche nicht an meinen Rechner...
Die Installationsqelle fuer das Main Repo sollte schon stimmen, kommt sie doch aus dem "Klick" fuer ebendies in der "Community Repositories" - Installation im Yast. Aber auch mit geaenderteer Quelle tuts nicht.

Da ueber rpm.pbone.net die libspeexdsp.so.1() auf packman.iu-bremen.de zu finden sind, anstatt auf ftp.skynet.be Server wie er ueber die "Community Repositories" eingetragen wird, habe ich es mal damit probiert. Gut, jetzt habe ich kein Prob mit libspeexdsp.so.1() mehr, dafuer wird nun libavcodec51-0.4.9svn-20080818.pm.0.x86_64 nicht installiert, weil libx264.so.60 nicht gefunden werden kann:

Code: Alles auswählen

libavcodec51 cannot be installed due to missing dependencies
    There are no installable providers of libx264.so.60()(64bit) for libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository]
    === libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] ===
        libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] is needed by libxine1-1.1.15-0.pm.0.x86_64[Packman_Repository] (libavcodec.so.51()(64bit))
        glibc-2.6.1-18.x86_64 is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libm.so.6()(64bit))
        zlib-1.2.3-75.x86_64 is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libz.so.1()(64bit))
    9 more...
            libvorbis-1.2.0-11.x86_64 is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libvorbis.so.0()(64bit))
            libtheora0-0.99.0.7-44.x86_64 is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libtheora.so.0()(64bit))
            faad2-2.6.1-1.4.x86_64[http://download.videolan.org/pub/videolan/vlc/SuSE/10.3/] is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libfaad.so.0()(64bit))
            libx264-60-0.60-4.1.x86_64[http://download.videolan.org/pub/videolan/vlc/SuSE/10.3/] provides libx264.so.60()(64bit), but another version of that package is already installed.
            libavutil49-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libavutil.so.49()(64bit))
            libamrwb3-7.0.0.3-0.pm.0.x86_64[Packman_Repository] is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libamrwb.so.3()(64bit))
            libamrnb3-7.0.0.2-0.pm.0.x86_64[Packman_Repository] is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libamrnb.so.3()(64bit))
            libschroedinger0-1.0.5-0.pm.1.x86_64[Packman_Repository] is needed by libavcodec51-0.4.9svn-20080818.pm.0.x86_64[Packman_Repository] (libschroedinger-1.0.so.0()(64bit))
        (null)
    Conflict Resolution:
        ( ) do not install libavcodec51
        ( ) Ignore this requirement just here

#### YaST2 conflicts list END ###

Yast sagt mir, das libx264.so.60() eigentlich nicht von Hand installiert zu werden braucht und sich der Paketmanager von alleine darum kuemmert. Es ist ja auch schon eine Version installiert, laut dem obigen Hinweis. Im Yast sieht es aber nicht so danach aus, auch ein rpm -qa findet dazu nix.

Ein Kollege riet mir, auf SuSE11 zu installieren. Gut, aber ich wuerd nun schon gern wissen, was da schief laeuft. Kann mir jemand helfen?


Viele Gruesse,
Radlwadl
radlwadl
Newbie
Newbie
Beiträge: 41
Registriert: 20. Feb 2006, 13:21
Kontaktdaten:

Re: Problem beim installieren von libxine1, SuSE 10.3, x86-64

Beitrag von radlwadl »

Hallo,

habe noch ein paar Stunden gegoogelt und probiert. Letztlich SuSE 11.0 installiert und gut is.

Danke und Gruesse,
Radlwadl
Antworten