Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Brauche hilfe mit ndiswrapper

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

[gelöst] Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

hi, ich versuche nun schon seit einiger zeit meinen wlan-adapter unter linux zum laufen zu bringen und bräuchte nun eine hilfe von einem der sich mit linux besser auskennt als ich :D . also zuerst hab ich mal im internet nach einem möglichem programm gesucht und schließlich ndiswrapper gefunden. bei der installation hab ich mich exat an einige anleitungen im internet gehalten und der treiber sollte auch funktionieren, schließlich steht er ja bei der liste vom ndiswrapper dabei (http://ndiswrapper.sourceforge.net/joom ... ,list_m-n/ ,nummer 18) aber anscheinend scheitert er beim laden des treibers, hier hab ich mal die log rauskopiert:

ndiswrapper version 1.53 loaded (smp=yes, preempt=no)
input: Power Button (FF) as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
ACPI: Power Button (FF) [PWRF]
input: Power Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4
ACPI: Power Button (CM) [PWRB]
usb 2-1:
reset high speed USB device using ehci_hcd and address 2
ndiswrapper (check_nt_hdr:150): kernel is 64-bit, but Windows driver is not 64-bit;bad magic:
010B
ndiswrapper (load_sys_files:206): couldn't prepare driver 'athfmwdl'
ndiswrapper (load_wrap_driver:108):
couldn't load driver athfmwdl; check system log for messages from 'loadndisdriver'
usbcore: registered new interface driver ndiswrapper

falls irgendwer eine erklärung parat hat, würde ich ihn bitten sie möglichst einfach zu erklären, bin nämlich noch ein linux neuling :D
Zuletzt geändert von Zapeth am 16. Aug 2008, 19:43, insgesamt 1-mal geändert.
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: Brauche hilfe mit ndiswrapper

Beitrag von lOtz1009 »

Zapeth hat geschrieben:ndiswrapper (check_nt_hdr:150): kernel is 64-bit, but Windows driver is not 64-bit;bad magic:
ich denke mal daran wird es liegen.
Zeig doch mal die Ausgabe von

Code: Alles auswählen

uname -a
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: Brauche hilfe mit ndiswrapper

Beitrag von Heinz-Peter »

Zapeth hat geschrieben:...also zuerst hab ich mal im internet nach einem möglichem programm gesucht und schließlich ndiswrapper gefunden...
Brauchst Du überhaupt ein ndiswrapper? Lese bitte das hier: http://www.linux-club.de/viewtopic.php?f=19&t=93338
Wir brauchen die Ausgabe von dem Script collectNWData.sh
Gruß
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Brauche hilfe mit ndiswrapper

Beitrag von Grothesk »

Vermutlich wird der ndiswrapper überhaupt nicht mehr benötigt, weil das Ding über den b43-Treiber (und der entsprechenden Firmware) zum funken gebracht werden müsste.
Näheres nach Bekanntgabe der Ausgaben des skriptes.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

ok, hier die ausgabe von uname -a:
Linux linux-x2yn 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux

und hier die collectNWData.txt

Code: Alles auswählen

collectNWData.sh V0.6.1-3
--- Welcher Netzwerkverbindungtyp soll getestet werden?
--- (2) Kabellose Verbindung (WLAN)
--- Welche Netzwerktopologie liegt vor?
--- (2) WLAN HW router <---> LinuxClient
--- Auf welchem Rechner wird das Script ausgeführt?
--- (1) LinuxClient

!!! CND0310W: Klassische Netzwerkkonfiguration mit ifup wurde entdeckt. Die Konfiguration mit knetworkmanager ist wesentlich einfacher
--- 1 Warnungen gefunden
==================================================================================================
==================================================================================================
*** uname
Linux linux-x2yn 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
==================================================================================================
*** SuSE release
openSUSE 11.0 (X86-64)
VERSION = 11.0
==================================================================================================
*** /etc/resolv
search site
==================================================================================================
*** /etc/hosts
127.0.0.1       localhost
127.0.0.2       linux-x2yn.site linux-x2yn
==================================================================================================
*** route
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
==================================================================================================
*** arp
==================================================================================================
*** ifconfig
lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:114 errors:0 dropped:0 overruns:0 frame:0
          TX packets:114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:0 
          RX bytes:7364 (7.1 Kb)  TX bytes:7364 (7.1 Kb)

==================================================================================================
*** ping tests
connect: Network is unreachable
Ping of 195.135.220.3 failed
ping: unknown host www.suse.de
Ping of www.suse.de failed
==================================================================================================
*** PCI devices
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
==================================================================================================
*** USB devices
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 1385:4250 Netgear, Inc WG111T
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
==================================================================================================
*** List of loaded modules
| ahci                    | ata_piix                | binfmt_misc             | button                   |
| cdrom                   | dm_mod                  | dock                    | edd                      |
| ehci_hcd                | ext3                    | fan                     | firmware_class           |
| floppy                  | fuse                    | i2c_core                | i2c_i801                 |
| intel_agp               | ipv6                    | iTCO_vendor_support     | iTCO_wdt                 |
| jbd                     | libata                  | loop                    | mbcache                  |
| microcode               | nvidia                  | parport                 | parport_pc               |
| pata_jmicron            | ppdev                   | processor               | r8169                    |
| rtc_cmos                | rtc_core                | rtc_lib                 | scsi_mod                 |
| sd_mod                  | sg                      | snd                     | snd_hda_intel            |
| snd_hwdep               | snd_mixer_oss           | snd_page_alloc          | snd_pcm                  |
| snd_pcm_oss             | snd_seq                 | snd_seq_device          | snd_timer                |
| soundcore               | sr_mod                  | thermal                 | uhci_hcd                 |
| usbcore                 |
==================================================================================================
*** cat /etc/sysconfig/network/ifcfg-[earwd]*
==================================================================================================
*** cat /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_CLIENT_KEY=''
WIRELESS_CLIENT_KEY_PASSWORD=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_EAP_AUTH=''
WIRELESS_EAP_MODE=''
WIRELESS_ESSID='netslave'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='@@@@@@'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_PEAP_VERSION=''
WIRELESS_POWER='yes'
WIRELESS_WPA_ANONID=''
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK=''
==================================================================================================
*** iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

==================================================================================================
*** grep -i radio /var/log/boot.msg
==================================================================================================
*** grep -i firmware /var/log/messages*
Aug  4 19:58:42 linux-x2yn firmware.sh[7100]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug  4 19:58:42 linux-x2yn firmware.sh[7110]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug  5 11:12:05 linux-x2yn firmware.sh[1926]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug  5 11:12:05 linux-x2yn firmware.sh[1930]: Cannot find  firmware file 'intel-ucode/06-0f-02'
==================================================================================================
*** ls -ls /lib/firmware
insgesamt 0
==================================================================================================
*** ndiswrapper -l
No ndiswrapper found
==================================================================================================
*** ps -eo comm | egrep -i wpa_supplicant|knetworkmanager 
knetworkmanager
knetworkmanager
==================================================================================================
*** grep NETWORKMANAGER /etc/sysconfig/network/config
NETWORKMANAGER=no
==================================================================================================
*** grep -i persistent /etc/sysconfig/network/config
==================================================================================================
*** grep 'eth|ath|wlan|ra' /etc/udev/rules.d/*net_persistent* /etc/udev/rules.d/70-persistent-net
/usr/bin/egrep: /etc/udev/rules.d/*net_persistent*: Datei oder Verzeichnis nicht gefunden
/etc/udev/rules.d/70-persistent-net.rules:SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:18:f3:09:45:7d", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
==================================================================================================
*** grep -r 'eth[0-10]|ath[0-10]|wlan[0-10]|ra[0-10]' /etc/modprobe.*
/etc/modprobe.conf:install eth0             /bin/true
/etc/modprobe.conf:install eth1             /bin/true
/etc/modprobe.d/ndiswrapper:alias wlan0 ndiswrapper
==================================================================================================
*** tail /var/log/messages*
No firmware messages found
==================================================================================================
*** iwlist scanning
No wireless networks detected
==================================================================================================
*** NWEliza states
DI:0 dI:0 NI:1 cNI:1 NDIS:0 NIWL:0 KM:0 AP:0 
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Re: Brauche hilfe mit ndiswrapper

Beitrag von Grothesk »

Sieht wirklich nach ndiswrapper aus, da es für die Atheros-USB-Chipsätze keine nativen Linux-Treiber gibt.
Allerdings würde ich dringend empfehlen, Suse in der 32bit-Variante zu installieren.
Du versuchst nämich gerade einen 32bit-Windowstreiber in dein 64bit-System zu laden. Das funktioniert nicht (Siehe auch entsprechende Meldung).

Also: Neuinstallieren, 32bit-Version nehmen, dann mit ndiswrapper das Glück nochmal versuchen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

gut, hab alles jetzt neuinstalliert, treiber mit ndiswrapper geladen und geht wieder nicht :/
hier eine aktuelle version der collectNWData.txt:

Code: Alles auswählen

collectNWData.sh V0.6.1-3
--- Which type of your network connection should be tested?
--- (2) Wireless connection (WLAN)
--- What's the type of networktopology?
--- (2) WLAN HW router <---> LinuxClient
--- On which host is the script executed?
--- (1) LinuxClient
!!! CND0110E: For the selected connection type there was no active network interface found on your system.
!!! CND0310W: Classic network configuration with ifup was detected. Configuration with knetworkmanager is much easier
--- 1 errors detected.
--- 1 warnings detected
==================================================================================================
==================================================================================================
*** uname
Linux linux-chrk 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
==================================================================================================
*** SuSE release
openSUSE 11.0 (i586)
VERSION = 11.0
==================================================================================================
*** /etc/resolv
domain site
==================================================================================================
*** /etc/hosts
127.0.0.1       localhost
127.0.0.2       linux-chrk.site linux-chrk
==================================================================================================
*** route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
==================================================================================================
*** arp
==================================================================================================
*** ifconfig
eth0      Link encap:Ethernet  HWaddr 00:18:F3:09:45:7D  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:219 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:536 errors:0 dropped:0 overruns:0 frame:0
          TX packets:536 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:40720 (39.7 Kb)  TX bytes:40720 (39.7 Kb)

==================================================================================================
*** ping tests
connect: Network is unreachable
Ping of 195.135.220.3 failed
ping: unknown host www.suse.de
Ping of www.suse.de failed
==================================================================================================
*** PCI devices
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 01)
==================================================================================================
*** USB devices
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 1385:4251 Netgear, Inc WG111T (no firmware)
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
==================================================================================================
*** List of loaded modules
| af_packet               | agpgart                 | ahci                    | ata_piix                 |
| binfmt_misc             | button                  | cdrom                   | dm_mod                   |
| dock                    | edd                     | ehci_hcd                | ext3                     |
| fan                     | firmware_class          | fuse                    | i2c_core                 |
| i2c_i801                | iTCO_vendor_support     | iTCO_wdt                | ide_cd_mod               |
| ide_core                | ide_disk                | intel_agp               | ip6_tables               |
| ip6t_LOG                | ip6t_REJECT             | ip6table_filter         | ip6table_mangle          |
| ip_tables               | ipt_LOG                 | ipt_REJECT              | iptable_filter           |
| iptable_mangle          | iptable_nat             | ipv6                    | jbd                      |
| joydev                  | libata                  | loop                    | lp                       |
| mbcache                 | microcode               | ndiswrapper             | nf_conntrack             |
| nf_conntrack_ipv4       | nf_conntrack_ipv6       | nf_conntrack_netbios_ns | nf_nat                   |
| parport                 | parport_pc              | pata_jmicron            | ppdev                    |
| processor               | r8169                   | rtc_cmos                | rtc_core                 |
| rtc_lib                 | scsi_mod                | sd_mod                  | sg                       |
| snd                     | snd_hda_intel           | snd_hwdep               | snd_mixer_oss            |
| snd_page_alloc          | snd_pcm                 | snd_pcm_oss             | snd_seq                  |
| snd_seq_device          | snd_timer               | soundcore               | sr_mod                   |
| st                      | thermal                 | uhci_hcd                | usbcore                  |
| x_tables                | xt_limit                | xt_pkttype              | xt_state                 |
| xt_tcpudp               |
==================================================================================================
*** cat /etc/sysconfig/network/ifcfg-[earwd]*
==================================================================================================
*** iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

==================================================================================================
*** grep -i radio /var/log/boot.msg
==================================================================================================
*** grep -i firmware /var/log/messages*
Aug 14 19:25:59 linux-chrk firmware.sh[7057]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug 14 19:25:59 linux-chrk firmware.sh[7130]: Cannot find  firmware file 'intel-ucode/06-0f-02'
==================================================================================================
*** ls -ls /lib/firmware
total 0
==================================================================================================
*** ndiswrapper -l
athfmwdl : driver installed
	device (1385:4251) present
netwg11t : driver installed
==================================================================================================
*** ps -eo comm | egrep -i wpa_supplicant|knetworkmanager 
knetworkmanager
==================================================================================================
*** grep NETWORKMANAGER /etc/sysconfig/network/config
NETWORKMANAGER=no
==================================================================================================
*** grep -i persistent /etc/sysconfig/network/config
==================================================================================================
*** grep 'eth|ath|wlan|ra' /etc/udev/rules.d/*net_persistent* /etc/udev/rules.d/70-persistent-net
/usr/bin/egrep: /etc/udev/rules.d/*net_persistent*: No such file or directory
/etc/udev/rules.d/70-persistent-net.rules:SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:18:f3:09:45:7d", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
==================================================================================================
*** grep -r 'eth[0-10]|ath[0-10]|wlan[0-10]|ra[0-10]' /etc/modprobe.*
/etc/modprobe.conf:install eth0             /bin/true
/etc/modprobe.conf:install eth1             /bin/true
==================================================================================================
*** tail /var/log/messages*
Aug 14 19:25:59 linux-chrk firmware.sh[7057]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug 14 19:25:59 linux-chrk firmware.sh[7130]: Cannot find  firmware file 'intel-ucode/06-0f-02'
Aug 14 19:26:00 linux-chrk avahi-dnsconfd[7205]: Successfully connected to Avahi daemon.
Aug 14 19:26:00 linux-chrk kernel: klogd 1.4.1, log source = /proc/kmsg started.
Aug 14 19:26:00 linux-chrk kernel: IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
---------------------------------------------------------------------------
==================================================================================================
*** iwlist scanning
No wireless networks detected
==================================================================================================
*** NWEliza states
IF:eth0  IP: IM:1
DI:1 dI:0 NI:1 cNI:1 NDIS:0 NIWL:0 KM:0 AP:0 
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7180
Registriert: 23. Jan 2008, 09:51

Re: Brauche hilfe mit ndiswrapper

Beitrag von lOtz1009 »

Poste doch mal bitte die Schritte mit denen du den Treiber mit ndiswrapper installiert hast. Ich denke mal da fehlt einer (ndiswrapper -ma).
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

ndiswrapper -ma? davon hab ich noch nirgends was gelesn das man den befehl braucht. also hier meine schritte:
zuerst ndiswrapper make, dann ndiswrapper make install, dann die .inf dateien hinzugefügt mit ndiswrapper -i dann ndiswrapper -l zur überprüfung schließlich modprobe ndiswrapper und dann noch zur endgültigen überprüfung mit dmesg aber da stand nix davon dass er die .sys dateien geladen hat...
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2435
Registriert: 24. Okt 2005, 14:04

Re: Brauche hilfe mit ndiswrapper

Beitrag von Heinz-Peter »

Zapeth hat geschrieben: ...ndiswrapper make, dann ndiswrapper make instal...
Warum mit make & make install?
Warum nicht so wie hier beschrieben: http://www.linux-club.de/viewtopic.php?f=19&t=33874
Gruß
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Brauche hilfe mit ndiswrapper

Beitrag von SUSEDJAlex »

Vieellll zu umständlich, Heinz-Peter !
Schau mal was ich hier schreibe:

@Zapeth:
als erstens alle Treiber entfernen mit ndiswrapper -r athfmwdl und ndiswrapper netwg11t

Step-by-Step:

1.)YAST->Software->Software installieren oder löschen
2.) als Suchwort eingeben:

Code: Alles auswählen

ndiswrapper
3.) selektiere nur ndiswrapper ( Abhängigkeiten werden automatisch aufgelöst)
4.) installieren und YAST beenden

so jetzt kommt der Teil in der Konsole:

Code: Alles auswählen

ndiswrapper -i netwg11t.inf ( bitte vorher ins Verzeichnis gehen, wo sich diese Datei befindet )
ndiswrapper -l
(ausgabe:) netwg11t.inf installed,hardware present
modprobe ndiswrapper
ndiswrapper -m
(ausgabe:) ndiswrapper modules alias wlan0 added
anschließend mit KNetworkmanager einrichten.
Mache bitte nicht den Fehler und installiere 2 Treiber für dein USB-WLAN-Stick, da kann es nicht funktionieren
In yast (System - Editor für /etc/sysconfig-Dateien) wird ndiswrapper unter der Option MODULES_LOADED_ON_BOOT eingetragen.

Noch ein Hinweis:

Code: Alles auswählen

Im jeweiligen Router muss bei den Verbindungen mit KNetworkmanager unbedingt der Modus auf "802.11g" eingestellt werden. Bei gemischten Modus kann es passieren, dass die Verbindung mal aufgebaut wird und mal nicht.
Hast du noch Fragen ? Dann rein damit.

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Brauche hilfe mit ndiswrapper (Zusatzinfos)

Beitrag von SUSEDJAlex »

allerdings sagt ja das hier:

Code: Alles auswählen

Card: Netgear WG111T
    *      Chipset: Atheros USB
    *      encryption: WPA-PSK (TKIP)
    *      usbid: 1385:4250
    *      Driver: Netgear windows driver Version: 21/06/2005, 1.2 from http://www.Netgear.de/download/WG111T/WG111T_GRV1.2.zip
    *      Other: This driver comes with two sets of .inf and .sys files: athfmwdl and wg111t. Both of these must be installed with their *.inf files.
Aber nur eins der beiden Treiber installieren. also nicht netwg11t.inf sondern athfmwdl.inf nehmen.
wenn du in der Konsole bist, bitte keinen WLAN-Verbindung nutzen bzw. aufbauen.
Gelegentlich erkennt openSUSE das als Laufwerk.

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

gut ich habs jetzt mal so versucht wies du beschrieben hast alex. allerdings frag ich mich wieso ich nicht beide .inf dateien installieren soll, schließlich wird extra in der liste (http://ndiswrapper.sourceforge.net/joom ... ,list_m-n/) bei mir darauf hingewiesen dass ich beide installieren soll (Other: This driver comes with two sets of .inf and .sys files: athfmwdl and wg111t. Both of these must be installed with their *.inf files.). außerdem noch eine zweite frage: muss die ausgabe von ndiswrapper -l wirklich so aussehen?

ndiswrapper -l
(ausgabe:) netwg11t.inf installed,hardware present

bei mir sieht sie nämlich so aus:

netwg11t : driver installed
device (1385:4250) present
achja, wenn ich knetworkmanager starten will, öffnet sich der nicht, kann ich das nicht mit yast machen? es wird ja auch in einigen foren beschrieben dass man das mit yast konfigurieren soll
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Brauche hilfe mit ndiswrapper

Beitrag von SUSEDJAlex »

@Zapeth:

Code: Alles auswählen

Card: Netgear WG111T
Chipset: Atheros USB
encryption: WPA-PSK (TKIP)
usbid: 1385:4251
Driver: Windows driver from Netgear website
Other: Both athfmwdl.inf and netwg11t.inf installed with ndiswrapper version 1.23 or later as there is a bug in previous versions of ndiswrapper (per the changelog). This bug caused me hours of frustration using ndiswrapper v1.22 (Ubuntu Edgy). If using vista compatible drivers (e.g. version 2.1) you will need to use wine (tested with version 0.9.49) to extract drivers and install netwg11t.inf from the Driver directory (only need one .inf) within “~/.wine/drive_c/Program\ Files/NETGEAR/WG111T”. Version 2.1 also allows WPA2 to work.
Dein Stick wird aber auch als den o.g. ausgegeben.

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

du meinst also ich soll mir jetzt den vista treiber runterladen und die .exe datei mit wine ausführen?
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: Brauche hilfe mit ndiswrapper

Beitrag von SUSEDJAlex »

Nein, ich wollte es nur damit sagen dass es auch mit dieser ID erkannt wird.

Wenn du es in YAST komplett einrichten willst, musst du das von Networkmanager in traditionelle Verbindung umstellen. Danach komplett in YAST eintragen.
Kann aber dir nicht versprechen, ob es klappt...

LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

naja eigentlich ist mein problem immer noch beim ndiswrapper...ich hab mit ndiswrapper -i den treiber athfmwdl.inf installiert und danach modprobe nidswrapper eingegeben und als ich mir die log mit dmesg angeschaut hab stand da zwar dass ndiswrapper ausgeführt wird aber nix davon dass er den treiber geladen hat. könnt es vielleicht an der software selbst oder so liegen?
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Brauche hilfe mit ndiswrapper

Beitrag von whois »

Hi

Hast du mal versucht ob es mit der tarditionellen Art ohne Ndiswrapper funktioniert?
Der Stick wird doch erkannt.

cu
Zapeth
Newbie
Newbie
Beiträge: 22
Registriert: 5. Aug 2008, 09:49

Re: Brauche hilfe mit ndiswrapper

Beitrag von Zapeth »

tja in gweisser weise hab ichs schon mal versucht, ich bin mir nur nicht sicher was du unter "traditionell" verstehst. ich hab ihn mal neu angeschlossen und er hat ihn nicht erkannt (zumindest hat er nichts gemledet das er was gefunden hat) und ich hab bei yast versucht ihn einzurichten was aber fehlgeschlagen ist weil er ihn ja offenbar nicht erkannt hat. außerdem:
Grothesk hat geschrieben:Sieht wirklich nach ndiswrapper aus, da es für die Atheros-USB-Chipsätze keine nativen Linux-Treiber gibt.
aber wenn du was anderes unter traditionell verstehst als ich kannst dus mir ja gerne erklären
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Brauche hilfe mit ndiswrapper

Beitrag von whois »

Ich hatte den Hinweis von Grothesk schlicht überlesen und der ist in dem Thema mit Sicherheit mehr drin als ich und hat daher auch mehr Plan.
Ich dachte nur der würde sich leichter einbinden lassen, weil ich selber mit einem ähnlichen Stick vor einiger Zeit wenig Probleme hatte,zwar nicht mit Suse aber...
Antworten