Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Start des ntpd dauert sehr lang

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 531
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Start des ntpd dauert sehr lang

Beitrag von f.gruber »

Hallo,
ich habe mit YAST den NTP so konfiguriert, dass er beim Systemstart gestartet wird.

Nun bemerke ich, dass beim Bootvorgang eine minutenlange Pause eintritt, dann kommt eine Zeile, die auf den ntpd hindeutet: Es wird folgende Meldung am Bildschirm angezeigt:

Code: Alles auswählen

ntpd: time slew +0.000000 s
. Deswegen gehe ich davon aus, das der NTP die Ursache für diese Verzögerung des Bootvorganges ist.

Hier der Auszug aus der /var/log/boot.msg:

Code: Alles auswählen

Starting INET services. (xinetd) done
ntpd: time slew +0.000000s
Starting network time protocol daemon (NTPD)<notice>startproc: execve (/usr/sbin/ntpd) [ /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf ], [ CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=80 PATH=/bin:/sbin:/usr/bin:/usr/sbin RUNLEVEL=5 PWD=/ SPLASHCFG= PREVLEVEL=N LINES=25 HOME=/ SHLVL=2 splash=silent SPLASH=no ROOTFS_BLKDEV=/dev/sda2 _=/sbin/startproc DAEMON=/usr/sbin/ntpd ]
done
Ich glaube, dass dieses Verhalten erst auftritt, seit ich auf Suse 11.0 upgedatet habe.

Wie kann ich dieses Problem lösen?
Gruß
Ferdinand
oelk
Member
Member
Beiträge: 210
Registriert: 24. Apr 2006, 20:12
Wohnort: Frankfurt am Main

Re: Start des ntpd dauert sehr lang

Beitrag von oelk »

Hi,
kann das Verhalten bestätigen.
Betreibe openSUSE 11.0 als Server ohne GUI.
Es spielt keine Rolle ob ich die Zeit "draussen" hole oder über eine lokale Funkuhr
(hier ExpertMouseClock von GUDE über COM1).
Habe leider noch keine Lösung gefunden und bin am suchen.
Von der Funkuhr kann er sowieso nicht gleich ein Signal bekommen,
aber zumindest draussen sollte doch de.pool.ntp.org sofort
eine Zeit liefern.

MfG
Shuttle SH67H7
Core i5-2500
32GB RAM
Samsung 500GB/16MB Cache
Samsung 1000GB/16MB Cache
openSUSE 13.2/X86_64/KDE 4.14.9
Linux 3.16.7-35-default SMP x86_64
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 531
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Start des ntpd dauert sehr lang

Beitrag von f.gruber »

Hallo,
danke für die Reaktion.

Immerhin ein (schwacher) Trost, wenn man das Problem nicht alleine hat.
Nach jedem Suse Update gibt es Fehler in dieser Art. Sind halt auch nur Menschen ... :roll:
Gruß
Ferdinand
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Start des ntpd dauert sehr lang

Beitrag von whois »

Hi

Kann ich auch bestätigen.
Das ist einer der Gründe weshalb ich es bei mir direkt wieder raus geworfen habe.

cu
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 531
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Start des ntpd dauert sehr lang

Beitrag von f.gruber »

whois hat geschrieben:Hi
Kann ich auch bestätigen.
Das ist einer der Gründe weshalb ich es bei mir direkt wieder raus geworfen habe.
cu
Hallo,
du sagst "rausgeworfen". Hast du den Server neu aufgesetzt? Ich möchte ja nicht die ganze Konfiguration verlieren.
Oder hast du ein Backup zurückgespielt?

Downgraden auf sichere Art, gibt es das überhaupt?

Ich werde es wohl halten, wie immer:
Etwas Geduld haben und öfter mal ein Online Update machen. Nach einiger Zeit spielt sich meistens wieder alles ein ...
Gruß
Ferdinand
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Start des ntpd dauert sehr lang

Beitrag von whois »

Hi

Meine Server in der Firma und zuhause laufen alle auf Debian, eine neue Suse Version ist mir da zu unsicher.
Das war nur Probeweise aufgesetzt um verschiedene andere Dinge zu testen, wie Samba,Lamp,Capis etc.
Deshalb war dies bei mir leicht zu handeln.

Ich denke das dies bei einer der nächsten upgrades gelöst wird,wenn ich das in der Mailing Liste richtig gelesen habe ist das Problem bekannt.

cu
oelk
Member
Member
Beiträge: 210
Registriert: 24. Apr 2006, 20:12
Wohnort: Frankfurt am Main

Re: Start des ntpd dauert sehr lang

Beitrag von oelk »

Hallo,

ich habe es jetzt folgendermassen am laufen:

/etc/ntp.conf:

Code: Alles auswählen

server 127.127.8.0 mode 14 prefer
server 127.127.1.0
fudge 127.127.1.0 stratum 10
server de.pool.ntp.org
driftfile /var/lib/ntp/drift/ntp.drift
logfile /var/log/ntp.log
key /etc/ntp.keys
trustedkey 1
requestkey 1
/etc/sysconfig/ntp:

Code: Alles auswählen

NTPD_ADJUST_CMOS_CLOCK="yes"
NTPD_OPTIONS="-g -u ntp:ntp"
NTPD_RUN_CHROOTED="yes"
NTPD_CHROOT_FILES=""
NTP_PARSE_LINK="/dev/refclock-0"
NTP_PARSE_DEVICE="/dev/ttyS0"
Ich habe das ganze in einer VM laufen (VirtualBox) und ntpdc -p
zeigt mir für alles Zeitquellen ein reach an bzw im Log-File ein
Syncronized für alle Quellen.
Ein restart des ntpd dauert zwar immer noch relativ lange, aber er macht es.

MfG
Shuttle SH67H7
Core i5-2500
32GB RAM
Samsung 500GB/16MB Cache
Samsung 1000GB/16MB Cache
openSUSE 13.2/X86_64/KDE 4.14.9
Linux 3.16.7-35-default SMP x86_64
Antworten