Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Juppi22
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jul 2005, 16:46

SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von Juppi22 »

Hallo,

zuerst hoffe, ich dass ich im richtigen Bereich gelandet bin. Ich habe nichts passerenderes gefunden, obwohl mein eigentliches Problem nicht der Samba-Server sondern der Client ist.

Meine Konfiguration:
SL 11.0 und KDE4 mit einem NAS-Server auf Basis 3.0.23a
lokal ist ein Sambaserver installiert, der allerdings nicht aktiv benutzt wird. Ich habe diesen nachträglich installiert, da ich Probleme mit der ein


Zu meinem Problem:
Ich habe einen NAS-Server, der unter Windows ganz normal angesprochen werden kann:
Hier das Ergebnis mit
smbclient -L //xxx.xxx.xxx.xxx

Code: Alles auswählen

Domain=[ARBEITSGRUPPE] OS=[Unix] Server=[Samba 3.0.23a]

        Sharename       Type      Comment
        ---------       ----      -------
        album           Disk
        iTunes          Disk
        usbcopy         Disk
        usbhdd          Disk
        filme           Disk      Filme
        fotos           Disk      Fotos
        share           Disk
        musik           Disk      mp3\'s and so on
        IPC$            IPC       IPC Service (SERVERNAME)
Domain=[ARBEITSGRUPPE] OS=[Unix] Server=[Samba 3.0.23a]

        Server               Comment
        ---------            -------
        SERVERNAME         SERVERNAME

        Workgroup            Master
        ---------            -------
        ARBEITSGRUPPE        SERVERNAME
Mit CIFS habe ich versucht den Rechner einzubinden. Das funktionierte gut, bis auf das Problem, dass ich die Dateien nicht lesen konnte (ls funktionierte fehlerfrei). Die Dateien wurden bei Leseversuch z.B. einer Textdatei mit ein Datei ohne Inhalt angezeigt.

Dann habe ich es mit smbfs versucht (kernel ist neu konfiguriert, compiliert und installiert).
Damit die Laufwerke beim Start gebunden werden, habe ich die /etc/samba/smbfstab eingerichtet:

Code: Alles auswählen

//SERVERNAME/musik  /daten/musik  smbfs  ip=xxx.xxx.xxx.xxx,password=*****,uid=1000,iocharset=UTF8,gid=100,username=USERNAME  
//SERVERNAME/fotos  /daten/fotos  smbfs  ip=xxx.xxx.xxx.xxx,password=*****,uid=1000,iocharset=UTF8,gid=100,username=USERNAME
//SERVERNAME/itunes  /daten/itunes  smbfs  ip=xxx.xxx.xxx.xxx,password=*****,uid=1000,iocharset=UTF8,gid=100,username=USERNAME 
//SERVERNAME/share  /daten/share  smbfs  ip=xxx.xxx.xxx.xxx,password=*****,uid=1000,iocharset=UTF8,gid=100,username=USERNAME 
Ergebnis:
Die Laufwerke werden eingebunden, und können normal bearbeitet werden.

ABER:
Nach einer gewissen Zeit hängt z.B. dolphin oder die zugreifenden Anwendungen. Der Server zeigt keine Auslastung an, scheint also ein Problem des Clients zu sein.

Also analysiere ich das Umfeld
1. smb4k zeigt keine Netzwerkumgebung an
2. beim Ausführen von "rcsmbfs restart" kommt eine Fehlermeldung, dass die /usr/lib/samba/smb.conf nicht gefunden wird
3. bei SWAT wird die Konfiguration des lokalen Servers nicht angezeigt und die ich kann die Dienste rcsmb und rcnmb und rcwind nur manuell und nicht über SWAT starten.
3. die smb.conf finde ich unter /etc/samba und hat den untenstehenden Inhalt.
4. die smb.conf habe ich dann manuell zusätzlich unter /usr/lib/samba kopiert.
5. smb4k zeigt alle eingebundenen Laufwerke an.

Code: Alles auswählen

[global]
	workgroup = ARBEITSGRUPPE
	os level = 20
	netbios name = Linux
	encrypt passwords = yes
	security = share
	usershare allow guests = No
[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes
....
...
Ergebnis:
Es ist nichts besser geworden. Ich habe keine Idee, wonach ich noch suchen soll. Egal was ich versucht habe, scheine ich nicht richtig gemacht zu haben.

gewünschtes Ziels:
1. Einbindung über CIFS. Hier habe ich vieles versucht, war ich in den Foren gelesen hab. Die Dateien können zum Verrecken nicht gelesen und zurückgeschrieben werden.
2. Eine Einbindung uber smbfs wäre auch ok, wenn ich dass mit dem zeitweise Ausfall des Clients im Griff bekäme.

Ich hoffe, dass einer etwas mit diesem Problem anfangen kann und eine gute Idee hat.

Mit freundlichen Grüßen
Juppi22
stka
Moderator
Moderator
Beiträge: 3357
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von stka »

Warum hast du den Kernel neu gebaut? Warum nutzt due den samba 3.0.23, der ist ja uralt. Bei suse 11 sollte mindestens der 3.0.28 dabei sein. Wenn du dein System, sprich samba und kernel neu gemacht hast, kann ich dir auch nicht sagen wo deine smb.conf liegen sollte. Bei einer standard Installation liegt die Datei in /etc/samba und wird auch gefunden.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
Juppi22
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jul 2005, 16:46

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von Juppi22 »

Die Samba-Version des NAS-Servers auf dem ich zugreifen möchte, ist 3.0.23. An dieser Version kann ich nichts ändern.

Die Version meines lokalen Samba-Servers ist 3.2.0-22.1.

Den Kernel habe ich neu compilieren, da standardmäßig eine smbfs-Unterstützung nicht gegeben ist und eine cifs-Einbindung nicht so funktioniert hat, dass ich damit arbeiten kann (siehe oben).

mfg
Juppi 22
schluckspecht

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von schluckspecht »

Hallo Juppi,

deine Aussagen verwirren mehr als das sie helfen. Es fängt schonmal damit an das du nicht das Samba-Paket benutzt das eigentlich für Suse 11.0 vorgesehen ist. Zweitens verstehe ich überhaupt nicht in welchem Zusammenhang diese veraltete Sambaversion mit dem NAS steht.

Deine Pfade stimmen nicht, weil du die veralteten Pakete bestimmt nicht über die Paketverwaltung installiert hast. Beschreibe doch mal wo du die Pakete bezogen hast, und wie du sie installiert hast. Und deine Kernelgeschichte ist die nächste Ungereimtheit.

Kannst du hier mal beschreiben um was für ein NAS es sich dabei überhaupt handelt. Es nutzt dir nichts wenn du dir dein ganzes System verbiegst nur um irgendeinen NAS-Server ans Laufen zu kriegen. Bau dir lieber ein paar alten Komponenten zusammen, und installier FreeNas.

Wie gesagt, alles sehr wirr was du da von dir gibst.
Juppi22
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jul 2005, 16:46

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von Juppi22 »

Als NAS-Server habe ich von ALLNET den ALL6500 NAS-Diskserver.

Das Sambapaket, welches ich auf meinem PC nutze ist die gleiche Version wie von der runtergeladenen OpenSuse 11.0 DVD.

Die Installation der OpenSuse 11.0 erfolgte als Update der OpenSuse 10.3 mit der runtergeladenen DVD.

In regelmäßigen Abständen habe ich das System über den Paketmanager aktualisiert. Ausnahmen sind hierbei die Packman-Pakete und Openoffice, die ich mit smart aktualisiere.

Ich habe gerade alle Module bezüglich der Versionen mit YAST geprüft und alle Versionen sind aktuell. Als Repositiories im Paketmanager sind eingetragen:

Code: Alles auswählen

openSUSE-DVD 11.0
URL: cd:///?devices=/dev/sr1,/dev/sr0
Kategorie: YaST

Updates for 11.0
URL: http://download.opensuse.org/update/11.0/
Kategorie: YUM

openSUSE-11.0-Oss
URL: http://download.opensuse.org/distribution/11.0/repo/oss/
Kategorie: YaST

openSUSE-11.0-Non-Oss
URL: http://download.opensuse.org/distribution/11.0/repo/non-oss/
Kategorie: YaST
Ob die Version von Samba auf dem oben genannten NAS etwas mit den Problemen zu tun hat, weiß ich nicht. Ich habe es nur der Vollständigkeit halber aufgeführt.

Den Kernel habe ich compiliert, weil ansonsten keine smbfs-Unterstützung gegeben ist.Folgende Schalter habe ich geändert:

Code: Alles auswählen

                                        <M>   SMB file system support (OBSOLETE, please use CIFS)                                                      
                                          [*]     Use a default NLS                                                                                      
                                          (cp437)   Default Remote NLS Option                                                                            
Damit funktioniert jetzt auch smbfs mit den oben beschriebenen Problemen.

mfg
Juppi_22
Juppi22
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jul 2005, 16:46

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von Juppi22 »

ich habe die message.log durchgesehen.

Hier ein Auszug, an dem man erkennen kann, dass eine Datei nicht gelesen werden kann. Es gibt ein "timed out". In der Oberfläche sieht es dann aus wie ein hang-up.

Code: Alles auswählen

Aug  8 21:08:45 linux kernel: smb_file_aio_read: Theme/Jump Street.mp3 validation failed, error=4294967291
Aug  8 21:09:15 linux kernel: smb_add_request: request [f30f1d80, mid=2362] timed out!
Aug  8 21:09:15 linux kernel: smb_file_aio_read: Theme/Jump Street.mp3 validation failed, error=4294967291
Aug  8 21:09:45 linux kernel: smb_add_request: request [f30f1d80, mid=2363] timed out!
Aug  8 21:10:15 linux kernel: smb_add_request: request [f30f1d80, mid=2364] timed out!
Aug  8 21:10:15 linux kernel: smb_lookup: find Theme/Jump Street.mp3 failed, error=-5
Aug  8 21:10:45 linux kernel: smb_add_request: request [f30f1d80, mid=2365] timed out!
Aug  8 21:11:15 linux kernel: smb_add_request: request [f30f1d80, mid=2366] timed out!
Aug  8 21:11:15 linux kernel: smb_lookup: find Theme/Jump Street.mp3 failed, error=-5
Aug  8 21:11:45 linux kernel: smb_add_request: request [f30f1d80, mid=2367] timed out!
Aug  8 21:12:15 linux kernel: smb_add_request: request [f30f1d80, mid=2368] timed out!
Aug  8 21:12:15 linux kernel: smb_lookup: find Theme/Jump Street.mp3 failed, error=-5
Aug  8 21:12:45 linux kernel: smb_add_request: request [f30f1d80, mid=2369] timed out!
Anschließend habe ich die Eintragungen aus der smbfstab herausgenommen, so dass die mounts nicht beim Start des Systems gemacht werden.

Über eine manuelle Ausführung der mounts verbinde ich mich mit dem NAS-Server.

Seitdem habe ich diese Probleme nicht mehr.

Die Lösung ist für mich sehr unlogisch und sehr umständlich, aber ich kann zur Not damit leben.

Trotzdem wäre mir wohler, wenn es noch gute Ideen gibt, was ich machen kann, um das eigentliche Problem zu lösen.

Wenn in der nächsten Zeit keine guten Ideen dazu kommen, werde ich diesen Thread als gelöst markieren.

mfg
Josef Schnieder
stka
Moderator
Moderator
Beiträge: 3357
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: SuSe 11: wo muss die smb.conf liegen : Probleme mit smbfs

Beitrag von stka »

Wenn es über die smbfstab nicht klappt, warum auch immer :schockiert:, kannst du dir ja ein init-skript schreiben, das dann die Freigabe mountet.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher
Antworten