Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Anmeldung auf Konsole nicht möglich [gelöst]

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
ukuarcor
Newbie
Newbie
Beiträge: 32
Registriert: 10. Mai 2006, 12:40

Anmeldung auf Konsole nicht möglich [gelöst]

Beitrag von ukuarcor »

Hallo,

ich weiß nicht, ob das Thema hier richtig platziert ist. Gehen wir es trotzdem einmal an:

Installation Suse 10.3 mit KDE. Die Anmeldung am KDE-Desktop gelingt immer. Gehe ich im KDE-Anmeldefenster auf die Konsolenanmeldung oder über die Konsole unter KDE auf Runlevel 3, passiert folgendes: Das Login erscheint, ich gebe meinen Benutzer ein und das System gibt mir nach "ENTER" wieder den Login ("localhost login:") ohne weitere Rückmeldung. Es findet keine Passwortabfrage statt, ich werde sozusagen als User ignoriert. Bei <Strg>+<Alt>+<F6> aus KDE auf eine neue Shell haben wir den gleichen Effekt.

Das Systemprotokoll zeigt keine Auffälligkeiten - meine Wahrnehmung - und ich wäre für jeden Hinweis dankbar, wo ich mit der Suche nach der Ursache beginnen sollte.

Vielen Dank für Euren Input
Zuletzt geändert von ukuarcor am 20. Aug 2008, 22:01, insgesamt 1-mal geändert.
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4449
Registriert: 14. Jun 2004, 09:12

Re: Anmeldung auf Konsole nicht möglich

Beitrag von Geier0815 »

Wenn Du dich wenigstens als root anmelden kannst, schau mal per "cat /etc/passwd" (ohne Anführungszeichen) nach ob in der Zeile wo der Benutzername steht evtl. so etwas wie "/bin/false" drinsteht.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Anmeldung auf Konsole nicht möglich

Beitrag von whois »

Hi

Sie auch mal unter Yast.

-Sicherheit und Benutzer
-Benutzer und Gruppenmanagement
-Standardeinstellungen für neue Benutzer
-Standard Login Shell

Ob da /bin/bash drin steht.

Das hat mir mal einiges versaut bei der aktuellen Version.

cu
ukuarcor
Newbie
Newbie
Beiträge: 32
Registriert: 10. Mai 2006, 12:40

Re: Anmeldung auf Konsole nicht möglich

Beitrag von ukuarcor »

Hi,

die Standard Login Shell steht korrekt auf /bin/bash.

Möglicherweise helfen noch folgende ergänzende Infos
- init 3 mit "root" ist identisch, also zwecklos
- ssh funktioniert weiterhin mit dem Standarduser
- mit init 1 funktioniert die Anmeldung als root. Wechsele ich in einen Runlevel größer 1, geht es wieder vor die Pumpe.

Offensichtlich liegt etwas beim Wechsel der Runlevel im Argen.

Die inittab zeigt sich auch nicht sonderlich zickig.

Code: Alles auswählen

#
# /etc/inittab
#
# Copyright (c) 1996-2002 SuSE Linux AG, Nuernberg, Germany.  All rights reserved.
#
# Author: Florian La Roche, 1996
# Please send feedback to http://www.suse.de/feedback
#
# This is the main configuration file of /sbin/init, which
# is executed by the kernel on startup. It describes what
# scripts are used for the different run-levels.
#
# All scripts for runlevel changes are in /etc/init.d/.
#
# This file may be modified by SuSEconfig unless CHECK_INITTAB
# in /etc/sysconfig/suseconfig is set to "no"
#

# The default runlevel is defined here
id:5:initdefault:

# First script to be executed, if not booting in emergency (-b) mode
si::bootwait:/etc/init.d/boot

# /etc/init.d/rc takes care of runlevel handling
#
# runlevel 0  is  System halt   (Do not use this for initdefault!)
# runlevel 1  is  Single user mode
# runlevel 2  is  Local multiuser without remote network (e.g. NFS)
# runlevel 3  is  Full multiuser with network
# runlevel 4  is  Not used
# runlevel 5  is  Full multiuser with network and xdm
# runlevel 6  is  System reboot (Do not use this for initdefault!)
#
l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
#l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6

# what to do in single-user mode
ls:S:wait:/etc/init.d/rc S
~~:S:respawn:/sbin/sulogin

# what to do when CTRL-ALT-DEL is pressed
ca::ctrlaltdel:/sbin/shutdown -r -t 4 now

# special keyboard request (Alt-UpArrow)
# look into the kbd-0.90 docs for this
kb::kbrequest:/bin/echo "Keyboard Request -- edit /etc/inittab to let this work."

# what to do when power fails/returns
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
#pn::powerfail:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# for ARGO UPS
sh:12345:powerfail:/sbin/shutdown -h now THE POWER IS FAILING

# getty-programs for the normal runlevels
# <id>:<runlevels>:<action>:<process>
# The "id" field  MUST be the same as the last
# characters of the device (after "tty").
1:2345:respawn:/sbin/mingetty --noclear tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6
#
#S0:12345:respawn:/sbin/agetty -L 9600 ttyS0 vt102
#cons:12345:respawn:/sbin/smart_agetty -L 38400 console

#
#  Note: Do not use tty7 in runlevel 3, this virtual line
#  is occupied by the programm xdm.
#

#  This is for the package xdmsc, after installing and
#  and configuration you should remove the comment character
#  from the following line:
#7:3:respawn:+/etc/init.d/rx tty7


# modem getty.
# mo:235:respawn:/usr/sbin/mgetty -s 38400 modem

# fax getty (hylafax)
# mo:35:respawn:/usr/lib/fax/faxgetty /dev/modem

# vbox (voice box) getty
# I6:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI6
# I7:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI7

# end of /etc/inittab
Mmmmh, sehr merkwürdig, das Ganze. Für mich zumindest. :???:

Grüße
whois
Ultimate Guru
Ultimate Guru
Beiträge: 16667
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Anmeldung auf Konsole nicht möglich

Beitrag von whois »

Nee meine inittab sieht nahezu identisch aus.
Daran scheint es nicht zu liegen.

Ich nehme an das gleiche passiert wenn du den runlevel in der inittab auf 3 änderst?
Singleuser Mode funktioniert,Merkwürdig.
ukuarcor
Newbie
Newbie
Beiträge: 32
Registriert: 10. Mai 2006, 12:40

Re: Anmeldung auf Konsole nicht möglich

Beitrag von ukuarcor »

War gerade per ssh drauf (das geht ja noch). Die User "root" und "ich_user" stehen in /etc/passwd auf /bin/bash.
Wenn ich direkt per Boot Option auf init 3 gehe, habe ich das gleiche Systemverhalten. Erstaunlich ist, daß ich am Login den Namen eingeben kann, das "Enter" jedoch ins Nichts läuft und wieder den Login anbietet. Man könnte den Eindruck gewinnen, daß ein Link defekt ist.

Schaue mir nochmal genau die Logfiles an. Vielleicht ist ja schon was beim Booten schief gegangen und KDE schert sich nicht drum. Gehe also erstmal tauchen.

Update:
Keine Auffälligkeiten in den Systemlogs. Die Büchse fährt völlig normal hoch..... Habe zugleich nochmal mit meiner mobilen Arbeitshilfe verglichen. Keine signifikanten Unterschiede.
Frage mich gerade, was passiert, wenn ich den KDE in die Tonnen trete und dann nochmal checke. Schlimmer kann's nicht werden.

Update1:
Aufgeben is nich ;) Also wieder auf Konsole nach init 3 gewechselt. tty 1 macht wie bereits bekannt keine Bemühungen, meinen User zur Eingabe eines passwortes aufzufordern. Auf tty7 findet sich aber folgender Eintrag:

Code: Alles auswählen

Shutting down service kdm                                              done
Shutting down service kdm                                              done
Master Resource Control: runlevel 3 has been                      reached
stty: standard input: unable to perform all requested operations
Danach hängt die Kiste und der Cursor blinkt föhlich vor sich hin.
Hat jemand eine Idee, wie ich herausfinden kann, was sich hinter der bedeutungsschweren Meldung zu "stty" als Grund verbergen könnte?
Grüße

Update2:
Werde direkt auf 11.0 updaten. Damit wird sich das Problem verflüchtigen.
Antworten