Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Tastenbelegungen funktionieren nicht unter KDE 4.1

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 296
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Tastenbelegungen funktionieren nicht unter KDE 4.1

Beitrag von transwarp »

Hallo.

Ich verwende OpenSUSE 11.0 und KDE 4.1 mit Compiz auf einem Testsystem.
Im Grunde genommen funktioniert auch alles soweit, bis auf einige Tastenbelegungen, die sich standhaft weigern ausgeführt zu werden.

Dazu zählt auch "ALT+F2" für "Befehl ausführen".
Obwohl das im Compiz-Konfigurationsmanager so eingetragen ist, wird es ignoriert. Ein entsprechender Tasteneintrag im K-Menü-Editor wird ebenfalls ignoriert.

Weiterhin versuche ich ganz simple den Firefox mit "ALT+F" zu starten, was mir ebenfalls in keiner Kombination gelingt. Das gleiche gilt für den Dolphin.

Entweder kommen sich hier K-Menü und CCSM in die Quere, oder es ist ein Bug. Andere Tastenkombinationen funktionieren hin und wieder.

Hat jemand einen Tipp oder einen Workaround, wie ich mein Problem aus der Welt schaffen kann? Die Suchfunktion im Forum hat mir nicht wirklich weiter geholfen.

Dank im voraus. :???:
openSUSE Tumbleweed | Kernel 4.16.12-1-desktop x86_64 | Plasma 5.12.5 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber
G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Re: Tastenbelegungen funktionieren nicht unter KDE 4.1

Beitrag von G aus W »

Hallo Transwarp,

kein Tip, sondern nur die Bestätigung, daß es bei mir genauso ist. Auch ohne Compiz. Ich habe viele Programme, die ich regelmäßig nutze, auf Tastenkürzel gelegt (meist die wenig benutzte "Fenster"-Taste plus irgend einen Buchstaben). Unter KDE 4.0 ging es noch, bei 4.1 werden diese Tastenkombinationen ignoriert.

Gruß Greg
Keks Dose
Member
Member
Beiträge: 157
Registriert: 13. Dez 2006, 13:39

Re: Tastenbelegungen funktionieren nicht unter KDE 4.1

Beitrag von Keks Dose »

Hat jemand einen Vorschlag, wie ich mir eine Tastenkombination anlege, mit der ich direkt auf den Desktop komme? Als Gewohnheitstier lag das immer auf Win+E, aber bei KDE 4.1 weiß ich nicht, wie ich das mache. In den Systemeinstellungen bei KWin habe ich nichts gefunden.

Danke,
Gruß,
Alexander
Benutzeravatar
transwarp
Hacker
Hacker
Beiträge: 296
Registriert: 9. Nov 2006, 19:28
Kontaktdaten:

Re: Tastenbelegungen funktionieren nicht unter KDE 4.1

Beitrag von transwarp »

Man kann sich folgendermaßen behelfen (Workaround):

1) Programme --> Dienstprogramme --> Desktop --> Compiz-Konfigurationsmanager starten

2) Dort auf "General Options" gehen und den Reiter "Commands" wählen.

3) Jetzt trägt man dort im Untermenü "Commands" jeweils die Kommandos ein, die man starten möchte (z.B. Firefox, Dolphin, etc.)

4) Das Untermenü "Keybindings" definiert die zugehörigen Tastaturkürzel, um die zuvor definierten Kommandos zu starten.

5) Also "Run Command 0": Auf den Button "Deaktiviert" klicken und "Aktiviert" wählen.

6) Gewünschte Tastenkombination eingeben.

7) ... schon sollte es gehen.


Frage:
Kennt jemand den Namen des Tools, das "Befehl ausführen" repräsentiert?
openSUSE Tumbleweed | Kernel 4.16.12-1-desktop x86_64 | Plasma 5.12.5 | AMD FX-6350 6x3,9 GHz | 16 Gb Mem | MSI 970A-G43 MB | Nvidia Geforce GTX1060 | Nouveau-Treiber
Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: Tastenbelegungen funktionieren nicht unter KDE 4.1

Beitrag von Escho »

Kennt jemand den Namen des Tools, das "Befehl ausführen" repräsentiert?
krunner

Und bei mir startet der auch mit Alt + F2

Edgar
Antworten