Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Externe USB HDD mittels hal und ntfs-3g automatisch mounten

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Gesperrt
kaltduscher_99
Newbie
Newbie
Beiträge: 6
Registriert: 27. Okt 2007, 18:26

Externe USB HDD mittels hal und ntfs-3g automatisch mounten

Beitrag von kaltduscher_99 » 1. Nov 2007, 18:38

Hallo,

unter OpenSuSE 10.3 wird meine schicke neue externe USB HDD standardmäßig nur read only über das filesystem "ntfs" eingebunden.
(bitte sagt jetzt nicht: "Dann formatiere sie eben mit ext3!" Diesemal muss es einfach NTFS sein.)

Folgender Weg führt zum automatischen Einbinden über hal und Konsorten beim Einstöpseln:

1. Platte einstöpseln und externe Platte mittels ntfs-config auf Schreibzugriff setzen
2. Platte wieder ausstöpseln
3. die durch ntfs-config geänderte /etc/fstab wieder durch die ursprüngliche ersetzen. ntfs-config legt einen Eintrag für die externe Platte an, der das automatische mounten über hal verhindert.
4. beim erneuten Einstöpseln sollte hal sich nun mit der Fehlermeldung
hal-storage-mount-removable-extra-options auth_self_keep_always <-- (action, result)
dem mounten verweigern
5. /etc/PolicyKit/PolicyKit.conf editieren:

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<!-- See the manual page PolicyKit.conf(5) for file format -->

<config version="0.1">

 <match action="hal-storage-mount-removable-*">
  <match user="1001|1002">
   <return result="yes"/>
  </match>
 </match>

</config>
bei match user= werden dabei alle user id's aufgeführt, die mounten dürfen sollen.
6. neu starten, das neu Laden der Enstellungen mittels polkit-reload-config funktionierte bei mir nicht.

Das sollte es gewesen sein.

ABER:

Es ist nicht möglich, Dateien mit Umlauten im Dateinamen auf das mit ntfs-3g eingebundene Laufwerk zu schreiben. Beim manuellen mounten müsste daher statt nls=utf-8 die Option locale=de.DE.UTF-8 gesetzt werden. Nur wie teile ich dies meinem Freund hal mit?

Ich freue mich auf eure Vorschläge!

Werbung:
kaltduscher_99
Newbie
Newbie
Beiträge: 6
Registriert: 27. Okt 2007, 18:26

Beitrag von kaltduscher_99 » 11. Nov 2007, 16:55

So, mittlerweile geht auch mounten "mit Umlauten" über hal:
Nachdem die Platte durch hal/ kde mediamanager eingebunden wurde als normaler user in der shell mit

Code: Alles auswählen

halmount -u /dev/sdb1
ausbinden und anschließend mit

Code: Alles auswählen

halmount /dev/sdb1 -o "locale=de_DE.UTF-8" 
wieder einbinden.

Über den KDE mediamanager geht es derzeit (KDE 3.5.7) wohl noch nicht.

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 27. Nov 2007, 16:15

kaltduscher_99 hat geschrieben:So, mittlerweile geht auch mounten "mit Umlauten" über hal:
Nachdem die Platte durch hal/ kde mediamanager eingebunden wurde als normaler user in der shell mit

Code: Alles auswählen

halmount -u /dev/sdb1
ausbinden und anschließend mit

Code: Alles auswählen

halmount /dev/sdb1 -o "locale=de_DE.UTF-8" 
wieder einbinden.

Über den KDE mediamanager geht es derzeit (KDE 3.5.7) wohl noch nicht.
es geht mit einem kleinen trick:

in /sbin/ eine neue datei mount.ntfs-3g.sh anlegen mit folgendem inhalt:

#!/bin/bash

/bin/ntfs-3g $1 $2 -o locale=de_DE.UTF-8


dann:
cd /sbin
chmod +x mount.ntfs-3g.sh
mv mount.ntfs-3g mount.ntfs-3g.orig
ln -s mount.ntfs-3g.sh mount.ntfs-3g

bei mir hats dann auch mit dem kde-automounter gefunzt.

danke für deinen beitrag, ohne den ich es nie geschafft hätte!

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 27. Nov 2007, 16:37

Das könnte ich mir auch gut im wiki vorstellen.
Überträgt das einer von euch? Ihr seid ja im Thema drin.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 28. Nov 2007, 22:20

Grothesk hat geschrieben:Das könnte ich mir auch gut im wiki vorstellen.
Überträgt das einer von euch? Ihr seid ja im Thema drin.
in welches wiki meinst du?

Smarty
Newbie
Newbie
Beiträge: 2
Registriert: 3. Dez 2007, 23:01

Beitrag von Smarty » 3. Dez 2007, 23:17

Hallo zusammen,

ihr habt hier ziemlich genau das beschrieben, was ich suche, ich kämpfe allerdings noch mit einer Fehlermeldung. Aber der Reihe nach:

Ich habe meine USB-Platte mit ntfs formatiert und dann nach dem Einbinden (Eintrag unter /media/My Book) mit ntfs-config Schreibzugriff gesetzt. Ich habe dabei das Verzeichnis /media/My Book übernommen.

Da ich feste fstab-Mounts nicht unter Media möchte, habe ich dort zwischenzeitlich ein anders Verzeichnis / Mountpunkt angegeben.
Ergebnis bis dahin war, daß er die Platte mit der bei Euch im ersten Teil genannten Fehlermeldung garnicht mehr gemountet hat.

Die fstab-Zeile ist nun aber (wie in Eurer Beschreibung empfohlen) auskommentiert.

Ich habe dann die Datei /etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi
weggeschoben. Danach kam zumindest wieder der EIntrag unter /media/My Book.
Dann habe ich /etc/PolicyKit/PolicyKit.conf wie beschrieben angepasst (copy + paste aus Eurer Beschreibung) und rebootet.

Dann habe ich die Datei mount.ntfs-3g.sh erstellt und den Link wie angegeben eingerichtet.

Bis dahin hat alles geklappt. Beim Anstecken kam wieder /media/My Book, er hat mir angeboten das MEdium in einem neuen Fenster zu öffnen... alles klar. Allerdings nur Read-Only.

Ich habe vermutet, daß das mit der hal/fdi/policy-Datei zusammenhängt, die ich oben weggeschoben hatte. Doch nachdem ich die wieder zurückgeholt habe passiert nun folgendes:

- Der Eintrag /media/My Book erschient beim Einstecken nicht mehr. Wenn ich den Dialog mit "In einem neuen fenster öffnen" bestätige, dann erhalte ich folgenden Fehler:
[code]
ntfs-3g: You must specify exactly one device and exactly one mount point. ntfs-3g 1.913 - Third Generation NTFS Driver Copyright (C) 2005-2006 Yura Pakhuchiy Copyright (C) 2006-2007 Szabolcs Szakacsits Usage: ntfs-3g <device|image_file> <mount_point> [-o option[,...]] Options: ro, force, locale=, uid=, gid=, umask=, fmask=, dmask=, streams_interface=. Please see details in the manual. Example: ntfs-3g /dev/sda1 /mnt/win -o force,locale=en_EN.UTF-8 Ntfs-3g news, support and information: http://ntfs-3g.org
[/code]

Kann damit jemand was anfangen? Ich bin für jeden Tip dankbar...

Danke und Gruß,
Martin Soltau

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16610
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 4. Dez 2007, 06:44

rainerklier hat geschrieben:in welches wiki meinst du?
In unsere Linuxclub Wiki. :wink:
http://wiki.linux-club.de/Hauptseite

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 4. Dez 2007, 20:36

Smarty hat geschrieben: Ich habe meine USB-Platte mit ntfs formatiert und dann nach dem Einbinden (Eintrag unter /media/My Book) mit ntfs-config Schreibzugriff gesetzt. Ich habe dabei das Verzeichnis /media/My Book übernommen.
ich denke da ist dein problem.
du solltest bei der konfiguration den schreibzugriff für alle externen platten aktivieren, nicht nur für bestimmte.

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 4. Dez 2007, 20:38

whois hat geschrieben:
rainerklier hat geschrieben:in welches wiki meinst du?
In unsere Linuxclub Wiki. :wink:
http://wiki.linux-club.de/Hauptseite
spricht was dagegen wenn ich eine wiki seite in de.opensuse.org erstelle (ich denke dort suchen die leute als erstes, ich zumindest hab zuerst auch dort gesucht), und dann im wiki.linux-club.de eine wiki seite mache, die dorthin verlinkt?

Smarty
Newbie
Newbie
Beiträge: 2
Registriert: 3. Dez 2007, 23:01

Beitrag von Smarty » 4. Dez 2007, 23:30

Hallo Rainerklier,

Ich bin mirnicht sicher, was Du meinst. Bei ntfs-config kommen zwei Dialoge.

Der Erste zeigt die vorhandenen Partitionen und hat im Default die ntfs-Partitionen angehakt. Da habe ich meine interne Festplatte rausgenommen, weil die will ich nicht mounten.

Dann folgt der Zweite Dialog. Der fragt nach Schreibzugriff für externe (da kann ich garnix auswählen) und interne (da stehen die, die ich im ersten Dialog ausgewählt habe) Laufwerke.

Für externe habe ich aktiviert, für interne eben nur die USB-Platte unter /dev/sdg1.

Wo siehst Du den Fehler? Muß ich auch meine interen Festplattenpartition mit ntfs aktivieren? Die will ich doch garnicht...

Danke und Gruß,
Martin

P.S.: Ich habe nun alle von ntfs-config angelegten Dateien im /media- und /etc/hal/fdi/policy-Verzeichnis gelöscht und die Platte neu via nfts-config eingehängt:
Er hat sie problemlos eingebunden - sogar mit schreibzugriff für root.
Nach Reboot und neu anhängen: Gleiche Fehlermeldung wie oben - You have to specify exactly one... :-(

P.P.S.: Wenn er mir wenigstens sagen würde, Wo zum Henker er meint, ein zweites Device oder einen zweiten Mountpoint her zu haben, dann könnte ich das ja beheben. Aber so... ratlose Grüße...

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 13. Dez 2007, 18:18

whois hat geschrieben:
rainerklier hat geschrieben:in welches wiki meinst du?
In unsere Linuxclub Wiki. :wink:
http://wiki.linux-club.de/Hauptseite
ich hab jetzt auf der Seite http://wiki.linux-club.de/opensuse/USB_Festplatte einen Link nach http://de.opensuse.org/NTFS reingemacht.

timetourist
Newbie
Newbie
Beiträge: 3
Registriert: 14. Aug 2007, 13:06

Beitrag von timetourist » 9. Feb 2008, 13:42

Es gibt auch noch einen ganz kurzen Weg, indem man einfach eine entsprechende fdi-Regel anlegt. Mehr nicht.

http://cloudkicker.net/2008/02/08/ext-ntfs-hdd/

rainerklier
Newbie
Newbie
Beiträge: 7
Registriert: 20. Nov 2006, 11:16

Beitrag von rainerklier » 16. Apr 2008, 22:45

timetourist hat geschrieben:Es gibt auch noch einen ganz kurzen Weg, indem man einfach eine entsprechende fdi-Regel anlegt. Mehr nicht.

http://cloudkicker.net/2008/02/08/ext-ntfs-hdd/
diese lösung ist beeindruckend gut, kurz, einfach, schnell und erfolgreich.

ich hab sie bei meinem 2. linux rechner ausprobiert und war in 1 minute fertig und es hat wunderbar geklappt!

nur um den trick mit der .sh datei und dem verlinken der mount.ntfs-3g auf die .sh datei kommt man nicht herum, sonst kann man keine dateien mit umlauten anlegen.

ingomueller.net
Newbie
Newbie
Beiträge: 1
Registriert: 19. Aug 2008, 10:38

Re: Externe USB HDD mittels hal und ntfs-3g automatisch mounten

Beitrag von ingomueller.net » 19. Aug 2008, 10:45

rainerklier hat geschrieben:
kaltduscher_99 hat geschrieben:in /sbin/ eine neue datei mount.ntfs-3g.sh anlegen mit folgendem inhalt:

#!/bin/bash

/bin/ntfs-3g $1 $2 -o locale=de_DE.UTF-8
Hat super funktioniert, lässt sich aber noch verbessern:

Code: Alles auswählen

#!/bin/bash
/bin/ntfs-3g $1 "$2" -o locale=de_DE.UTF-8,$4
So funktionieren auch Festplattennamen mit Leerzeichen und Optionen, die von außen gesetzt werden, werden mitübernommen (durch das $4).

Viele Grüße, Ingo

Gesperrt