Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SSH Access denied?

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
Meister Gandolf

SSH Access denied?

Beitrag von Meister Gandolf »

Hallo Forum !

Folgendes Phänomen habe ich bzw. mein Server :-) bei dem ich Eure Hilfe brauche.
Habe einen Server mit SuSE 9.0 Professional aufgesetzt - was bisher immer klappte. Diesmal jedoch habe ich direkt ein Online-Update gemacht (fast wie bei Windows :-)). Dabei wurde auch der SSH-Daemon aktualisiert.
Wenn ich einen Login per SSH machen will kann ich zwar den Benutzernamen und das Kennwort eintragen, doch bekomme ich IMMER die Meldung "Access denied". Gebe ich das selbe Kennwort direkt an der Konsole ein klappt es. Habe testweise auch einen neuen User angelegt der der Gruppe root und ssh zugehörig ist - auch hier, kein Zutritt per SSH.
Werden die Kennwörter, die für den SSH-Zugriff erlaubt sind noch mal extra gespeichert? Kann ich das wo nachschauen? Hat jemand sonst eine Idee, wo ich nach der Ursache suchen kann?
Schon alles merkwürdig.

Danke vorab und Gruß,

Sandro
Benutzeravatar
moenk
Administrator
Administrator
Beiträge: 1398
Registriert: 15. Aug 2003, 15:36
Wohnort: N52° 27.966' E013° 20.087'
Kontaktdaten:

Beitrag von moenk »

Damit ssh benutzt werden kann muss der sshd laufen. Das kann in der Runlevel-Konfiguration (Yast2-Module) eingestellt werden. Gruppenzuweisungen sind nicht erforderlich.
Gast

Beitrag von Gast »

moenk hat geschrieben:Damit ssh benutzt werden kann muss der sshd laufen. Das kann in der Runlevel-Konfiguration (Yast2-Module) eingestellt werden. Gruppenzuweisungen sind nicht erforderlich.
Hallo !

Das der Läuft beweist ja, dass ich überhaupt per SSH auf die Mashcine komme. Nur werden alle Kennwörter abgelehnt. :-(
Mittlerweile habe ich gelesen, dass seit SuSE 9.0. zu 8.2, bei SSH einiges geändert wurde - auch, was die Kennwortübermittlung betrifft. Nur weiß ich nicht, wie ich jetzt weiter komme.

Gruß,

Sandro
knallo

Beitrag von knallo »

Das gleiche problem hab ich auch :cry:
knallo

Beitrag von knallo »

Applies to: SUSE LINUX 8.0-9.0

Symptom
After updating to OpenSSH version 3.7.1,it is no longer possible to login via PuTTY (a Windows SSH client). The file /var/log/messages contains the following (or a similar) message:
Nov 12 11:17:22 magnesium sshd[14522]: Failed password for root from ::ffff:192.168.0.5 port 1131
or
Nov 12 11:18:39 magnesium sshd[14539]: Received disconnect from ::ffff:192.168.0.5: 11:
No supported authentication methods available
The login process works without problems from a different Linux machine.
Cause
The password authentication has been switched off for the SSH service
whereas the PAM authentication and therewith the associated "ChallengeResponseAuthentication" (which is necessary for the latter) have been activated instead (see configuration file at /etc/ssh/sshd_config). The Challenge/Response mechanism is disabled in PuTTY's configuration for the protocol version 1 (default in PuTTY).
Solution
Set the protocol used by default by PuTTY to "version 2". The Challenge/Response mechanism is activated by default in PuTTY for this protocol. Select the menu options "Connection" -> "SSH" and change the "Preferred SSH protocol version" from "1" to "2". Make sure that the option "Attempt 'keyboard-interactive' authentication (SSH2)" in the submenu "Auth" is activated.
If you have to necessarily use the SSH protocol version 1, activate the option "Attempt TIS or CryptoCard authentication (SSH1)" in the same menu.

To save your settings on a permanent basis, select the menu item "Session" and press "Default Settings" first and then "Save".

A current PuTTY version is included in the directory dosutils/putty on the first SUSE Installation CD/DVD.



greetz und gute rutsch knallo :D
Thomas

Vielen Dank!

Beitrag von Thomas »

:D

Vielen Dank für den wertvollen Tip, ich war gerade auch am verzweifeln. Jetzt läuft´s einwandfrei.

thomas[/quote]
okleinecke
Newbie
Newbie
Beiträge: 1
Registriert: 25. Jan 2004, 16:01

Danke du Held ;-)

Beitrag von okleinecke »

Und ich dachte ich bin Linux-Freak ;-)),

Hab auch ewig an dem gleichen Prob gehangen (hatte vorübergehend kein inet..), und jetzt seh ich das es der scheiss putty war.....
DANKE VIELMALS!!!
poiin2000
Member
Member
Beiträge: 55
Registriert: 29. Jan 2004, 17:04
Wohnort: Pforzheim
Kontaktdaten:

Beitrag von poiin2000 »

SuSE hat sich bei 9.0 eine Kleinigkeit abseits des Standards in der /etc/ssh/sshd_config erlaubt.

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication no
ist in

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
zu ändern.

Alternativ könnten auch ssh-schlüssel mittels dem Programm ssh-keygen erstellt werden.


poiin2000
ACQ

Beitrag von ACQ »

poiin2000 hat geschrieben:SuSE hat sich bei 9.0 eine Kleinigkeit abseits des Standards in der /etc/ssh/sshd_config erlaubt.

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication no
ist in

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
zu ändern.

Alternativ könnten auch ssh-schlüssel mittels dem Programm ssh-keygen erstellt werden.


poiin2000
Vielen dank fur die losung, wusste gar nicht mehr wass es sonst nog sein konte.

(Und entschuldigung fur slechtes Deutsch, es ist ein bischen rostig)
workingneo
Newbie
Newbie
Beiträge: 1
Registriert: 30. Okt 2004, 14:29

Beitrag von workingneo »

mega cool! :shock:
da wäre ich nie drauf gekommen! :)
tbreiten
Newbie
Newbie
Beiträge: 1
Registriert: 30. Okt 2004, 22:30
Kontaktdaten:

Beitrag von tbreiten »

Danke das was ich hier gelesen habe hat geholfen.
Nur das beim anmelde Versuch (nach den Putty Einstellungen) nach der PW Eingabe ein Ausnahmefehler von Putty auftrat.
Ich hatte Putty v0.52 genutzt als der Fehler aufgetreten ist. Nach einem Upgrade ging es dann. Die Version weis ich nicht, da ich seither mit Develop Versionen von Putty arbeite (Develop 30-10-04)

Gruß :)
We accomplish all that what we do through delegation either to time or to other people.
Stephen R. Covey
blackbirddh
Newbie
Newbie
Beiträge: 1
Registriert: 31. Aug 2005, 22:09
Wohnort: Taufkirchen

Beitrag von blackbirddh »

... von mir auch ein Danke, genau das war auch mein Problem.

Ich hatte das schon mal, habe dann auch die Antwort in einem Forum gefunden und danach scheinbar gleich wieder vergessen.

CU all
Blackbird
__________________________
Wer später bremst ist länger schnell
Antworten