Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

pptpd und standartgateway

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Chris78
Member
Member
Beiträge: 67
Registriert: 15. Mär 2004, 13:34

pptpd und standartgateway

Beitrag von Chris78 »

Hallo.
Ich habe ein funktionierendes VPN mit PPTPD installiert. Nur hätte ich noch gerne das, wenn der Client die IP bekommt auch den richtigen Standartgateway zuweist. wenn ich mit ipconfig nachschaue legt pptpd den Standartgateway auf die IP Adresse, die auch der client bekommt.

Ethernetadapter "LAN-Verbindung":

Verbindungsspezifisches DNS-Suffix: tux-net
IP-Adresse. . . . . . . . . . . . : 192.168.1.81
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.1.11

PPP-Adapter "heim":

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . : 192.168.1.100
Subnetzmaske. . . . . . . . . . . : 255.255.255.255
Standardgateway . . . . . . . . . : 192.168.1.100
Hat jemand eine Idee wie ich den Standartgateway zugewiesen bekomme?
Triton
Member
Member
Beiträge: 88
Registriert: 22. Feb 2004, 17:20

Beitrag von Triton »

Hallo

Wie sieht denn Deine pptpd.conf aus ?
Wie sieht denn Deine options.pppX aus?

Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . : 192.168.1.100
Subnetzmaske. . . . . . . . . . . : 255.255.255.255
Standardgateway . . . . . . . . . : 192.168.1.100

Das ist doch alles richtig soweit oder?
Du hast doch den Standardgateway mit 192.168.1.100 erhalten?


Gruss Triton
Gast

Beitrag von Gast »

Pptpd.conf:

speed 115200
option /etc/ppp/options.ppp0
debug
localip 192.168.1.11
remoteip 192.168.1.100-199
listen 192.168.1.11
pidfile /var/run/pptpd.pid



options.ppp0:

lock
debug
auth
+chap
+chapms
+chapms-v2
mppe-40
mppe-128
mppe-stateless
name poseidon
proxyarp
ms-dns 194.25.2.129
netmask 255.155.255.0

Ich habe allerdings noch ein Problem:
Ich kann nur lokal eine VPN - Verbindung aufbauen. Wenn ich versuche übers Internet den Server zu erreiche, bekomme ich nur, keine Antwort.
Ich habe VPN in der Firewall freigegeben in
/etc/sysconfig/SuSEfirewall2:
FW_SERVICES_EXT_IP="gre"
Auch wenn ich die Firewall deaktiviere bekomme ich von Außen auch keine Verbindung.
Was kann das sein?
charlie
Newbie
Newbie
Beiträge: 5
Registriert: 2. Mai 2004, 13:06

Beitrag von charlie »

HI,

poste mal bitte ein lsmod , wenn das nicht drinn ist ip_gre mal mit modprobe laden...

charlie
Antworten