Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Cyrus baut keine Verbindung zum Server auf

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Linuxmaker
Newbie
Newbie
Beiträge: 6
Registriert: 9. Mai 2004, 13:29

Cyrus baut keine Verbindung zum Server auf

Beitrag von Linuxmaker »

Hallo,

ich versuche soeben Cyrus auf einem SuSE 8.2 Linux zum Laufen zu bringen.

telnet localhost imap funktioniert auf, der Cyrus-Server läuft also. Nur wenn ich mit

cyradm -user tester localhost
alternativ:
cyradm -user tester eagle
oder:
cyradm -user tester 192.168.0.2

das Postfach anlegen will, hängt sich der Prozeß auf.

Genauso wenn ich cyradm eingebe und in der Shell

info
eingebe, erhalte ich die Meldung "info: no connection to server"

connect 192.168.0.2 in der cyradm-Shell hängt den Prozeß wieder auf.

Wie kann ich also eine Verbindung zum Server aufbauen, bzw. was funktiniert da nicht?

Gruß

Andreas
condor81
Member
Member
Beiträge: 86
Registriert: 17. Mär 2004, 18:38
Wohnort: Schweiz

Beitrag von condor81 »

Hi, was sagt denn dein LogFile, wenn du den Cyrus startest? Ich hatte auch Probleme mit dem Teil, konnte es aber lösen. Eventuell laufen andere Dienste auf den beiden Ports 110 und 143.

Grüsse
condor
Starte Linux und du spürst, daß du ein Gehirn hast.
Triton
Member
Member
Beiträge: 88
Registriert: 22. Feb 2004, 17:20

Beitrag von Triton »

Beitrag löschen
Zuletzt geändert von Triton am 18. Jul 2004, 01:06, insgesamt 1-mal geändert.
Linuxmaker
Newbie
Newbie
Beiträge: 6
Registriert: 9. Mai 2004, 13:29

Beitrag von Linuxmaker »

Hi und Dankeschön,

vorab der Part der Logs, nach Cyrus-Start:

May 12 09:05:41 eagle master[4437]: about to exec /usr/lib/cyrus/bin/ctl_cyrusdb
May 12 09:05:41 eagle ctl_cyrusdb[4437]: recovering cyrus databases
May 12 09:05:42 eagle ctl_cyrusdb[4437]: skiplist: recovered /var/lib/imap/mailboxes.db (0 records, 144 bytes) in 0 seconds
May 12 09:05:42 eagle ctl_cyrusdb[4437]: done recovering cyrus databases
May 12 09:05:42 eagle master[4436]: unable to bind socket for service pop3: Address already in use
May 12 09:05:42 eagle master[4436]: ready for work
May 12 09:05:42 eagle master[4438]: about to exec /usr/lib/cyrus/bin/tls_prune
May 12 09:05:42 eagle master[4439]: about to exec /usr/lib/cyrus/bin/ctl_deliver
May 12 09:05:42 eagle master[4440]: about to exec /usr/lib/cyrus/bin/ctl_cyrusdb
May 12 09:05:42 eagle ctl_cyrusdb[4440]: checkpointing cyrus databases
May 12 09:05:42 eagle ctl_cyrusdb[4440]: archiving log file: /var/lib/imap/db/log.0000000001
May 12 09:05:42 eagle ctl_cyrusdb[4440]: archiving database file: /var/lib/imap/mailboxes.db
May 12 09:05:42 eagle ctl_cyrusdb[4440]: done checkpointing cyrus databases
May 12 09:05:42 eagle master[4436]: process 4440 exited, status 0
May 12 09:05:42 eagle ctl_deliver[4439]: DBERROR db4: 4 lockers
May 12 09:05:42 eagle ctl_deliver[4439]: duplicate_prune: pruning back 3 days
May 12 09:05:42 eagle ctl_deliver[4439]: duplicate_prune: purged 0 out of 0 entries
May 12 09:05:42 eagle tls_prune[4438]: tls_prune: purged 0 out of 0 entries
May 12 09:05:42 eagle master[4436]: process 4439 exited, status 0
May 12 09:05:42 eagle master[4436]: process 4438 exited, status 0

Sieht so aus, als ob Du mit Port 110 recht hast, Condor. Wie hast Du denn das bei Dir gelöst? In der /etc/inetd.conf ist pop3 bei mir auskommentiert.

Und meine /etc/imapd.conf, Triton, sieht wie folgt aus:

configdirectory: /var/lib/imap
partition-default: /var/spool/imap
sievedir: /var/lib/sieve
admins: cyrus
allowanonymouslogin: no
autocreatequota: 10000
reject8bit: no
quotawarn: 90
timeout: 30
poptimeout: 10
dracinterval: 0
drachost: localhost
sasl_pwcheck_method: saslauthd
lmtp_overquota_perm_failure: no
#
# if you want TLS, you have to generate certificates and keys
#
#tls_cert_file: /usr/ssl/certs/cert.pem
#tls_key_file: /usr/ssl/certs/skey.pem
#tls_ca_file: /usr/ssl/CA/CAcert.pem
#tls_ca_path: /usr/ssl/CA

Eigentlich das, was SuSE 8.2 als Standard anbietet. Wenn ich mich als Cyrus einlogge, ist genau dasselbe Problem.

Grüße

Andreas
Linuxmaker
Newbie
Newbie
Beiträge: 6
Registriert: 9. Mai 2004, 13:29

Beitrag von Linuxmaker »

Hi,

ich habe inzwischen im xinetd pop3 deaktiviert und

lsof -i :110 liefert nichts mehr. Dafür liefert mir lsof -i :143 folgende Ausgabe:

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
master 4436 cyrus 7u IPv4 56750 TCP *:imap (LISTEN)

Das scheint ja auch richtig zu sein. Dennoch cyradm funktioniert nach wie vor noch nicht.
cyradm> info
info: no connection to server

und bei
cyradm> connect localhost

hängt er wieder. Warum?

Grüße

Andreas
Gesperrt