Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit Firewall und Samba

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Waldi
Newbie
Newbie
Beiträge: 1
Registriert: 11. Mai 2004, 00:39
Kontaktdaten:

Problem mit Firewall und Samba

Beitrag von Waldi »

Hallo zusammen,

Ich habe nun seit ca. 3 Tagen einen neuen "Server" mit SuSE 9.1 und folgendender Ausstattung:

- Yeong Yang B0420 Cube-Case
- 550 LC-Power Netzteil
- Asus P4P800 Deluxe
- 512 MB DDR Infineon
- 20 GB HDD (Systemplatte, Primary Master)
- 3x 120GB HDD
- 1x 80 GB HDD (an Via-Raid-Controller)

Da ich absoluter Linux-Anfänger bin, bin ich schon recht froh, dass der PPPoE Zugang, der DHCP-Server und die Firewall läuft, ich ausserdem von den Windows-Rechnern im Netzwerk aufs Internet zugreifen kann.
Da ich mich, wie gesagt, auf Neuland begeben habe, habe ich auch alle Konfigurationen mittels Kontrollzentrum-->YAST--> Netzwerkdienste vorgenommen.

Nun zu meinem Problem:
Nachdem die ersten Gehversuche mit PPPoE und DHCP geklappt haben (allerdings nur dann, wenn die Firewall aktiv ist) wollte ich nun den Samba-Server aktivieren. Hier ist nun folgenedes Problem aufgetreten:
Wenn die Firewall deaktiviert wurde, funktioniert der Samba-Dienst (pdc, nach Anleitung des Video-Tutorials) einwandfrei, allerdings geht dann der Internetzugang nicht mehr. Bei aktivierter Firewall, funktioniert zwar Internet für die Clients, nicht jedoch der Samba-Zugriff. Genauso verhält es sich mit dem Apache-Webserver.
Ich gehe also davon aus, dass ich ein Konfigurationsproblem in der Firewall habe. Da ich jedoch in YAST nur wenig einstellen kann, waren meinem Möglichkeiten zunächst begrenzt, was genau sollte ich an den Konfigurationen verändern??

Ich habe mich bereits mit den Grundfunktionen von VI vertraut gemacht, bin also durchaus in der Lage conf-Dateien zu verändern. :)

vielen Dank schonmal

Gruß

Ralf
Olaf64
Newbie
Newbie
Beiträge: 5
Registriert: 13. Mai 2004, 12:56
Wohnort: Münster

Beitrag von Olaf64 »

Hallo,

du musst tatsaechlich das Firewall - Script manuell anpassen:

/etc/sysconfig/SuSEfirewall2

unter Punkt # 9.)

FW_SERVICES_INT_TCP=""

aendern zu

FW_SERVICES_INT_TCP="80 139"
bzw. entsprechende namen aus /etc/services

139 ist fuer Samba, ohne weiter Massnahmen funktioniert aber dann nur das Verbinden mit der ip-adresse statt dem Rechnernamen,
also in windows:
net use * \\192.168.1.1\freigabe /persistent:yes
Ansonsten musst du auch noch netbios-tcp und udp-ports freigeben,
was ich auf einer firewall nicht fuer empfehlenswert halte.

Dein Internet-Zugriff funktioniert uebrigens nur mit FireWall,
da erst im firewall-Script IP-Forwarding und IP-Masquerading aktiviert werden und somit Pakete von einer (echten-)Netzwerkkarte
auf das DSL-Modem weitergereicht werden.
(Punkt # 5.) und # 6.) in SuSEfirewall2)
Das kann man zwar auch ausserhalb der Firewall konfigurieren,
ist aber nicht zu empfehlen, da dann dein netz evtl. voellig offen ist.

Gruss
Olaf
Antworten