Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] squid und squidguard wollen noch nicht so recht?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Xero
Member
Member
Beiträge: 107
Registriert: 31. Dez 2003, 15:43
Wohnort: Baden-Württemberg
Kontaktdaten:

Beitrag von Xero »

Also du filterst nur die porn-domains, aber das weißt du ja warscheinlich, ansonsten läuft bei mir genau die gleiche conf perfekt (wenn denn der Squid im Browser drin steht ;-)), nur eine Abweichung, ich benutze nicht

Code: Alles auswählen

/usr/sbin/squidGuard -c /etc/squidguard.conf 
sondern nur

Code: Alles auswählen

/usr/sbin/squidGuard 
Sollte aber eigentlich nichts machen. Außerdem seltsam: rotznase hat genau das gleiche Problem wie du!
Grüße, Xero

Die Board Suche ist dein Bester Freund, also benutze sie auch!!!!!!!!
UHU
Newbie
Newbie
Beiträge: 2
Registriert: 14. Jul 2004, 16:49

Beitrag von UHU »

Hallo,

nicht nur Rotznase hat dieses Problem. Bei meinem Server SuSE 9.1 mit squidguard 1.2.0 -373 org SuSE und squid 2.5 Stabel 5-42.9 org.SuSE ist das ein Blinker :? (geht, geht nicht, geht, geht nicht .....). Das frustrierende ist alles ohne Fehlermeldungen. In den Logs kommt am Schluss nach jedem Restart immer "squidGuard ready for requests". ps -A listet auch brav 5* squidguard . Es wird trotzdem nicht immer gefiltert. Hilft ein ./configure make make install. Der Quelle ?
Tut mir leid das ich nicht helfen kann. Vielleicht jemand anders?

MfG UHU
UHU
Newbie
Newbie
Beiträge: 2
Registriert: 14. Jul 2004, 16:49

Beitrag von UHU »

:) scheine eine Lösung gefunden zu haben.
Bitte versucht es doch auch mal zu testen!
Eigentlich wollte ich squidgurad aus den Quellen neu kompailliern. Beim Download ftp://ftp.teledanmark.no/pub/www/proxy/squidGuard/bin ich auf folgenden Text gestossen!
Nota Bene!
==========
.db files created with Berkeley DB version 2.7.X are NOT
compatible with Berkeley DB version 3.2.X! If you created files
with "squidGuard-1.1.X -C" you must export them to a plain text
file (listdb file.db > file) and remove all .db files and run
"squidGuard-1.2.0 -C"

Also auch mal ausprobieren! Besonders da ich keine .db Dateien im orginal (von webmin runtergeladenen ) blacklists finden konnte!
Also als root angemeldet und # squidGuard –d –C all eingegeben.
Jetzt habe ich auch in meinen Verzeichnissen der Datenbank .db Dateien die zwar nicht 0bytes haben aber für meinen Texteditor leer sind.
Und plötzlich geht’s! Ist nur noch die frage wie lange?

Bin auf eure Ergebnisse gespannt.

Mit freundlichen Grüßen UHU
rolscha
Newbie
Newbie
Beiträge: 1
Registriert: 5. Nov 2004, 00:49

Squid

Beitrag von rolscha »

Ich habe das gleiche Problem mit SquidGuard, richtig implementiert, startet mit squid aber keine Reaktion auf die in der .conf definierten Einträge.

Wir sind intensiv dran...... und ich werde Euch auf dem Laufenden halten.

Gruß
Roland :?
Antworten