Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Linux 9.0, Squid und co.

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
CaptainCookii
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 09:45

Linux 9.0, Squid und co.

Beitrag von CaptainCookii »

Moin zusammen...ich hab mich hier nun durch einige Posts durchgewühlt und ein paar sachen schon ausprobiert. Alles ganz gut und schön soweit. Ich hab nur genau das Problem das anscheind viele haben. Vielleicht hab ich auch was vergessen ich weiß es nicht :) Also das Problem ist folgendes:

Ich hab auf dem Rechner mit Internetanbindung, auf dem Linux 9.0 läuft. Und zur Zeit nur einen Rechner mit Win XP Prof. Der Linux Rechner und der Win XP rechner sind im Netzwerk per Hub verbunden. (Hat den Grund, der Hub verstärkt das signal noch ein bißchen weil 2 Etagen dazwischen liegen). So nun will ich eben das der Linux Rechner als Proxy funktioniert und hab mir auch ganz brav Squid runtergeladen und das auch mit der Standartconfig zum laufen bekommen. (bevor einer fragt..ja ich habe auf allow all umgestellt). So...dazu wäre noch zu sagen, der Linux Pc hat Ip: 192.168.0.1 und der Win Rechner dem entsprechend dann 192.168.0.2 alles im Subnetz 255.255.255.0 alles so wie es sein soll. Problem ist jetzt nur das der Win Rechner einfach keine Verbindung zum Linux Rechner kriegt. Der Ping geht sauber durch, also Verbindung ist ansich da. Nur der Linux Pc reagiert nicht drauf. vielleicht hab ich evtl auch was im Internetexplorer beim Win client falsch eingestellt. Hat da evtl jemand ne Idee was ich noch nachschaun könnte. Oder irgendwie ne andere Idee? Achso ich hab die Firewall von Suse auch schon eingestellt. Da konnte ich aber nix weiter finden was mir weiter hilft.

Danke schonmal fürs durchlesen ^^

Der Cookii
Xero
Member
Member
Beiträge: 107
Registriert: 31. Dez 2003, 15:43
Wohnort: Baden-Württemberg
Kontaktdaten:

Beitrag von Xero »

Um zu sagen, ob du was falsch bei den clients eingestellt hast, müsste man erst mal wissen, was du da überhaupt eingestellt hast...
Grüße, Xero

Die Board Suche ist dein Bester Freund, also benutze sie auch!!!!!!!!
CaptainCookii
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 09:45

Beitrag von CaptainCookii »

Also beim Client hab ich so wie es sein soll, die IP fest vergeben, also 192.168.0.2/255.255.255.0. Die erste frage wäre dann...müßte ich den linux rechner dann icht auch sehen bei der Netzwerkumgebung? Denn bei Linux taucht der Client auf. Dann wäre noch die frage was genau ich beim Client am Browser (IE) einstellen muss. Doch eigentlich nur die Server IP und den Port oder nicht?
Xero
Member
Member
Beiträge: 107
Registriert: 31. Dez 2003, 15:43
Wohnort: Baden-Württemberg
Kontaktdaten:

Beitrag von Xero »

Trag mal bei den TCP/IP Settings noch deinen Linux-Rechner als Gateway ein, und außerdem noch DNS-Server (siehe http://www.fli4l.de/german/dns.htm für die von deinem Provider) .

Und hast du einfach die IP des Linux-Rechners eingetragen oder http://<IP> eingetragen? Muss nämlich so heißen (wenn ich mich recht erinnere), und den Port den du in Squid eingetragen hast (Standart: 3128).

Außerdem: Hast du bei dem Firewall "Vor internem Netzt schützen" aktiviert? Dass dasf nicht sein!
Grüße, Xero

Die Board Suche ist dein Bester Freund, also benutze sie auch!!!!!!!!
CaptainCookii
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 09:45

Beitrag von CaptainCookii »

Also die Firwall Einstellungen bei Linux sind soweit ok, das mit dem Internen Netzwerk dachte ich mir schon und habs auch erst gar nicht aktiviert. Bei Squid hab ich eben auf allow all umgestellt und ansonsten erstmal alles so gelassen wie in der standartmäßig schon angegeben. So und bei dem Xp Client hatte ich bisher nur bei TCP/IP einstellungen eben die eigene IP fest eingestellt. Also eben 192.168.0.2 und ansonsten noch nix weiter. Ich werd das gleich mal probieren mit den DNS einstellungen und co und dann mal sehen was passiert. Muss ich denn sonst bei Linux noch irgendwas beachten? Muss evtl Samba laufen vorher oder geht squid auch alleine?

Grüße

Cookii
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Beitrag von marcor »

CaptainCookii hat geschrieben:Also die Firwall Einstellungen bei Linux sind soweit ok, das mit dem Internen Netzwerk dachte ich mir schon und habs auch erst gar nicht aktiviert. Bei Squid hab ich eben auf allow all umgestellt und ansonsten erstmal alles so gelassen wie in der standartmäßig schon angegeben. So und bei dem Xp Client hatte ich bisher nur bei TCP/IP einstellungen eben die eigene IP fest eingestellt. Also eben 192.168.0.2 und ansonsten noch nix weiter. Ich werd das gleich mal probieren mit den DNS einstellungen und co und dann mal sehen was passiert. Muss ich denn sonst bei Linux noch irgendwas beachten? Muss evtl Samba laufen vorher oder geht squid auch alleine?

Grüße

Cookii
Guckst du hier http://www.newbie-net.de/anleitung_squid.html
Funktioniert dein Routing denn ohne Squid??
Antworten