Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Intel 2100 und WEP

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
BabsiNeuer
Newbie
Newbie
Beiträge: 30
Registriert: 20. Apr 2004, 19:14

Intel 2100 und WEP

Beitrag von BabsiNeuer »

Hallo!

Ein neuer Tag,eine neue Herausforderung; Weiß jemand wie es mit der WEP Unterstützung seitens INTEL für diese Karte aussieht? Hat schon jemand Erfahrung damit gemacht?

lg Babsi
Software is like sex; it's better when it's free. (Linus Torvalds)
gast

Beitrag von gast »

Bei mir hat WEP nur in Verbindung mit dem Packet 'hostap' funktioniert.

- Also in Yast zusätzlich o.g. Packet plus Quellen installieren
- Hostap-Modul laden mit 'modprobe hostap'
- neuester IPW2100 Treiber bei Sourceforge heruntergeladen (bei mir war das 'ipw2100-0.43.tgz'
- Treiber installieren mit 'make HOSTAP=/usr/src/kernel-modules/hostap-driver-1.3.0'
- Die Firmware (ipw2100-1.0.fw) nach /usr/lib/hotplug/firmware kopieren (gibt's bei Intel.com)
- Anschließend habe ich die Karte in Yast konfiguriert
- Was mich ein wenig verwunderte, ich musste den Rechner neu starten (hallo, ist hier windows oder was!?) damit die Karte richtig funktionierte
- beim Aufruf von 'lsmod' sollte nun u.a. die Module hostap und ipw2100 auftauchen

So neben bei, SUSE bietet aber einen aktualisierten Kernel mit neuerem Centrino-Treiber an, vielleicht hat sich da ja hinsichtlich WEP bereits etwas getan.
Benutzeravatar
BabsiNeuer
Newbie
Newbie
Beiträge: 30
Registriert: 20. Apr 2004, 19:14

Beitrag von BabsiNeuer »

Danke für den Tipp! Ich werde das mal probieren-hoffentlich klappt es!

lg Babsi
Software is like sex; it's better when it's free. (Linus Torvalds)
Benutzeravatar
BabsiNeuer
Newbie
Newbie
Beiträge: 30
Registriert: 20. Apr 2004, 19:14

Beitrag von BabsiNeuer »

Ok, jetzt habe ich die Konfiguration der IPW2100 schon wieder erfolglos versucht! :(

Zuerst habe ich hostap von der SuSE 9.1 DVD nachinstalliert (das war bei mir nicht installiert?), danach habe ich das SuSEupdate gestartet und natürlich meine Kernel aktualisiert.
Anschließend habe ich mir ipw2100-0.43.tgz herunter geladen. In /home/myDir/TestDir habe ich die Datei dann entpackt und den Befehl: make HOSTAP=/usr/src/kernel-modules/hostap-driver-1.3.0 gestartet.
Das Kompilieren verlief fehlerfrei, daher kopierte ich die entpackte Firmware, welche auch auf ipw2100.sourceforge.org/firmware .php erhältlich ist in das Verzeichnis /usr/lib/hotplug/firmware/.

Bis hierher alles klar, nun starte ich Yast und konfiguriere meine Netzwerkkarte inklusive 128bit Schlüssel, welcher als Hexzahl vorliegt, und speichere die Werte. (2. (100 MBit)Netzwerkkarte habe ich herausgelöscht). Ich musste nicht neu starten, daher habe ich sicherheitshalber händisch neu gestartet.

Die Karte scheint sich nach dem Neustart nicht in mein Netz einwählen zu wollen. Mit iwlist eth0 scanning sehe ich meine Accesspoint.

Was mache ich falsch? Infrastructure-Mode gibts ja nicht mehr, der heißt im neuen SuSE "Verwaltet", in die ESSID trage ich den Namen meines APs ein, bei Verschlüsselungskey trage ich meine 128 bit Schlüssel ein, bei Spitzname ist es eigentlich egal was man einträgt und daher schreibe ich hier mal demo hinein.
Um sicherzustellen, dass der richtigie Kanal gewählt wird stelle ich diesen bei den Experteneinstellungen ein.

Was mich wundert ist, was macht ipw2100-0.42 in /usr/src/kernel-modules/? Ich habe doch gar nicht die Version 0.42 downgeloaded, sonder 0.43?

Ich verstehe jetzt gar nichts mehr. :(

lg Babsi
Software is like sex; it's better when it's free. (Linus Torvalds)
gast

Beitrag von gast »

Hi,

ich bin der 'gast' von oben. Hab' jetzt einen ordnungsgemäßen Account.

Ich hatte auch Probleme als ich die Mbit-Rate und den Kanal in YaST eingestellt hatte. Versuch' es mal in beiden Fällen mit 'Automatisch' bzw. 'auto'.

Das mit ipw2100-0.42 in /usr/src/kernel-modules/ kommt daher, dass Suse die Treiber-Version mit dem Kernel ausliefert. Vor dem Kernel-Update hat dort noch ipw2100-0.39 gestanden. Ist also in Ordnung.

Wenn Du als Benutzer 'root' an der Shell 'lsmod' ausführst, wird dann das Modul 'hostap' aufgeführt?

Gruß
skoraa
Benutzeravatar
BabsiNeuer
Newbie
Newbie
Beiträge: 30
Registriert: 20. Apr 2004, 19:14

Beitrag von BabsiNeuer »

Hallo!

Vorerst möchte ich dir für deine Geduld danken. :)

Hier mein das Ergebnis meines Aufrufes:

linux:/home/myAcc # lsmod | grep host
hostap 94984 1 ipw2100

Die LED im Notebook blinkt außerdem auch schon fleißig, bzw. sehe ich meinen AP:

linux:/home/myAcc # iwlist eth0 scanning
eth0 Scan completed :
Cell 01 - Address: 00:60:F8:00:67:76
ESSID:"radio"
Mode:Master
Frequency:2.422GHz
Bit Rate:1Mb/s
Bit Rate:2Mb/s
Bit Rate:5.5Mb/s
Bit Rate:11Mb/s
Bit Rate:22Mb/s
Quality:67/100 Signal level:-31 dBm Noise level:-98 dBm
Encryption key:on

Die Zeile Bit Rate:22Mb/s stimmt, da es sich beim AP um ein D-Linkprodukt handelt, welcher bis zu 44Mb/s unterstützt.

Das Problem welches ich jetzt noch habe ist, dass sich die WLAN-Karte nicht in den AP einbuchen kann. :(

Hier der Auszug aus meiner ifcfg-wlan...:

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='LHB6.dkYIOPpnsu8'
WIRELESS_AP=''
WIRELESS_BITRATE='11'
WIRELESS_CHANNEL='3'
WIRELESS_ESSID='radio'
WIRELESS_KEY=''
WIRELESS_MODE='Managed'
WIRELESS_NICK='linux'
WIRELESS_NWID=''
WIRELESS_POWER='yes'
_nm_name='bus-pci-0000:02:02.0'

lg Babsi
Software is like sex; it's better when it's free. (Linus Torvalds)
skoraa
Newbie
Newbie
Beiträge: 2
Registriert: 10. Mai 2004, 08:51

Beitrag von skoraa »

Hi,

bin der 'gast' von oben. Hat nur noch keinen Account.

Wie sieht es aus wenn du mit 'rcnetwork restart' Dein Netzwerk neu startest?
Hier sollte es keine Fehlermeldung geben.

Funktioniert ein Ping an Deinen Access-Point?

Gruß
skoraa
Gast

Beitrag von Gast »

Hallo!

Der Aufruf von rcnetwork restart liefert:
Shutting down network interfaces:
eth0 device: Intel Corp. PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
eth0 configuration: wlan-id-00:04:23:8d:a5:f9 done
eth1 device: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 81)
eth1 configuration: done
Shutting down service network . . . . . . . . . . . . . done.
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
eth0 device: Intel Corp. PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
eth0 configuration: wlan-id-00:04:23:8d:a5:f9
eth0 (DHCP) . . . . . no IP address yet... backgrounding. waiting
eth1 device: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 81)
eth1 No configuration found for eth1 unused
Setting up service network . . . . . . . . . . . . . . done.

Den AP kann ich auch nicht anpingen und in dessen Logfile taucht die Karte auch nicht auf.

lg Babsi
skoraa
Newbie
Newbie
Beiträge: 2
Registriert: 10. Mai 2004, 08:51

Beitrag von skoraa »

Sieht meiner Meinung nach gut aus. Was mir auffällt ist, dass keine IP Adresse via DHCP zugewiesen wird. Habe bis jetzt noch nie DHCP eingesetzt, sondern feste IP Adressen vergeben. Hast Du schon mal versucht, der Wlan-Karte eine feste IP Adresse zu geben?

Gruß
skoraa
Antworten