Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE 9.1 Cups Druckserver + Windows XP Client

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
it-ruffy
Member
Member
Beiträge: 56
Registriert: 5. Mär 2004, 13:38
Wohnort: Hildesheim
Kontaktdaten:

SuSE 9.1 Cups Druckserver + Windows XP Client

Beitrag von it-ruffy »

Ich habe ein seltsames problem mit dem Cups Server auf SuSE 9.1 Pro und einem Windows XP Druckclient!

Ich habe Cups als Server eingerichtet, das Webinterface für verschiedene IPs im Netzwerk freigeschaltet, darunter auch der Windows XP Client, um den es hier geht.

Als nächstes per Webinterface die Einstellungen an Cups vorgenommen, die Druckerwarteschalngen erstellt, darunter auch eine RAW für Windows XP.

Nun habe ich den Windows XP Rechner nach den Drucker suchen lassen im Netzwerk, er erkennt ihn, nimmt auch die korrekte IPP-Adresse und kann ihn ansprechen...
Versucht man allerdings die RAW-Warteschlange zu nutzen, verlangt Win XP nach einem Treiber für den Drucker auf den Server (den Client?), der Treiber ist auf dem Windows Rechner installiert und funktioniert und auch auf dem Linux Rechner, dort funktioniert er auch, der Treiber ist von Cups, andere Linux Clienten können einwandfrei drucken...

Der Windows Client kann mit einem modifizierten Treiber auch direkt über die Linux Warteschlangen drucken, jedoch ist die Druckausgabe anders als in der Seitenansicht unter Windows, deshalb muss das RAW-Device funktionieren und da weiß nich nicht weiter und keine Anleitung kann mir helfen...

Windows XP verlangt permanent nach einen Treiber, damit das RAW Device angesprochen werden kann, aber der Win Treiber liegt nur als .exe vor und kann daher nicht ins Cups Verzeichnis für Treiber installiert werden. Auf Windows selbst ist der Treiber auch fehlerfrei installiert und funktioniert (wenn Drucker lokal angeschlossen ist).
Bei jedem Druckversuch kommen die Daten nicht beim Rechner mit den Cups Server an, es wird auch nicht im Protokoll von Cups gelistet, das ist das komische...

Wie kann ich dieses Treiberproblem lösen? Samba ist keine Lösung, da nicht notwendig für Win XP, hab ich aber trotzdem installiert und hilft nicht. Es liegt eindeutig an diesem verlangten Treiber, wobei Windows nicht genau sagt, auf welchen Rechner sich der Treiber befinden soll und wofür der da sein soll...
openSuSE 10.2, Gnome
Windows XP
thomas_brune
Newbie
Newbie
Beiträge: 4
Registriert: 10. Mai 2004, 18:28
Wohnort: Im Weingarten 5-7
Kontaktdaten:

Re: SuSE 9.1 Cups Druckserver + Windows XP Client

Beitrag von thomas_brune »

[quote="it-ruffy"]Ich habe ein seltsames problem mit dem Cups Server auf SuSE 9.1 Pro und einem Windows XP Druckclient!

Windows XP verlangt permanent nach einen Treiber, damit das RAW Device angesprochen werden kann, aber der Win Treiber liegt nur als .exe vor und kann daher nicht ins Cups Verzeichnis für Treiber installiert werden. Auf Windows selbst ist der Treiber auch fehlerfrei installiert und funktioniert (wenn Drucker lokal angeschlossen ist).



Hast du mal versucht den Treiber zu entpacken?
In der Regel ist die ".exe" Datei bei Treibern nur ein selbstentpackendes Archiv.
it-ruffy
Member
Member
Beiträge: 56
Registriert: 5. Mär 2004, 13:38
Wohnort: Hildesheim
Kontaktdaten:

Beitrag von it-ruffy »

Nee, das geht bei den Epson Treibern leider nicht! Ist ne Installationsdatei, es gibt keine gepackte Version der Treiber meines Druckrs, auch der Versuch, die direkt aus dem Windows Ordner zu ziehen und in den entsprechenden CUPS Treiber Ordner zu kopieren, scheiterte...

Es handelt sich um einen Epson Stylus Photo 890 USB, vielleicht kennt sich damit einer gut aus...
openSuSE 10.2, Gnome
Windows XP
thomas_brune
Newbie
Newbie
Beiträge: 4
Registriert: 10. Mai 2004, 18:28
Wohnort: Im Weingarten 5-7
Kontaktdaten:

Beitrag von thomas_brune »

Klar geht das.
Ich habe gerade von epson.de den Treiber geladen und mit WinZip einwandfrei entpacken können..
Gast

Beitrag von Gast »

nun Ich habe der selbe problem gehabt mit meine HP 990cxi
Treiber hin oder her, es druckt einfach nicht mit XP.. Alles versucht, Server ist komplett offen, und der Drucker ist auch in Netz vorhanden... Trotz dem es druckt einfach nicht in XP.. Linux Client, 98 Client und 2k Client kein problem und hier der lösung:

funzt SUPER!! und frage mich nicht wieso aber der Apple Color LW 12/660 PS Treiber als ersatz ist hervoragend für eine HP Tintepisser unter Windows XP.

ciao
it-ruffy
Member
Member
Beiträge: 56
Registriert: 5. Mär 2004, 13:38
Wohnort: Hildesheim
Kontaktdaten:

Beitrag von it-ruffy »

Joa, ich möchte aber ungerne einen Postscript Treiber verwenden, damit funzt es ja auch ^^ Genauso die Standard Linux Warteschlangen (mit spezialtreiber unter win xp), jedoch liegt mir viel am Win XP Treiber aufgrund der guten Überwachung und der einfachen Einstellbarkeit...

Ausserdem sieht der Ausdruck dann nicht anders aus als unter Windows, das ist derzeit der Fall, ich setze grade einen Samba Server auf, damit ich es auch mal versuchen kann, die Epson Treiber auf den Linux Rechner zu entpacken...
openSuSE 10.2, Gnome
Windows XP
it-ruffy
Member
Member
Beiträge: 56
Registriert: 5. Mär 2004, 13:38
Wohnort: Hildesheim
Kontaktdaten:

Beitrag von it-ruffy »

Ich habe nun mal die Treiber ins Samba Treiber Verzeichnis (/var/lib/samba/drivers) entpackt und auch in die Unterverzeichnisse, habe dann noch die Gruppe lp als Druckeradmin freigegeben und den Eintrag valid users = %s, username in die smb.conf in die entsprechenden Abschnitte hinzugefügt und wieder versucht, den Drucker über Win anzusprechen, er verlangt wieder nach dem Treiber, da dieser angeblich nicht auf dem entfernten Rechner zur Verfügung stehe...

Das Ding will mich wohl verarschen, hab doch den Treiber nun auf den Linux Rechner entpackt, das komische ist nur, dass die Dateien nur enden mit .dl_ .ex_ , richtig installieren kann man den Treiber ja net unter Linux...

Also, wer kann mir nun beim letzten Schritt vor der Lösung helfen, damit Win die Berechtigung bekommt und auch den Treiber auf dem Linux Rechner findet ^^

EDIT:
Anscheind hat hier keiner Ahnung davon, echt schade, aber wieso zickt windows denn auch immer so rum, für mich wieder einPunkt, an dem ich sagen kann - Windows sucks - weil mit Linux Rechnern passiert sowas nicht, andersherum funzt es ja 1A, aber dann steht der Drucker am falschen Ort und deshalb muss er am Linux Rechner bleiben und das scheiß Windows muss den Druckertreiber fressen...

Mal wieder ein deutlich Hass zeichen von Bill Gates abgefuckten leuten, dass sie ihr Win als bestes System machen wollen und den Umgang mit allen anderen System vehement blockieren...
openSuSE 10.2, Gnome
Windows XP
wanjelik
Newbie
Newbie
Beiträge: 1
Registriert: 6. Aug 2004, 00:52

ich habe folgende Lösung gefunden

Beitrag von wanjelik »

Hallo!

Ich hatte das gleiche Problem Drucken von einem W2K Rechner auf einen Epson C70 der an einem Linux Suse 9.1 Rechner hängt. Die Druckerverwaltung moserte immer etwas einem fehlenden Treiber und ich kam nicht weiter. Folgendes hat bei mir Abhilfe geschaffen. Die Treiber.exe von Epson auf dem Windows Rechner mit WinRAR enpacken (ist ein selbsextrahierendes Zip Archiv). Dann den freigegebenen Drucker installieren und wenn Windows nach dem fehlenden Treiber schreit das Verzeichnis in das entpackt wurde angeben. Das Funktioniert bei mir prächtig und ich habe die ganze Kontrolle über den Drucker wie unter Windows :-).

PS: und ich habe Linux erst seit 3 Tagen ;-)
Antworten