Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Maus mit 5 Tasten und einem Rad...

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
ChriChra
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 19:54

Maus mit 5 Tasten und einem Rad...

Beitrag von ChriChra »

Ja, ich weiß das dieses Problem öfters auftaucht, aber ich hab da etwas spezielles, zu dem ich nirgends eine Lösung gefunden hab.

Ich nutze SuSE 9.0 und hab eine optische Funkmaus der Firma Typhoon. DIese Maus hat 5 Tasten und ein Rad (also 7 Tasten). Ich hab es ja schon geschafft, das sich alle tasten unter X rühren, hab aber nun das Prblem, das Tase 4+5 (links und rechts) als 2tes Rad anerkant werden und ich so mit diesen Tasten im Mozilla nach rechts und links scrollen kann. Das will ich aber nicht, sondern ich will darauf die funktionen Vor und Zurück haben.

Ich hab bereits das Programm "mousemap" versucht (damit kann man ja den Maustasten Tastaturtasten zuordnen), aber nicht herrausgefunden, wie ich dem Button 4 die Tasten ALT+<- und dem Button 5 die tasten ALT+-> zuordnen kann.

Ich hoffe ihr könnt mir da irgendwie weiterhelfen...bin nämlich ein neuling und somit absolut überfordert...
towo
Moderator
Moderator
Beiträge: 3730
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo »

/etc/X11/XF86Config:

Code: Alles auswählen

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Autodetection"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection
Signatur nach Diktat spazieren gegangen

Bild
ChriChra
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 19:54

Beitrag von ChriChra »

Danke für die schnelle antwort, aber wenn ich das so einstelle, dann sind die beiden äußeren Tasten (also 4 & 5) deaktiviert und xev zeigt mir beim drücken auch keine Aktion an.

Meine Konfiguration in der XF86Config sieht folgendermaßen aus:

Code: Alles auswählen

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/psaux"
  Option       "InputFashion" "Mouse"
  Option       "Name" "PS/2-Mouse;IMPS/2"
  Option       "Protocol" "ExplorerPS/2"
  Option       "Buttons" "7"
  Option       "ZAxisMapping" "6 7"
EndSection
Wenn ich jetzt die Tasten mittels

Code: Alles auswählen

xmodmap -e "pointer = 1 2 3 6 7 4 5"
umlege, dann funktioniert das Rad für auf und ab scrollen wunderbar, nur die 4te und 5te Taste (laut xev dann Button 6 & 7), verhalten sich wie ein horivontales Rad (also scrollen nach rechts und lilnks).

Wie schaffe ich es, das statt scoll nach rechts und links ein Vor und Zurück im Browser passiert?!
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4014
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

ChriChra hat geschrieben:Danke für die schnelle antwort, aber wenn ich das so einstelle, dann sind die beiden äußeren Tasten (also 4 & 5) deaktiviert und xev zeigt mir beim drücken auch keine Aktion an.

Meine Konfiguration in der XF86Config sieht folgendermaßen aus:

Code: Alles auswählen

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/psaux"
  Option       "InputFashion" "Mouse"
  Option       "Name" "PS/2-Mouse;IMPS/2"
  Option       "Protocol" "ExplorerPS/2"
  Option       "Buttons" "7"
  Option       "ZAxisMapping" "6 7"
EndSection
Wenn ich jetzt die Tasten mittels

Code: Alles auswählen

xmodmap -e "pointer = 1 2 3 6 7 4 5"
umlege, dann funktioniert das Rad für auf und ab scrollen wunderbar, nur die 4te und 5te Taste (laut xev dann Button 6 & 7), verhalten sich wie ein horivontales Rad (also scrollen nach rechts und lilnks).

Wie schaffe ich es, das statt scoll nach rechts und links ein Vor und Zurück im Browser passiert?!
Versuche so:
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"

MfG
misiu
ChriChra
Newbie
Newbie
Beiträge: 3
Registriert: 7. Mai 2004, 19:54

Beitrag von ChriChra »

Hab ich versucht. Dann geht das Rad ganz normal (also auf und ab), aber die beiden zusätzlichen Tasten sind tot (also auch keine aktion in xev).
c64zottel
Newbie
Newbie
Beiträge: 1
Registriert: 26. Mai 2004, 14:38
Wohnort: bw
Kontaktdaten:

Beitrag von c64zottel »

hey,

hast du die zwei tasten mitlerweile schon ins leben gerufen ?

cu...
Gwenny
Newbie
Newbie
Beiträge: 1
Registriert: 29. Nov 2004, 00:34

mousemap

Beitrag von Gwenny »

Hi,

hier die Befehlszeile für Mousemap:

mousemap "Alt_L Left" "Alt_L Right" "1 2 3 6 7 4 5"

damit hat es auf jeden Fall bei mir funktioniert.

Gruß Gwenny
JesusE

Beitrag von JesusE »

Ich versuch das grad unter 9.3. Bei mir steht dann in der Konsole:

alex@linux:~> mousemap "Alt_L Left" "Alt_L Right" "1 2 3 6 7 4 5"
alex@linux:~> mousemap v0.4 (PID 9196) - mapping table: 1 2 3 6=Alt_L Left 7=Alt_L Right 4 5
X Error of failed request: BadAccess (attempt to access private resource denied)
Major opcode of failed request: 28 (X_GrabButton)
Serial number of failed request: 11
Current serial number in output stream: 13

Bei mir machen die Daumentasten so sinnlose Funktionen wie Hilfe (F1) und Reload (F5). Deshalb hätte ich auch gern "Vorwärts" und "Rückwärts". Kann mir jemand helfen?
Benutzeravatar
ManuelW
Member
Member
Beiträge: 202
Registriert: 18. Mai 2004, 21:05
Wohnort: Leipzig
Kontaktdaten:

Beitrag von ManuelW »

Du hast in dem Fall evtl. mousemap schon am laufen.

killall -9 mousemap

und dann die zeile nochmal eingeben, dann klappt es.
JesusE

Beitrag von JesusE »

JIPPPPPPPPPPIE!! .-)) Ich freu mich wie ein kleines Kind! Das muss nun nur noch in mein kleines Script. Ich hoff, das passt dann. Super. Ansonsten ist es bestimmt ein Klacks.

Danke!!!
Dick van Dijk
Newbie
Newbie
Beiträge: 7
Registriert: 16. Jul 2004, 14:57
Wohnort: in der PFALZ

Beitrag von Dick van Dijk »

jesusE

hi
Kannst du mal die Config hier abdrucken, damit ich die genauso reinschreiben kann, habe das gleiche Problem und freue mich daß du dich freust.... ich möchte mich auch freuen!!!

Vielen Dank...
mfg Dick van Dijk
SEIEN WIR REALISTISCH, VERUCHEN WIR DAS UNMÖGLICHE (CHE)!


Skype nutzer!! (dick_van_dijk)
tapf!
Newbie
Newbie
Beiträge: 7
Registriert: 23. Apr 2005, 11:17

Beitrag von tapf! »

So hab nach nen HD Crash wieder SuSE aufs Notbuch gebügelt. Jetzt fehlen mir zwei Sachen:

Wie heisst das Tasten-Test-Programm?

Wo und wie bekomme ich wieder mousemap? Das letztemal hab ichs nicht nachinstalliert, aber jhetzt meldet er er hätte es nicht.

FAbian
TobiTobsen
Newbie
Newbie
Beiträge: 7
Registriert: 28. Nov 2005, 18:44

Beitrag von TobiTobsen »

Hallo

also bei mir klappt es leider nicht so gut. Wenn ich z.b. den Befehl
mousemap "Alt_L Left" "Alt_L Right" "1 2 3 6 7 4 5" eingebe zielt es auf mein Mausrad ab

Mache ich hingegeb
mousemap "Alt_L Left" "Alt_L Right" "1 2 3 4 5 6 7"
Ist das Mausrad wieder da und ansonsten nix.

Meine beiden Daumentasten sind mit den Funktionen der linken Maustatste belegt. Und ich kriege sie irgendwie nicht geändert.

Könnt ihr mir helfen
NachtDruide
Newbie
Newbie
Beiträge: 1
Registriert: 2. Jul 2006, 16:58
Wohnort: HP
Kontaktdaten:

Beitrag von NachtDruide »

Hi!

Ich hatte so'n ähnliches Problem...
bei meiner Maus haben die Daumentasten 8 und 9

bei mir sieht das also so aus
mousemap "Alt_L Left" "Alt_R Right" " 1 3 2 4 5 8 9"

Ich benutze aber auch evdev und event2 in der xorg.conf

mit xmodmap -e "pointer = 1 3 2 4 5 8 9 ....... 32" geht das bei mir auch

Viel Glück! ;)

P.S. ich benutze SuSE 10.0 <--hatte ich vergessen...
Antworten