Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

USBVIEW ?

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
outkast
Newbie
Newbie
Beiträge: 10
Registriert: 2. Feb 2004, 21:24
Wohnort: LK Lichtenfels
Kontaktdaten:

USBVIEW ?

Beitrag von outkast »

Hallo,
habe Suse 9.1 auf meinem Rechner neu installiert und versuche gerade meine Digikam und meinem Mp3 Player anzuschließen....
es läuft nur nicht.
Usbview sagt mir:
--------------------------------------------------------------------------
Can not open the file /proc/bus/usb/devices

Verify that you have USB compiled into your Kernel,
have the USB core module loaded, and have the usbdevfs filesystem mounted.
--------------------------------------------------------------------------

gut nur wie stell ich das am besten an?
Ich habe auch im Forum nichts wirklich passendes dafür gefunden.

Bin ratlos...
Danke für eure hilfe
Windows is out!
Linux is in!

Open Source rules!
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Also, wie ich schonmal gepostet habe. Seit Kernel 2.6 läuft das mit usb etwas anders. Im Normalfall solltest du nur anstecken müssen, dann ca. 20-30 Sekunden waren und dir das Verzeichnis /media auflisten lassen, Dort werden dann alle USB-geräte mit einem etwas kryptischen Namen aufgelistet. Sobald du das USB-Gerät wieder absteckst, verschwindet das Verzeichnis wieder.

usbview zeigt deswegen einen Fehler, da die "Datei" wirklich nicht existiert. Im Zuge der Kernelbereinigung wurde usb nämlich nach /sys/bus/usb umgezogen. Halt, halt, halt, nicht gleich umstellen. usbview kann damit nämlich gar nichts anfangen, da dort keine devices mehr existiert sondern eine Ordnerstruktur, mit der usbview nichts anfangen kann.

Damit das Ganze aber trotzem geht. besätige die Fehlermeldung, Starte "configure", geh auf Dateiauswahl und wähle die einzige "Datei" die unter /proc/bus/usb noch existiert. Die ist ein Verweis für ältere Programme. Ist jedoch anzunehmen, dass es demnächst eine neure Version von usbview gibt (oder was anderers) oder schon gibt, das dann wieder Ordnungsgemäß arbeitet.

"Datei" habe ich deshalb verwendet, weil weder unter /proc noch unter "/sys" wirklich Dateien existieren. Das sind nur dynamische Informationen deines Kernels, die nur in das globale Dateikonzept von Linux gibt. (Eigentlich kennt Linux nur Dateien, auch Geräte u. Verzeichnisse sind für Linux Dateien)
Benutzeravatar
outkast
Newbie
Newbie
Beiträge: 10
Registriert: 2. Feb 2004, 21:24
Wohnort: LK Lichtenfels
Kontaktdaten:

Beitrag von outkast »

Vielen Dank für deine professionelle Antwort.

Jetzt klappt alles.
:wink:
Windows is out!
Linux is in!

Open Source rules!
Benutzeravatar
Pipen
Newbie
Newbie
Beiträge: 8
Registriert: 15. Apr 2004, 19:51
Wohnort: Hamburg

USB-View

Beitrag von Pipen »

:!: :!: Dem kann ich mich nur anschließen :!: :!:
Super gute beschreibung!

Frage, warum wird so ein Programm in eine Distribution aufgenommen, wenn ein normaler User beim Aufruf dieses Programmes außer einer Fehlermeldung keinen Nutzen davon hat?

Als Linux-Newbie hat man so echt keine Chance und bei mehreren solchen Fehlermeldungen ist es dann auch nicht verwunderlich, wenn M$ wieder einen neuen (alten) User zu seinem Kundenkreis zählen kann.


Gruß aus HH
towo
Moderator
Moderator
Beiträge: 3730
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: USB-View

Beitrag von towo »

Pipen hat geschrieben::!: :!: Dem kann ich mich nur anschließen :!: :!:
Super gute beschreibung!

Frage, warum wird so ein Programm in eine Distribution aufgenommen, wenn ein normaler User beim Aufruf dieses Programmes außer einer Fehlermeldung keinen Nutzen davon hat?

Als Linux-Newbie hat man so echt keine Chance und bei mehreren solchen Fehlermeldungen ist es dann auch nicht verwunderlich, wenn M$ wieder einen neuen (alten) User zu seinem Kundenkreis zählen kann.


Gruß aus HH
Wieso, das Programm funz doch! Must bei "Configure" nur /proc/bus/usb/devices_please-use-sysfs-instead eintragen.
Signatur nach Diktat spazieren gegangen

Bild
Benutzeravatar
Pipen
Newbie
Newbie
Beiträge: 8
Registriert: 15. Apr 2004, 19:51
Wohnort: Hamburg

USB-View

Beitrag von Pipen »

@towo2099
......sicher, nach einer Umstellung der Pfadangabe funktioniert das Programm. Aber wenn ich dies nicht zufällig hier im Forum gelesen hätte, dann hätte ich keinen Plan gehabt, welche Datei das Programm gerne öffnen möchte. :?

Ich bin leider nicht mit Linux groß geworden. :oops:
Bei einer *.ini-Datei wäre ich wohl auch schneller fündig geworden.
Ich muß halt noch sehr viel mehr über Linux lernen, wo und in welcher Datei bestimmte, für mich relevante Werte eingetragen sind.

Deshalb suche ich ja nach solchen Schlüsselwörtern um meinen Horizont zu erweitern und die "Fehler" abzustellen.

Gruß Pipen
Gruß aus HH
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Ist 'ne historische Gegebenheit. Bis SuSE 9.0 ging's ja ohne Probleme, da der Pfad noch gestimmt hat. Mit 9.1 kam der neue Kernel 2.6 bei dem die Architektur grundlegend geändert wurde. Wahrscheinlich haben die bei SuSE das einfach übersehen, da dies eigentlich nur eine Hilfe für "einfache" Anwender ist. Es gibt andere Möglichkeiten um an die gleichen Informationen zu kommen, was von Admin's häufig auch gemacht wird.

Gesteht den Machern von SuSE doch zu, dass bei der Produktvielfalt, die sie in der zwischenzeit mitliefern, Kleinigkeiten übersehen werden.
Benutzeravatar
Pipen
Newbie
Newbie
Beiträge: 8
Registriert: 15. Apr 2004, 19:51
Wohnort: Hamburg

USB-View

Beitrag von Pipen »

@nobbiew

Tja, dann ich bin wohl ein einfacher Anwender. :oops:
Doch leider habe ich nun mal unter SuSe 9.1 ein paar Probleme, welche den USB-Bus betreffen. Also, was macht ein "einfacher Anwender"....?
Ich für meinen Teil, weil keine große Ahnung von Linux, schaue erst einmal unter Software -> Suche -> USB als Suchbegriff nach, ob ich etwas zu diesem Thema finde. Vielleicht muss ich ja auch noch irgendwas installieren? -Klasse, nach kurzer Zeit werde ich auch sogleich fündig "USB-View" ist mein Retter!
Und dieses Programm listet mir dann bestimmt alles an angeschlossener Hardware auf, welche an meinem Rechner angeschlossen ist. (Denke ich noch bei mir.) Das Resultat ist mittlerweile bekannt.

Für Profis mögen solche kleinen unzulänglichkeiten ein Lacher sein, für einen Anfänger sind sie es leider nicht. :?

Niemand ist perfekt, doch wie gesagt, ich bin Klicki-Bunti verwöhnt.
:wink:

P.S.: Wenn ich schon mal bei dem Thema bin, kannst du mir vielleicht verraten wie Profis vorgehen, um störrische USB-Geräte in das System einzubinden?
Mein USB-Headset (Plantronics) + USB-Chipkartenlesegerät (Kobil Kaan Standard Plus) funktioniert unter SuSe 8.2 + 9.0 einwandfrei, unter SuSe 9.1 jedoch bisher noch nicht?!
Achja, diese Geräte werden mit USB-View gelistet, sollten also zumindest korrekt erkannt worden sein?!

Gruß Pipen
Gruß aus HH
Benutzeravatar
Pipen
Newbie
Newbie
Beiträge: 8
Registriert: 15. Apr 2004, 19:51
Wohnort: Hamburg

USB-Allgemein

Beitrag von Pipen »

:D :D Nachtrag :D :D

Mein USB-Headset funktioniert plötzlich......keine Ahnung, ob es am letzten Update liegt, welches ich vor zwei Tagen eingespielt habe.??

Mal schauen, ob mein Chipcardreader auch funktioniert....

Gruß Pipen
Gruß aus HH
lebertran
Newbie
Newbie
Beiträge: 2
Registriert: 28. Mai 2004, 21:47
Wohnort: WI

usbview hilft leider nur temporaer

Beitrag von lebertran »

seit einer neuinstallation von suse 9.1 habe ich ein echtes problem mit meiner maus.
von der hardware her ist das alles nicht exotisches:
vobis notebook modell 8375 mit folgendem USB:

UHCI Host Controller
Manufacturer: Linux 2.6.4-54.5-default uhci_hcd
(usbview output)
nebendran sitzt noch ein synaptics touchpad.

es ist nicht so, dass die usb maus (optical logitech) gar nicht erkannt wuerde, das ding ist einfach instabil, d.h. nach einigen sekunden oder auch minuten - je nach laune - bleibt das ding "stecken" javascript:emoticon(':o') bis ich
a.) den sax anwerfe oder
b.) die maus aus- und wieder einstoepsle. oder
c.) usbview ausfuehre.
javascript:emoticon(':?')
alle drei moeglichkeiten finde aber auf dauer wenig zielfuehrend.
weiss jemand abhilfe?
lebertran
Newbie
Newbie
Beiträge: 2
Registriert: 28. Mai 2004, 21:47
Wohnort: WI

viellecht doch besser als eigenes Thema...

Beitrag von lebertran »

hmmm.
vielleicht sollte ich doch einen eigenen thread zu diesem thema aufmachen. => ich bin raus und mit einem eigenen thema unter "hardware"
Antworten