Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Mail() funktioniert nicht mit Apache2+PHP

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
PolyMorPhi
Newbie
Newbie
Beiträge: 16
Registriert: 5. Mai 2004, 16:20

Mail() funktioniert nicht mit Apache2+PHP

Beitrag von PolyMorPhi »

Nach ewigem hin und her habe ich den Schoschonen Version 2 mit PhP zum laufen gebracht.
Und weil das alles schon soviel Spass gemacht hat funktioniert der mail() Befehl unter PhP nicht obwohl Postfix installiert ist.
Hat da schon jemand anders Erfahrungen gemacht?
Benutzeravatar
germanny
Newbie
Newbie
Beiträge: 46
Registriert: 7. Mai 2004, 11:59
Wohnort: Schleswig-Holstein/RD
Kontaktdaten:

9.1 php4 - mail() auch nach update nicht...

Beitrag von germanny »

Moin allemiteinand :)

Sooo.. habe soeben Suse online-Update ausgeführt.
Neben einigen anderen (Kernel!) wurde auch ein PHP4-Core - Patch eingespielt.
Laut Hinweis sollten dadurch die Apache2/PHP4 Error beseitigt sein.
So auch das mail() Prob.
Nach dem Update finde ich mich erstmal an der Console wieder.. der vorher installierte Nvidia-treiber will nicht mit dem runtergeladenen Kernel..grrr :evil:..Yast starten, da sax2 auch nicht einfach so will.., standard nv - Treiber wählen - O.K.
Rechner komplett runtergefahren, neustart. Alles OK.

Mit meinem w2000 PC den Indianer kontaktiert, die Webseiten, an denen ich gerade schraube, geladen. Auch OK.
ABER IMMERNOCH :
Fatal error: Call to undefined function: mail() in /srv/www/htdocs/include/mail_inc.php on line 32
:evil: AAARRGH..

So ist die Codezeile in meinem php-script:
--------------------snip---------------------------
/* Verschicken der Mail */
mail($toaddr, $subject, $message, $headers);
-------------snap----------------------------------

Die Einträge in der php.ini:
--------------snip------------------
[mail function]
; For Win32 only.
;SMTP = 192.168.41.101

; For Win32 only.
;sendmail_from = webmaster@susi.xxxnet.de

sendmail_path = /usr/sbin/sendmail -t -i
---------------snap----------------

Und auf dem w2000er mit xampp läuft´s wunderbar.. :roll:
Benutzeravatar
AlBundy
Member
Member
Beiträge: 64
Registriert: 28. Apr 2004, 11:49
Wohnort: Leipzig
Kontaktdaten:

Ähnliches Schicksal

Beitrag von AlBundy »

Mich würde die Lösung dieses Problems auch interessieren ....

Al
Gast

Suse 9.1 PHP mail() funzt wieder !!

Beitrag von Gast »

:o 8) !!

Na das ist aber suuper.. die Mailfunktion mail() tut es ab heute wieder!
Hab gerade das neueste Update von den Suses installiert.
War wieder´n Kernel + ein neuer PHP-Patch. :o

Das war jetzt aber prompte Fehlerbehebung.
Muss die Suses doch mal loben *hiermitlob* :twisted:

Und das Nvidia-Prob soll auch gelöst sein, gleich mal den Treiber installieren..
Benutzeravatar
AlBundy
Member
Member
Beiträge: 64
Registriert: 28. Apr 2004, 11:49
Wohnort: Leipzig
Kontaktdaten:

Et läuft

Beitrag von AlBundy »

Endlich - ein halber Tag Rumfriemeln war umsonst. Aber wenigstens funktioniert mail() nun wieder.

Al
froya
Newbie
Newbie
Beiträge: 1
Registriert: 1. Jul 2004, 14:19

Re: Suse 9.1 PHP mail() funzt wieder !!

Beitrag von froya »

kann deiner meinung leider nicht mitteilen. habe gepatcht. tut es immer noch nicht. support kannst du vergessen eben so viele patchs. glaube, die 9.1 version wurde nicht von suse sonder von micr..osof... produziert.
soviele fehler..... mein gott...
also. fazit: finger weg von SUSE, finger weg von 9.1 :evil:
Antworten