Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Installation von CDROM

Moderator: Moderatoren

Antworten
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

Installation von CDROM

Beitrag von multilingus »

Hallo Leute!
Habe mir das Gnu/Linux Powerpack geleistet nachdem die Installation von den ISO images nicht über die base files hinaus ging.
Aber auch mit den dem Buch beigefügten CDs komm ich nicht weiter!
Ich hänge Swap- und Rootpartition ein und formattiere sie, installiere Kernel und Driver - und kann dann nicht weiter, weil tasksel und dann apt keine CD findet... obwohl die das Installationsprogramm gerade noch benutzt hat. Er gragt mich immer wieder nach /dev/cdrom und das keine gültige CD vorhanden ist!

Versteh ich nicht. /dev/cdrom ist das device für die CDROM, gemountet auf /cdrom. und /dev/cdrom ist ein Link auf /dev/hdc!

Wer kann mir die Augen öffnen??

Gruß
multilingus
Opera forever!
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Beitrag von wenf »

hast du bei denen kernel modulen vielleicht ide-scsi geladen ?
dann gibt es nun kein /dev/hdc mehr sonder /dev/sr0
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

SCSI-CDROM

Beitrag von multilingus »

Hi Wenf,
cdrom ist gelinkt mit sr1 (bei dem Buch sind 2 DVDs, Laufwerk ist CD/DVD). Andere Geräte die zur cdrom-Gruppe gehören, sind ganz verschiedenen Treibern (major device no.) zugeordnet, wobei sr0 und sr1 zum gleichen Treiber gehören. hdc gehört, wie Du schon vermuteste zu einem anderen Treiber.
Wie dem auch sei, ich habe die ganzen anderen devices der cdrom-Gruppe (20+) noch nicht ausprobiert.
Hast Du nicht noch eine andere Idee welche Bezeichnung es sein könnte?
Es ist ziemlich aufwendig, die alle zu testen!

Gruß
multilingus :(
Opera forever!
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Beitrag von wenf »

versuche doch mal im pfad
/dev/cdrom wegzunehmen
/dev/sr0
/dev/sr1
auszuprobieren

verstehe jetzt nicht ganz, was dein Lauferk ist
hdc ? oder sr1
was ist dann sr0
(beginnt immer mit 0)
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

Aktuell sr1

Beitrag von multilingus »

Hi wenf,

Habe immer angenommen, daß /dev/cdrom mit /dev/hdc gelinkt ist.
Nach deinem Hinweis hab ich nochmal nachgeschaut und festgestellt, daß /dev/cdrom mit /dev/sr1 gelinkt ist.
Das Laufwerk ist ein kombiniertes CD-R/W und DVD-R. Ich vermute, als CD-RW ist es sr0 und als DVD sr1 (?), was möglicherweise beim Hochfahren des Installationssystems mit der DVD erkannt wurde.

/dev/cdrom aus dem Pfad nehmen, meinst du damit im /dev-Verzeichnis löschen?
Mit ls -l | grep cdrom findest Du, daß die Gruppe namens "cdrom" etliche Einträge von /dev umfaßt.

Die Frage für mich ist, welches device Apt akzeptieren würde.

Seit Monaten werden Notebooks mit Centrino-Technologie und ähnlicher Ausstattung wie mein Samsung X05 1,4GHz an allen Ecken verkauft. Es mußdoch auch schon mal jemand Debian darauf installiert haben...

Gruß

multilingus
Opera forever!
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Re: Aktuell sr1

Beitrag von wenf »

/dev/cdrom aus dem Pfad nehmen, meinst du damit im /dev-Verzeichnis löschen?

nein

bei der Debian installation kannst du angeben, wo cdrom ist

da kannst du das eingeben


Seit Monaten werden Notebooks mit Centrino-Technologie und ähnlicher Ausstattung wie mein Samsung X05 1,4GHz an allen Ecken verkauft.....

http://www.linux-on-laptops.com/samsung.html
schau da mal vorbei -
vielleicht kannst du dir ja etwas davon abschauen
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

CDROM

Beitrag von multilingus »

Wenf,
das ist genau die Stelle, wo das Installationsprogramm auf stur schaltet.
Ob ich da /dev/cdrom wie vorgeschlagen oder /dev/sr0 oder /dev/sr1 eingebe und mit TAB auf OK gehe oder gleich RETURN drücke, ich komm auf jeden Fall in eine Endlosschleife aus der ich nur mit CANCEL-RETURN herauskomme! Es wird noch nicht einmal getestet, was im Laufwerk ist.

Rein theoretisch könnte der Vorschlagstring den Fehler haben, mit /def/ zu beginnen. Hab noch nicht ausprobiert, nur die Devicenamen einzugeben!

Gruß

multilingus
Opera forever!
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Beitrag von wenf »

ok - wenn debian stur is, dann brich doch einfach ab


versuche eine CD zu mounten - obs geht
dann editiere dir /etc/apt-get/source-list oder so

dann apt-cache update
oder apt-cdrom starten und das für dich machen lassen

und dann dselect oder mit apt-get install paketname software installieren
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

By hand...

Beitrag von multilingus »

Hi,
nach vielem Probieren ist es mir jetzt endlich gelungen, die Installation von CD, so wie es eigentlich sein sollte, anzuwerfen.

Habe mir den Kernel "compact" gewählt und irgendwann von automatischer auf manuelle Installation umgeschaltet - und siehe da, er kennt die cdrom!
Nach nochmaligem Check daß das nicht nur ein Traum ist, hab ich eine Sources.List erstellen lassen. Das Installationsprogramm hat alle CDs und DVDs gescant, und alles aufgeschrieben.

Nächster Schritt Installation der Packages... das Laufwerk hat garnicht mehr stillgestanden. Die Binaries hat er glaube ich, nicht gefunden, weil er immer wieder nach den Directories gefragt und mit error 1 abgeschlossen hat.
Weiß nicht, wo ich nachschauen kann, was er jetzt tatsächlich geladen hat.

Komme nach wie vor nicht ins Netz, sonst wäre im Nu alles noch Ausstehende gesaugt und abgeschlossen!

Gruß

multilingus
Opera forever!
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Beitrag von wenf »

apt-cache search <packagename>
apt-cache showpkg <packagename>

meinst du das ?
Benutzeravatar
multilingus
Newbie
Newbie
Beiträge: 36
Registriert: 7. Apr 2004, 21:50
Wohnort: Bremen

3 CDs - 3 Std. laden!

Beitrag von multilingus »

Hallo Wenf!

Habe heute wieder mit der NetzinstallationsISO einen neuen Versuch gestartet.
Dieses Mal konnte ich mit /dev/sr0 meine CDs benutzen (zum 1. Mal!).
Nachdem das Scannen der CDs abgeschlossen war, konnte ich nach 4 oder 5 Fehlversuchen das Installationsprogramm dazu bringen schließlich doch anzufangen, binaries + etc. zu laden.

Dann rauschten die ganzen Namen schneller als ich mitlesen konnte über den Schirm mit ein Paar Unterbrechungen für Konfigurations-Entscheidungen. Das ging dann knappe 2 1/2 Std.so.

freeX86 war auch dabei, konnte aber nicht gestartet werden, weil Display 0,0 nicht da sei?!??

Das werd ich auch noch herausbekommen - aber nicht mehr heute abend!

Den Atherostreiber für die WLAN-Karte konnte ich nicht kompilieren.

ifconfig zeigt ein gre0 an, ein schüchternes Ping an meinen Router über Kabel hat nicht geklappt...

Viele Grüße
multilingus
Opera forever!
Antworten