Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Abspielen einer CD unter Suse 9.1 nicht möglich

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Polo
Newbie
Newbie
Beiträge: 8
Registriert: 4. Mai 2004, 16:09
Wohnort: Deggendorf

[solved] Abspielen einer CD unter Suse 9.1 nicht möglich

Beitrag von Polo »

Hallo,

Seit Tagen versuche ich eine CD abzuspielen, es klappt nicht. Nicht mit XMMS oder KsCD. Es kommt immer die Meldung Verzeichnis nicht lesbar oder Keine CD oder kein Medium gefunden. Benutze Suse 9.1 für AMD 64 mit KDE 3.2. Irgendwelche Patche kann ich auch nicht laden, da ich keinen Internetzugang unter LInux hinkriege, aber das ist eine andere Baustelle. Rechner ist ein FS Scaleo AMD64 mit 1GB und zwei DVD -laufwerken einer als Brenner. Der Soundchip wird als ViaVT8237 richtig erkannt, auch WAV-Dateien werden korrekt abgespielt.

Unter 9.0 und meinem Uraltrechner Pentium 1 mit 150SX hat es auf Anhieb funktioniert.

Vielen dank

KP
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

seit 9.1 gibt es einen supermounter (wie bei mdk schon lange...)
dh du legst eine cd ein wartest kurz und es erscheint ein popup "Audio CD gefunden...soll diese mit KsCD abgespielt werden?"

drückt man "ja" wird die tatsächlich mit KsCD abgespielt...hehe

funktioniert bei dir der supermounter nicht? kommt kein popup? auch bei daten-disks nicht?
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
Polo
Newbie
Newbie
Beiträge: 8
Registriert: 4. Mai 2004, 16:09
Wohnort: Deggendorf

Beitrag von Polo »

Hallo Gimpel,

vielen Dank für die Antwort. Es funktioniert jetzt teilweise, aber ohne Ton.

Im DVD-brennerlaufwerk wird die CD erkannt und auch abgespielt, aber es kommt kein Ton aus dem Lautsprecher. Das normale DVD/CD- laufwerk erkennt die selbe CD nicht und auch XMMS nicht alle DatenCD´s oder DVD´S werden erkannt.

Hardwareseitig sind die DVD-Laufwerke nur über das Flachkabel mit dem IDE Anschluß verbunden es gibt keinen extra Audioanschluß.

KP
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

hehe...böse böse falle! mein 9.0 hab ich deswegen in der mitte zerlegt und neu zusammen gebaut bis ich rausgefunden habe dass:

- bei KsCD mal auf das lautstärke symbol klicken und auf 95% oder so (steht defaultmäßig auf 50)
- Kmix (den blauen regler in der taskleiste) --->rechtsklick--->mixerfenster anzeigen--->ext. source playback: regler bei "CD" auf 95% oder so (50 defaultmäßig)
(bei den default-einstellungen kam kein ton trotz verstärker auf 12 uhr)
:wink:
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
Polo
Newbie
Newbie
Beiträge: 8
Registriert: 4. Mai 2004, 16:09
Wohnort: Deggendorf

Beitrag von Polo »

Hallo Gimpel ,
vielen Dank für die Tips. Habe alles so eingestellt. Habe auch unter XMMS digitalen Zugriff aktiviert und bei den DVD-Laufwerken den DMA eingestellt----Nix bleibt alles absolut stumm.
Aber wo viel Schatten, brennt auch ein Licht. WAV - Dateien werden abgespielt. Sonst nichts.

Gruß
KP :(
towo
Moderator
Moderator
Beiträge: 3730
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo »

Polo hat geschrieben:Hallo Gimpel ,
vielen Dank für die Tips. Habe alles so eingestellt. Habe auch unter XMMS digitalen Zugriff aktiviert und bei den DVD-Laufwerken den DMA eingestellt----Nix bleibt alles absolut stumm.
Aber wo viel Schatten, brennt auch ein Licht. WAV - Dateien werden abgespielt. Sonst nichts.

Gruß
KP :(
Auf den Gedanken, mal ein Audiokabel vom Laufwerk zur Soundkarte anzuschließen bist Du wohl nicht gekommen?
Signatur nach Diktat spazieren gegangen

Bild
Polo
Newbie
Newbie
Beiträge: 8
Registriert: 4. Mai 2004, 16:09
Wohnort: Deggendorf

Beitrag von Polo »

Hallo towo
Doch auf diese Idee bin ich auch schon gekommen, nur ist der rechner fertig gekauft worden und eine Audiokabel war ncht dabei. Außerdem funktioniert es unter XP auch ohne extra Kabel und so bin ich naiver Weise davon aufgegangen, dass es dann unter Linux auch so geht. War vielleicht zuviel von 9.1 verlangt. Mittlerweile habe ich die Kiste auch aufgemacht und reingeschaut. Ein Audiokabel ist nicht angeschlossen.
Das andere Problem ist aber auch, dass die CD im DVD-laufwerk überhapt nicht erkannt wird. Es heißt nur keine CD, wenn sie abgespielt würde, wäre ich auch schon einen Schritt weiter. Audiokabel werde ich aber trotzdem besorgen.

Danke KP
Fish
Newbie
Newbie
Beiträge: 44
Registriert: 7. Feb 2004, 11:01

Beitrag von Fish »

Das selbe habe ich seit dem Kernel Sicherheits online Update, kurz YOU.
Vorher konnte ich Audio CD´s hören, jetzt geht nix mehr.
Hab auch neu aufgesetzt, vorm Update gings, nach her nicht mehr.

Da es ein Sicherheitsupdate ist wollte ich nicht darauf verzichten...

Vorher habe ich noch bemerkt dass ich keine DVD´s mehr brennen kann (ging vorher auch problemlos). Obs mit normalen CD´s auch nicht hinhaut weiss ich noch nicht.

P.S: Ich kann allerdings die Audio CD´s mit dem CD-Creator rippen, aber "on the fly" anhören oder im Konqueror oder sonst wo öffnen geht nicht..
Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai »

Ähhh 2 Laufwerke. Geht das denn unter Windows?

Audiodaten von AudioCDs werden direkt aus dem CD Laufwerk auf die Soundkarte / bzw Motherboard geschleift. Du bekommst da nur aus beiden Laufwerken Ton, wenn Die Karte / Mainboard 2 Audioeingänge hat und auch beide Kabel verbunden sind.

CD LW hat 3 Kabel:
Strom gross vierpolig
IDE dünn flach 40 oder 80 polig
Sound dünn 3-4 polig

Auf Sound kann man verzichten, wenn über dieses LW keine AudioCDs laufen sollen.
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)
Polo
Newbie
Newbie
Beiträge: 8
Registriert: 4. Mai 2004, 16:09
Wohnort: Deggendorf

Beitrag von Polo »

Hallo,

mittlerweile habe ich ein Audiokabel besorgt und angeschlossen. Auch mein zweites DVDrecorderLW erkennt die CD und spielt sie auch ab, aber es kommt nichts aus dem Lautsprecher heraus. Das andere LW weigert sich allerdings nach wie vor CD zu erkennen, geschweige denn abzuspielen.

Mit dem paralell instalierten Win XP funktionieren beide LW und CD´s werden auch korrekt abgespielt und man hört auch was.

Jetzt fällt mir nichts mehr ein, auch Suse konnte mir nicht helfen. :idea:

Vielleicht hat noch jemand eine Idee.

KP
GraveDigger
Member
Member
Beiträge: 61
Registriert: 20. Feb 2004, 20:13
Wohnort: unter der Erde

Beitrag von GraveDigger »

Nur ne kurze Info: Unter Winblech wird beim Mediaplayer die Audiodaten digital eingelesen und über den Systembus und die CPU geschleust, damit wird der Weg über das Audiokabel schlichtweg umgangen, was dazu führt, das du so ziemlich JEDE Audio-CD ohne extra Kabel spielen kannst. Was das AudioCD playback unter linux angeht, so ist das standartmäßig deaktiviert, um die CPU zu schonen... ALSO: WENN ES DENN NICHT GEHT...
ERSTMAL: Check erstmal, ob du das kabel RICHTIG installiert hast, also OB ES das RICHTIGE Laufwerk mit dem RICHTIGEN eingang der Soundkarte verbindet.
2. Schau nach, ob bei deiner Soundkarte überhaupt die Schnittstelle aktiviert und luatgeregelt ist. Starte mal kamix und bei ext. Source Playback stelle die Lautstärke der eingänge hoch, die Lautstärke bei kscd (oder was auch immer) muß natürlich auch entsprechend geregelt sein.
3. Schaue bei den einstellungen von kscd nach, auf welches Gerät verwiesen wird. Standartmäßig is das nämlich /dev/cdrom, wenn du aber 2 dvd-lws hast, kann es sein, daß /dev/cdrom nicht existiert... laß also diesen Eintrag auf das richtige Gerät verweist.
4. WENN ES DANN IMMERNOCH NICHT KLAPPT: dann mach dich mal schlau, ob es für deine Soundkarte überhaupt entsprechende Treiber gibt, die das unterstützen (was eigentlich immer der fall sein sollte), oder ob die module dafür irgendwie besonders konfiguriert werden müssen oder so... das is zwar ÄUSSERST unwahrscheinlich, aber nicht unmöglich....


Kommentare wie "Windows kanns, Linux nicht" und "Ich hab halt zuviel Erwartungen gestellt" kannst du dir getrost sonst wo hin stecken, denn in den meisten Fällen sagen sie nur "Ich bin zu dumm es richtig zu machen". Sicherlich gibt es Hardware, die von Linux nicht oder nur teilweise unterstützt wird, aber bitte, das Thema betrifft NICHT Audio-CD wiedergabe!!!!


Und noch n Tipp, für die Zukunft allgemein: Rumheulen kann jeder, aber lesen und denken anscheinend nicht... MIT EIN BISSCHEN AHNUNG von Computern, die man nicht gleich hat, weil man ein extremer Gamer oder sowas ist, lassen sich SEHR VIELE Probleme auch so lösen...
Antworten