Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Kein Sound mehr unter Suse 9.1 Pro

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

[solved] Kein Sound mehr unter Suse 9.1 Pro

Beitrag von wild_man »

Hi !

Ich habe von 9.0 Pro auf 9.1 Pro geupdatet (komplette Neuinstallation) und seitdem funktioniert mein Sound nicht mehr (KDE 3.2.1/Kernel 2.6.4-52-default). Meine Soundkarte ist eine Terratec 512i Digital und wird richtig erkannt als Fortemedia Xwave QS3000A [FM801]. Die Hardware ist auch aktiviert, aber gibt keinen Ton von sich. Unter 9.0 lief das alles tadellos. Hab schon im Forum herumgelesen, aber nichts über dieses Problem gefunden.Shit. Hat jemand einen TIIIP ?

ciao
wild_man :(
________________________________
The sweetest place on earth is 127.0.0.1
mbingo

Beitrag von mbingo »

Hallo schau mal unter kein Sound nach.
Ziehe alle USB Geräte raus.
Die haben auf gut Deutsch Scheiße programmiert.
Die Soundkarte wird dann von einem USB Gerät gestört.
Haben alle die selben Probleme

Gruß

Marc
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Beitrag von wild_man »

mbingo hat geschrieben:Hallo schau mal unter kein Sound nach.
Ziehe alle USB Geräte raus.
Die haben auf gut Deutsch Scheiße programmiert.
Die Soundkarte wird dann von einem USB Gerät gestört.
Haben alle die selben Probleme

Gruß

Marc
Hi Marc,

die Sache ist die: ich habe überhaupt KEINE USB Geräte in Benutzung und auch keine angeschlossen. Ebenfalls ist die USB Unterstützung im BIOS ausgeschaltet. Deswegen scheint das hier vielleicht ein anderes Problem zu sein ? Haste'n anderen Tip/Idee ?

Hat schon jemand mal beim Suse Support direkt nachgefragt ? Falls nicht, werde ich das mal machen. Ich hab die FAQs dort mal durchforstet, aber keinen Hinweis zur Behebung dieses Problems gefunden. Hiiiiiiiilfe !
________________________________
The sweetest place on earth is 127.0.0.1
Tommyboy
Newbie
Newbie
Beiträge: 36
Registriert: 14. Apr 2004, 11:00
Wohnort: Stuttgart

Hallo zusammen ich habe ein ähnliches Problem

Beitrag von Tommyboy »

Hallo zusammen,

Ich habe ein etwas älteres MSI-Motherboard mit integrierter Soundkarte.
Was ich nicht ganz verstehe, ist das meine Soundkarte richtig erkannt wurde und die Signaltöne spielt, aber wenn ich Cd´s oder Mp3´s anhören möchte kommt kein einziger Ton raus? Habe Auch Linux 9.1 Nur habe ich USB-Geräte an meinem Rechner hängen. Soll ich nochmals Neu installiernen ohne USB?

Gruß Tom
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: Kein Sound mehr unter Suse 9.1 Pro

Beitrag von wild_man »

wild_man hat geschrieben:Hi !

Ich habe von 9.0 Pro auf 9.1 Pro geupdatet (komplette Neuinstallation) und seitdem funktioniert mein Sound nicht mehr (KDE 3.2.1/Kernel 2.6.4-52-default). Meine Soundkarte ist eine Terratec 512i Digital und wird richtig erkannt als Fortemedia Xwave QS3000A [FM801]. Die Hardware ist auch aktiviert, aber gibt keinen Ton von sich. Unter 9.0 lief das alles tadellos. Hab schon im Forum herumgelesen, aber nichts über dieses Problem gefunden.Shit. Hat jemand einen TIIIP ?

ciao
wild_man :(
Haaalllo Gemeinde !

Hat niemand einen Tip zur Lösung ?

Gruss
________________________________
The sweetest place on earth is 127.0.0.1
copricorn

Re: Hallo zusammen ich habe ein ähnliches Problem

Beitrag von copricorn »

Tommyboy hat geschrieben:Hallo zusammen,

Ich habe ein etwas älteres MSI-Motherboard mit integrierter Soundkarte.
Was ich nicht ganz verstehe, ist das meine Soundkarte richtig erkannt wurde und die Signaltöne spielt, aber wenn ich Cd´s oder Mp3´s anhören möchte kommt kein einziger Ton raus? Habe Auch Linux 9.1 Nur habe ich USB-Geräte an meinem Rechner hängen. Soll ich nochmals Neu installiernen ohne USB?

Gruß Tom
Starte mal als root yast2, im Soundmodul nimmst du dann das Häckchen bei "Sequenzer starten" weg. Dann muesste es gehen.
dirk-1974
Newbie
Newbie
Beiträge: 2
Registriert: 7. Mai 2004, 15:14

Kein Sound mehr unter Suse 9.1 Pro

Beitrag von dirk-1974 »

Hallo zusammen,

das Problem auf USB zu schieben, scheint mir zu einfach.
Auf meinen PC habe ich alle was mit USB zu tun hat, entfernt.
Trotzdem kommt kein Sound zustande.
Auf meinen Laptop funktioniert der Sound einwandfrei (Konsole + KDE)
und das mit USB (die gleichen Geräte wie beim PC).

Dirk :shock:
dirk-1974
Newbie
Newbie
Beiträge: 2
Registriert: 7. Mai 2004, 15:14

Kein Sound mehr unter Suse 9.1 Pro

Beitrag von dirk-1974 »

Hallo,

kurz noch eine Anmerkung:

Wenn ich die Module meiner Soundkarte entlade und anschliessend wieder lade,
funktioniert der Sound (mit USB-Geräte) auf der Konsole und KDE.

Soundkarte: C-Media; CMI8738/C3DX
Modul: snd_cmipci

Versuch mal euer Glück.

Dirk :lol:
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: Kein Sound mehr unter Suse 9.1 Pro

Beitrag von wild_man »

wild_man hat geschrieben:Hi !

Ich habe von 9.0 Pro auf 9.1 Pro geupdatet (komplette Neuinstallation) und seitdem funktioniert mein Sound nicht mehr (KDE 3.2.1/Kernel 2.6.4-52-default). Meine Soundkarte ist eine Terratec 512i Digital und wird richtig erkannt als Fortemedia Xwave QS3000A [FM801]. Die Hardware ist auch aktiviert, aber gibt keinen Ton von sich. Unter 9.0 lief das alles tadellos. Hab schon im Forum herumgelesen, aber nichts über dieses Problem gefunden.Shit. Hat jemand einen TIIIP ?

ciao
wild_man :(
Hi,

also ich glaube auch nicht, dass das Soundproblem etwas mit USB zu tun hat. Wie gesagt, ich habe keine USB Geräte angeschlossen und es "tönt" trotzdem nichts. Habe auch immer noch keinen brauchbaren Tip in Erfahrung bringen können. Bin ich der Einzige hier, bei dem der Sound unter 9.1 nicht funktioniert ? Heuuul .... und immer noch : HIIIILFE !

Greetz
________________________________
The sweetest place on earth is 127.0.0.1
libBushNetmask.so

soundkarte

Beitrag von libBushNetmask.so »

hi

puhhh...und ich dachte ich hätt was vermurgst :(

hab die selben prob's wie ihr unter 9.1mit der soundkarte <kann ebenfalls<keine tönchen entlocken :( hab zum-andern 2 soundkarten auf dem rechner //eine direct auf dem board / und ne extra soundkarte funzen beide nich mehr egal was ich mach !(Alsa soundserver /automatisch erkennen / sequenzer aus -an / etc...)
am anfang nach dem update von 9.0 auf 9.1 funzten beide .....mußte allerdings nach jedem neustart des sytems die karte mit yast neu konfig..:( nach diversen online updates ...kernel etc.....funzt jetzt was soundkarte betrifft ......NIX....mehr!!!!!

naja kann man nur hoffen imo das SuSe nen patch /bugfix bald bereit stellt !!

gruß
fliwa
Newbie
Newbie
Beiträge: 4
Registriert: 3. Mai 2004, 11:23

No Sound

Beitrag von fliwa »

Grüß Euch alle..

Hat denn jemand eine Lösung gefunden für das Sound problem?
Ich hab bisher meinem Sound on Board keinen Muckser entlocken können.
Ich dachte schon es läge an meinem Motherboard (ASrock P4VT8+ )
Soundgerät ist: VIA VT8233/A/8235 AC97 Audio Controller.

Ich weiß mir auch keinen Rat mehr.
Wen ich unter Lautstärke den MAster auf über 73% stelle, kommt ein Pfeifton, der sich in der Frequenz ändert, je höher ich den Master Regler schiebe.

Also falls jemand eine Lösung weiß, ich wäre einer der Dankbaren.
:-) grüße fLiWa

EDIT: Also ich hab Ton jetzt.
Ich habe, vertrottelt wie ich bin, im AlsamixerGUI rumgespielt, leider weiß ich nicht mehr was ich verstellt habe. <---trottel eben

Jetzt geht der Sound, ich werd versuchen das nachzuvollziehen und mach dann hier Meldung.
Sofern ichs reproduzieren kann.

greetz fLiWa
life live - live life
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: No Sound

Beitrag von wild_man »

fliwa hat geschrieben:Grüß Euch alle..

EDIT: Also ich hab Ton jetzt.
Ich habe, vertrottelt wie ich bin, im AlsamixerGUI rumgespielt, leider weiß ich nicht mehr was ich verstellt habe. <---trottel eben

Jetzt geht der Sound, ich werd versuchen das nachzuvollziehen und mach dann hier Meldung.
Sofern ichs reproduzieren kann.

greetz fLiWa
Hi !

Versuch mal, das zu reproduzieren. Wäre wichtig.
Ich hab zwar auch schon im AlsamixerGUI mit ein paar Einstellungen rumgespielt, hat aber nix gebracht. Mein Sound bleibt tot. :(
________________________________
The sweetest place on earth is 127.0.0.1
fliwa
Newbie
Newbie
Beiträge: 4
Registriert: 3. Mai 2004, 11:23

suse 9.1 AlsamixerGUI meine Einstelungen

Beitrag von fliwa »

Meine Einstellung im Alsa Mixer GUI
Master - 80%
Master Mono - aus
PCM - aus <---??kapier ich auch nich so wirklich
surround Center und LFE - 100%
Line - voll ( darüber die beiden punkte sind weiß bei mir - einfach anklicken)
Line in As Surro - aus
CD - 100% (die beiden Punkte sind rot)
Mic, Mic Boost und Mic select - aus
Video - 80% (die beiden Punkte drüber sind weiß)
Phone - aus
IE958- IE958 Capture Monitor - Capture valid und Output - aus
IE958 Playback AC97 - 80%
IE958 - Playback source - aus
PC Speaker - 80%
Sonst ist alles aus bis auf
VIA DXS - 80%

Das sind die Werte die ich habe, wobei mir immer noch nicht klar ist was das Lautsprecher Symbol aussagt das entweder grün unterlegt oder weiß ist?!
Bei allen sind die Lautsprechersymbole grün unterlegt die ich auch aktiviert habe.
Bei CD sind die Punkte unter den Lautsprecher symbolen ROT

Ach ja, in der Taskleiste hab ich das Lautsprechersymbol von KaMix.
KaMix Einstellung:
Reiter - Playback - beide 80%
Reiter - Ext. Source Playback - Line und Cd auf 80%
Mic - aus
Reiter - Capture - aus Capture source - beide auf Cd

Wie gesagt, so wirklich weiß ich auch nicht was da bgeht.

USB Webcam einfach mal komplett abstecken, falls vorhanden.

Ich weiß das liest sich voll DAU mäßig, aber hier sitzt ein Linux Anfänger, jedenfalls einer der bisher null Probs mit Sound hatte.

Greez fLiWa

Edit: Mir fällt noch ein, ich habe nach dem Rumspielen in der AlsamixerGUI einen System reboot gemacht. Daraufhin ging der Sound.

Übrigends scheint man hier in diesem Thread die selben Probleme zu haben:
http://www.linux-club.de/viewtopic.php?t=6231
life live - live life
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: suse 9.1 AlsamixerGUI meine Einstelungen

Beitrag von wild_man »

fliwa hat geschrieben:Meine Einstellung im Alsa Mixer GUI
Master - 80%
Master Mono - aus ..............
Hi Fliwa !

Danke für deine Mühe ! Egal ob sich deine Beschreibung ein wenig "DAUig" anhört ... beim Lösen von Problems fängt man immer ziemlich unten an :) Ich habe auf deine Beschreibung hin auch mal ein wenig an diesem Alsa Mixer herumgespielt (vorher auf ALSA 1.0.4 geupdatet -> http://packman.links2linux.de/?action=217) ... und siehe da: es funktioniert ! Cool !
Bin auch (noch) kein Vollfreak, wenns um diese ganze bunte KDE Story geht, aber es ist schon ärgerlich, dass die "Standardeinstellungen" bei der Installation von SuSE 9.1 Pro in Sachen Sound wohl voll daneben sind. Ich hab dieses Soundproblem auch schon beim Suse Service gepostet, aber noch keine Antwort drauf erhalten. Wenn ich was höre werd ich's hier veröffentlichen. Na ja .... man lernt nie aus .... thx nochmal
________________________________
The sweetest place on earth is 127.0.0.1
fliwa
Newbie
Newbie
Beiträge: 4
Registriert: 3. Mai 2004, 11:23

Beitrag von fliwa »

Das freut mich aber jetzt wirklich.
Klasse das es nu funzzt.

Grüße fLiWa :-)
life live - live life
Gast

Beitrag von Gast »

Hallo,
ich hänge mich einfach mal hier rein, denn ich habe auch Probleme mit dem Sound unter SuSE 9.1 und Kernel 2.6.4-54.5.

Mein Problem ist, das sich der Pinguin beim Runterfahren aufhängt, wenn er versucht alsasound zu beenden.

Ich habe zwei zwei Soundkarten installiert.
Die erste ist Onboard - MSI 6378 Ver.1; VIA 686B - die zweite ist eine PCI.

In der /etc/modprobe.d/sound steht folgndes:

options snd-ens1370 enable=1 index=0 joystick=0
options snd-via82xx ac97_clock=48000 ac97_quirk=-1
enable=1 index=1 joystick=0
# RE4e.xqKuJL067p4:ES1370 [AudioPCI]
alias snd-card-0 snd-ens1370
# hlTL.7pz2GijuJ12:VT82C686 AC97 Audio Controller
alias snd-card-1 snd-via82xx

Wenn ich alsasound starte, funktionieren auch Beide.

Ich habe die Module auch schon von Hand - via modprobe - geladen.
Doch sobald ich den VIA entlade, friert der Pinguin gar mächtig ...

Sind die Module in dem Kernel-Packet enthalten oder in dem Alsa-Packet.
Könnte also ein Alsa-Update die Eiszeit für den Pinguin beenden?

Danke und Gruß
Froelix
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: suse 9.1 AlsamixerGUI meine Einstelungen

Beitrag von wild_man »

fliwa hat geschrieben:Meine Einstellung im Alsa Mixer GUI
Master - 80%
Master Mono - aus
PCM - aus <---??kapier ich auch nich so wirklich
surround Center und LFE - 100%
Line - voll ( darüber die beiden punkte sind weiß bei mir - einfach anklicken)
............
Nochmal kurz zum Abschluss:
Ich habe mein Soundproblem jetzt lokalisiert. Nach durchtesten verschiedener Einstellungen im "Alsa Mixer GUI" hab ich festgestellt dass mein Sound funktioniert, sobald ich die Einstellung für "IEC 958 RAW Data" abschalte (klick auf die grünen Lautsprechersymbole über dieser Option). Ist diese Option aktiviert bleibt der Sound bei mir stumm.
Muss nur noch rausfinden, wie diese Einstellung beim Systemstart immer automatisch übernommen wird, da sie beim Start immer wieder auf diesen "Default" Wert zurückgesetzt wird. Weiss das jemand ?

ciao
wild_man
________________________________
The sweetest place on earth is 127.0.0.1
Fish
Newbie
Newbie
Beiträge: 44
Registriert: 7. Feb 2004, 11:01

Beitrag von Fish »

Schau mal ob du die selbe Einstellung im Kontrollzentrum machen kannst, dann übernimmts die bei Neustart.

Ansonsten mal unter den Optionen vom Mixer nachsehen...
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Beitrag von wild_man »

Fish hat geschrieben:Schau mal ob du die selbe Einstellung im Kontrollzentrum machen kannst, dann übernimmts die bei Neustart.

Ansonsten mal unter den Optionen vom Mixer nachsehen...
Hi Fish,

danke für den Tip, aber im Kontrollzentrum und im Mixer gibts leider keine Möglichkeit/Option dieses "IEC 958 RAW Data" abzuschalten. Haste noch'n Tip ?
________________________________
The sweetest place on earth is 127.0.0.1
Benutzeravatar
wild_man
Newbie
Newbie
Beiträge: 27
Registriert: 24. Apr 2004, 23:41
Wohnort: Raum Heidelberg
Kontaktdaten:

Re: suse 9.1 AlsamixerGUI meine Einstelungen

Beitrag von wild_man »

wild_man hat geschrieben: Nochmal kurz zum Abschluss:
Ich habe mein Soundproblem jetzt lokalisiert. Nach durchtesten verschiedener Einstellungen im "Alsa Mixer GUI" hab ich festgestellt dass mein Sound funktioniert, sobald ich die Einstellung für "IEC 958 RAW Data" abschalte (klick auf die grünen Lautsprechersymbole über dieser Option). Ist diese Option aktiviert bleibt der Sound bei mir stumm.
Muss nur noch rausfinden, wie diese Einstellung beim Systemstart immer automatisch übernommen wird, da sie beim Start immer wieder auf diesen "Default" Wert zurückgesetzt wird. Weiss das jemand ?

ciao
wild_man
Hi Leute,

ich hab selber rausgefunden, wie man Werte des ALSA Mixers manuell und dauerhaft ändern kann:

Die Datei "etc/asound.state" enthält die Werte aller Regler des ALSA Mixers. Hier kann man alle per Hand standardmässig Ein- bzw Ausschalten, in dem man die Values verändert (true oder false). Diese Einstellungen werden beim Start immer übernommen.

Ich habe also den folgenden Eintrag geändert:
- name 'IEC958 Raw Data Playback Switch'
- value false (stand vorher auf true)
... und mein Soundproblem ist behoben.

Vielleichts hilfts ja noch Anderen.

Bis denne
wild_man
________________________________
The sweetest place on earth is 127.0.0.1
Antworten