Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Nochmal ganz von vorne.... :-(((

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
KUHnsmann
Newbie
Newbie
Beiträge: 20
Registriert: 28. Apr 2004, 14:30

Nochmal ganz von vorne.... :-(((

Beitrag von KUHnsmann »

Also ich habe das T-Sinus 111 und krieg das einfach nicht gebacken.. :(

Bin nach der Anleitung von da bomb und nach einer anderen aus dem forum gegangen (die komischerweise teilweise total verschieden waren..) und komm immer noch nich ins Netz geschweige in den Router!

was kann ihc machen? Router kann ich nicht anpingen und mein suseplugger meint immernoch das mein "WLAN network interface" unkonfiguriert ist... aber verfügbar :?

Kann mir jemand genau seine Installation von seinem T-Sinus mit Linux 9.0 mitteilen (kuhnsmann@web.de) oder hier posten??
Wäre sehr dankbar darüber...

P.S.: Bin zwar Noob aber den Kernel konnt ich schon installieren und den WLAN Treiber von www.linux-wlan.org konnte ich auch installieren! also bei make install war alles palletti!

MfG KUHnsmann
baseman_2004
Newbie
Newbie
Beiträge: 19
Registriert: 4. Mai 2004, 13:43
Wohnort: Tamm
Kontaktdaten:

Beitrag von baseman_2004 »

Auf ihrem System müssen die Kernelsources installiert sein. Wenn sie nicht drauf sind über Yast nachinstallieren!

Jetzt muss man erst mal die Kernelsources konfigurieren, dazu geht man in das Verzeichnis usr/src/linux dort gibt man dann make cloneconfig && make dep ein.

Das dauert jetzt ein bisschen. Nach diesem Vorgang, geht es jetzt zur Installation des Treibers. Falls sie ihn noch nicht haben, können sie ihn hier ( ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/ ) runterladen. Die aktuelle Version ist derzeit, linux-wlan-ng-0.2.1-pre19.tar.gz.

Jetzt kopieren wir erst einmal linux-wlan-ng-0.2.1-pre19.tar.gz in ein Verzeichnis das unter Linux zugänglich ist.

Jetzt wird die Konsole geöffnet und man wechselt in das Verzeichnis, wo sich linux-wlan-ng-0.2.1-pre19.tar.gz befindet.

Die Datei entpackt man dann mit tar zxvf linux-wlan-ng-0.2.1-pre19.tar.gz.

Jetzt wechselt man in das soeben erstelle Verzeichnis namens linux-wlan-ng-0.2.1-pre19 und führt dort den Befehl make config aus.

Nun werden einem ein paar Fragen gestellt, die Beantwortet man alle mit n außer die frage " - Build Prism2.5 USB (_usb) driver?", die muss mit y beantwortet werden.

Wenn man die Konfiguration geschafft hat, dann gibt man noch make all ein und anschließend make install

Jetzt wäre die Innstallations des Treibers geschafft, jetzt muss er noch Konfiguriert werden. Dazu wechselt man in das Verzeichnis /etc/wlan. Dort findet man eine Datei, die wlan.conf heißt. Dort gibt man noch seine eigene SSID ein und speichert das ganze ab. Die Datei wlancfg-DEFAULT muss in wlancfg-<eigene ssid> umbenannt werden. Also ein kleines Beispiel: Wenn meine SSID linux ist, dann muss die Datei wlancfg-DEFAULT in wlancfg-linux umbenannt werden.

Jetzt gibt man in der console chkconfig --add wlan und chkconfig wlan on ein.

Jetzt muss man mit einem Editor die Datei /etc/modules.conf öffnen und alias wlan0 prism2_usb einfügen, wo man es einfügt ist eigentlich egal.

Jetzt muss man noch eine Datei erstellen namens ifcfg-wlan0. Der Inhalt dieser Datei wäre:



DEVICE=wlan0

ONBOOT=yes

BOOTPROTO=static # wenn man einen DHCP-Server benutzt muss man static mit dhcp ersetzen und man kann die nachfolgende Zeile löschen.

IPADDR=192.168.0.11

GATEWAYDEV=wlan0

GATEWAY=192.168.0.1 # ip adresse des routers

TYPE=Ethernet

USERCTL=yes

NETMASK=255.255.255.0

NETWORK=192.168.0.0

BROADCAST=192.168.0.255

PEERDNS=no




Diese Datei muss nach /etc/sysconfig/network kopiert werden.

Jetzt öffnet man Yast und öffnet die Netwerkgeräte. Jetzt müsste ein Adapter namens wlan0 vorhanden sein, der muss jetzt auch noch konfiguriert werden. Also die SSID eintragen, falls vorhanden die Webverschlüsselung und den Standartgateway. Danach neustart und alles müsste gehen.

^ Anmerkung: Der Adapter war bei mir inYast nich drinne, geht aber trotzdem ;)
KUHnsmann
Newbie
Newbie
Beiträge: 20
Registriert: 28. Apr 2004, 14:30

Beitrag von KUHnsmann »

VIELEN DANK!!!

Es hat funktioniert! Doch nach etwa 2 Stunden im Internet surfen, ging wieder gar nichts.... :cry:
Konnte auch nach Neustart nich ins routermenü geschweige ins internet! kwifimanager zeigt auch kein Wireless-Gerät mehr an...

Da is mir aufgefallen dass ich das alias wlan0 prism2_usb nich eingetragen hab. NEUINSTALLATION, wlan0 prism2_usb miteingetragen neustart und dann ging wieder nix!

NEUINSTALLATION, installation der treiber usw ohne wlan0 prism2_usb:
Internet funzt! Aber wieder nur für ne halbe stunde!

Was kann ich tun?? Bild

MfG
baseman_2004
Newbie
Newbie
Beiträge: 19
Registriert: 4. Mai 2004, 13:43
Wohnort: Tamm
Kontaktdaten:

Beitrag von baseman_2004 »

Hmm....

Das hatte ich auf linux 8.2 auch manchmal seit 9.0 gehts jetzt immer ;) .
Da kann ich dir leider net weiterhelfen... sorry

Kann hier irghendjemand was dazu sagen?
Antworten