Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Player für DVD's und Videos, nicht Caffeine?

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Gast

Beitrag von Gast »

also unter Yast2 Module/Netzwerkgeräte find ich nix besonderes (ISDN, DSL, Anrufbeantworter...)
oder ist das das?

warum spielt den xmms kein *.wav ab?

was stimmt mit dem GraKa-Treiber net?
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

bin noch immer in der fh....
wegen ethernet-adapter schau ich daheim

wegen xmms...weiß net...bei mir tuts...poste mal bitte die liste der eingabe-plugins von xmms (einstellungen)

wegen GraKa bitte im SuSE-Forum posten !!! das passt garnet in multimedia...
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
aurial

Beitrag von aurial »

Hallo brenner05,

wegen der Netzwerkkarte:

Yast / Netzwerkgeräte / Netzwerkkarte / Im unteren Abschnitt auf Ändern / Alle Einträge dort löschen

(SOFERN das beim Yast für SuSE 9.1 auch noch so ist)


Was Probleme mit Xine anbelangt: Tipp in einer normalen Konsole mal xine-check ein, und poste die Textausgabe, die Du daraufhin erhälst.


Was XMMS anbelangt: das mal starten, dann auf Optionen / Einstellungen. In dem daraufhin erscheinenden Fenster im Abschnitt Eingabe-Plugins mal schauen, ob dort ein Eintrag namens "Wave-Spieler" vorhanden ist (Du musst in der Liste eventuell erst nach unten scrollen, damit Du ihn siehst).


Was Probleme mit Grafikkarte anbelangt: Geh mal ins KDE-Kontrollzentrum / Erscheinungsbild / Stil / Effekte und schalte mal alles auf "Deaktivieren" - nun schau, ob die Probleme immer noch da sind.

Hab ich noch was vergessen ... falls ja, dann teil es mir mit.

Bis demnächst dann
brenner05

Beitrag von brenner05 »

das kam, als ich xine-checkeingegeben habe:

Please be patient, this script may take a while to run...
[ good ] you're using Linux, doing specific tests
[ good ] looks like you have a /proc filesystem mounted.
[ good ] You seem to have a reasonable kernel version (2.6.4-52-default)
[ good ] intel compatible processor, checking MTRR support
[ good ] you have MTRR support and there are some ranges set.
[ good ] found the player at /usr/bin/xine
[ good ] /usr/bin/xine is in your PATH
[ good ] found /usr/bin/xine-config in your PATH
[ good ] plugin directory /usr/lib/xine/plugins/1.0.0 exists.
[ good ] found unknown plugin: xineplug_flac.so
[ good ] found input plugins
[ good ] found demux plugins
[ good ] found decoder plugins
[ good ] found video_out plugins
[ good ] found audio_out plugins
[ good ] skin directory /usr/share/xine/skins exists.
[ good ] found logo in /usr/share/xine/skins
[ good ] I even found some skins.
[ good ] /dev/cdrom points to /dev/hda
[ good ] /dev/dvd points to /dev/hdd
[ hint ] DMA is disabled for your DVD interface.
This will probably result in a serious performance hit when
playing DVDs. You can issue the command
hdparm -d1 /dev/hdd
as root to enable DMA. It would be wise to add this command to
some script that is executed executed at boot time.
Note that you probably have to set the DMA mode for your drive as well.
Most DVD-ROMs work fine with multiword DMA mode 2. You can use
hdparm -d1 -X34 /dev/hdd
(as root again) to set this mode. Maybe UDMA2 will give you even better
performance, but it only works well with some controllers. You'll
probably need UDMA capable IDE cables for this mode. If you want
to try: make backups of your important data and type (as root again)
sync
hdparm -d1 -X66 /dev/hdd
If your System still works fine after this, you probably want to keep
these settings (add them to some boot script).
If your system hangs or behaves very strangely after a few minutes, you
should reboot immediately and never use this setting again on this
machine. Good luck ;-)
press <enter> to continue...

[ good ] found xvinfo: X-Video Extension version 2.2
[ good ] your Xv extension supports YV12 overlays (improves MPEG performance)
[ good ] your Xv extension supports YUY2 overlays
[ good ] Xv ports: YUY2 YV12 UYVY I420 YUY2 YV12 UYVY I420


wo start ich xmms überhaup und wie komme ich ins kde-kontrollzentrum? :oops:
aurial

Beitrag von aurial »

Hallo brenner05,
[ hint ] DMA is disabled for your DVD interface.
This will probably result in a serious performance hit when
playing DVDs
Na da haben wir doch schon ein Xine-Problem. DMA ist bei Dir ausgeschaltet, was mit empfindlichen Performance-Einbussen bei der DVD-Wiedergabe verbunden sein kann (als Folge davon ruckelt es).

Schalt DMA halt mal ein. Entweder durch Eingabe von

Code: Alles auswählen

hdparm -d1 /dev/hdd 
für normales DMA oder

Code: Alles auswählen

hdparm -d1 -X34 /dev/hdd
für Multiword DMA mode 2 oder

Code: Alles auswählen

hdparm -d1 -X66 /dev/hdd
für UltraDMA mode 2

Je weiter unten, desto besser / schneller. Allerdings muss das Bessere / Schnellere auch von Deinem DVD-Laufwerk unterstützt werden, sonst gibt es eventuell eine Fehlermeldung (oder es klappt einfach nicht mit dem DMA). Was Dein DVD-Laufwerk kann, entnimmst Du Deiner Bedienungsanleitung. Ferner musst Du die Kommandos in einer Root-Konsole eintippen.

Dann teste mal, ob's nicht mehr ruckelt.

Um einen der oben genannten DMA-Modes dann dauerhaft einzustellen, geht mit Hilfe von Yast / Hardware / IDE-DMA-Modus und dort entsprechend einstellen (auch hier wieder der Hinweis: ist unter SuSE 9.0 so, hoffentlich gibt es das auch (noch) beim 9.1er-Yast).

Ansonsten: Wenn Dein DVD-Bild mehr oder minder stark flimmert, kann das am eingeschalteten De-Interlace liegen. Schalt es mal ab, denn für DVD-Spielfilme wird das in der Regel nicht benötigt.

XMMS startet man bei mir (SuSE 9.0) via SuSE-Menu (bei Windows würde man Start-Menu dazu sagen) / Multimedia / Audio Wiedergabe / XMMS. Ist das bei Dir nicht dort?

Herzliche Grüße



Herzliche Grüße
brenner05

Beitrag von brenner05 »

/dev/hdd:
setting using_dma to 1 (on)
using_dma = 1 (on)

ich habe normales dma gewählt, das kam daraufhin.
die dvd wird immer noch net korrekt abgespielt, habe auch schon höher versucht!
brenner05

Beitrag von brenner05 »

der wave-spieler ist vorhanden! immer wenn ich *.wav dateien abspielen will, öffnet sich ein fenster namens spiele-dateien.

die *.wav dateien kann ich nicht abspielen.
aurial

Beitrag von aurial »

Hallo brenner05,
die dvd wird immer noch net korrekt abgespielt, habe auch schon höher versucht!
Datengrundlage unzureichend. Erbitte präziseren Input ;-)
(inwiefern wird denn was genau net korrekt abgespielt)
die *.wav dateien kann ich nicht abspielen.
Geh mal ins KDE-Kontrollzentrum / KDE-Komponenten / Dateizuordnungen / audio (aufs Pluszeichen klicken) / x-wav / XMMS / Bearbeiten / Programme und guck mal, was dort alles steht.

Übrigens (hatte ich bereits gestern geschrieben, aber ist hier nicht angekommen - vielleicht bzw. wahrscheinlich hab ich auch nur vergessen, auf Absenden zu klicken; das kommt davon, wenn mehrere Foren-Fenster offen sind :-)

Dass Dein System-Start so lahm ist, kann auch an der DMA-Problematik liegen. Genauso wie beim DVD-Laufwerk beschrieben, lässt sich nämlich auch für eine IDE-Platte ein DMA-Modus aktivieren, der sich spürbar auf die Lade-/ Speicher-Geschwindigkeit der Platte auswirkt.

Heutige, moderne Platten können mindestens Ultra-DMA mode 2, mode 3, mode 4 oder sogar mode 5. Also aktiviere das mal (den richtigen Mode entsprechend Deiner Platte) mittels Yast; Du wirst daraufhin einen viel schnelleren Rechner haben.

Herzliche Grüße
brenner05

Beitrag von brenner05 »

wie komme ich denn nun in das kde-kontrollzentrum, das ist doch net gleiche wie yast?!
brenner05

Beitrag von brenner05 »

wegen der dvd's:
es flimmert leicht bei schnellen bewegungen
brenner05

Beitrag von brenner05 »

das dvd-laufwerk habe ich nun in yast auf dma-modus (standard) eingestellt, hat aber leider nix gebracht.
Gast

Beitrag von Gast »

Hallo brenner05,
wie komme ich denn nun in das kde-kontrollzentrum, das ist doch net gleiche wie yast?
SuSE-Menü / Kontrollzentrum

Oder SuSE-Menü / Einstellungen / Kontrollzentrum

Sach mal (ist jetzt echt nicht böse gemeint): Muss man Dir eigentlich wirklich immer alles erklären? Probier doch erst mal selber ein bißchen herum, bevor Du hier oder anderswo Fragen stellst.

Habe bis jetzt noch niemanden kennengelernt, der, nachdem er immerhin ein Linux erfolgreich installierte, das KDE-Kontrollzentrum nicht gefunden hat :-)
wegen der dvd's:
es flimmert leicht bei schnellen bewegungen
Flimmert leicht bei was für Videomaterial??? Original-Spielfilm einer DVD? Zusätzliche Extras bei einer DVD? Vom Fernsehen aufgenommenes Zeug? Irgendwelcher Krempel aus dem Internet?

Das spielt eine Rolle, die ich gerne erklären kann, wenn Du das näher präzisiert hast.
das dvd-laufwerk habe ich nun in yast auf dma-modus (standard) eingestellt, hat aber leider nix gebracht.
Haste auch das DMA für die Platte entsprechend eingestellt zwecks besserer HD-Performance und schnellerem System-Start (siehe letzten Beitrag von mir)?

Herzliche Grüße
Gast

Beitrag von Gast »

1. wusste net das kde-kontrollzentrum gleich YaST ist
2. DMA für Platte und DVD-Laufwerk ist eingestellt
DMA für Platte war schon aktiviert

3. hatte ich schon einmal erwähnt, original-dvd's keine extras, der film selbst
4. der systemstart hat sich NICHT verschnellert

so, das wär's fürs erste.

ich habe gedacht, dass kde-kontrollzentrum etwas anderes ist, da anscheinend der eintrag bei suse linux 9.1 net mehr vorhanden ist.
aurial

Beitrag von aurial »

Hallo Gast (brenner05?),

Das KED-Kontrollzentrum ist nicht gleich Yast.

Wenn Du es im SuSE-Menü nicht findest, dann öffne mal eine normale Konsole und tipp dort

Code: Alles auswählen

kcontrol
ein. Dann die Sachen einstellen, die ich weiter oben bereits erwähnt hatte.

Was das Flimmern anbelangt: Start mal Kaffeine, geh auf DVD-Wiedergabe und schau mal, ob der Kaffeine-Menüpunkt Ansicht / Deinterlace aktiviert ist (ob dort ein Haken ist)

Herzliche Grüße
Hanns
Newbie
Newbie
Beiträge: 2
Registriert: 21. Jun 2004, 17:37

WAV Dateien mit XMMS abspielen

Beitrag von Hanns »

Hallo. Bei mir spielt XMMS auch keine Wavs ab. Habe auch schon im Kontrollzentrum geschaut, wie es beschrieben wurde und dort sind auch die .wav Dateien mit XMMS verknüpft. In den XMMS Optionen Audio-I/O-Plugins ist für die Wave Wiedergabe Das Wave Spieler 1.2.10 angegeben (libwav.so). XMMS lädt die WAVE Dateien noch nicht einmal in die Playlist.

Wäre schön, wenn es eine Lösung dafür gibt.

Gruß
Hanns
Benutzeravatar
Bill wie gates
Newbie
Newbie
Beiträge: 49
Registriert: 11. Jun 2004, 13:20
Wohnort: in Bayern

Beitrag von Bill wie gates »

@Gast Brenner 04 05 oder wie auch immer

Bin selbst ein absoluter Newbie.Wegen des langsamen Systemstarts.
Ruf mal /boot/grub/menu.lst auf.Darin änderst Du splash=silent in splash=verbose.Beim nächsten Start von suse siehst Du dann,woran es hapert.
Für Deine Grafikkarte kann ich Dir nur folgendes Forum empfehlen:
SAX und 3D mit Wolfgang67 .Für mich ein echter Profi.Oder:
http://www.linux-club.de/suse-support-forum/372.html
Ansonsten hilft viel im Forum stöbern und mitlesen und nicht die geduld verlieren.
In diesem Sinne................
Benutzeravatar
Bill wie gates
Newbie
Newbie
Beiträge: 49
Registriert: 11. Jun 2004, 13:20
Wohnort: in Bayern

Beitrag von Bill wie gates »

@Hanns!

Hab'mal eine CD mit grip nach .wav gerippt.Wird anstandslos unter XMMS abgespielt.Probier mal das ALSA -Plugin libALSA.so als Ausgabe .Das funzt bei mir.Hoffe,das hilft.
Ciao bis demnächst............
Hanns
Newbie
Newbie
Beiträge: 2
Registriert: 21. Jun 2004, 17:37

WaveDateien

Beitrag von Hanns »

@Bill wie gates

Danke für den Tip. Hab ich direkt mal probiert, geht aber nicht.
Habe mittlerweile herausgefunden, daß es daran lag, das es 8-bit WAV Dateien waren, die ich in die Playliste laden wollte. Die spielt der XMMS nicht ab. 16-bit WAVs funktionieren einwandfrei.

Gruß
Hanns
Antworten