Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

suse will nicht auf 2k rechner drucken.

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Gast

suse will nicht auf 2k rechner drucken.

Beitrag von Gast »

Hallöchen,

dummer Linux-Newb (ich :) ) hat ein Problem:

Ausgangssituation:

-Office G 85 auf Win200prof-rechner installiert und freigegeben.
-alles druckt einwandfrei darauf.

-suse-arbeitsplatz (8.2) testhalber installiert, findet drucker über yast, lässt sich installieren und im yast antesten (bekomme ein ok zurück), verweigert mir aber das drucken. sende ich nen druckauftrag los, landet der im nirvana oder so. smbclient ist übrigens installiert.

wahrscheinlich hab ich irgendwas hundsdummes übersehen - blos was? :?

vielen dank für etwaige hilfe :D
Ghoul
Member
Member
Beiträge: 176
Registriert: 28. Mär 2004, 17:52
Wohnort: Niemandsland bei Bremen

Re: suse will nicht auf 2k rechner drucken.

Beitrag von Ghoul »

Wenn ich das recht verstehe willst du über Netzwerk Drucken, oder hast du Suse auf dem selben Rechner Installiert uns wilst Dierekt Drucken?
Über Netzwerk hatte ich ähnliches Problem, da auf dem Rechner wo der Drucker angeschlossen war,
zwei Netzwerkkarten (eine Netzwerkkarte und eine digi TV Karte) aktiv waren. Habe dann in der Datei /etc/hosts folgendes eingetragen
"IPadresse Rechnername.Arbeitsgruppe.test Rechnername" .
Das .test ist mit irgendwelchen IP Regeln konform und muss mit angegeben werden.
Zuhause hat man ja meist nur Rechnername und Arbeitsgruppe.

mfg
Ghoul
Benutzeravatar
JRB
Newbie
Newbie
Beiträge: 1
Registriert: 30. Apr 2004, 12:59
Wohnort: Berlin Charlottenburg
Kontaktdaten:

Beitrag von JRB »

Hallo :)

hatte das gleiche problem, in Yast lässt sich alles prima installieren, die Suse installation tut so als ob sie den Druckauftrag übers Netzwerk absendet, am w2k rechner und dem daran angeschlossenen Drucker kommt jedoch nichts an.

im Yast-Dialog steht sogar das der Drucker bereit ist (in grün).

nach langem suchen scheint der fehler in der /etc/cups/printers.conf zu liegen, bei mir ist es jedenfalls so, der Yast erzeugt u.a.eine Zeile mit der Zugangsinformationen:
/etc/cups/printers.conf
DeviceURI smb:// username: passwort @ rechnername.Arbeitsgruppe / druckerwarteschlange
ohne leerzeichen versteht sich.

einfach die Arbeitsgruppe aus der DeviceURI löschen,
den cupsdienst neu starten ( /etc/init.d/cups restart )

dann sollte es gehen.

gruss J.Berndt :D

PS:
interessant wäre es noch raus zu finden was da tatsächlich passiert?
warscheinlich hängt der samba-client (dienst) noch den arbeitsgruppennamen an die DeviceURI ran, was dann dazu führt das der Windowsrechner sich nicht mehr angesprochen fühlt ( der name wird nicht mehr richtig aufgelösst)
sasch_bb

SuSe9 vs WinXP Prof

Beitrag von sasch_bb »

Hallo,

also meine konfi sieht so aus:

WinXp Prof : Drucker ESC600_S (freigegeben für GAST - Einfache Dateifreigabe)
Suse9 druckt über Cups

und in die printers.conf muss :
smb://Gast@Workgroup/winxp/ESC600_S
stehen, schon funtzs
Gast

Beitrag von Gast »

cool, danke für die vielen antworten, probiere ich gleich morgen mal herum. :D
Antworten