Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 9.0 Prof als Gateway (Notebook) geht, vom PC aus nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Gast

Suse 9.0 Prof als Gateway (Notebook) geht, vom PC aus nicht

Beitrag von Gast »

Hallo zusammen,

ich hab folgendes Problem seit neuestem.

Auf meinem Rechner sitzt eine Linux-Distri, mit der ich partout kein Internet einstellen kann, aber immerhin das Netzwerk ist super einzustellen.

Auf meinem Notebook ist Suse 9.0 Prof und als Router (Gateway) eingerichtet.

Wenn ich damit ins Internet einwähle, kann ich mit der Distri auf dem Rechner auch ins Internet.

Umgekehrt:
Auf dem Notebook ist die gleiche Situation, nur diesmal umgekehrt, dass Suse auf dem Rechner für die Distri auf dem Notebook der Gateway sein soll.

Die Einchrichtung von Suse in yast ist identisch (nur die IPs sind natürlich umgekehrt).

PROBLEM: Wenn in nun ins Internet gehe (wohlgemerkt auf dem Recher), dann kann ich mit der Distri auf dem Notebook nicht ins Internet, es ist als sei gar kein Speed da bzw. als ob die Verbindung gar nicht übers Netzwerk zustande kommt.

Bisher hatte das alles super funktioniert, es liegt also an Suse und irgendeinem Problem, warum es nicht mehr geht.

Inzwischen hab ich auf dem Rechner Suse 9.0 Prof neu installieren müssen, weil sowieso notwendig.

Wieder in yast die gleichen Einstellungen vorgenommen, wie ich sie auf dem Notebook auch habe, aber es geht nicht, auch mit anderen Distris gehts nicht, obwohl es vorher mal gegangen war.

Warum funktioniert es mit der Suse auf dem Notebook, auf dem Rechner aber nicht?

Zugang auf dem Rechner ins Internet: AVM ISDN PCI v 1.0
Zugang auf dem Notebook ins Internet: AVM USB v. 2.1

Ich will ja nicht immer Windows aufrufen auf dem Rechner, denn mit Fritz.web und Freigabe im Netzwerk kann ich mit allen Distris übers Netz ins Internet.

Gruss
Windhund
Benutzeravatar
maxpowers
Member
Member
Beiträge: 71
Registriert: 20. Apr 2004, 12:32
Wohnort: Xanten

Beitrag von maxpowers »

Hi Windhund,

deine Schilderungen verwirren mich ein wenig :) aber grundlegend brauchst du für Internet:

Entweder einen funktionierenden Proxyserver - dessen Adresse du den Klients einträgst. - entfällt bei Dir aber da du den Gatewaymodus nutzen möchtest.

Daher kommen wir zum 2. Weg. Du musst deinem Klient bekanntmachen wo sich der nächste Rechner auf dem Weg ins Internet befindet (in dem Fall dein Gateway PC).
Also Standardgateway der Klients auf die IP des sich ins Internet einwählenden PC's setzen.
Wichtig ist nun noch die Namensauflösung!!! D.h. entweder musst du deinen Clients nen Server im Internet bekannt geben der NAMEN in IPS umwandelt - oder im besten Fall macht das dein eigener Internetgateway für die Clients. DNS Server ist hier das Schlagwort.
Desweiteren musst Du unbedingt Firewallregeln usw. anpassen, wenn den hoffentlich eine Firewall installiert ist...
Aber dazu gibts ja hier genug nette Anleitungen :)
carpe - diem
Gast

Beitrag von Gast »

Hallo maxpowers,

danke erst mal für deine Mühe, mir zu antworten.

Dass meine Schilderung etwas verwirrend ist, glaub ich dir.

Ich werde jetzt einfach nochmal all das durchgehen, was du mir da geschrieben hast.

Dann schau ich mal, ob ich nicht doch was übersehen habe.

Vielen Dank!

Gruss
Windhund
Gast

Beitrag von Gast »

Hallo maxpowers,
Problem gelöst. danke noch einmal.

Gruss
Windhund
Gast

Beitrag von Gast »

Hallo noch einmal.

Ich will wenigstens noch schreiben, was war:

In yast hab ich noch mal routing angeklickt, da hab ich dann gesehen, dass noch die personal firewall eingerichtet war.

yast hat dann auf firewall2 umgestellt und schon hat alles wieder funktioniert.

Manchmal sieht man den Wald vor lauter Bäumen nicht .....

So ist es mir gegangen :-)

Aber nun bin ich froh, dass ich wieder so arbeiten kann.

Gruss
Windhund
Antworten