Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Ich will einen Router und DHCP Server einrichten HELP

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
faximan
Newbie
Newbie
Beiträge: 1
Registriert: 25. Apr 2004, 08:58

Ich will einen Router und DHCP Server einrichten HELP

Beitrag von faximan »

Hallo ich schlage mir gerade wahrscheinlich die Nact um die Ohren, bei dem versuch ein NAT und DHCP einzurichten.
SYSTEM Suse 9.0
2 Netzwerkkarten
eth0 = Lan
eth1= Kabelmodem (Ish mit eigenen DHCP der aber nicht Lanfähig ist, bei windows XP funzt es mit der dau methode "einfach ind die 2 netzwerkkarte einstöpsel zieht sich ip automatisch und dann internet connetion shahring aktivieren.... und fertig".)

Den Dhcp hatte ich erst versucht über Yast ans laufen zu bekommen was aber nicht funktioniert jetzt habe ich folgende config der dhcp.conf:

Code: Alles auswählen

#### Server:/etc/dhcpd.conf ##################################################

# Minimale Ausleihzeit in Sekunden (1 Stunde)
default-lease-time 3600;

# Maximale Ausleihzeit in Sekunden (24 Stunden)
max-lease-time 86400;

# Für die Netzwerkkarte eth0 (LAN) gelten folgende Einstellungen
subnet 192.168.0.0 netmask 255.255.255.0 {
  # Domainname = mylan
  option domain-name "mylan";

  # zwei DNS-Server
  option domain-name-servers 212.185.249.180, 194.25.2.129;

  # Internet-Gateway
  option routers 192.168.0.1;

  # Netzmaske
  option subnet-mask 255.255.255.0;

  # dynamische Zuweisung bei fremden Rechnern im LAN
  range 192.168.0.100 192.168.0.200;

}
1
# Für die Netzwerkkarte eth1 (DSL) gelten folgende Einstellungen
subnet 10.0.0.1 netmask 255.255.255.255 {
}
 
#############################################################################
Ip's werden jetzt vergeben aber kein gateway, wenn ich die daten bei den clients eingebe (gateway etc.) bekomme beim starten des dhcp noch folgende meldung:

** You must add a ddns-update-style statement to /etc/dhcpd.conf.
To get the same behaviour as in 3.0b2pl11 and previous
versions, add a line that says "ddns-update-style ad-hoc;"


funzt es auch nicht vielleicht könnte mir jemand mal ein genaues HOWTO
zukommen lassen - habe leider noch keins gefunden...


Danke
Triton
Member
Member
Beiträge: 88
Registriert: 22. Feb 2004, 17:20

Beitrag von Triton »

Mach mal diesen Eintrag noch in Deine dhcpd.conf rein dann sollte es funktionieren.

Code: Alles auswählen

authoritative;
ddns-update-style none;
ddns-updates off;
default-lease-time 60000;
log-facility local7;
max-lease-time 72000;
Gruss Triton
Antworten