Am 20.05.2022 bekommt das Forum ein neues Update. Ab ca. 12:00 ist das Forum nicht mehr erreichbar und wird spätestens am 21.05. wieder online sein. Alle bis dahin erstellten Daten bleiben natürlich erhalten.

Vielen Dank für euer Verständnis. Bei Rückfragen: webmaster@linux-club.de (Christian)

[gelöst]Eclipsestart - Fehlermeldung

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
fabilazar
Member
Member
Beiträge: 94
Registriert: 5. Nov 2005, 22:13

[gelöst]Eclipsestart - Fehlermeldung

Beitrag von fabilazar »

hallo,
ich habe mir das Eclipse 3.0.0 über yast installiert und wollte es hinterher aus dem Eclipse-Programm auktualisieren. Aber nach der IInstallation kann ich es nicht einmal starten, das ist der Fehler (Log-Datei):

Code: Alles auswählen

!SESSION Mrz 17, 2006 00:22:29.353 ---------------------------------------------
eclipse.buildId=200406251208
java.version=1.5.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE

!ENTRY org.eclipse.osgi Mrz 17, 2006 00:22:29.360
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: /usr/lib/eclipse/libswt-pi-gtk-3062.so: /opt/gnome/lib/libpangoft2-1.0.so.0: undefined symbol: g_assert_warning
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1660)
	at java.lang.Runtime.loadLibrary0(Runtime.java:822)
	at java.lang.System.loadLibrary(System.java:992)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:100)
	at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:118)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:268)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:153)
	at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:122)
	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:72)
	at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:335)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:183)
	at org.eclipse.core.launcher.Main.run(Main.java:644)
	at org.eclipse.core.launcher.Main.main(Main.java:628)

Kann jmd. was damit anfangen?
Gruss
Zuletzt geändert von fabilazar am 18. Mär 2006, 17:55, insgesamt 1-mal geändert.
fabilazar
Member
Member
Beiträge: 94
Registriert: 5. Nov 2005, 22:13

Beitrag von fabilazar »

Hat keiner eine Idee???
ich habe über die Suche ein paar Beiträge gefunden, die darauf hinweisen, dass es das gtk-qt-engine sein könnte. Ich habe es aktualisiert und das Eclipse konnte ich dennoch nicht starten (dieselbe Fehlermeldung s.o.). Danach habe ich es gelöscht aber auch da gab es keine Veränderung :?
Ich habe es mit der neuesten Eclipse 3.1.2 ausprobiert und mit der 3.0.0 bei beiden derselbe Fehler.

Also das kann es doch nicht sein! Ich habe das Java 1.5.0_06 installiert und will mit Eclipse unter Suse 9.2 programmieren. Was muss ich tun damit ich es noch klappt?
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

java.lang.UnsatisfiedLinkError: /usr/lib/eclipse/libswt-pi-gtk-3062.so: /opt/gnome/lib/libpangoft2-1.0.so.0: undefined symbol: g_assert_warning
dein swt passt NICHT zu den restlichen Bibliotheken ... das ist alles.
welches swt hast du installiert ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
fabilazar
Member
Member
Beiträge: 94
Registriert: 5. Nov 2005, 22:13

Beitrag von fabilazar »

Hallo oc2pus,

ich habe die SWT Library for GTK2 Version 3.0-5.1 installiert.
Wenn das die falsche ist welche brauche ich dann?
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

was hast du denn überhaupt installiert ?

rpm -qa | grep eclipse
rpm -qa | grep java
rpm -qa | grep swt

welche SuSE-Version ?

hast du die SuSE-pakete verwandt oder einfach die binaries von der jeweiligen Homepage installiert ...

ohne mehr Input ist leider keine weitere Hilfe möglich :mrgreen:
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
fabilazar
Member
Member
Beiträge: 94
Registriert: 5. Nov 2005, 22:13

Beitrag von fabilazar »

Hallo,
ich habe es jetzt endlich hingekriegt :D
Es lag nicht an dem swt, sondern an pango. Ich habe das pango-devel nachinstalliert und schon läuft das ganze :wink:
Aber danke dir für den entscheidenden Hinweis mit swt, so wusste ich wenigstens nach was ich googlen musste. So hab ich dann auch die Antwort auf mein Problem gefunden.
Vielen Dank!
Gruss
Fabi
Antworten