Am 20.05.2022 bekommt das Forum ein neues Update. Ab ca. 12:00 ist das Forum nicht mehr erreichbar und wird spätestens am 21.05. wieder online sein. Alle bis dahin erstellten Daten bleiben natürlich erhalten.

Vielen Dank für euer Verständnis. Bei Rückfragen: webmaster@linux-club.de (Christian)

SAMBA-freigabe/rechte-drucker/ip4000-HILFE

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
zar77
Newbie
Newbie
Beiträge: 21
Registriert: 15. Mär 2006, 18:15

SAMBA-freigabe/rechte-drucker/ip4000-HILFE

Beitrag von zar77 »

hallo gemeinde,

erstmal ein lob an die macher hier. das forum hat mir schon oft geholfen.
was meine linux-kenntnisse anbelangt bin ich anfänger, bitte bei der hilfe beachten.
die faqs und howtos zu meinem fall habe ich durchgearbeitet. mittlerweile klingt das aber alles gleich für mich.......sorry.
nun zu meiner ausgangssituation. ich habe ein netzwerk mit 4 PC.
auf 3en läuft windows (noch) und auf einem suse 10.
an der suse hängt auch der drucker (ip4000)
das drucken im netzwerk funktioniert nur der statusmonitor unter windows kann nicht auf den drucker zugreifen ---> PROBLEM 1
weiterhin habe ich versucht, verschiedene useraccounts einzurichten um diese den freigaben zuzuordnen. dabei bekomme ich im swat aber auch in der konsole diese fehlermeldung:
"Failed to initialise SAM_ACCOUNT for user user1. Does this user exist in the UNIX password database ?" ---> PROBLEM 2
zur veranschaulichung meine jetzige smb.conf:

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2006/03/16 12:17:17

[global]
workgroup = DAHEEME
map to guest = Bad User
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
domain master = No
ldap ssl = no
cups options = raw
include = /etc/samba/dhcp.conf

[win-platte]
path = /windows/C/
read only = No
hosts allow = pc1

[ablage]
path = /home/zar/ablage
read only = No
guest ok = Yes

[anhÄnge]
path = /home/zar/anhänge
valid users = user1
read only = No

[ip4000]
path = /tmp/
printable = Yes

der zugriff auf (ablage) geht, weil "guest ok = Yes" - richtig?
beim zugiff auf die anderen beiden werde ich nach user+passwort gefragt ---> PROBLEM 3
der zugang zu beiden, einmal mit "valid users" bzw. "hosts allow" sind verschiedene varianten?! spielt dabei die groß/kleinschreibg der namen ne rolle?
mit "smbpasswd -a user1" habe ich versucht das einzurichten - richtig? bloss da kommt dann wieder problem 2 zum vorschein.

da ich nun nicht mehr weiss was ich noch einstellen soll, wende ich mich an euch. was kann/muss an der smb.conf noch geändert werden?!
danke im voraus für eure hilfe.

mfg zar77
Zuletzt geändert von zar77 am 16. Mär 2006, 13:01, insgesamt 1-mal geändert.
Fat_Fox
Hacker
Hacker
Beiträge: 335
Registriert: 2. Mär 2005, 09:56
Wohnort: /home/fat_fox
Kontaktdaten:

Beitrag von Fat_Fox »

na der user muss lokal auch existieren, also in der /etc/passwd drinstehen, wie hast du denn den user angelegt ?

valid users authentifiziert auf benutzer ebene,nur die angegebenen user dürfen auf das share zugreifen

allow hosts indentifiziert einen oder mehrere rechner über hostnamen bzw. ip-adressen

angenommen du hast 2 win-clients winA mit den usern userA1 und userA2 und winB mit den usern userB1 und user B2

dann muss es auf dem linux-rechner 4 benutzeraccounts geben
userA1,userA2,userB1,userB2 die die selben passwörter haben wie die windows user

diese müssen dann über smbpasswd -a dem sambaserver nähergebracht werden als passwort hier ruhig das selbe wie lokal verwenden, dann erst sind die user gültige sambauser.

jetzt machst du eine freigabe mit den optionen

[freigabe]
path =
comment =
readonly = no
valid users = winA1
hosts allow = winA

auf diese freigabe darf dann nur der nutzer winA1 von winA aus zugreifen, wenn winB2 das von winB aus versucht gehts nicht.
-= Fat_Fox =-

Phantasie ist wichtiger als Wissen, denn Wissen ist begrenzt. (Albert Einstein)

Wer gebrauchte Hardware für Desktop PC's oder einen Compaq Proliant 5500 loswerden möchte der meldet sich bitte per PN
zar77
Newbie
Newbie
Beiträge: 21
Registriert: 15. Mär 2006, 18:15

Beitrag von zar77 »

hallo dicker fuchs,

wie in meinem beitrag geschrieben:
einmal über die konsole mit: "smbpasswd -a user1" und dann auch über swat.
beide male die fehlermeldung wie schon beschrieben.
Fat_Fox
Hacker
Hacker
Beiträge: 335
Registriert: 2. Mär 2005, 09:56
Wohnort: /home/fat_fox
Kontaktdaten:

Beitrag von Fat_Fox »

du musst doch aber unter yast---> sicherheit und benutzer noch den eigendlichen user anlegen, so das du dich mit dem auch lokal am linux rechner anmelden kannst wie du es mit deinem linux-account tust
-= Fat_Fox =-

Phantasie ist wichtiger als Wissen, denn Wissen ist begrenzt. (Albert Einstein)

Wer gebrauchte Hardware für Desktop PC's oder einen Compaq Proliant 5500 loswerden möchte der meldet sich bitte per PN
zar77
Newbie
Newbie
Beiträge: 21
Registriert: 15. Mär 2006, 18:15

so...

Beitrag von zar77 »

das problem mit der fehlermeldung konnte ich selbst lösen. bevor ich mit smbpasswd -a den user hinzufügen kann muss erst noch useradd ausgeführt werden.

nun zu den freigaben. geht es nicht, dass man der jeweiligen freigabe den samba-benutzer mit dazugehörigen passwort zuweist.
ich möchte nicht zig user über yast anlegen. die anmeldung an den freigaben soll nur über die mit smbpasswd erzeugten user erfolgen. geht das?

nun besteht noch das problem mit dem statusmonitor unter windows.
er versucht zuzugreifen (die lampe blickt ab und zu), bekommt jedoch keine verbindg
Fat_Fox
Hacker
Hacker
Beiträge: 335
Registriert: 2. Mär 2005, 09:56
Wohnort: /home/fat_fox
Kontaktdaten:

Beitrag von Fat_Fox »

das problem mit der fehlermeldung konnte ich selbst lösen. bevor ich mit smbpasswd -a den user hinzufügen kann muss erst noch useradd ausgeführt werden.
das erzähl ich doch die ganze zeit !
nun zu den freigaben. geht es nicht, dass man der jeweiligen freigabe den samba-benutzer mit dazugehörigen passwort zuweist.
ich möchte nicht zig user über yast anlegen. die anmeldung an den freigaben soll nur über die mit smbpasswd erzeugten user erfolgen. geht das?
das geht auch dann musst du allerdings den server im security level "share" betreiben, schau hierzu die tutorials durch da solltest du was zu finden.
nun besteht noch das problem mit dem statusmonitor unter windows.
er versucht zuzugreifen (die lampe blickt ab und zu), bekommt jedoch keine verbindg
das leigt darin das der user mit dem sich windows autetifiziert nicht berechtigt ist auf dem drucker was zu tun wel der nemich root gehört, meines erachtens gibt es die option printer admin die man unter global einfügen kann, google mal danach, ich glaube das sollte so aussehen:

Code: Alles auswählen

[global]
printer admin = root administrator berechtigter-user
-= Fat_Fox =-

Phantasie ist wichtiger als Wissen, denn Wissen ist begrenzt. (Albert Einstein)

Wer gebrauchte Hardware für Desktop PC's oder einen Compaq Proliant 5500 loswerden möchte der meldet sich bitte per PN
zar77
Newbie
Newbie
Beiträge: 21
Registriert: 15. Mär 2006, 18:15

so...

Beitrag von zar77 »

das problem mit dem statusmonitor besteht weiterhin. habe gegoogelt und die besagte zeile beim drucker und im global eingefügt. hat leider nüscht gebracht.
ausserdem meckert smbclient... die zeile an. das steht aber in den howtos.
wer hat noch ne idee?

danke wieder im voraus.
mfg zar77
zar77
Newbie
Newbie
Beiträge: 21
Registriert: 15. Mär 2006, 18:15

mmmmh

Beitrag von zar77 »

guten abend,

hat den niemand das gleiche problem oder ist es noch keinem aufgefallen?

mfg zar77
Antworten